]> git.pld-linux.org Git - packages/balsa.git/blob - balsa.spec
2cfcbb8942dfd51973cf76db937f1d6fe5e675f1
[packages/balsa.git] / balsa.spec
1 # TODO:
2 # - use webkit as html widget?
3 # - gtkhtml4 causes gtk2/gtk3 conflict:
4 #       Gtk-ERROR **: GTK+ 2.x symbols detected. Using GTK+ 2.x and GTK+ 3 in the same process is not supported
5 #
6 # Conditional build:
7 %bcond_without  ldap            # build without LDAP support
8 %bcond_with     gpgme           # build with GPG support (experimental)
9 %bcond_without  esmtp           # build without ESMTP support
10 %bcond_without  gtkhtml         # build without HTML support
11 %bcond_without  gtkhtml2        # build with libgtkhtml-2 (default gtkhtml-4)
12 %bcond_with     compface        # build with Compface
13 %bcond_with     gtksourceview   # build with GtkSourceView
14 %bcond_without  gtkspell        # build without GtkSpell
15 %bcond_with     sqlite          # build with SQLite for GPE address books
16
17 Summary:        Balsa Mail Client
18 Summary(es.UTF-8):      Balsa es un lector de e-mail
19 Summary(pl.UTF-8):      Balsa - klient poczty
20 Summary(pt_BR.UTF-8):   Balsa é um leitor de e-mail
21 Name:           balsa
22 Version:        2.4.10
23 Release:        0.1
24 License:        GPL v3+
25 Group:          X11/Applications
26 Source0:        http://pawsa.fedorapeople.org/balsa/%{name}-%{version}.tar.bz2
27 # Source0-md5:  fa2b7cb9d248912ac2e3dcc08cd6aa5b
28 Patch0:         %{name}-desktop.patch
29 Patch1:         %{name}-gtkhtml4.patch
30 URL:            http://balsa.gnome.org/
31 BuildRequires:  ORBit2-devel >= 1:2.12.4
32 BuildRequires:  aspell-devel >= 2:0.50
33 BuildRequires:  autoconf >= 2.52
34 BuildRequires:  automake
35 %{?with_compface:BuildRequires: compface-devel}
36 BuildRequires:  docbook-dtd412-xml
37 BuildRequires:  gettext-devel
38 BuildRequires:  glib2-devel >= 2.6.4-1
39 BuildRequires:  gmime-devel >= 2.4.0
40 BuildRequires:  gnome-doc-utils
41 BuildRequires:  gnome-icon-theme
42 %{?with_gpgme:BuildRequires:    gpgme-devel >= 1:0.9.0}
43 BuildRequires:  gtk+2-devel >= 2:2.10.0
44 %{?with_gtksourceview:BuildRequires:    gtksourceview-devel}
45 %{?with_gtkspell:BuildRequires: gtkspell-devel}
46 BuildRequires:  heimdal-devel
47 BuildRequires:  intltool
48 %{?with_esmtp:BuildRequires:    libesmtp-devel >= 1.0.4}
49 %if %{with gtkhtml}
50 %{!?with_gtkhtml2:BuildRequires:        gtkhtml-devel >= 4.0}
51 %{?with_gtkhtml2:BuildRequires: libgtkhtml-devel >= 2.0}
52 %endif
53 BuildRequires:  libgnomeui-devel >= 2.3.3.1-2
54 BuildRequires:  libltdl-devel
55 BuildRequires:  libnotify-devel
56 BuildRequires:  libtool
57 BuildRequires:  libunique-devel
58 %{?with_ldap:BuildRequires:     openldap-devel >= 2.4.6}
59 BuildRequires:  openssl-devel >= 0.9.7d
60 BuildRequires:  pcre-devel >= 3.0
61 BuildRequires:  pkgconfig
62 BuildRequires:  rpmbuild(macros) >= 1.197
63 BuildRequires:  scrollkeeper >= 0.1.4
64 # actually, it requires sqlite >= 2.8
65 %{?with_sqlite:BuildRequires:   sqlite3-devel}
66 %{?with_gpgme:Requires: gpgme >= 1:0.9.0}
67 Requires(post,postun):  scrollkeeper
68 # sr@Latn vs. sr@latin
69 Conflicts:      glibc-misc < 6:2.7
70 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
71
72 %description
73 Balsa is an e-mail reader. This client is part of the GNOME desktop
74 environment. It supports local mailboxes, POP3 and IMAP.
75
76 %description -l es.UTF-8
77 Balsa es un lector de e-mail. Es parte del entorno GNOME. Soporta
78 cajas de correo electrónico locales, POP3 y IMAP.
79
80 %description -l pl.UTF-8
81 Balsa to klient e-mail. Jest częścią środowiska GNOME. Obsługuje POP3,
82 IMAP oraz lokalne skrzynki pocztowe.
83
84 %description -l pt_BR.UTF-8
85 Balsa é um leitor de e-mail, parte do ambiente de desktop GNOME.
86 Suporta caixas de correio locais, POP3 a IMAP.
87
88 %prep
89 %setup -q
90 %patch0 -p1
91 %{!?with_gtkhtml2:%patch1 -p1}
92
93 %build
94 %{__libtoolize}
95 %{__aclocal}
96 %{__autoconf}
97 %{__autoheader}
98 %{__autoconf}
99 %configure \
100         --with-gss \
101         --with-ssl \
102         --with-unique \
103         --disable-silent-rules \
104         %{!?with_esmtp:--without-esmtp} \
105 %if %{with gtkhtml}
106         --with-html-widget=%{?with_gtkhtml2:gtkhtml2}%{!?with_gtkhtml2:gtkhtml4} \
107 %else
108         --disable-gtkhtml \
109 %endif
110         %{?with_gpgme:--with-gpgme} \
111         %{?with_compface:--with-compface} \
112         %{?with_gtksourceview:--with-gtksourceview} \
113         %{?with_gtkspell:--with-gtkspell} \
114         %{?with_sqlite:--with-sqlite} \
115         %{?with_ldap:--with-ldap}
116 %{__make}
117
118 %install
119 rm -rf $RPM_BUILD_ROOT
120
121 %{__make} install \
122         DESTDIR=$RPM_BUILD_ROOT
123
124 [ -d $RPM_BUILD_ROOT%{_datadir}/locale/sr@latin ] || \
125         mv -f $RPM_BUILD_ROOT%{_datadir}/locale/sr@{Latn,latin}
126 %find_lang %{name} --with-gnome --all-name
127
128 %clean
129 rm -rf $RPM_BUILD_ROOT
130
131 %post
132 %scrollkeeper_update_post
133
134 %postun
135 %scrollkeeper_update_postun
136
137 %files -f %{name}.lang
138 %defattr(644,root,root,755)
139 %doc AUTHORS ChangeLog NEWS README TODO
140 %attr(755,root,root) %{_bindir}/balsa
141 %attr(755,root,root) %{_bindir}/balsa-ab
142 %dir %{_sysconfdir}/sound/events
143 %{_sysconfdir}/sound/events/balsa.soundlist
144 %{_datadir}/%{name}
145 %{_datadir}/sounds/%{name}
146 %{_mandir}/man1/balsa.1*
147 %{_omf_dest_dir}/%{name}
148 %{_desktopdir}/balsa.desktop
149 %{_pixmapsdir}/gnome-balsa2.png
150 %{_iconsdir}/hicolor/48x48/mimetypes/*.png
This page took 0.040136 seconds and 2 git commands to generate.