]> git.pld-linux.org Git - packages/balsa.git/blob - balsa.spec
- use libunique, BR: libunique-devel
[packages/balsa.git] / balsa.spec
1 # TODO:
2 #       - not packaged /usr/share/locale/ar/LC_MESSAGES/balsa.mo
3 #       - problems with id locale
4 #       - finish support for gtkhtml-4
5 #
6 # Conditional build:
7 %bcond_without  ldap            # build without LDAP support
8 %bcond_with     gpgme           # build with GPG support (experimental)
9 %bcond_without  esmtp           # build without ESMTP support
10 %bcond_without  gtkhtml         # build without HTML support
11 %bcond_with     gtkhtml2        # build with libgtkhtml-2 (default gtkhtml-3)
12 %bcond_with     compface        # build with Compface
13 %bcond_with     gtksourceview   # build with GtkSourceView
14 %bcond_without  gtkspell        # build without GtkSpell
15 %bcond_with     sqlite          # build with SQLite for GPE address books
16 #
17 Summary:        Balsa Mail Client
18 Summary(es.UTF-8):      Balsa es un lector de e-mail
19 Summary(pl.UTF-8):      Balsa - klient poczty
20 Summary(pt_BR.UTF-8):   Balsa é um leitor de e-mail
21 Name:           balsa
22 Version:        2.4.9
23 Release:        0.1
24 License:        GPL v3+
25 Group:          X11/Applications
26 Source0:        http://pawsa.fedorapeople.org/balsa/%{name}-%{version}.tar.bz2
27 # Source0-md5:  bd7ac44f0cf3117a5fdb46d17dac2b51
28 Patch0:         %{name}-desktop.patch
29 Patch1:         %{name}-gtkhtml4.patch
30 URL:            http://balsa.gnome.org/
31 BuildRequires:  ORBit2-devel >= 1:2.12.4
32 BuildRequires:  aspell-devel >= 2:0.50
33 BuildRequires:  autoconf >= 2.52
34 BuildRequires:  automake
35 %{?with_compface:BuildRequires: compface-devel}
36 BuildRequires:  docbook-dtd412-xml
37 BuildRequires:  gettext-devel
38 BuildRequires:  glib2-devel >= 2.6.4-1
39 BuildRequires:  gmime-devel >= 2.4.0
40 BuildRequires:  gnome-doc-utils
41 %{?with_gpgme:BuildRequires:    gpgme-devel >= 1:0.9.0}
42 BuildRequires:  gtk+2-devel >= 2:2.10.0
43 %{?with_gtksourceview:BuildRequires:    gtksourceview-devel}
44 %{?with_gtkspell:BuildRequires: gtkspell-devel}
45 BuildRequires:  heimdal-devel
46 BuildRequires:  intltool
47 %{?with_esmtp:BuildRequires:    libesmtp-devel >= 1.0.4}
48 %if %{with gtkhtml}
49 %{!?with_gtkhtml2:BuildRequires:        gtkhtml-devel >= 3.14}
50 %{?with_gtkhtml2:BuildRequires: libgtkhtml-devel >= 2.0}
51 %endif
52 BuildRequires:  libgnomeui-devel >= 2.3.3.1-2
53 BuildRequires:  libltdl-devel
54 BuildRequires:  libnotify-devel
55 BuildRequires:  libtool
56 BuildRequires:  libunique-devel
57 %{?with_ldap:BuildRequires:     openldap-devel >= 2.4.6}
58 BuildRequires:  openssl-devel >= 0.9.7d
59 BuildRequires:  pcre-devel >= 3.0
60 BuildRequires:  pkgconfig
61 BuildRequires:  rpmbuild(macros) >= 1.197
62 BuildRequires:  scrollkeeper >= 0.1.4
63 # actually, it requires sqlite >= 2.8
64 %{?with_sqlite:BuildRequires:   sqlite3-devel}
65 %{?with_gpgme:Requires: gpgme >= 1:0.9.0}
66 Requires(post,postun):  scrollkeeper
67 # sr@Latn vs. sr@latin
68 Conflicts:      glibc-misc < 6:2.7
69 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
70
71 %description
72 Balsa is an e-mail reader.  This client is part of the GNOME
73 desktop environment.  It supports local mailboxes, POP3 and
74 IMAP.
75
76 %description -l es.UTF-8
77 Balsa es un lector de e-mail. Es parte del entorno GNOME. Soporta
78 cajas de correo electrónico locales, POP3 y IMAP.
79
80 %description -l pl.UTF-8
81 Balsa to klient e-mail. Jest częścią środowiska GNOME. Obsługuje POP3,
82 IMAP oraz lokalne skrzynki pocztowe.
83
84 %description -l pt_BR.UTF-8
85 Balsa é um leitor de e-mail, parte do ambiente de desktop GNOME.
86 Suporta caixas de correio locais, POP3 a IMAP.
87
88 %prep
89 %setup -q
90 %patch0 -p1
91 %patch1 -p1
92
93 %build
94 %{__libtoolize}
95 %{__aclocal}
96 %{__autoconf}
97 %{__autoheader}
98 %{__autoconf}
99 %configure \
100         --with-gss \
101         --with-ssl \
102         --with-unique \
103         %{!?with_esmtp:--without-esmtp} \
104         %{!?with_gtkhtml:--disable-gtkhtml}\
105         %{?with_gtkhtml2:--with-gtkhtml=2}\
106         %{?with_gpgme:--with-gpgme} \
107         %{?with_compface:--with-compface} \
108         %{?with_gtksourceview:--with-gtksourceview} \
109         %{?with_gtkspell:--with-gtkspell} \
110         %{?with_sqlite:--with-sqlite} \
111         %{?with_ldap:--with-ldap}
112 %{__make}
113
114 %install
115 rm -rf $RPM_BUILD_ROOT
116
117 %{__make} install \
118         DESTDIR=$RPM_BUILD_ROOT
119
120 [ -d $RPM_BUILD_ROOT%{_datadir}/locale/sr@latin ] || \
121         mv -f $RPM_BUILD_ROOT%{_datadir}/locale/sr@{Latn,latin}
122 %find_lang %{name} --with-gnome --all-name
123
124 %clean
125 rm -rf $RPM_BUILD_ROOT
126
127 %post
128 %scrollkeeper_update_post
129
130 %postun
131 %scrollkeeper_update_postun
132
133 %files -f %{name}.lang
134 %defattr(644,root,root,755)
135 %doc AUTHORS ChangeLog NEWS README TODO
136 %attr(755,root,root) %{_bindir}/*
137 %{_sysconfdir}/sound/events/*
138 %{_datadir}/%{name}
139 %{_datadir}/sounds/%{name}
140 %{_libdir}/bonobo/servers/*.server
141 %{_datadir}/idl/*.idl
142 %{_mandir}/man1/*
143 %{_omf_dest_dir}/%{name}
144 %{_desktopdir}/*.desktop
145 %{_pixmapsdir}/*
146 %{_iconsdir}/hicolor/48x48/mimetypes/*.png
This page took 0.052637 seconds and 3 git commands to generate.