]> git.pld-linux.org Git - packages/bakefile.git/blob - bakefile.spec
ba1ded0cbc84ece3a275ea1ea5b1eecad1d2a7db
[packages/bakefile.git] / bakefile.spec
1 Summary:        Native makefiles generator
2 Summary(pl.UTF-8):      Generator natywnych plików typu Makefile
3 Name:           bakefile
4 Version:        0.2.9
5 Release:        1
6 License:        MIT
7 Group:          Development/Building
8 Source0:        http://downloads.sourceforge.net/bakefile/%{name}-%{version}.tar.gz
9 # Source0-md5:  b53813d155df1a45371abc8f781e6d88
10 Patch0:         %{name}-empy.patch
11 URL:            http://bakefile.sourceforge.net/
12 BuildRequires:  autoconf >= 2.53
13 BuildRequires:  automake >= 1.6
14 BuildRequires:  libtool
15 BuildRequires:  python-devel >= 1:2.5
16 BuildRequires:  rpm-pythonprov
17 %pyrequires_eq  python-modules
18 Requires:       empy >= 3.1
19 Requires:       python-libxml2
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 Bakefile is cross-platform, cross-compiler native makefiles generator.
24 It takes compiler-independent description of build tasks as input and
25 generate native makefile (autoconf's Makefile.in, Visual C++ project,
26 bcc makefile etc.).
27
28 %description -l pl.UTF-8
29 Bakefile to generator natywnych plików typu Makefile dla wielu
30 platform i kompilatorów. Przyjmuje na wejściu niezależny od
31 kompilatora opis zadań budowania i tworzy natywny plik (Makefile.in
32 dla autoconfa, projekt dla Visual C++, makefile dla bcc itd.).
33
34 %prep
35 %setup -q
36 %patch0 -p1
37
38 %build
39 %{__libtoolize}
40 %{__aclocal} -I admin
41 %{__autoconf}
42 %{__automake}
43 %configure
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47
48 %{__make} install \
49         DESTDIR=$RPM_BUILD_ROOT
50
51 # use system available modules
52 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/{empy,py25modules}
53
54 %{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/*.la
55 find $RPM_BUILD_ROOT%{_libdir}/%{name} -name '*.py' | grep -E -v '/bakefile(_gen)?\.py' | xargs %{__rm}
56
57 %clean
58 rm -rf $RPM_BUILD_ROOT
59
60 %files
61 %defattr(644,root,root,755)
62 %doc AUTHORS COPYING NEWS README THANKS doc/html
63 %attr(755,root,root) %{_bindir}/bakefile
64 %attr(755,root,root) %{_bindir}/bakefile_gen
65 %attr(755,root,root) %{_bindir}/bakefilize
66 %{_datadir}/%{name}
67 %dir %{_libdir}/%{name}
68 %{_libdir}/%{name}/*.py[oc]
69 %attr(755,root,root) %{_libdir}/%{name}/_bkl_c.so
70 %attr(755,root,root) %{_libdir}/%{name}/bakefile.py
71 %attr(755,root,root) %{_libdir}/%{name}/bakefile_gen.py
72 %{_aclocaldir}/bakefile*.m4
73 %{_mandir}/man1/bakefile.1*
74 %{_mandir}/man1/bakefile_gen.1*
75 %{_mandir}/man1/bakefilize.1*
This page took 0.091922 seconds and 3 git commands to generate.