]> git.pld-linux.org Git - packages/bacula.git/commitdiff
Fix for wx-console build error
authorJacek Konieczny <jajcus@jajcus.net>
Sun, 11 Nov 2012 14:57:19 +0000 (15:57 +0100)
committerJacek Konieczny <jajcus@jajcus.net>
Sun, 11 Nov 2012 15:11:58 +0000 (16:11 +0100)
For some reason, unknown to me, bacula build would fail if 'wx/config.h'
is included after 'bacula.h', with:

In file included from /usr/include/c++/4.7.2/i686-pld-linux/bits/gthr.h:150:0,
                 from /usr/include/c++/4.7.2/ext/atomicity.h:34,
                 from /usr/include/c++/4.7.2/bits/basic_string.h:41,
                 from /usr/include/c++/4.7.2/string:54,
                 from /usr/include/wx-2.8/wx/string.h:176,
                 from /usr/include/wx-2.8/wx/confbase.h:18,
                 from /usr/include/wx-2.8/wx/config.h:15,
                 from main.cpp:56:
/usr/include/c++/4.7.2/i686-pld-linux/bits/gthr-default.h:160:1: error: type of 'pthread_mutex_init' is unknown
/usr/include/c++/4.7.2/i686-pld-linux/bits/gthr-default.h:160:1: error: invalid type in declaration before ';' token
/usr/include/c++/4.7.2/i686-pld-linux/bits/gthr-default.h:161:1: error: type of 'pthread_mutex_destroy' is unknown
/usr/include/c++/4.7.2/i686-pld-linux/bits/gthr-default.h:161:1: error: invalid type in declaration before ';' token
/usr/include/c++/4.7.2/i686-pld-linux/bits/gthr-default.h: In function 'int __gthread_mutex_destroy(__gthread_mutex_t*)':
/usr/include/c++/4.7.2/i686-pld-linux/bits/gthr-default.h:760:52: error: '__gthrw_pthread_mutex_destroy' cannot be used as a function

bacula-wx-console-build.patch [new file with mode: 0644]
bacula.spec

diff --git a/bacula-wx-console-build.patch b/bacula-wx-console-build.patch
new file mode 100644 (file)
index 0000000..9f6b9ee
--- /dev/null
@@ -0,0 +1,143 @@
+diff -dur -x '*~' bacula-5.2.12.orig/src/wx-console/authenticate.c bacula-5.2.12/src/wx-console/authenticate.c
+--- bacula-5.2.12.orig/src/wx-console/authenticate.c   2012-09-13 10:51:19.000000000 +0200
++++ bacula-5.2.12/src/wx-console/authenticate.c        2012-11-11 15:54:51.436987760 +0100
+@@ -48,6 +48,7 @@
+ #undef _DEBUG
++#include <wx/string.h>
+ #include "bacula.h"
+ #include "console_conf.h"
+ #include "jcr.h"
+diff -dur -x '*~' bacula-5.2.12.orig/src/wx-console/console_conf.c bacula-5.2.12/src/wx-console/console_conf.c
+--- bacula-5.2.12.orig/src/wx-console/console_conf.c   2012-09-13 10:51:19.000000000 +0200
++++ bacula-5.2.12/src/wx-console/console_conf.c        2012-11-11 15:54:56.003685331 +0100
+@@ -57,6 +57,7 @@
+ #undef _DEBUG
++#include <wx/string.h>
+ #include "bacula.h"
+ #include "console_conf.h"
+diff -dur -x '*~' bacula-5.2.12.orig/src/wx-console/console_thread.cpp bacula-5.2.12/src/wx-console/console_thread.cpp
+--- bacula-5.2.12.orig/src/wx-console/console_thread.cpp       2012-09-13 10:51:19.000000000 +0200
++++ bacula-5.2.12/src/wx-console/console_thread.cpp    2012-11-11 15:55:02.753731018 +0100
+@@ -46,6 +46,7 @@
+ #undef _DEBUG
++#include <wx/string.h>
+ #include "bacula.h"
+ #include "console_conf.h"
+diff -dur -x '*~' bacula-5.2.12.orig/src/wx-console/main.cpp bacula-5.2.12/src/wx-console/main.cpp
+--- bacula-5.2.12.orig/src/wx-console/main.cpp 2012-09-13 10:51:19.000000000 +0200
++++ bacula-5.2.12/src/wx-console/main.cpp      2012-11-11 15:55:09.187107901 +0100
+@@ -50,6 +50,7 @@
+ #undef _DEBUG
++#include <wx/string.h>
+ #include "bacula.h"
+ #include <wx/wxprec.h>
+diff -dur -x '*~' bacula-5.2.12.orig/src/wx-console/wxbconfigfileeditor.cpp bacula-5.2.12/src/wx-console/wxbconfigfileeditor.cpp
+--- bacula-5.2.12.orig/src/wx-console/wxbconfigfileeditor.cpp  2012-09-13 10:51:19.000000000 +0200
++++ bacula-5.2.12/src/wx-console/wxbconfigfileeditor.cpp       2012-11-11 15:55:13.980473688 +0100
+@@ -41,6 +41,7 @@
+ #undef _DEBUG
++#include <wx/string.h>
+ #include "bacula.h"
+ #include "wxbconfigfileeditor.h"
+ #include <wx/file.h>
+diff -dur -x '*~' bacula-5.2.12.orig/src/wx-console/wxbconfigpanel.cpp bacula-5.2.12/src/wx-console/wxbconfigpanel.cpp
+--- bacula-5.2.12.orig/src/wx-console/wxbconfigpanel.cpp       2012-09-13 10:51:19.000000000 +0200
++++ bacula-5.2.12/src/wx-console/wxbconfigpanel.cpp    2012-11-11 15:55:19.013841104 +0100
+@@ -41,6 +41,7 @@
+ #undef _DEBUG
++#include <wx/string.h>
+ #include "bacula.h"
+ #include "wxbconfigpanel.h"
+ #include <wx/arrimpl.cpp>
+diff -dur -x '*~' bacula-5.2.12.orig/src/wx-console/wxbhistorytextctrl.cpp bacula-5.2.12/src/wx-console/wxbhistorytextctrl.cpp
+--- bacula-5.2.12.orig/src/wx-console/wxbhistorytextctrl.cpp   2012-09-13 10:51:19.000000000 +0200
++++ bacula-5.2.12/src/wx-console/wxbhistorytextctrl.cpp        2012-11-11 15:55:36.350625198 +0100
+@@ -41,6 +41,7 @@
+ #undef _DEBUG
++#include <wx/string.h>
+ #include "bacula.h"
+ #include "wxbhistorytextctrl.h"
+diff -dur -x '*~' bacula-5.2.12.orig/src/wx-console/wxblistctrl.cpp bacula-5.2.12/src/wx-console/wxblistctrl.cpp
+--- bacula-5.2.12.orig/src/wx-console/wxblistctrl.cpp  2012-09-13 10:51:19.000000000 +0200
++++ bacula-5.2.12/src/wx-console/wxblistctrl.cpp       2012-11-11 15:55:43.314005711 +0100
+@@ -42,6 +42,7 @@
+ #undef _DEBUG
++#include <wx/string.h>
+ #include "bacula.h"
+ #include "wxblistctrl.h"
+diff -dur -x '*~' bacula-5.2.12.orig/src/wx-console/wxbmainframe.cpp bacula-5.2.12/src/wx-console/wxbmainframe.cpp
+--- bacula-5.2.12.orig/src/wx-console/wxbmainframe.cpp 2012-09-13 10:51:19.000000000 +0200
++++ bacula-5.2.12/src/wx-console/wxbmainframe.cpp      2012-11-11 15:55:48.770709354 +0100
+@@ -41,6 +41,7 @@
+ #undef _DEBUG
++#include <wx/string.h>
+ #include "bacula.h"
+ #include "wxbmainframe.h" // class's header file
+diff -dur -x '*~' bacula-5.2.12.orig/src/wx-console/wxbrestorepanel.cpp bacula-5.2.12/src/wx-console/wxbrestorepanel.cpp
+--- bacula-5.2.12.orig/src/wx-console/wxbrestorepanel.cpp      2012-09-13 10:51:19.000000000 +0200
++++ bacula-5.2.12/src/wx-console/wxbrestorepanel.cpp   2012-11-11 15:55:55.700756326 +0100
+@@ -69,6 +69,7 @@
+ #undef _DEBUG
++#include <wx/string.h>
+ #include "bacula.h"
+ #include "wxbrestorepanel.h"
+diff -dur -x '*~' bacula-5.2.12.orig/src/wx-console/wxbtableparser.cpp bacula-5.2.12/src/wx-console/wxbtableparser.cpp
+--- bacula-5.2.12.orig/src/wx-console/wxbtableparser.cpp       2012-09-13 10:51:19.000000000 +0200
++++ bacula-5.2.12/src/wx-console/wxbtableparser.cpp    2012-11-11 15:56:01.374128112 +0100
+@@ -48,6 +48,7 @@
+ #undef _DEBUG
++#include <wx/string.h>
+ #include "bacula.h"
+ #include "wxbtableparser.h" // class's header file
+diff -dur -x '*~' bacula-5.2.12.orig/src/wx-console/wxbtreectrl.cpp bacula-5.2.12/src/wx-console/wxbtreectrl.cpp
+--- bacula-5.2.12.orig/src/wx-console/wxbtreectrl.cpp  2012-09-13 10:51:19.000000000 +0200
++++ bacula-5.2.12/src/wx-console/wxbtreectrl.cpp       2012-11-11 15:56:06.807498286 +0100
+@@ -42,6 +42,7 @@
+ #undef _DEBUG
++#include <wx/string.h>
+ #include "bacula.h"
+ #include "wxbtreectrl.h"
+diff -dur -x '*~' bacula-5.2.12.orig/src/wx-console/wxbutils.cpp bacula-5.2.12/src/wx-console/wxbutils.cpp
+--- bacula-5.2.12.orig/src/wx-console/wxbutils.cpp     2012-09-13 10:51:19.000000000 +0200
++++ bacula-5.2.12/src/wx-console/wxbutils.cpp  2012-11-11 15:56:11.697531443 +0100
+@@ -41,6 +41,7 @@
+ #undef _DEBUG
++#include <wx/string.h>
+ #include "bacula.h"
+ #include "wxbutils.h"
+ #include "wxbmainframe.h"
index ef98b5b82be46e3e0a3f7a74624e21db828ca344..c4c7e19d258ffdad1ca080a5e950202d3cc90ebb 100644 (file)
@@ -48,6 +48,7 @@ Patch1:               %{name}-branding.patch
 Patch2:                %{name}-conf.patch
 Patch3:                %{name}-desktop.patch
 Patch4:                make_catalog_backup-setup-home.patch
+Patch5:                %{name}-wx-console-build.patch
 URL:           http://www.bacula.org/
 BuildRequires: acl-devel
 BuildRequires: autoconf
@@ -447,6 +448,7 @@ Nagios plugin to check bacula.
 %patch2 -p1
 %patch3 -p1
 %patch4 -p1
+%patch5 -p1
 
 tar -xf %{SOURCE2} && ln -s bacula-rescue-* rescue
 
This page took 0.095455 seconds and 4 git commands to generate.