]> git.pld-linux.org Git - packages/bacula.git/commitdiff
- merge install-cats-no-fail.patch into bacula-dbi_fixes.patch, as seems the bug...
authorElan Ruusamäe <glen@pld-linux.org>
Wed, 8 Dec 2010 19:32:46 +0000 (19:32 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    bacula-dbi_fixes.patch -> 1.3
    bacula.spec -> 1.176
    install-cats-no-fail.patch -> 1.2

bacula-dbi_fixes.patch
bacula.spec
install-cats-no-fail.patch [deleted file]

index e049ecbbcd7fd0067c50cb4d682049778018fa52..e32091689645af9b8446e10b5cc5bac85b48987c 100644 (file)
 -      $(INSTALL_SCRIPT) drop_bacula_tables $(DESTDIR)$(scriptdir)/drop_bacula_tables
 -      $(INSTALL_SCRIPT) drop_bacula_database $(DESTDIR)$(scriptdir)/drop_bacula_database
 +      for dbtype in bdb mysql postgresql sqlite3 sqlite; do \
 -      $(INSTALL_SCRIPT) drop_bacula_tables $(DESTDIR)$(scriptdir)/drop_bacula_tables
 -      $(INSTALL_SCRIPT) drop_bacula_database $(DESTDIR)$(scriptdir)/drop_bacula_database
 +      for dbtype in bdb mysql postgresql sqlite3 sqlite; do \
-+              [ -f create_$${dbtype}_database ] && $(INSTALL_SCRIPT) create_$${dbtype}_database $(DESTDIR)$(scriptdir)/create_$${dbtype}_database; \
-+              [ -f update_$${dbtype}_tables ] && $(INSTALL_SCRIPT) update_$${dbtype}_tables $(DESTDIR)$(scriptdir)/update_$${dbtype}_tables; \
-+              [ -f make_$${dbtype}_tables ] && $(INSTALL_SCRIPT) make_$${dbtype}_tables $(DESTDIR)$(scriptdir)/make_$${dbtype}_tables; \
-+              [ -f grant_$${dbtype}_privileges ] && $(INSTALL_SCRIPT) grant_$${dbtype}_privileges $(DESTDIR)$(scriptdir)/grant_$${dbtype}_privileges; \
-+              [ -f drop_$${dbtype}_tables ] && $(INSTALL_SCRIPT) drop_$${dbtype}_tables $(DESTDIR)$(scriptdir)/drop_$${dbtype}_tables; \
-+              [ -f drop_$${dbtype}_database ] && $(INSTALL_SCRIPT) drop_$${dbtype}_database $(DESTDIR)$(scriptdir)/drop_$${dbtype}_database; \
++              [ ! -f create_$${dbtype}_database ] || $(INSTALL_SCRIPT) create_$${dbtype}_database $(DESTDIR)$(scriptdir)/create_$${dbtype}_database; \
++              [ ! -f update_$${dbtype}_tables ] || $(INSTALL_SCRIPT) update_$${dbtype}_tables $(DESTDIR)$(scriptdir)/update_$${dbtype}_tables; \
++              [ ! -f make_$${dbtype}_tables ] || $(INSTALL_SCRIPT) make_$${dbtype}_tables $(DESTDIR)$(scriptdir)/make_$${dbtype}_tables; \
++              [ ! -f grant_$${dbtype}_privileges ] || $(INSTALL_SCRIPT) grant_$${dbtype}_privileges $(DESTDIR)$(scriptdir)/grant_$${dbtype}_privileges; \
++              [ ! -f drop_$${dbtype}_tables ] || $(INSTALL_SCRIPT) drop_$${dbtype}_tables $(DESTDIR)$(scriptdir)/drop_$${dbtype}_tables; \
++              [ ! -f drop_$${dbtype}_database ] || $(INSTALL_SCRIPT) drop_$${dbtype}_database $(DESTDIR)$(scriptdir)/drop_$${dbtype}_database; \
 +      done
 +
 +              $(INSTALL_SCRIPT) fix_postgresql_tables $(DESTDIR)$(scriptdir)/fix_postgresql_tables
 +      done
 +
 +              $(INSTALL_SCRIPT) fix_postgresql_tables $(DESTDIR)$(scriptdir)/fix_postgresql_tables
index 0b7ecf3a22f2f18827f8eff36a1bbcc99c6116fc..50713eea9cce5c642eb4f81ff1df32cd0ca25b11 100644 (file)
@@ -54,7 +54,6 @@ Patch8:               %{name}-dbi_dbcheck.patch
 Patch9:                %{name}-openssl1.patch
 Patch10:       %{name}-dvd_rewind.patch
 Patch11:       qmake-bin.patch
 Patch9:                %{name}-openssl1.patch
 Patch10:       %{name}-dvd_rewind.patch
 Patch11:       qmake-bin.patch
-Patch12:       install-cats-no-fail.patch
 Patch13:       make_catalog_backup-setup-home.patch
 URL:           http://www.bacula.org/
 BuildRequires: acl-devel
 Patch13:       make_catalog_backup-setup-home.patch
 URL:           http://www.bacula.org/
 BuildRequires: acl-devel
@@ -472,7 +471,6 @@ Nagios plugin to check bacula.
 %patch9 -p1
 %patch10 -p1
 %patch11 -p1
 %patch9 -p1
 %patch10 -p1
 %patch11 -p1
-%patch12 -p1
 %patch13 -p1
 
 tar -xf %{SOURCE2} && ln -s bacula-rescue-* rescue
 %patch13 -p1
 
 tar -xf %{SOURCE2} && ln -s bacula-rescue-* rescue
diff --git a/install-cats-no-fail.patch b/install-cats-no-fail.patch
deleted file mode 100644 (file)
index 2f22127..0000000
+++ /dev/null
@@ -1,26 +0,0 @@
-do not let missing sqlite build make install for cycle to abort script with error
-
-fix is to invert the condition to be get hit by "set -e" exit on error
-
-Author: Elan Ruusamäe <glen@delfi.ee>
---- bacula-5.0.3/src/cats/Makefile.in~ 2010-10-22 14:00:55.000000000 +0300
-+++ bacula-5.0.3/src/cats/Makefile.in  2010-10-22 14:00:57.433667998 +0300
-@@ -133,12 +133,12 @@
- install: @LIBTOOL_INSTALL_TARGET@ @INCLUDE_INSTALL_TARGET@
-       for dbtype in bdb mysql postgresql sqlite3 sqlite; do \
--              [ -f create_$${dbtype}_database ] && $(INSTALL_SCRIPT) create_$${dbtype}_database $(DESTDIR)$(scriptdir)/create_$${dbtype}_database; \
--              [ -f update_$${dbtype}_tables ] && $(INSTALL_SCRIPT) update_$${dbtype}_tables $(DESTDIR)$(scriptdir)/update_$${dbtype}_tables; \
--              [ -f make_$${dbtype}_tables ] && $(INSTALL_SCRIPT) make_$${dbtype}_tables $(DESTDIR)$(scriptdir)/make_$${dbtype}_tables; \
--              [ -f grant_$${dbtype}_privileges ] && $(INSTALL_SCRIPT) grant_$${dbtype}_privileges $(DESTDIR)$(scriptdir)/grant_$${dbtype}_privileges; \
--              [ -f drop_$${dbtype}_tables ] && $(INSTALL_SCRIPT) drop_$${dbtype}_tables $(DESTDIR)$(scriptdir)/drop_$${dbtype}_tables; \
--              [ -f drop_$${dbtype}_database ] && $(INSTALL_SCRIPT) drop_$${dbtype}_database $(DESTDIR)$(scriptdir)/drop_$${dbtype}_database; \
-+              [ ! -f create_$${dbtype}_database ] || $(INSTALL_SCRIPT) create_$${dbtype}_database $(DESTDIR)$(scriptdir)/create_$${dbtype}_database; \
-+              [ ! -f update_$${dbtype}_tables ] || $(INSTALL_SCRIPT) update_$${dbtype}_tables $(DESTDIR)$(scriptdir)/update_$${dbtype}_tables; \
-+              [ ! -f make_$${dbtype}_tables ] || $(INSTALL_SCRIPT) make_$${dbtype}_tables $(DESTDIR)$(scriptdir)/make_$${dbtype}_tables; \
-+              [ ! -f grant_$${dbtype}_privileges ] || $(INSTALL_SCRIPT) grant_$${dbtype}_privileges $(DESTDIR)$(scriptdir)/grant_$${dbtype}_privileges; \
-+              [ ! -f drop_$${dbtype}_tables ] || $(INSTALL_SCRIPT) drop_$${dbtype}_tables $(DESTDIR)$(scriptdir)/drop_$${dbtype}_tables; \
-+              [ ! -f drop_$${dbtype}_database ] || $(INSTALL_SCRIPT) drop_$${dbtype}_database $(DESTDIR)$(scriptdir)/drop_$${dbtype}_database; \
-       done
-               $(INSTALL_SCRIPT) fix_postgresql_tables $(DESTDIR)$(scriptdir)/fix_postgresql_tables
This page took 0.054891 seconds and 4 git commands to generate.