]> git.pld-linux.org Git - packages/bacula.git/commitdiff
- rel 0.3; builds with dbi as default
authorMariusz Mazur <mmazur@pld-linux.org>
Wed, 22 Apr 2009 10:52:36 +0000 (10:52 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- there's a chance it actually works
- TODO: the %banner warning

Changed files:
    bacula.spec -> 1.109

bacula.spec

index e553e7ad750bd8e1d857588b1fd0c0deebddae42..c81a3a58781afec55d0a0965573f770cd798555a 100644 (file)
@@ -58,7 +58,7 @@ Summary:      Bacula - The Network Backup Solution
 Summary(pl.UTF-8):     Bacula - rozwiązanie do wykonywania kopii zapasowych po sieci
 Name:          bacula
 Version:       3.0.0
-Release:       0.2
+Release:       0.3
 Epoch:         0
 License:       extended GPL v2
 Group:         Networking/Utilities
@@ -82,6 +82,7 @@ Patch3:               %{name}-branding.patch
 Patch4:                %{name}-conf.patch
 Patch5:                %{name}-desktop.patch
 Patch6:                %{name}-64bitbuild_fix.patch
+Patch7:                %{name}-dbi_fixes.patch
 URL:           http://www.bacula.org/
 BuildRequires: acl-static
 BuildRequires: automake
@@ -455,6 +456,7 @@ danego systemu, należy ponownie uruchomić ./getdiskinfo .
 %patch4 -p1
 %patch5 -p1
 %patch6 -p1
+%{?with_dbi:%patch7 -p1}
 
 tar -xf %{SOURCE2} && ln -s bacula-rescue-* rescue
 
@@ -463,6 +465,10 @@ sed -i -e 's#bindir=.*#bindir=%{_bindir}#g' \
        src/cats/grant_* src/cats/make_* src/cats/update_*
 sed -i -e 's/@hostname@/--hostname--/' src/*/*.conf.in
 
+for dbtype in bdb mysql postgresql sqlite3 sqlite; do
+       sed -i -e "s,@DB_TYPE@,$dbtype,g" src/cats/*_${dbtype}_*
+done
+
 %build
 cp -f %{_datadir}/automake/config.sub autoconf
 cd autoconf && %{__aclocal} -I bacula-macros -I gettext-macros && cd ..
@@ -819,7 +825,15 @@ fi
 %{_mandir}/man8/bacula-dir.8*
 %{_mandir}/man8/dbcheck.8*
 %{_libexecdir}/%{name}/query.sql
-%if %{with sqlite3}
+%if %{with bdb} || %{with dbi}
+%attr(755,root,root) %{_libexecdir}/%{name}/create_bdb_database
+%attr(755,root,root) %{_libexecdir}/%{name}/drop_bdb_database
+%attr(755,root,root) %{_libexecdir}/%{name}/drop_bdb_tables
+%attr(755,root,root) %{_libexecdir}/%{name}/grant_bdb_privileges
+%attr(755,root,root) %{_libexecdir}/%{name}/make_bdb_tables
+%attr(755,root,root) %{_libexecdir}/%{name}/update_bdb_*
+%endif
+%if %{with sqlite3} || %{with dbi}
 %attr(755,root,root) %{_libexecdir}/%{name}/create_sqlite3_database
 %attr(755,root,root) %{_libexecdir}/%{name}/drop_sqlite3_database
 %attr(755,root,root) %{_libexecdir}/%{name}/drop_sqlite3_tables
@@ -827,7 +841,7 @@ fi
 %attr(755,root,root) %{_libexecdir}/%{name}/make_sqlite3_tables
 %attr(755,root,root) %{_libexecdir}/%{name}/update_sqlite3_*
 %endif
-%if %{with sqlite}
+%if %{with sqlite} || %{with dbi}
 %attr(755,root,root) %{_libexecdir}/%{name}/create_sqlite_database
 %attr(755,root,root) %{_libexecdir}/%{name}/drop_sqlite_database
 %attr(755,root,root) %{_libexecdir}/%{name}/drop_sqlite_tables
@@ -835,7 +849,7 @@ fi
 %attr(755,root,root) %{_libexecdir}/%{name}/make_sqlite_tables
 %attr(755,root,root) %{_libexecdir}/%{name}/update_sqlite_*
 %endif
-%if %{with mysql}
+%if %{with mysql} || %{with dbi}
 %attr(755,root,root) %{_libexecdir}/%{name}/create_mysql_database
 %attr(755,root,root) %{_libexecdir}/%{name}/drop_mysql_database
 %attr(755,root,root) %{_libexecdir}/%{name}/drop_mysql_tables
@@ -843,20 +857,23 @@ fi
 %attr(755,root,root) %{_libexecdir}/%{name}/make_mysql_tables
 %attr(755,root,root) %{_libexecdir}/%{name}/update_mysql_*
 %endif
-%if %{with pgsql}
+%if %{with pgsql} || %{with dbi}
 %attr(755,root,root) %{_libexecdir}/%{name}/create_postgresql_database
 %attr(755,root,root) %{_libexecdir}/%{name}/drop_postgresql_database
 %attr(755,root,root) %{_libexecdir}/%{name}/drop_postgresql_tables
 %attr(755,root,root) %{_libexecdir}/%{name}/grant_postgresql_privileges
 %attr(755,root,root) %{_libexecdir}/%{name}/make_postgresql_tables
 %attr(755,root,root) %{_libexecdir}/%{name}/update_postgresql_*
+%attr(755,root,root) %{_libexecdir}/%{name}/fix_postgresql_*
 %endif
+%if %{without dbi}
 %attr(755,root,root) %{_libexecdir}/%{name}/create_bacula_database
 %attr(755,root,root) %{_libexecdir}/%{name}/drop_bacula_database
 %attr(755,root,root) %{_libexecdir}/%{name}/drop_bacula_tables
 %attr(755,root,root) %{_libexecdir}/%{name}/grant_bacula_privileges
 %attr(755,root,root) %{_libexecdir}/%{name}/make_bacula_tables
 %attr(755,root,root) %{_libexecdir}/%{name}/update_bacula_tables
+%endif
 %attr(755,root,root) %{_libexecdir}/%{name}/make_catalog_backup
 %attr(755,root,root) %{_libexecdir}/%{name}/delete_catalog_backup
 
This page took 0.113838 seconds and 4 git commands to generate.