]> git.pld-linux.org Git - packages/axis.git/blob - axis.spec
- added patch 1 (missing xsd files)
[packages/axis.git] / axis.spec
1 # TODO
2 #  - castor is needed by axis-1.2.1-0.2jpp.1.noarch
3 #  - package axis2, axis is obsolete. see NOTE below.
4 # NOTE
5 #  - it won't compile with java 1.6. see:
6 #    https://fcp.surfsite.org/modules/newbb/viewtopic.php?topic_id=55862&viewmode=flat&order=ASC&start=20
7 %define archivever %(echo %{version} | tr . _)
8 Summary:        A SOAP implementation in Java
9 Summary(pl.UTF-8):      Implementacja SOAP w Javie
10 Name:           axis
11 Version:        1.4
12 Release:        0.1
13 License:        Apache Software License
14 Group:          Development/Languages/Java
15 Source0:        http://ws.apache.org/axis//dist/%{archivever}/%{name}-src-%{archivever}.tar.gz
16 # Source0-md5:  3dcce3cbd37f52d70ebeb858f90608dc
17 Source1:        axis-build.properties
18 Patch0:         axis-classpath.patch
19 Patch1:         axis-missing_xsd.patch
20 URL:            http://ws.apache.org/axis/
21 BuildRequires:  ant >= 1.6
22 BuildRequires:  ant-nodeps
23 BuildRequires:  jdk
24 # Mandatory requires
25 BuildRequires:  jaf
26 BuildRequires:  java-commons-discovery
27 BuildRequires:  java-commons-httpclient
28 BuildRequires:  java-commons-logging
29 BuildRequires:  javamail
30 BuildRequires:  jaxp_parser_impl
31 BuildRequires:  jpackage-utils
32 BuildRequires:  logging-log4j
33 BuildRequires:  rpmbuild(macros) >= 1.300
34 BuildRequires:  servletapi5
35 BuildRequires:  wsdl4j
36 # optional requires
37 BuildRequires:  castor
38 BuildRequires:  httpunit
39 BuildRequires:  jakarta-oro
40 BuildRequires:  jimi
41 BuildRequires:  jms
42 BuildRequires:  jsse
43 BuildRequires:  junit
44 Requires:       jaf
45 Requires:       jakarta-commons-discovery
46 Requires:       jakarta-commons-httpclient
47 Requires:       jakarta-commons-logging
48 Requires:       java
49 Requires:       javamail
50 Requires:       jaxp_parser_impl
51 Requires:       logging-log4j
52 Requires:       jpackage-utils
53 Requires:       log4j
54 Requires:       wsdl4j
55 BuildArch:      noarch
56 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
57
58 %description
59 Apache AXIS is an implementation of the SOAP ("Simple Object Access
60 Protocol") submission to W3C.
61
62 From the draft W3C specification:
63
64 SOAP is a lightweight protocol for exchange of information in a
65 decentralized, distributed environment. It is an XML based protocol
66 that consists of three parts: an envelope that defines a framework for
67 describing what is in a message and how to process it, a set of
68 encoding rules for expressing instances of application-defined
69 datatypes, and a convention for representing remote procedure calls
70 and responses.
71
72 This project is a follow-on to the Apache SOAP project.
73
74 %description -l pl.UTF-8
75 Apache AXIS to implementacja SOAP ("Simple Object Access Protocol")
76 przekazanego do W3C.
77
78 Z projektu specyfikacji W3C:
79
80 SOAP to lekki protokół do wymiany informacji w scentralizowanym,
81 rozproszonym środowisku. Jest to protokół oparty na XML-u, składający
82 się z trzech części: koperty definiującej szkielet do opisu zawartości
83 i sposobu przetwarzania komunikatu, zbioru reguł kodowania do
84 wyrażania instancji typów danych zdefiniowanych w aplikacji oraz
85 konwencji reprezentowania zdalnych wywołań procedur i odpowiedzi.
86
87 Ten projekt jest następcą projektu Apache SOAP.
88
89 %package javadoc
90 Summary:        Javadoc for %{name}
91 Summary(pl.UTF-8):      Dokumentacja javadoc dla pakietu %{name}
92 Group:          Documentation
93 Requires:       jpackage-utils
94
95 %description javadoc
96 Javadoc for %{name}.
97
98 %description javadoc -l pl.UTF-8
99 Dokumentacja javadoc dla pakietu %{name}.
100
101 %package manual
102 Summary:        Manual for %{name}
103 Summary(pl.UTF-8):      Podręcznik do pakietu %{name}
104 Group:          Development/Languages/Java
105
106 %description manual
107 Documentation for %{name}.
108
109 %description manual -l pl.UTF-8
110 Podręcznik do pakietu %{name}.
111
112 %prep
113 %setup -q -n %{name}-%{archivever}
114
115 # Remove provided binaries
116 # find -name '*.jar' | xargs rm -v
117 find -name '*.class' | xargs rm -v
118
119 %patch0 -p1
120 %patch1 -p1
121
122 cp %SOURCE1 build.properties
123
124 %build
125 export JAVA_HOME=%{java_home}
126
127 CLASSPATH=$(build-classpath ecj tools)
128 export CLASSPATH
129 %ant dist
130
131 %install
132 rm -rf $RPM_BUILD_ROOT
133 ### Jar files
134 install -d $RPM_BUILD_ROOT%{_javadir}/%{name}
135
136 cd build/lib
137 install axis.jar axis-ant.jar saaj.jar jaxrpc.jar \
138         $RPM_BUILD_ROOT%{_javadir}/%{name}
139 cd -
140
141 cd $RPM_BUILD_ROOT%{_javadir}/%{name}
142 for jar in *.jar ; do
143         vjar=$(echo $jar | sed s+.jar+-%{version}.jar+g)
144         mv $jar $vjar
145         ln -fs $vjar $jar
146 done
147 cd -
148
149 ### Javadoc
150 install -d $RPM_BUILD_ROOT%{_javadocdir}/%{name}-%{version}
151 cp -a build/javadocs/* $RPM_BUILD_ROOT%{_javadocdir}/%{name}-%{version}
152 ln -s %{name}-%{version} $RPM_BUILD_ROOT%{_javadocdir}/%{name} # ghost symlink
153
154 %clean
155 rm -rf $RPM_BUILD_ROOT
156
157 %post javadoc
158 ln -nfs %{name}-%{version} %{_javadocdir}/%{name}
159
160 %files
161 %defattr(644,root,root,755)
162 %doc LICENSE README release-notes.html changelog.html
163 %dir %{_javadir}/%{name}
164 %{_javadir}/%{name}/*.jar
165
166 %files javadoc
167 %defattr(644,root,root,755)
168 %{_javadocdir}/%{name}-%{version}
169 %ghost %{_javadocdir}/%{name}
170
171 %files manual
172 %defattr(644,root,root,755)
173 %doc docs/*
This page took 0.353623 seconds and 4 git commands to generate.