]> git.pld-linux.org Git - packages/axis.git/blob - axis.spec
- dropped build.properties. It does not work or I am too stupid to use ant.
[packages/axis.git] / axis.spec
1 # TODO
2 #  - castor is needed by axis-1.2.1-0.2jpp.1.noarch
3 #  - package axis2, axis is obsolete. see NOTE below.
4 # NOTE
5 #  - it won't compile with java 1.6. see:
6 #    https://fcp.surfsite.org/modules/newbb/viewtopic.php?topic_id=55862&viewmode=flat&order=ASC&start=20
7 %define archivever %(echo %{version} | tr . _)
8 Summary:        A SOAP implementation in Java
9 Summary(pl.UTF-8):      Implementacja SOAP w Javie
10 Name:           axis
11 Version:        1.4
12 Release:        0.1
13 License:        Apache Software License
14 Group:          Development/Languages/Java
15 Source0:        http://ws.apache.org/axis/dist/%{archivever}/%{name}-src-%{archivever}.tar.gz
16 # Source0-md5:  3dcce3cbd37f52d70ebeb858f90608dc
17 Patch0:         axis-classpath.patch
18 Patch1:         axis-missing_xsd.patch
19 URL:            http://ws.apache.org/axis/
20 BuildRequires:  ant >= 1.6
21 BuildRequires:  ant-nodeps
22 BuildRequires:  java-gcj-compat-devel
23 # Mandatory requires
24 # BuildRequires:        jaf
25 # BuildRequires:        java-commons-discovery
26 # BuildRequires:        java-commons-httpclient
27 # BuildRequires:        java-commons-logging
28 # BuildRequires:        java-xmlbeans
29 # BuildRequires:        javamail
30 # BuildRequires:        jaxp_parser_impl
31 # BuildRequires:        jpackage-utils
32 # BuildRequires:        logging-log4j
33 # BuildRequires:        rpmbuild(macros) >= 1.300
34 # BuildRequires:        servletapi5
35 # BuildRequires:        wsdl4j
36 # # optional requires
37 # BuildRequires:        castor
38 # BuildRequires:        httpunit
39 # BuildRequires:        jakarta-oro
40 # # BuildRequires:      jimi
41 # # BuildRequires:      jms
42 # BuildRequires:        jsse
43 # BuildRequires:        junit
44 Requires:       jaf
45 Requires:       jakarta-commons-discovery
46 Requires:       jakarta-commons-httpclient
47 Requires:       jakarta-commons-logging
48 Requires:       javamail
49 Requires:       jaxp_parser_impl
50 Requires:       logging-log4j
51 Requires:       jpackage-utils
52 Requires:       log4j
53 Requires:       wsdl4j
54 BuildArch:      noarch
55 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
56
57 %description
58 Apache AXIS is an implementation of the SOAP ("Simple Object Access
59 Protocol") submission to W3C.
60
61 From the draft W3C specification:
62
63 SOAP is a lightweight protocol for exchange of information in a
64 decentralized, distributed environment. It is an XML based protocol
65 that consists of three parts: an envelope that defines a framework for
66 describing what is in a message and how to process it, a set of
67 encoding rules for expressing instances of application-defined
68 datatypes, and a convention for representing remote procedure calls
69 and responses.
70
71 This project is a follow-on to the Apache SOAP project.
72
73 %description -l pl.UTF-8
74 Apache AXIS to implementacja SOAP ("Simple Object Access Protocol")
75 przekazanego do W3C.
76
77 Z projektu specyfikacji W3C:
78
79 SOAP to lekki protokół do wymiany informacji w scentralizowanym,
80 rozproszonym środowisku. Jest to protokół oparty na XML-u, składający
81 się z trzech części: koperty definiującej szkielet do opisu zawartości
82 i sposobu przetwarzania komunikatu, zbioru reguł kodowania do
83 wyrażania instancji typów danych zdefiniowanych w aplikacji oraz
84 konwencji reprezentowania zdalnych wywołań procedur i odpowiedzi.
85
86 Ten projekt jest następcą projektu Apache SOAP.
87
88 %package javadoc
89 Summary:        Javadoc for %{name}
90 Summary(pl.UTF-8):      Dokumentacja javadoc dla pakietu %{name}
91 Group:          Documentation
92 Requires:       jpackage-utils
93
94 %description javadoc
95 Javadoc for %{name}.
96
97 %description javadoc -l pl.UTF-8
98 Dokumentacja javadoc dla pakietu %{name}.
99
100 %package manual
101 Summary:        Manual for %{name}
102 Summary(pl.UTF-8):      Podręcznik do pakietu %{name}
103 Group:          Development/Languages/Java
104
105 %description manual
106 Documentation for %{name}.
107
108 %description manual -l pl.UTF-8
109 Podręcznik do pakietu %{name}.
110
111 %prep
112 %setup -q -n %{name}-%{archivever}
113
114 # Remove provided binaries
115 # find -name '*.jar' | xargs rm -v
116 find -name '*.class' | xargs rm -v
117
118 %patch0 -p1
119 %patch1 -p1
120
121 %build
122
123 # requiredJars="activation bsf castor commons-codec commons-discovery commons-httpclient commons-logging httpunit jsse junit log4j mail xmlbeans servlet wsdl4j"
124 # for I in $requiredJars; do
125 #   ln -sf $(find-jar $I) lib/$I
126 # done
127
128 CLASSPATH=$(build-classpath ecj tools)
129 export CLASSPATH
130 %ant -Dbuild.compiler=modern dist
131
132 %install
133 rm -rf $RPM_BUILD_ROOT
134 ### Jar files
135 install -d $RPM_BUILD_ROOT%{_javadir}/%{name}/lib
136
137 cd build/lib
138 install axis.jar axis-ant.jar saaj.jar jaxrpc.jar \
139         $RPM_BUILD_ROOT%{_javadir}/%{name}
140 cd -
141
142 cd $RPM_BUILD_ROOT%{_javadir}/%{name}
143 for jar in *.jar ; do
144         vjar=$(echo $jar | sed s+.jar+-%{version}.jar+g)
145         mv $jar $vjar
146         ln -fs $vjar $jar
147 done
148 cd -
149
150 ### Javadoc
151 install -d $RPM_BUILD_ROOT%{_javadocdir}/%{name}-%{version}
152 cp -a build/javadocs/* $RPM_BUILD_ROOT%{_javadocdir}/%{name}-%{version}
153 ln -s %{name}-%{version} $RPM_BUILD_ROOT%{_javadocdir}/%{name} # ghost symlink
154
155 %clean
156 rm -rf $RPM_BUILD_ROOT
157
158 %post javadoc
159 ln -nfs %{name}-%{version} %{_javadocdir}/%{name}
160
161 %files
162 %defattr(644,root,root,755)
163 %doc LICENSE README release-notes.html changelog.html
164 %dir %{_javadir}/%{name}
165 %{_javadir}/%{name}/*.jar
166
167 %files javadoc
168 %defattr(644,root,root,755)
169 %{_javadocdir}/%{name}-%{version}
170 %ghost %{_javadocdir}/%{name}
171
172 %files manual
173 %defattr(644,root,root,755)
174 %doc docs/*
This page took 0.095008 seconds and 3 git commands to generate.