]> git.pld-linux.org Git - packages/axis.git/blame - axis.spec
- dropped build.properties. It does not work or I am too stupid to use ant.
[packages/axis.git] / axis.spec
CommitLineData
952ffbef 1# TODO
952ffbef 2# - castor is needed by axis-1.2.1-0.2jpp.1.noarch
87cd0875 3# - package axis2, axis is obsolete. see NOTE below.
4# NOTE
5# - it won't compile with java 1.6. see:
6# https://fcp.surfsite.org/modules/newbb/viewtopic.php?topic_id=55862&viewmode=flat&order=ASC&start=20
952ffbef
ER
7%define archivever %(echo %{version} | tr . _)
8Summary: A SOAP implementation in Java
d7049fd1 9Summary(pl.UTF-8): Implementacja SOAP w Javie
952ffbef 10Name: axis
3a5f3841 11Version: 1.4
fc8003da 12Release: 0.1
952ffbef
ER
13License: Apache Software License
14Group: Development/Languages/Java
071c13c6 15Source0: http://ws.apache.org/axis/dist/%{archivever}/%{name}-src-%{archivever}.tar.gz
3a5f3841 16# Source0-md5: 3dcce3cbd37f52d70ebeb858f90608dc
3a5f3841 17Patch0: axis-classpath.patch
93768a76 18Patch1: axis-missing_xsd.patch
21fcb34a 19URL: http://ws.apache.org/axis/
2bbdba56 20BuildRequires: ant >= 1.6
3a5f3841 21BuildRequires: ant-nodeps
071c13c6 22BuildRequires: java-gcj-compat-devel
952ffbef 23# Mandatory requires
ef13bd39 24# BuildRequires: jaf
25# BuildRequires: java-commons-discovery
26# BuildRequires: java-commons-httpclient
27# BuildRequires: java-commons-logging
28# BuildRequires: java-xmlbeans
29# BuildRequires: javamail
30# BuildRequires: jaxp_parser_impl
31# BuildRequires: jpackage-utils
32# BuildRequires: logging-log4j
33# BuildRequires: rpmbuild(macros) >= 1.300
34# BuildRequires: servletapi5
35# BuildRequires: wsdl4j
36# # optional requires
37# BuildRequires: castor
38# BuildRequires: httpunit
39# BuildRequires: jakarta-oro
40# # BuildRequires: jimi
41# # BuildRequires: jms
42# BuildRequires: jsse
43# BuildRequires: junit
952ffbef
ER
44Requires: jaf
45Requires: jakarta-commons-discovery
340429f1 46Requires: jakarta-commons-httpclient
952ffbef 47Requires: jakarta-commons-logging
952ffbef
ER
48Requires: javamail
49Requires: jaxp_parser_impl
56506b98 50Requires: logging-log4j
d57efde4 51Requires: jpackage-utils
952ffbef
ER
52Requires: log4j
53Requires: wsdl4j
54BuildArch: noarch
55BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
56
57%description
58Apache AXIS is an implementation of the SOAP ("Simple Object Access
59Protocol") submission to W3C.
60
61From the draft W3C specification:
62
63SOAP is a lightweight protocol for exchange of information in a
64decentralized, distributed environment. It is an XML based protocol
65that consists of three parts: an envelope that defines a framework for
66describing what is in a message and how to process it, a set of
67encoding rules for expressing instances of application-defined
68datatypes, and a convention for representing remote procedure calls
69and responses.
70
71This project is a follow-on to the Apache SOAP project.
72
cd04c4e5 73%description -l pl.UTF-8
21fcb34a
JB
74Apache AXIS to implementacja SOAP ("Simple Object Access Protocol")
75przekazanego do W3C.
76
77Z projektu specyfikacji W3C:
78
cd04c4e5
JR
79SOAP to lekki protokół do wymiany informacji w scentralizowanym,
80rozproszonym środowisku. Jest to protokół oparty na XML-u, składający
81się z trzech części: koperty definiującej szkielet do opisu zawartości
82i sposobu przetwarzania komunikatu, zbioru reguł kodowania do
83wyrażania instancji typów danych zdefiniowanych w aplikacji oraz
84konwencji reprezentowania zdalnych wywołań procedur i odpowiedzi.
21fcb34a 85
cd04c4e5 86Ten projekt jest następcą projektu Apache SOAP.
21fcb34a 87
952ffbef
ER
88%package javadoc
89Summary: Javadoc for %{name}
d7049fd1 90Summary(pl.UTF-8): Dokumentacja javadoc dla pakietu %{name}
d57efde4
ER
91Group: Documentation
92Requires: jpackage-utils
952ffbef
ER
93
94%description javadoc
95Javadoc for %{name}.
96
cd04c4e5 97%description javadoc -l pl.UTF-8
21fcb34a
JB
98Dokumentacja javadoc dla pakietu %{name}.
99
952ffbef
ER
100%package manual
101Summary: Manual for %{name}
d7049fd1 102Summary(pl.UTF-8): Podręcznik do pakietu %{name}
952ffbef
ER
103Group: Development/Languages/Java
104
105%description manual
106Documentation for %{name}.
107
cd04c4e5
JR
108%description manual -l pl.UTF-8
109Podręcznik do pakietu %{name}.
21fcb34a 110
952ffbef
ER
111%prep
112%setup -q -n %{name}-%{archivever}
113
114# Remove provided binaries
ef13bd39 115# find -name '*.jar' | xargs rm -v
d57efde4 116find -name '*.class' | xargs rm -v
952ffbef 117
3a5f3841 118%patch0 -p1
93768a76 119%patch1 -p1
3a5f3841 120
952ffbef 121%build
ef13bd39 122
123# requiredJars="activation bsf castor commons-codec commons-discovery commons-httpclient commons-logging httpunit jsse junit log4j mail xmlbeans servlet wsdl4j"
124# for I in $requiredJars; do
125# ln -sf $(find-jar $I) lib/$I
126# done
952ffbef 127
3a5f3841 128CLASSPATH=$(build-classpath ecj tools)
129export CLASSPATH
ef13bd39 130%ant -Dbuild.compiler=modern dist
952ffbef
ER
131
132%install
952ffbef
ER
133rm -rf $RPM_BUILD_ROOT
134### Jar files
ef13bd39 135install -d $RPM_BUILD_ROOT%{_javadir}/%{name}/lib
952ffbef
ER
136
137cd build/lib
d57efde4 138install axis.jar axis-ant.jar saaj.jar jaxrpc.jar \
21fcb34a 139 $RPM_BUILD_ROOT%{_javadir}/%{name}
952ffbef
ER
140cd -
141
142cd $RPM_BUILD_ROOT%{_javadir}/%{name}
21fcb34a
JB
143for jar in *.jar ; do
144 vjar=$(echo $jar | sed s+.jar+-%{version}.jar+g)
145 mv $jar $vjar
146 ln -fs $vjar $jar
147done
952ffbef
ER
148cd -
149
150### Javadoc
952ffbef 151install -d $RPM_BUILD_ROOT%{_javadocdir}/%{name}-%{version}
d57efde4
ER
152cp -a build/javadocs/* $RPM_BUILD_ROOT%{_javadocdir}/%{name}-%{version}
153ln -s %{name}-%{version} $RPM_BUILD_ROOT%{_javadocdir}/%{name} # ghost symlink
952ffbef
ER
154
155%clean
156rm -rf $RPM_BUILD_ROOT
157
158%post javadoc
d57efde4 159ln -nfs %{name}-%{version} %{_javadocdir}/%{name}
952ffbef
ER
160
161%files
162%defattr(644,root,root,755)
163%doc LICENSE README release-notes.html changelog.html
164%dir %{_javadir}/%{name}
165%{_javadir}/%{name}/*.jar
166
167%files javadoc
168%defattr(644,root,root,755)
d57efde4
ER
169%{_javadocdir}/%{name}-%{version}
170%ghost %{_javadocdir}/%{name}
952ffbef
ER
171
172%files manual
173%defattr(644,root,root,755)
174%doc docs/*
This page took 0.064174 seconds and 4 git commands to generate.