]> git.pld-linux.org Git - packages/axis.git/blame - axis.spec
- started update to 1.4
[packages/axis.git] / axis.spec
CommitLineData
952ffbef 1# TODO
952ffbef 2# - castor is needed by axis-1.2.1-0.2jpp.1.noarch
87cd0875 3# - package axis2, axis is obsolete. see NOTE below.
4# NOTE
5# - it won't compile with java 1.6. see:
6# https://fcp.surfsite.org/modules/newbb/viewtopic.php?topic_id=55862&viewmode=flat&order=ASC&start=20
952ffbef
ER
7%define archivever %(echo %{version} | tr . _)
8Summary: A SOAP implementation in Java
d7049fd1 9Summary(pl.UTF-8): Implementacja SOAP w Javie
952ffbef 10Name: axis
3a5f3841 11Version: 1.4
12Release: 0.1
952ffbef
ER
13License: Apache Software License
14Group: Development/Languages/Java
21fcb34a 15Source0: http://ws.apache.org/axis//dist/%{archivever}/%{name}-src-%{archivever}.tar.gz
3a5f3841 16# Source0-md5: 3dcce3cbd37f52d70ebeb858f90608dc
17Source1: axis-build.properties
18Patch0: axis-classpath.patch
21fcb34a 19URL: http://ws.apache.org/axis/
2bbdba56 20BuildRequires: ant >= 1.6
3a5f3841 21BuildRequires: ant-nodeps
952ffbef
ER
22BuildRequires: jdk
23# Mandatory requires
24BuildRequires: jaf
3a5f3841 25BuildRequires: java-commons-discovery
26BuildRequires: java-commons-httpclient
27BuildRequires: java-commons-logging
952ffbef
ER
28BuildRequires: javamail
29BuildRequires: jaxp_parser_impl
d57efde4
ER
30BuildRequires: jpackage-utils
31BuildRequires: logging-log4j
32BuildRequires: rpmbuild(macros) >= 1.300
952ffbef
ER
33BuildRequires: servletapi5
34BuildRequires: wsdl4j
35# optional requires
36BuildRequires: castor
37BuildRequires: httpunit
38BuildRequires: jakarta-oro
39BuildRequires: jimi
40BuildRequires: jms
41BuildRequires: jsse
42BuildRequires: junit
952ffbef
ER
43Requires: jaf
44Requires: jakarta-commons-discovery
340429f1 45Requires: jakarta-commons-httpclient
952ffbef
ER
46Requires: jakarta-commons-logging
47Requires: java
48Requires: javamail
49Requires: jaxp_parser_impl
56506b98 50Requires: logging-log4j
d57efde4 51Requires: jpackage-utils
952ffbef
ER
52Requires: log4j
53Requires: wsdl4j
54BuildArch: noarch
55BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
56
57%description
58Apache AXIS is an implementation of the SOAP ("Simple Object Access
59Protocol") submission to W3C.
60
61From the draft W3C specification:
62
63SOAP is a lightweight protocol for exchange of information in a
64decentralized, distributed environment. It is an XML based protocol
65that consists of three parts: an envelope that defines a framework for
66describing what is in a message and how to process it, a set of
67encoding rules for expressing instances of application-defined
68datatypes, and a convention for representing remote procedure calls
69and responses.
70
71This project is a follow-on to the Apache SOAP project.
72
cd04c4e5 73%description -l pl.UTF-8
21fcb34a
JB
74Apache AXIS to implementacja SOAP ("Simple Object Access Protocol")
75przekazanego do W3C.
76
77Z projektu specyfikacji W3C:
78
cd04c4e5
JR
79SOAP to lekki protokół do wymiany informacji w scentralizowanym,
80rozproszonym środowisku. Jest to protokół oparty na XML-u, składający
81się z trzech części: koperty definiującej szkielet do opisu zawartości
82i sposobu przetwarzania komunikatu, zbioru reguł kodowania do
83wyrażania instancji typów danych zdefiniowanych w aplikacji oraz
84konwencji reprezentowania zdalnych wywołań procedur i odpowiedzi.
21fcb34a 85
cd04c4e5 86Ten projekt jest następcą projektu Apache SOAP.
21fcb34a 87
952ffbef
ER
88%package javadoc
89Summary: Javadoc for %{name}
d7049fd1 90Summary(pl.UTF-8): Dokumentacja javadoc dla pakietu %{name}
d57efde4
ER
91Group: Documentation
92Requires: jpackage-utils
952ffbef
ER
93
94%description javadoc
95Javadoc for %{name}.
96
cd04c4e5 97%description javadoc -l pl.UTF-8
21fcb34a
JB
98Dokumentacja javadoc dla pakietu %{name}.
99
952ffbef
ER
100%package manual
101Summary: Manual for %{name}
d7049fd1 102Summary(pl.UTF-8): Podręcznik do pakietu %{name}
952ffbef
ER
103Group: Development/Languages/Java
104
105%description manual
106Documentation for %{name}.
107
cd04c4e5
JR
108%description manual -l pl.UTF-8
109Podręcznik do pakietu %{name}.
21fcb34a 110
952ffbef
ER
111%prep
112%setup -q -n %{name}-%{archivever}
113
114# Remove provided binaries
3a5f3841 115# find -name '*.jar' | xargs rm -v
d57efde4 116find -name '*.class' | xargs rm -v
952ffbef 117
3a5f3841 118%patch0 -p1
119
120cp %SOURCE1 build.properties
121
952ffbef 122%build
d57efde4 123export JAVA_HOME=%{java_home}
952ffbef 124
3a5f3841 125CLASSPATH=$(build-classpath ecj tools)
126export CLASSPATH
127%ant dist
952ffbef
ER
128
129%install
952ffbef
ER
130rm -rf $RPM_BUILD_ROOT
131### Jar files
952ffbef
ER
132install -d $RPM_BUILD_ROOT%{_javadir}/%{name}
133
134cd build/lib
d57efde4 135install axis.jar axis-ant.jar saaj.jar jaxrpc.jar \
21fcb34a 136 $RPM_BUILD_ROOT%{_javadir}/%{name}
952ffbef
ER
137cd -
138
139cd $RPM_BUILD_ROOT%{_javadir}/%{name}
21fcb34a
JB
140for jar in *.jar ; do
141 vjar=$(echo $jar | sed s+.jar+-%{version}.jar+g)
142 mv $jar $vjar
143 ln -fs $vjar $jar
144done
952ffbef
ER
145cd -
146
147### Javadoc
952ffbef 148install -d $RPM_BUILD_ROOT%{_javadocdir}/%{name}-%{version}
d57efde4
ER
149cp -a build/javadocs/* $RPM_BUILD_ROOT%{_javadocdir}/%{name}-%{version}
150ln -s %{name}-%{version} $RPM_BUILD_ROOT%{_javadocdir}/%{name} # ghost symlink
952ffbef
ER
151
152%clean
153rm -rf $RPM_BUILD_ROOT
154
155%post javadoc
d57efde4 156ln -nfs %{name}-%{version} %{_javadocdir}/%{name}
952ffbef
ER
157
158%files
159%defattr(644,root,root,755)
160%doc LICENSE README release-notes.html changelog.html
161%dir %{_javadir}/%{name}
162%{_javadir}/%{name}/*.jar
163
164%files javadoc
165%defattr(644,root,root,755)
d57efde4
ER
166%{_javadocdir}/%{name}-%{version}
167%ghost %{_javadocdir}/%{name}
952ffbef
ER
168
169%files manual
170%defattr(644,root,root,755)
171%doc docs/*
This page took 0.072518 seconds and 4 git commands to generate.