]> git.pld-linux.org Git - packages/axis-c.git/blob - axis-c.spec
a5663a5dac0d2e871d287460031916059b7e7f92
[packages/axis-c.git] / axis-c.spec
1 # TODO:
2 # - look at examples. maybe package it, or simply include in -examples?
3 %define         fversion        %(echo %{version} |tr . -)
4 Summary:        WebServices - Axis
5 Summary(pl):    WebServices - Axis
6 Name:           axis-c
7 Version:        1.2
8 Release:        1
9 License:        Apache Software License
10 Group:          Libraries
11 Source0:        http://www.apache.org/dist/ws/axis-c/source/linux/%{name}-src-%{fversion}-linux.tar.gz
12 # Source0-md5:  9c68ba2f2d8029aed0694881bc2f491b
13 URL:            http://ws.apache.org/axis/
14 BuildRequires:  apr-util-devel
15 BuildRequires:  apr-devel
16 BuildRequires:  apache-devel
17 BuildRequires:  autoconf
18 BuildRequires:  automake
19 BuildRequires:  libtool
20 BuildRequires:  expat-devel
21 BuildRequires:  xerces-c-devel
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 Apache Axis is an implementation of the SOAP ("Simple Object Access
26 Protocol") submission to W3C.
27
28 %description -l pl
29 Apache Axis jest implementacj± SOAP ("Simple Object Access Protocol")
30 przekazan± do W3C.
31
32 %package devel
33 Summary:        WebServices - Axis - development files
34 Summary(pl):    WebServices - Axis - pliki nag³ówkowe
35 Group:          Development/Libraries
36 Requires:       %{name} = %{version}-%{release}
37
38 %description devel
39 WebServices - Axis - development files.
40
41 %description devel -l pl
42 WebServices - Axis - pliki nag³ówkowe.
43
44 %package static
45 Summary:        WebServices - Axis - static files
46 Summary(pl):    WebServices - Axis - biblioteka statyczna
47 Group:          Development/Libraries
48 Requires:       %{name}-devel = %{version}-%{release}
49
50 %description static
51 WebServices - Axis - static files.
52
53 %description static -l pl
54 WebServices - Axis - biblioteka statyczna.
55
56 %prep
57 %setup -q -n %{name}-src-%{fversion}-linux
58 rm -rf include/expat
59 ln -sf %{_includedir} include/expat
60 ln -sf %{_includedir}/apache/* %{_includedir}/apr/* include/apache2_0
61
62 %build
63 %{__libtoolize}
64 %{__aclocal}
65 %{__autoconf}
66 %{__autoheader}
67 %{__automake}
68 CFLAGS="%{rpmcflags} -I`pwd`/include -I%{_includedir}/apr-util -I%{_includedir}/apr"
69 CXXFLAGS="%{rpmcflags} -I`pwd`/include -I%{_includedir}/apr-util -I%{_includedir}/apr"
70 %configure
71 %{__make} \
72         AXISCPP_HOME="`pwd`"
73
74 %install
75 rm -rf $RPM_BUILD_ROOT
76 install -d $RPM_BUILD_ROOT%{_includedir}
77 %{__make} install \
78         DESTDIR=$RPM_BUILD_ROOT
79
80 cp -r include/axis $RPM_BUILD_ROOT%{_includedir}
81
82 %clean
83 rm -rf $RPM_BUILD_ROOT
84
85 %post   -p /sbin/ldconfig
86 %postun -p /sbin/ldconfig
87
88 %files
89 %defattr(644,root,root,755)
90 %doc LICENSE NOTICE docs/TODO.txt docs/linux docs/*.html
91 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
92
93 %files devel
94 %defattr(644,root,root,755)
95 %doc docs/apidocs/html docs/RFC/* docs/QnA/*
96 %{_libdir}/lib*.la
97 %attr(755,root,root) %{_libdir}/lib*.so
98 %{_includedir}/axis
99
100 %files static
101 %defattr(644,root,root,755)
102 %{_libdir}/lib*.a
This page took 0.046216 seconds and 2 git commands to generate.