]> git.pld-linux.org Git - packages/awscli.git/commitdiff
up to 1.25.2 auto/th/awscli-1.25.2-1
authorJan Palus <atler@pld-linux.org>
Mon, 6 Jun 2022 10:41:51 +0000 (12:41 +0200)
committerJan Palus <atler@pld-linux.org>
Mon, 6 Jun 2022 10:41:51 +0000 (12:41 +0200)
awscli-relax_deps.patch
awscli.spec

index dc62d2a0d0ecc1c977f1dd15dcf749e162b820f3..6336481b1a7591d1d34470b8c88af84a51bfce98 100644 (file)
@@ -4,10 +4,10 @@ diff --color -ur awscli-1.22.21.orig/setup.cfg awscli-1.22.21/setup.cfg
 @@ -4,10 +4,10 @@
  [metadata]
  requires_dist = 
-       botocore==1.25.9
--      docutils>=0.10,<0.16
+       botocore==1.27.2
+-      docutils>=0.10,<0.17
 +      docutils>=0.10
-       s3transfer>=0.5.0,<0.6.0
+       s3transfer>=0.6.0,<0.7.0
        PyYAML>=3.10,<5.5
 -      colorama>=0.2.5,<0.4.5
 +      colorama>=0.2.5
@@ -20,10 +20,10 @@ diff --color -ur awscli-1.22.21.orig/setup.py awscli-1.22.21/setup.py
 @@ -25,10 +25,10 @@
  
  install_requires = [
-     'botocore==1.25.9',
--    'docutils>=0.10,<0.16',
+     'botocore==1.27.2',
+-    'docutils>=0.10,<0.17',
 +    'docutils>=0.10',
-     's3transfer>=0.5.0,<0.6.0',
+     's3transfer>=0.6.0,<0.7.0',
      'PyYAML>=3.10,<5.5',
 -    'colorama>=0.2.5,<0.4.5',
 +    'colorama>=0.2.5',
index 555e7b39215957297cc30ea0bb6017b916a703fe..5147b277b8fad4c014a4b712e12d476aae8e694e 100644 (file)
@@ -3,12 +3,12 @@
 %define                pypi_name       awscli
 Summary:       Universal Command Line Environment for AWS
 Name:          awscli
-Version:       1.23.9
+Version:       1.25.2
 Release:       1
 License:       ASL 2.0 and MIT
 Group:         Applications/Networking
 Source0:       https://files.pythonhosted.org/packages/source/a/awscli/%{name}-%{version}.tar.gz
-# Source0-md5: d7558233cd42ed7005d0b6eb67cef8d4
+# Source0-md5: 233e803b9074fcc0907afc75bd00ed6a
 Patch0:                %{name}-relax_deps.patch
 URL:           https://aws.amazon.com/cli/
 BuildRequires: rpm-pythonprov
@@ -27,12 +27,12 @@ Services.
 Summary:       Python 3 package for awscli
 Group:         Libraries/Python
 Requires:      python3-PyYAML >= 3.10
-Requires:      python3-botocore >= 1.23.33
+Requires:      python3-botocore >= 1.27.2
 Requires:      python3-colorama >= 0.2.5
 Requires:      python3-docutils >= 0.10
 Requires:      python3-modules >= 1:3.6
 Requires:      python3-rsa >= 3.1.2
-Requires:      python3-s3transfer >= 0.5
+Requires:      python3-s3transfer >= 0.6.0
 Obsoletes:     python-awscli < 1.20.40
 
 %description -n python3-%{pypi_name}
This page took 0.172582 seconds and 4 git commands to generate.