]> git.pld-linux.org Git - packages/awscli.git/blob - awscli.spec
- updated to 1.25.97
[packages/awscli.git] / awscli.spec
1 %define         module          awscli
2 %define         egg_name        awscli
3 %define         pypi_name       awscli
4 Summary:        Universal Command Line Environment for AWS
5 Summary(pl.UTF-8):      Uniwersalne środowisko linii polecen dla AWS
6 Name:           awscli
7 Version:        1.25.97
8 Release:        1
9 License:        ASL 2.0 and MIT
10 Group:          Applications/Networking
11 Source0:        https://files.pythonhosted.org/packages/source/a/awscli/%{name}-%{version}.tar.gz
12 # Source0-md5:  d6c22af249563d28b471bec4c60be82a
13 Patch0:         %{name}-relax_deps.patch
14 URL:            https://aws.amazon.com/cli/
15 BuildRequires:  python3-modules >= 1:3.7
16 BuildRequires:  python3-setuptools
17 BuildRequires:  rpm-pythonprov
18 BuildRequires:  rpmbuild(macros) >= 1.719
19 Requires:       python3-%{pypi_name} = %{version}
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 This package provides a unified command line interface to Amazon Web
25 Services.
26
27 %description -l pl.UTF-8
28 Ten pakiet dostarcza ujednolicony interfejs linii poleceń do usług
29 Amazon Web Services.
30
31 %package -n python3-%{pypi_name}
32 Summary:        Python 3 package for awscli
33 Summary(pl.UTF-8):      Pakiet Pythona 3 do awscli
34 Group:          Libraries/Python
35 Requires:       python3-modules >= 1:3.6
36 Obsoletes:      python-awscli < 1.20.40
37
38 %description -n python3-%{pypi_name}
39 Python 3 package for awscli.
40
41 %description -n python3-%{pypi_name} -l pl.UTF-8
42 Pakiet Pythona 3 do awscli.
43
44 %prep
45 %setup -q
46 %patch0 -p1
47
48 %{__rm} -r %{name}.egg-info
49
50 %build
51 %py3_build
52
53 %install
54 rm -rf $RPM_BUILD_ROOT
55 %py3_install
56
57 # We don't need the Windows CMD script
58 %{__rm} $RPM_BUILD_ROOT%{_bindir}/aws.cmd
59
60 # Fix path and permissions for bash completition
61 install -d $RPM_BUILD_ROOT%{bash_compdir}
62 %{__mv} $RPM_BUILD_ROOT%{_bindir}/aws_bash_completer $RPM_BUILD_ROOT%{bash_compdir}
63 # Fix path and permissions for zsh completition
64 install -d $RPM_BUILD_ROOT%{zsh_compdir}
65 %{__mv} $RPM_BUILD_ROOT%{_bindir}/aws_zsh_completer.sh $RPM_BUILD_ROOT%{zsh_compdir}
66
67 %clean
68 rm -rf $RPM_BUILD_ROOT
69
70 %files
71 %defattr(644,root,root,755)
72 %doc README.rst LICENSE.txt
73 %attr(755,root,root) %{_bindir}/aws
74 %attr(755,root,root) %{_bindir}/aws_completer
75 %{bash_compdir}/aws_bash_completer
76 %{zsh_compdir}/aws_zsh_completer.sh
77
78 %files -n python3-%{pypi_name}
79 %defattr(644,root,root,755)
80 %{py3_sitescriptdir}/%{module}
81 %{py3_sitescriptdir}/%{egg_name}-%{version}-py*.egg-info
This page took 0.569738 seconds and 4 git commands to generate.