]> git.pld-linux.org Git - packages/awscli.git/blame - awscli.spec
new, version 1.15.2
[packages/awscli.git] / awscli.spec
CommitLineData
9611de34
ER
1#
2# Conditional build:
3%bcond_without python2 # CPython 2.x module
4%bcond_without python3 # CPython 3.x module
5
6%define module awscli
7%define egg_name awscli
8%define pypi_name awscli
9Summary: Universal Command Line Environment for AWS
10Name: awscli
11Version: 1.15.2
12Release: 1
13License: ASL 2.0 and MIT
14Group: Applications/Networking
15Source0: https://pypi.io/packages/source/a/awscli/%{name}-%{version}.tar.gz
16# Source0-md5: 8800e388fd08a96a7b1f2ab478551bc6
17URL: http://aws.amazon.com/cli
18BuildRequires: rpm-pythonprov
19BuildRequires: rpmbuild(macros) >= 1.719
20%if %{with python2}
21BuildRequires: python3-modules
22BuildRequires: python3-setuptools
23%endif
24%if %{with python3}
25BuildRequires: python-modules
26BuildRequires: python-setuptools
27%endif
28BuildArch: noarch
29BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31%description
32This package provides a unified command line interface to Amazon Web
33Services.
34
35%package -n python-%{pypi_name}
36Summary: Python 2 package for awscli
37Group: Libraries/Python
38Requires: python-PyYAML >= 3.10
39Requires: python-botocore = 1.9.1
40Requires: python-colorama >= 0.2.5
41Requires: python-docutils >= 0.10
42Requires: python-modules
43Requires: python-rsa >= 3.1.2
44Requires: python-s3transfer >= 0.1.9
45
46%description -n python-%{pypi_name}
47Python 2 package for awscli.
48
49%package -n python3-%{pypi_name}
50Summary: Python 3 package for awscli
51Group: Libraries/Python
52Requires: python3-PyYAML >= 3.10
53Requires: python3-botocore = 1.9.1
54Requires: python3-colorama >= 0.2.5
55Requires: python3-docutils >= 0.10
56Requires: python3-modules
57Requires: python3-rsa >= 3.1.2
58Requires: python3-s3transfer >= 0.1.9
59
60%description -n python3-%{pypi_name}
61Python 3 package for awscli.
62
63%prep
64%setup -q
65
66rm -r %{name}.egg-info
67
68%build
69%if %{with python3}
70%py_build
71%endif
72%if %{with python3}
73%py3_build
74%endif
75
76%install
77rm -rf $RPM_BUILD_ROOT
78%if %{with python2}
79%py_install
80%py_postclean
81%endif
82%if %{with python3}
83%py3_install
84%endif
85
86# We don't need the Windows CMD script
87rm $RPM_BUILD_ROOT%{_bindir}/aws.cmd
88
89# Fix path and permissions for bash completition
90install -d $RPM_BUILD_ROOT%{bash_compdir}
91mv $RPM_BUILD_ROOT%{_bindir}/aws_bash_completer $RPM_BUILD_ROOT%{bash_compdir}
92# Fix path and permissions for zsh completition
93install -d $RPM_BUILD_ROOT%{zsh_compdir}
94mv $RPM_BUILD_ROOT%{_bindir}/aws_zsh_completer.sh $RPM_BUILD_ROOT%{zsh_compdir}
95
96%clean
97rm -rf $RPM_BUILD_ROOT
98
99%files
100%defattr(644,root,root,755)
101%doc README.rst LICENSE.txt
102%attr(755,root,root) %{_bindir}/aws
103%attr(755,root,root) %{_bindir}/aws_completer
104%{bash_compdir}/aws_bash_completer
105%{zsh_compdir}/aws_zsh_completer.sh
106
107%if %{with python2}
108%files -n python-%{pypi_name}
109%defattr(644,root,root,755)
110%{py_sitescriptdir}/%{module}
111%{py_sitescriptdir}/%{egg_name}-%{version}-py*.egg-info
112%endif
113
114%if %{with python3}
115%files -n python3-%{pypi_name}
116%defattr(644,root,root,755)
117%{py3_sitescriptdir}/%{module}
118%{py3_sitescriptdir}/%{egg_name}-%{version}-py*.egg-info
119%endif
This page took 0.095376 seconds and 4 git commands to generate.