]> git.pld-linux.org Git - packages/avscan.git/commitdiff
- new auto/th/avscan-5.1.1-1
authorJakub Bogusz <qboosh@pld-linux.org>
Sat, 8 Feb 2014 18:57:45 +0000 (19:57 +0100)
committerJakub Bogusz <qboosh@pld-linux.org>
Sat, 8 Feb 2014 18:57:45 +0000 (19:57 +0100)
avscan-verbose.patch [new file with mode: 0644]
avscan.spec [new file with mode: 0644]

diff --git a/avscan-verbose.patch b/avscan-verbose.patch
new file mode 100644 (file)
index 0000000..ebd54b0
--- /dev/null
@@ -0,0 +1,52 @@
+--- avscan-5.1.1-openssl/Makefile.orig 2009-04-07 02:00:00.000000000 +0200
++++ avscan-5.1.1-openssl/Makefile      2014-02-08 09:32:50.727904846 +0100
+@@ -40,7 +40,7 @@
+ #
+ all config:
+       @for subdir in $(ALL_SRC_DIRS); do                      \
+-            $(MAKE) -s -C $$subdir -f Makefile $@;            \
++            $(MAKE) -C $$subdir -f Makefile $@;               \
+         done
+       @echo "To install, type \"su\" (to gain root privileges)\
+ and then type \"make install\"."
+@@ -50,7 +50,7 @@
+ #
+ install:
+       @for subdir in $(ALL_SRC_DIRS); do                      \
+-            $(MAKE) -s -C $$subdir -f Makefile $@;            \
++            $(MAKE) -C $$subdir -f Makefile $@;               \
+         done
+       @echo "Installation complete."
+@@ -59,5 +59,5 @@
+ #
+ clean:
+       @for subdir in $(ALL_SRC_DIRS); do                      \
+-            $(MAKE) -s -C $$subdir -f Makefile $@;            \
++            $(MAKE) -C $$subdir -f Makefile $@;               \
+         done
+--- avscan-5.1.1-openssl/avscan/Makefile.orig  2009-04-07 02:00:00.000000000 +0200
++++ avscan-5.1.1-openssl/avscan/Makefile       2014-02-08 09:33:46.621235835 +0100
+@@ -51,11 +51,9 @@
+ OBJ_C = $(SRC_C:.c=.o)
+ OBJ_CPP       = $(SRC_CPP:.cpp=.o)
+ .c.o:
+-      @echo "Compiling module $*.o"
+-      @+$(CC) -c $*.c $(INC_DIRS) $(CFLAGS)
++      $(CC) -c $*.c $(INC_DIRS) $(CFLAGS)
+ .cpp.o:
+-      @echo "Compiling module $*.o"
+-      @+$(CPP) -c $*.cpp $(INC_DIRS) $(CFLAGS) $(CPPFLAGS)
++      $(CPP) -c $*.cpp $(INC_DIRS) $(CFLAGS) $(CPPFLAGS)
+ $(BIN): prebuild config modules postbuild
+@@ -66,7 +64,7 @@
+ modules: $(OBJ_C) $(OBJ_CPP)
+       @echo -n "Linking modules..."
+-      @$(CPP) $(OBJ_C) $(OBJ_CPP) -o $(BIN) $(LIB_DIRS) $(LIBS)
++      $(CPP) $(OBJ_C) $(OBJ_CPP) -o $(BIN) $(LIB_DIRS) $(LIBS)
+       @echo -n "   "
+       @-$(LS) $(LSFLAGS) $(BIN)
diff --git a/avscan.spec b/avscan.spec
new file mode 100644 (file)
index 0000000..ee78e78
--- /dev/null
@@ -0,0 +1,72 @@
+Summary:       AntiVirus Scanner
+Summary(pl.UTF-8):     Skaner antywirusowy
+Name:          avscan
+Version:       5.1.1
+Release:       1
+License:       GPL v2 with OpenSSL exception
+Group:         X11/Applications
+Source0:       http://wolfsinger.com/~wolfpack/packages/%{name}-%{version}-openssl.tar.bz2
+# Source0-md5: e8e76867fbdf4ddef9504b604db95667
+Patch0:                %{name}-verbose.patch
+URL:           http://freecode.com/projects/avscan
+BuildRequires: clamav-devel
+BuildRequires: endeavour-devel >= 3
+BuildRequires: gtk+-devel >= 1.2
+BuildRequires: libstdc++-devel
+Requires:      endeavour >= 3
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%description
+AVScan is an anti-virus scanner that uses the ClamAV library
+(libclamav) and GTK+ 1.2. It allows you to create a list of scan items
+for frequently scanned locations and features on-demand virus database
+updating, manual drag and drop object scanning, and pausing and
+resuming of scanning, all in a simple GUI environment.
+
+%description -l pl.UTF-8
+AVScan to skaner antywirusowy wykorzystujący bibliotekę narzędzia
+ClamAV (libclamav) oraz GTK+ 1.2. Pozwala na tworzenie list elementów
+do regularnego skanowania, umożliwia uaktualnianie na żądanie bazy
+danych wirusów, ręczne przeciąganie obiektów do przeskanowania,
+zatrzymywanie i wznawianie skanowania - wszystko w prostym środowisku
+graficznym.
+
+%prep
+%setup -q -n %{name}-%{version}-openssl
+%patch0 -p1
+
+%build
+./configure Linux
+%{__make} \
+       CC="%{__cc}" \
+       CPP="%{__cxx}" \
+       CFLAGS="%{rpmcflags} -Wall \
+               `gtk-config --cflags` \
+               -DHAVE_CLAMAV `clamav-config --cflags` \
+               -DHAVE_LIBENDEAVOUR2 `endeavour2-base-config --cflags`"
+
+%install
+rm -rf $RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT%{_bindir}
+
+%{__make} install \
+       PREFIX=$RPM_BUILD_ROOT%{_prefix} \
+       EDV_BIN_DIR=$RPM_BUILD_ROOT%{_libdir}/endeavour2/bin \
+       MAN_DIR=$RPM_BUILD_ROOT%{_mandir}/man1 \
+       INSTBINFLAGS="-m755"
+
+# fix symlink to buildroot
+ln -sf ../%{_lib}/endeavour2/bin/avscan $RPM_BUILD_ROOT%{_bindir}/avscan
+
+bzip2 -d $RPM_BUILD_ROOT%{_mandir}/man1/*.bz2
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files
+%defattr(644,root,root,755)
+%doc AUTHORS LICENSE README
+%attr(755,root,root) %{_bindir}/avscan
+%attr(755,root,root) %{_libdir}/endeavour2/bin/avscan
+%{_datadir}/endeavour2/help/avscan
+%{_mandir}/man1/avscan.1*
This page took 0.116371 seconds and 4 git commands to generate.