]> git.pld-linux.org Git - packages/avogadro.git/blobdiff - avogadro.spec
- missing BRs
[packages/avogadro.git] / avogadro.spec
index c8a44833d32f5df2d1dc4a2e7937d2445c957fe4..ad59c031135827df101007c6f93af9814ada04c3 100644 (file)
@@ -1,23 +1,34 @@
+
+%define                qtver   4.7.0
+
 Summary:       An advanced molecular editor for chemical purposes
 Name:          avogadro
-Version:       1.0.0
-Release:       0.1
+Version:       1.0.1
+Release:       4
 License:       GPL v2
 Group:         Applications/Editors
-URL:           http://avogadro.openmolecules.net/
 Source0:       http://downloads.sourceforge.net/avogadro/%{name}-%{version}.tar.bz2
+# Source0-md5: 0d5c391197101f0aab7be6b59f81e6fd
 # fix build with sip 4.10
-Patch0:                %{name}-sip.patch
+URL:           http://avogadro.openmolecules.net/
+Patch0:                %{name}-python2.7.patch
+Patch1:                %{name}-linguist.patch
+Patch2:                %{name}-cmake.patch
+Patch3:                %{name}-sipfix.patch
+BuildRequires: QtNetwork-devel
+BuildRequires: QtOpenGL-devel
 BuildRequires: boost-devel >= 1.35
-BuildRequires: cmake >= 2.6.0
+BuildRequires: boost-python-devel
+BuildRequires: cmake >= 2.8.0
 BuildRequires: desktop-file-utils
 BuildRequires: docbook-utils
-BuildRequires: eigen2-devel >= 2.0.3
+BuildRequires: eigen >= 1:2.0.12
 BuildRequires: glew-devel >= 1.5.0
-BuildRequires: numpy
+BuildRequires: python-numpy-devel
 BuildRequires: openbabel-devel >= 2.2.2
-BuildRequires: qt4-build >= 4.5.1
-BuildRequires: sip-devel
+BuildRequires: qt4-build >= %{qtver}
+BuildRequires: qt4-qmake >= %{qtver}
+BuildRequires: sip
 Requires:      %{name}-libs = %{version}-%{release}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -27,7 +38,6 @@ computational chemistry, molecular modeling, bioinformatics, materials
 science, and related areas, which offers flexible rendering and a
 powerful plugin architecture.
 
-
 %package libs
 Summary:       Shared libraries for Avogadro
 Group:         Libraries
@@ -40,7 +50,6 @@ Avogadro.
 Summary:       Development files for Avogadro
 Group:         Development/Libraries
 Requires:      %{name}-libs = %{version}-%{release}
-Requires:
 
 %description devel
 This package contains files to develop applications using Avogadros
@@ -48,13 +57,15 @@ libraries.
 
 %prep
 %setup -q
-%patch0 -p1 -b .sip410
-
+%patch0 -p0
+%patch1 -p0
+%patch2 -p1
+%patch3 -p0
 
 %build
 install -d build
 cd build
-%{cmake} \
+%cmake \
        -DENABLE_GLSL=ON \
        -DENABLE_PYTHON=ON \
        -DENABLE_UPDATE_CHECKER=OFF \
@@ -62,29 +73,20 @@ cd build
        -DCMAKE_INSTALL_PREFIX=%{_prefix} \
        -DLIB_INSTALL_DIR=%{_libdir} \
        ..
-cd ..
-%{__make} -C %{_target_platform}
 
+%{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
-%{__make} install DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
-
-# system menu entry
-desktop-file-install --vendor=""                 \
-  --dir=$RPM_BUILD_ROOT%{_desktopdir}  \
-  $RPM_BUILD_ROOT%{_desktopdir}/avogadro.desktop
-
+%{__make} -C build install \
+       DESTDIR=$RPM_BUILD_ROOT
 
 %post libs -p /sbin/ldconfig
-
 %postun libs -p /sbin/ldconfig
 
-
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-
 %files
 %defattr(644,root,root,755)
 %doc AUTHORS ChangeLog COPYING
@@ -93,16 +95,14 @@ rm -rf $RPM_BUILD_ROOT
 %{_pixmapsdir}/%{name}-icon.png
 %{_desktopdir}/%{name}.desktop
 
-
 %files devel
 %defattr(644,root,root,755)
 %{_datadir}/lib%{name}
 %{_includedir}/%{name}
 %{_libdir}/*.so
 
-
 %files libs
 %defattr(644,root,root,755)
-%{py_sitedir}/Avogadro.so
+%{_datadir}/python*/site-packages/Avogadro.so
 %{_libdir}/%{name}
 %attr(755,root,root) %{_libdir}/*.so.*
This page took 0.085007 seconds and 4 git commands to generate.