]> git.pld-linux.org Git - packages/avogadro.git/blame - avogadro.spec
- fix sip compilation
[packages/avogadro.git] / avogadro.spec
CommitLineData
4d9dc8e3 1
0bfdc0c5 2%define qtver 4.7.0
4d9dc8e3 3
638a5511
AM
4Summary: An advanced molecular editor for chemical purposes
5Name: avogadro
0bfdc0c5 6Version: 1.0.1
57ad39c7 7Release: 2
638a5511
AM
8License: GPL v2
9Group: Applications/Editors
638a5511 10Source0: http://downloads.sourceforge.net/avogadro/%{name}-%{version}.tar.bz2
0bfdc0c5 11# Source0-md5: 0d5c391197101f0aab7be6b59f81e6fd
638a5511 12# fix build with sip 4.10
4d9dc8e3 13URL: http://avogadro.openmolecules.net/
0bfdc0c5 14Patch0: %{name}-python2.7.patch
5654b505 15Patch1: %{name}-linguist.patch
6e530d33 16Patch2: %{name}-cmake.patch
57ad39c7 17Patch3: %{name}-sipfix.patch
638a5511 18BuildRequires: boost-devel >= 1.35
4d9dc8e3 19BuildRequires: cmake >= 2.8.0
638a5511
AM
20BuildRequires: desktop-file-utils
21BuildRequires: docbook-utils
4d9dc8e3 22BuildRequires: eigen >= 1:2.0.12
638a5511 23BuildRequires: glew-devel >= 1.5.0
53ea67fc 24BuildRequires: python-numpy-devel
638a5511 25BuildRequires: openbabel-devel >= 2.2.2
4d9dc8e3 26BuildRequires: qt4-build >= %{qtver}
27BuildRequires: qt4-qmake >= %{qtver}
28BuildRequires: sip
638a5511
AM
29Requires: %{name}-libs = %{version}-%{release}
30BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32%description
33An advanced molecular editor designed for cross-platform use in
34computational chemistry, molecular modeling, bioinformatics, materials
35science, and related areas, which offers flexible rendering and a
36powerful plugin architecture.
37
638a5511
AM
38%package libs
39Summary: Shared libraries for Avogadro
40Group: Libraries
41
42%description libs
43This package contains the shared libraries for the molecular editor
44Avogadro.
45
46%package devel
47Summary: Development files for Avogadro
48Group: Development/Libraries
49Requires: %{name}-libs = %{version}-%{release}
638a5511
AM
50
51%description devel
52This package contains files to develop applications using Avogadros
53libraries.
54
55%prep
56%setup -q
0bfdc0c5 57%patch0 -p0
5654b505 58%patch1 -p0
6e530d33 59%patch2 -p1
57ad39c7 60%patch3 -p0
638a5511 61
638a5511
AM
62%build
63install -d build
64cd build
4d9dc8e3 65%cmake \
638a5511
AM
66 -DENABLE_GLSL=ON \
67 -DENABLE_PYTHON=ON \
68 -DENABLE_UPDATE_CHECKER=OFF \
69 -DCMAKE_BUILD_TYPE=Release \
70 -DCMAKE_INSTALL_PREFIX=%{_prefix} \
71 -DLIB_INSTALL_DIR=%{_libdir} \
72 ..
5654b505 73
74%{__make}
638a5511 75
638a5511
AM
76%install
77rm -rf $RPM_BUILD_ROOT
5654b505 78%{__make} -C build install \
79 DESTDIR=$RPM_BUILD_ROOT
638a5511 80
638a5511 81%post libs -p /sbin/ldconfig
638a5511
AM
82%postun libs -p /sbin/ldconfig
83
638a5511
AM
84%clean
85rm -rf $RPM_BUILD_ROOT
86
638a5511
AM
87%files
88%defattr(644,root,root,755)
89%doc AUTHORS ChangeLog COPYING
90%attr(755,root,root) %{_bindir}/%{name}
91%{_datadir}/%{name}
92%{_pixmapsdir}/%{name}-icon.png
93%{_desktopdir}/%{name}.desktop
94
638a5511
AM
95%files devel
96%defattr(644,root,root,755)
97%{_datadir}/lib%{name}
98%{_includedir}/%{name}
99%{_libdir}/*.so
100
638a5511
AM
101%files libs
102%defattr(644,root,root,755)
55c00b95 103%{_datadir}/python*/site-packages/Avogadro.so
638a5511
AM
104%{_libdir}/%{name}
105%attr(755,root,root) %{_libdir}/*.so.*
This page took 0.049685 seconds and 4 git commands to generate.