]> git.pld-linux.org Git - packages/avifile.git/commitdiff
ac 2.50 fixes avifile-0_6-0_20010713_1
authorArtur Frysiak <artur@frysiak.net>
Mon, 16 Jul 2001 16:01:22 +0000 (16:01 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    avifile-ac250.patch -> 1.1
    avifile.spec -> 1.54

avifile-ac250.patch [new file with mode: 0644]
avifile.spec

diff --git a/avifile-ac250.patch b/avifile-ac250.patch
new file mode 100644 (file)
index 0000000..b316ca5
--- /dev/null
@@ -0,0 +1,95 @@
+--- avifile-0.6/plugins/libffmpeg/libavcodec/Makefile.am.wiget Mon Jul 16 16:02:37 2001
++++ avifile-0.6/plugins/libffmpeg/libavcodec/Makefile.am       Mon Jul 16 16:02:37 2001
+@@ -1,14 +1,15 @@
+ noinst_LTLIBRARIES = libavcodec.la
+-I386_SOURCE_FILES = 386/fdct_mmx.s i386/fdctdata.s i386/sad_mmx.s
++I386_SOURCE_FILES_C = i386/fdctdata.c
++I386_SOURCE_FILES_S = i386/fdct_mmx.s i386/sad_mmx.s
+ libavcodec_la_SOURCES = common.c utils.c mpegvideo.c h263.c jrevdct.c \
+       jfdctfst.c mpegaudio.c ac3enc.c mjpegenc.c resample.c dsputil.c \
+       motion_est.c imgconvert.c imgresample.c msmpeg4.c \
+-      mpeg12.c h263dec.c mpegaudiodec.c $(I386_SOURCE_FILES)
++      mpeg12.c h263dec.c mpegaudiodec.c 
+ libavcodec_la_LDFLAGS = -module
+-
++libavcodec_la_LIBADD = $(patsubst %.c, %.o, $(I386_SOURCE_FILES_C)) $(patsubst %.s, %.o, $(I386_SOURCE_FILES_S))
+ LIBS =
+ # i386 specific stuff
+@@ -16,5 +17,5 @@
+ # SSE can also be added
+ #CFLAGS += -DCONFIG_SSE
+-#%.o: %.s
+-#     nasm -f elf -o $@ $<
++%.o: %.s
++      nasm -f elf -o $@ $<
+--- avifile-0.6/acinclude.m4.wiget     Mon Jul 16 16:03:09 2001
++++ avifile-0.6/acinclude.m4   Mon Jul 16 16:04:20 2001
+@@ -415,8 +415,8 @@
+ AC_CACHE_VAL(ac_cv_have_x,
+ [# One or both of the vars are not set, and there is no cached value.
+ ac_x_includes=NO ac_x_libraries=NO
+-AC_PATH_X_DIRECT
+-AC_PATH_X_XMKMF
++_AC_PATH_X_DIRECT
++_AC_PATH_X_XMKMF
+ if test "$ac_x_includes" = NO || test "$ac_x_libraries" = NO; then
+   AC_MSG_ERROR([Can't find X includes. Please check your installation and add the correct paths!])
+ else
+@@ -1662,52 +1662,6 @@
+ AC_SUBST($1)dnl
+ ])
+-
+-# Check whether LC_MESSAGES is available in <locale.h>.
+-# Ulrich Drepper <drepper@cygnus.com>, 1995.
+- 
+-# serial 1
+- 
+-AC_DEFUN(AM_LC_MESSAGES,
+-  [if test $ac_cv_header_locale_h = yes; then
+-    AC_CACHE_CHECK([for LC_MESSAGES], am_cv_val_LC_MESSAGES,
+-      [AC_TRY_LINK([#include <locale.h>], [return LC_MESSAGES],
+-       am_cv_val_LC_MESSAGES=yes, am_cv_val_LC_MESSAGES=no)])
+-    if test $am_cv_val_LC_MESSAGES = yes; then
+-      AC_DEFINE(HAVE_LC_MESSAGES)
+-    fi
+-  fi])
+- 
+-dnl From Jim Meyering.
+-dnl FIXME: migrate into libit.
+-
+-AC_DEFUN(AM_FUNC_OBSTACK,
+-[AC_CACHE_CHECK([for obstacks], am_cv_func_obstack,
+- [AC_TRY_LINK([#include "obstack.h"],
+-            [struct obstack *mem;obstack_free(mem,(char *) 0)],
+-            am_cv_func_obstack=yes,
+-            am_cv_func_obstack=no)])
+- if test $am_cv_func_obstack = yes; then
+-   AC_DEFINE(HAVE_OBSTACK)
+- else
+-   LIBOBJS="$LIBOBJS obstack.o"
+- fi
+-])
+-
+-dnl From Jim Meyering.  Use this if you use the GNU error.[ch].
+-dnl FIXME: Migrate into libit
+-
+-AC_DEFUN(AM_FUNC_ERROR_AT_LINE,
+-[AC_CACHE_CHECK([for error_at_line], am_cv_lib_error_at_line,
+- [AC_TRY_LINK([],[error_at_line(0, 0, "", 0, "");],
+-              am_cv_lib_error_at_line=yes,
+-            am_cv_lib_error_at_line=no)])
+- if test $am_cv_lib_error_at_line = no; then
+-   LIBOBJS="$LIBOBJS error.o"
+- fi
+- AC_SUBST(LIBOBJS)dnl
+-])
+-
+ # Macro to add for using GNU gettext.
+ # Ulrich Drepper <drepper@cygnus.com>, 1995.
index c604f85463396a223d2efdb01cf85ea7503c4360..23bb6c7068d77010ccc1a359a95772dbb1352a88 100644 (file)
@@ -15,6 +15,7 @@ Patch1:               %{name}-deplib.patch
 Patch2:                %{name}-ac3.patch
 Patch3:                %{name}-mga.patch
 Patch4:                %{name}-ffmpeg.patch
+Patch5:                %{name}-ac250.patch
 BuildRequires: XFree86-devel
 BuildRequires: SDL-devel >= 1.2.0
 BuildRequires: ac3dec-devel >= 0.6.1
@@ -60,12 +61,13 @@ libaviplay.
 %patch2 -p1
 %patch3 -p1
 %patch4 -p1
+%patch5 -p1 -b .wiget
 
 %build
-rm -f missing
+rm -f missing aclocal.m4
 libtoolize --copy --force
 aclocal
-autoconf
+autoconf || :
 automake -a -c --foreign
 %configure \
        --with-qt-includes=%{_includedir}/qt \
@@ -74,7 +76,6 @@ automake -a -c --foreign
        --disable-ffmpeg
 
 touch lib/dummy.cpp
-gcc -c plugins/libwin32/loader/stubs.s -o plugins/libwin32/loader/stubs.lo
 %{__make}
 
 %install
This page took 0.061072 seconds and 4 git commands to generate.