]> git.pld-linux.org Git - packages/avifile.git/commitdiff
9444afa31ad6101435dff2e70aaaba9c avifile-0.6-beta1-beta2.diff.gz
authorJan Rękorajski <baggins@pld-linux.org>
Thu, 25 Jan 2001 14:56:19 +0000 (14:56 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
289d4dd041d54024a2eda26d9badcb72  avifile-0.6.0-beta1.tar.gz
20700cfaca415aa495616f86b1473941  avifile-bitrate.patch
addf518a67b3ab495f79b6cbc66cd724  avifile-opt.patch
46e25ddb95b42f5ab41b040391913f5b  avifile-shareware.patch

Changed files:
    avifile-bitrate.patch -> 1.1
    avifile-opt.patch -> 1.1
    avifile-shareware.patch -> 1.1

avifile-bitrate.patch [new file with mode: 0644]
avifile-opt.patch [new file with mode: 0644]
avifile-shareware.patch [new file with mode: 0644]

diff --git a/avifile-bitrate.patch b/avifile-bitrate.patch
new file mode 100644 (file)
index 0000000..ed2a766
--- /dev/null
@@ -0,0 +1,19 @@
+--- avifile-0.6.0/plugins/libwin32/videocodec/Module.cpp~      Mon Jan 22 12:23:33 2001
++++ avifile-0.6.0/plugins/libwin32/videocodec/Module.cpp       Wed Jan 24 00:29:25 2001
+@@ -51,7 +51,7 @@
+           int newkey;
+           int bitrate;        
+           int count=4;
+-          if(RegOpenKeyExA(HKEY_CURRENT_USER, "Software\\LinuxLoader\\div3", 0, 0, &newkey)!=0)
++          if(RegOpenKeyExA(HKEY_CURRENT_USER, "Software\\LinuxLoader\\Div3", 0, 0, &newkey)!=0)
+           {
+ //            cerr<<"Could not open Divx key"<<endl;
+               goto no_reg;
+@@ -63,6 +63,7 @@
+               goto no_reg;
+           }    
+  
++          cout << "::module bitrate: " << bitrate << endl;
+           *(double*)((char*)_handle+0x14c0)=bitrate;
+           RegCloseKey(newkey);
+       no_reg:
diff --git a/avifile-opt.patch b/avifile-opt.patch
new file mode 100644 (file)
index 0000000..c912966
--- /dev/null
@@ -0,0 +1,101 @@
+diff -ur avifile-0.6.0.orig/configure.in avifile-0.6.0/configure.in
+--- avifile-0.6.0.orig/configure.in    Mon Jan 22 08:09:41 2001
++++ avifile-0.6.0/configure.in Wed Jan 24 16:42:49 2001
+@@ -79,11 +79,6 @@
+ AC_FUNC_VPRINTF
+ AC_CHECK_FUNCS(ftime gettimeofday strdup strstr)
+-dnl remove me
+-CFLAGS="$CFLAGS -march=i586"
+-
+-
+-
+ USE_QT=1
+ USE_QTRECOMP=1
+diff -ur avifile-0.6.0.orig/lib/aviplay/Makefile.am avifile-0.6.0/lib/aviplay/Makefile.am
+--- avifile-0.6.0.orig/lib/aviplay/Makefile.am Mon Jan 22 07:53:27 2001
++++ avifile-0.6.0/lib/aviplay/Makefile.am      Wed Jan 24 16:38:44 2001
+@@ -1,7 +1,7 @@
+ noinst_LTLIBRARIES=libaviplay.la
+ libaviplay_la_SOURCES=audio.cpp aviplay.cpp renderer.cpp aviplay2.cpp
+-CXXFLAGS=-march=i586 -I../../include @SDL_CFLAGS@ @X_INCLUDES@
++CXXFLAGS=-I../../include @SDL_CFLAGS@ @X_INCLUDES@
+ LIBS=
+ noinst_HEADERS=RegAccess.h audio.h aviplay2.h aviplay_impl.h
+diff -ur avifile-0.6.0.orig/lib/aviread/Makefile.am avifile-0.6.0/lib/aviread/Makefile.am
+--- avifile-0.6.0.orig/lib/aviread/Makefile.am Tue Jan 16 21:57:12 2001
++++ avifile-0.6.0/lib/aviread/Makefile.am      Wed Jan 24 16:38:59 2001
+@@ -1,6 +1,6 @@
+ noinst_LTLIBRARIES=libaviread.la
+ libaviread_la_SOURCES=asfinput.cpp AsfReadHandler.cpp AviReadHandler.cpp AviRead.cpp Cache.cpp
+ noinst_HEADERS=asfinput.h AsfReadHandler.h AviReadHandler.h AviRead.h Cache.h asffmt.h
+-CXXFLAGS=-I../../include -Wno-multichar -fno-omit-frame-pointer
++CXXFLAGS=-I../../include -Wno-multichar
+ LIBS=
+diff -ur avifile-0.6.0.orig/lib/common/Makefile.am avifile-0.6.0/lib/common/Makefile.am
+--- avifile-0.6.0.orig/lib/common/Makefile.am  Mon Jan 22 06:13:32 2001
++++ avifile-0.6.0/lib/common/Makefile.am       Wed Jan 24 16:39:14 2001
+@@ -1,4 +1,4 @@
+ noinst_LTLIBRARIES=libcommon.la
+ libcommon_la_SOURCES=mmx.cpp image.cpp impl_video.cpp impl_audio.cpp util.cpp ldt_keeper.cpp
+-CXXFLAGS=-I../../include -fno-exceptions -Os
++CXXFLAGS=-I../../include -fno-exceptions
+diff -ur avifile-0.6.0.orig/player/Makefile.am avifile-0.6.0/player/Makefile.am
+--- avifile-0.6.0.orig/player/Makefile.am      Thu Jan 18 01:30:20 2001
++++ avifile-0.6.0/player/Makefile.am   Wed Jan 24 16:39:43 2001
+@@ -29,7 +29,7 @@
+ DEFINES=
+ CXXFLAGS=-I../include @X_INCLUDES@ @QT_INCLUDES@ @SDL_CFLAGS@ \
+-    -DSHARE_PATH=\"@datadir@/avifile\" -DWIN32_PATH=\"@WIN32_PATH@\" -march=i586
++    -DSHARE_PATH=\"@datadir@/avifile\" -DWIN32_PATH=\"@WIN32_PATH@\"
+     
+ MOC=@MOC@
+ UIC=@UIC@
+diff -ur avifile-0.6.0.orig/plugins/libmp3lame_audioenc/lame3.70/Makefile.am avifile-0.6.0/plugins/libmp3lame_audioenc/lame3.70/Makefile.am
+--- avifile-0.6.0.orig/plugins/libmp3lame_audioenc/lame3.70/Makefile.am        Tue Jan 16 21:57:41 2001
++++ avifile-0.6.0/plugins/libmp3lame_audioenc/lame3.70/Makefile.am     Wed Jan 24 16:40:46 2001
+@@ -31,7 +31,7 @@
+         interface.c \
+         main.c 
+-CC_OPTS =  -O3 -fomit-frame-pointer -funroll-loops -ffast-math  -finline-functions -Wall
++CC_OPTS = -fomit-frame-pointer -funroll-loops -ffast-math  -finline-functions -Wall
+ # 10/99 added -D__NO_MATH_INLINES to fix a bug in *all* versions of
+ # gcc 2.8+ as of 10/99.  
+@@ -44,4 +44,4 @@
+ get_audio.h gpkplotting.h gtkanal.h huffman.h id3tag.h ieeefloat.h\
+ l3bitstream-pvt.h l3bitstream.h l3side.h lame.h machine.h mpg123.h\
+ mpglib.h newmdct.h portableio.h psymodel.h quantize-pvt.h quantize.h\
+-reservoir.h rtp.h tables.h timestatus.h util.h version.h 
+\ No newline at end of file
++reservoir.h rtp.h tables.h timestatus.h util.h version.h 
+diff -ur avifile-0.6.0.orig/plugins/libmpeg_audiodec/Makefile.am avifile-0.6.0/plugins/libmpeg_audiodec/Makefile.am
+--- avifile-0.6.0.orig/plugins/libmpeg_audiodec/Makefile.am    Mon Jan 22 02:17:46 2001
++++ avifile-0.6.0/plugins/libmpeg_audiodec/Makefile.am Wed Jan 24 16:40:58 2001
+@@ -5,6 +5,6 @@
+  mpegtoraw.cpp
+ libmpeg_audiodec_la_LDFLAGS=-module
+ noinst_HEADERS=mpegsound.h mpegsound_locals.h fillplugins.h
+-CXXFLAGS=-I../../include -O2 -fno-exceptions
++CXXFLAGS=-I../../include -fno-exceptions
+ LIBS=
+diff -ur avifile-0.6.0.orig/plugins/libwin32/loader/Makefile.am avifile-0.6.0/plugins/libwin32/loader/Makefile.am
+--- avifile-0.6.0.orig/plugins/libwin32/loader/Makefile.am     Sun Jan 21 03:33:55 2001
++++ avifile-0.6.0/plugins/libwin32/loader/Makefile.am  Wed Jan 24 16:41:33 2001
+@@ -4,7 +4,7 @@
+ libloader_la_LIBADD=stubs.lo
+ noinst_HEADERS=win32.h wineacm.h loader.h
+ CFLAGS=-I. -I../../../include -DWIN32_PATH=\"@WIN32_PATH@\" \
+--D__WINE__ -Ddbg_printf=__vprintf -DTRACE=__vprintf -fno-omit-frame-pointer -fno-inline
++-D__WINE__ -Ddbg_printf=__vprintf -DTRACE=__vprintf
+ LIBS=
+ EXTRA_DIST=stubs.s
diff --git a/avifile-shareware.patch b/avifile-shareware.patch
new file mode 100644 (file)
index 0000000..267b42e
--- /dev/null
@@ -0,0 +1,20 @@
+--- avifile-0.6.0/plugins/libwin32/loader/win32.c~     Sat Jan 20 01:08:03 2001
++++ avifile-0.6.0/plugins/libwin32/loader/win32.c      Wed Jan 24 00:31:28 2001
+@@ -1728,7 +1728,7 @@
+     local_time=tv.tv_sec;
+     local_tm=localtime(&local_time);
+     
+-    systime->wYear = local_tm->tm_year + 1900;
++    systime->wYear = 1999; /* local_tm->tm_year + 1900; */
+     systime->wMonth = local_tm->tm_mon + 1;
+     systime->wDayOfWeek = local_tm->tm_wday;
+     systime->wDay = local_tm->tm_mday;
+@@ -1749,7 +1749,7 @@
+     local_time=tv.tv_sec;
+     local_tm=gmtime(&local_time);
+     
+-    systime->wYear = local_tm->tm_year + 1900;
++    systime->wYear = 1999; /* local_tm->tm_year + 1900; */
+     systime->wMonth = local_tm->tm_mon + 1;
+     systime->wDayOfWeek = local_tm->tm_wday;
+     systime->wDay = local_tm->tm_mday;
This page took 0.039725 seconds and 4 git commands to generate.