]> git.pld-linux.org Git - packages/avifile.git/blob - avifile.spec
30263b5932b0d285e414aa47b9ef6c40a974a2bb
[packages/avifile.git] / avifile.spec
1 # It's sick.
2 %define         _snapver        20020412
3 %define         _snap           %{_snapver}
4 %define         _ver    0.7
5 Summary:        Library for playing AVI files
6 Summary(pl):    Biblioteka do odtwarzania plików AVI
7 Name:           avifile
8 Version:        %{_ver}
9 Release:        0.%{_snap}.3
10 Epoch:          3
11 License:        GPL
12 Group:          X11/Libraries
13 URL:            http://avifile.sourceforge.net/
14 Source0:        http://avifile.sourceforge.net/%{name}%{version}-%{_snap}.tar.gz
15 Source1:        %{name}.desktop
16 Patch0:         %{name}-shareware.patch
17 Patch1:         %{name}-deplib.patch
18 Patch2:         %{name}-ac3.patch
19 Patch3:         %{name}-size_t.patch
20 Patch4:         %{name}-amfix.patch
21 BuildRequires:  XFree86-devel
22 BuildRequires:  SDL-devel >= 1.2.0
23 BuildRequires:  ac3dec-devel >= 0.6.1
24 BuildRequires:  libjpeg-devel
25 BuildRequires:  unzip
26 BuildRequires:  qt-devel
27 %ifarch %{ix86}
28 BuildRequires:  divx4linux-devel
29 %endif
30 BuildRequires:  autoconf
31 BuildRequires:  automake
32 BuildRequires:  libtool
33 BuildRequires:  libogg-devel
34 BuildRequires:  libvorbis-devel
35 BuildRequires:  lame-libs-devel
36 %ifarch %{ix86}
37 BuildRequires:  xvid-devel
38 %endif
39 BuildConflicts: wine-devel
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 %define         _prefix         /usr/X11R6
43 %define         _mandir         %{_prefix}/man
44
45 %description
46 Avifile is a library that allow programs to read and write compressed
47 AVI files (Indeo Video, DivX :-), etc.) under x86 Linux.
48 (De)compression is performed with various plugins (Win32, FFMpeg,...)
49
50 %description -l pl
51 Avifile jest bibliotek± s³u¿±c± do odczytywania i zapisywania
52 skompresowanych plików AVI (Indeo Video, DivX :-), etc.) pod Linuksem.
53 Do (de)kompresji u¿ywane s± pluginy (win32, FFMpeg, ...)
54
55 %package devel
56 Summary:        Header file required to build programs using libavifile
57 Summary(pl):    Pliki nag³ówkowe wymagane przez programy u¿ywaj±ce libavifile
58 Group:          X11/Development/Libraries
59 Requires:       XFree86-devel
60 Requires:       %{name} = %{version}
61
62 %description devel
63 Header files required to build programs using libavifile.
64
65 %description devel -l pl
66 Pliki nag³ówkowe niezbêdne do kompilacji programów korzystaj±cych z
67 libavifile.
68
69 %package aviplay
70 Summary:        Player for AVI/ASF/WMF files
71 Summary(pl):    Odtwarzacz plików AVI/ASF/WMF
72 Group:          X11/Applications/Multimedia
73 Requires:       %{name} = %{version}
74
75 %description aviplay
76 Sample player for AVI, ASF, WFM (with straming support) files.
77
78 %description aviplay -l pl
79 Przyk³adowy odtwarzacz plików AVI, ASF, WFM (ze wsparciem dla
80 odtwarzania z sieci.)
81
82 %package utils
83 Summary:        Sample programs using the avifile library
84 Summary(pl):    Przyk³adowe programy u¿ywaj±ce biblioteki avifile
85 Group:          X11/Applications/Multimedia
86 Requires:       %{name} = %{version}
87
88 %description utils
89 Qt-based AVI utilities with few other useful supporting tools for TV
90 capturing, AVI recompression, benchmarking, joining AVI files. These
91 programs have more bugs as they are not as extensively developed as
92 player.
93
94 %description utils -l pl
95 Kilka u¿ytecznych narzêdzi do przechwytywania TV, rekompresji AVI,
96 benchmarkowania, ³±czenia plików AVI. Maj± wiêcej b³êdów, poniewa¿ nie
97 s± tak intensywnie rozwijane jak odtwarzacz.
98
99 %ifarch %{ix86}
100 %package win32
101 Summary:        Win32 audio/video plugin
102 Summary(pl):    Plugin audio/video win32
103 Group:          X11/Libraries
104 Requires:       %{name} = %{version}
105 Requires:       w32codec
106
107 %description win32
108 Plugin for using Win32 DLL libraries in avifile located in
109 /usr/lib/win32.
110
111 %description win32 -l pl
112 Plugin do u¿ywania w avifile zlokalizowanych w /usr/lib/win32
113 bibliotek DLL Win32.
114 %endif
115
116 %package ffmpeg
117 Summary:        GPL MPEG4 codec
118 Summary(pl):    Kodek MPEG4 na licencji GPL
119 Group:          X11/Libraries
120 Requires:       %{name} = %{version}
121
122 %description ffmpeg
123 ffmpeg is a hyper fast realtime audio/video encoder, a streaming
124 server and a generic audio and video file converter.
125
126 It can grab from a standard Video4Linux video source and convert it
127 into several file formats based on DCT/motion compensation encoding.
128 Sound is compressed in MPEG audio layer 2 or using an AC3 compatible
129 stream.
130
131 %description ffmpeg -l pl
132 ffmpeg jest hiperszybkim koderem audio/wideo czasu rzeczywistego,
133 serwerem strumieni oraz standardowym konwerterem plików audio-wideo.
134
135 Mo¿e pobieraæ ze standardowego Video4Linux ¼ród³o obrazu i konwertowaæ
136 je do kilku formatów plików opartych na kodowaniu DCT/kompensacji
137 ruchu. D¼wiêk jest kompresowany w MPEG audio layer 2 lub u¿ywaj±c
138 kompatybilnego z AC3 strumienia.
139
140 %ifarch %{ix86}
141 %package divx4
142 Summary:        Fast MPEG4 codec
143 Summary(pl):    Szybki kodek MPEG4
144 Group:          X11/Libraries
145 Requires:       %{name} = %{version}
146 Requires:       divx4linux
147 ExclusiveArch:  %{ix86}
148
149 %description divx4
150 DivX MPEG-4 decoder and encoder.
151
152 %description divx4 -l pl
153 Dekoder i koder MPEG-4 DivX.
154 %endif
155
156 %package vorbis
157 Summary:        Vorbis audio plugin
158 Summary(pl):    Plugin vorbis audio.
159 Group:          X11/Libraries
160 Requires:       %{name} = %{version}
161
162 %description vorbis
163 Plugin for decompression of Vorbis audio streams.
164
165 %description vorbis -l pl
166 Plugin do dekompresji strumieni audio Vorbis.
167
168 %package mad
169 Summary:        MAD - MPEG audio plugin
170 Summary(pl):    MAD - plugin MPEG audio
171 Group:          X11/Libraries
172 Requires:       %{name} = %{version}
173
174 %description mad
175 Plugin for decompression of MPEG-1 Layer I/II/III audio streams.
176
177 %description mad -l pl
178 Plugin do dekompresji strumieni d¼wiêkowych MPEG-1 Layer I/II/III.
179
180 %package lame_audioenc
181 Summary:        MP3 audio encoder plugin
182 Summary(pl):    Plugin enkoduj±cy d¼wiêk w formacie MP3
183 Group:          X11/Libraries
184 Requires:       %{name} = %{version}
185
186 %description lame_audioenc
187 Plugin for mp3 encoding capability of avirecompress tool.
188
189 %description lame_audioenc -l pl
190 Plugin umo¿liwiaj±cy avirecompressowi kodowanie mp3.
191
192 %ifarch %{ix86}
193 %package xvid
194 Summary:        XVID codec
195 Summary(pl):    Kodek XVID
196 Group:          X11/Libraries
197 Requires:       %{name} = %{version}
198 Requires:       xvid
199 ExclusiveArch:  %{ix86}
200
201 %description xvid
202 XVID decoder and encoder.
203
204 %description xvid -l pl
205 Dekoder i koder XVID.
206 %endif
207
208 %prep
209 %setup -q -n avifile%{_ver}-%{_snapver}
210 %patch0 -p1
211 # was broken and need fixing; without this xmms and avi plugin is broken
212 %patch1 -p1
213 %patch2 -p1
214 %patch3 -p1
215 %patch4 -p1
216
217 %build
218 rm -f missing aclocal.m4
219 libtoolize --copy --force
220 aclocal
221 autoconf
222 autoheader
223 automake -a -c --foreign
224
225 cd plugins/libmad/libmad
226 autoconf
227 cd ../../..
228
229 cd libmmxnow
230 autoconf
231 cd ..
232
233 # This is The WRONG Way (tm)
234 GEN_MOC="`grep -Rl '^ *Q_OBJECT$' *`"
235 for f in $GEN_MOC; do moc -o "${f%.[!.]*}.moc" "$f"; done
236
237 %configure CPPFLAGS="-I/usr/include/divx" AS="%{__cc}" \
238         --with-qt-includes=%{_includedir}/qt \
239         --with-libac3-path=%{_prefix} \
240         --enable-release \
241         --enable-ffmpeg \
242         --disable-x86opt
243
244 touch lib/dummy.cpp
245 %{__make}
246
247 %install
248 rm -rf $RPM_BUILD_ROOT
249 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir},/usr/lib/win32,%{_pixmapsdir},%{_applnkdir}/Multimedia}
250
251 # avoid relinking
252 for f in plugins/*/lib*.la ; do
253         sed -e '/^relink_command/d' $f > $f.new
254         mv -f $f.new $f
255 done
256
257 %{__make} install \
258         DESTDIR="$RPM_BUILD_ROOT"
259
260 cp -f include/fourcc.h $RPM_BUILD_ROOT/%{_includedir}/%{name}
261
262 gzip -9nf README doc/{CREDITS,EXCEPTIONS,KNOWN_BUGS,LICENSING} \
263         doc/{README-DEVEL,TODO,VIDEO-PERFORMANCE,WARNINGS}
264
265 install %{SOURCE1} $RPM_BUILD_ROOT%{_applnkdir}/Multimedia
266 install bin/test.png $RPM_BUILD_ROOT%{_pixmapsdir}/avifile.png
267
268 %clean
269 rm -rf $RPM_BUILD_ROOT
270
271 %post   -p /sbin/ldconfig
272 %postun -p /sbin/ldconfig
273
274 %files
275 %defattr(644,root,root,755)
276 %doc *.gz doc/{CREDITS,EXCEPTIONS,KNOWN_BUGS,LICENSING}.gz
277 %doc doc/{TODO,VIDEO-PERFORMANCE,WARNINGS}.gz
278 %attr(755,root,root) %{_libdir}/lib*.so.*.*
279 %dir %{_libdir}/avifile*
280 %attr(755,root,root) %{_libdir}/avifile*/libaudiodec.so*
281 %attr(755,root,root) %{_libdir}/avifile*/libaudiodec.la
282 %attr(755,root,root) %{_libdir}/avifile*/libmpeg_audiodec.so*
283 %attr(755,root,root) %{_libdir}/avifile*/libmpeg_audiodec.la
284 %attr(755,root,root) %{_libdir}/avifile*/libac3pass.so*
285 %attr(755,root,root) %{_libdir}/avifile*/libac3pass.la
286 %attr(755,root,root) %{_libdir}/avifile*/libmjpeg.so*
287 %attr(755,root,root) %{_libdir}/avifile*/libmjpeg.la
288
289 %files devel
290 %defattr(644,root,root,755)
291 %doc doc/README-DEVEL*
292 %attr(755,root,root) %{_bindir}/avifile-config
293 %attr(755,root,root) %{_bindir}/mmxnow-config
294 %attr(755,root,root) %{_libdir}/lib*.la
295 %{_libdir}/lib*.so
296 %{_includedir}/%{name}
297
298 %files aviplay
299 %defattr(644,root,root,755)
300 %attr(755,root,root) %{_bindir}/aviplay
301 %{_datadir}/%{name}*
302 %{_applnkdir}/Multimedia/*
303 %{_pixmapsdir}/*
304
305 %files utils
306 %defattr(644,root,root,755)
307 %attr(755,root,root) %{_bindir}/avi[bcmrt]*
308 %attr(755,root,root) %{_bindir}/kv4lsetup
309
310 %ifarch %{ix86}
311 %files win32
312 %defattr(644,root,root,755)
313 %attr(755,root,root) %{_libdir}/avifile*/libwin32.so*
314 %attr(755,root,root) %{_libdir}/avifile*/libwin32.la
315 %endif
316
317 %files ffmpeg
318 %defattr(644,root,root,755)
319 %attr(755,root,root) %{_libdir}/avifile*/libffmpeg.so*
320 %attr(755,root,root) %{_libdir}/avifile*/libffmpeg.la
321
322 %ifarch %{ix86}
323 %files divx4
324 %defattr(644,root,root,755)
325 %attr(755,root,root) %{_libdir}/avifile*/libdivx4.so*
326 %attr(755,root,root) %{_libdir}/avifile*/libdivx4.la
327 %endif
328
329 %files vorbis
330 %defattr(644,root,root,755)
331 %attr(755,root,root) %{_libdir}/avifile*/libvorbis*.so*
332 %attr(755,root,root) %{_libdir}/avifile*/libvorbis*.la
333
334 %files mad
335 %defattr(644,root,root,755)
336 %attr(755,root,root) %{_libdir}/avifile*/libmad*.so*
337 %attr(755,root,root) %{_libdir}/avifile*/libmad*.la
338
339 %files lame_audioenc
340 %defattr(644,root,root,755)
341 %attr(755,root,root) %{_libdir}/avifile*/libmp3lamebin_audioenc.so*
342 %attr(755,root,root) %{_libdir}/avifile*/libmp3lamebin_audioenc.la
343
344 %ifarch %{ix86}
345 %files xvid
346 %defattr(644,root,root,755)
347 %attr(755,root,root) %{_libdir}/avifile*/libxvid.so*
348 %attr(755,root,root) %{_libdir}/avifile*/libxvid.la
349 %endif
This page took 0.078882 seconds and 2 git commands to generate.