]> git.pld-linux.org Git - packages/avahi.git/blob - avahi.spec
- fix building Avahi-*.gir
[packages/avahi.git] / avahi.spec
1 #
2 # TODO:
3 #       - finish with_apidocs
4 #       - check BRs for gtk+3
5 #       - make gtk3 bcond enabled by default when gtk+3 will be stable
6 #       - introspection files
7 #       - dbus files
8 #
9 # Conditional build:
10 %bcond_with     apidocs         # build API documentation
11 %bcond_without  dotnet          # build without dotnet bindings
12 %bcond_without  gtk             # build without GTK+
13 %bcond_with     gtk3            # build without GTK+3
14 %bcond_without  pygtk           # build without PyGTK
15 %bcond_without  qt              # build without (any) qt bindings
16 %bcond_without  qt3             # build without qt3 bindings
17 %bcond_without  qt4             # build without qt4 bindings
18
19 %ifnarch %{ix86} %{x8664} alpha arm hppa ia64 mips ppc s390 s390x sparc sparcv9
20 %undefine with_dotnet
21 %endif
22 %ifarch i386
23 %undefine with_dotnet
24 %endif
25
26 %if %{without qt}
27 %undefine       with_qt3
28 %undefine       with_qt4
29 %endif
30
31 %{?with_dotnet:%include /usr/lib/rpm/macros.mono}
32 Summary:        Free mDNS/DNS-SD/Zeroconf implementation
33 Summary(pl.UTF-8):      Wolna implementacja mDNS/DNS-SD/Zeroconf
34 Name:           avahi
35 Version:        0.6.26
36 Release:        2
37 License:        LGPL v2.1+
38 Group:          Applications
39 Source0:        http://avahi.org/download/%{name}-%{version}.tar.gz
40 # Source0-md5:  2b2b1899fcec5ae74e92f111598913a1
41 Source1:        %{name}-daemon
42 Source2:        %{name}-dnsconfd
43 Source3:        %{name}.png
44 Source4:        %{name}-daemon.upstart
45 Source5:        %{name}-dnsconfd.upstart
46 Patch0:         %{name}-desktop.patch
47 Patch1:         %{name}-glade.patch
48 Patch2:         %{name}-destdir.patch
49 Patch3:         %{name}-mono-dir.patch
50 Patch4:         nss-mdns-package.patch
51 Patch5:         %{name}-dhclient_hooks.patch
52 Patch6:         %{name}-autoipd-sbin_ip.patch
53 Patch7:         %{name}-gtk_detect.patch
54 Patch8:         gir.patch
55 URL:            http://avahi.org/
56 BuildRequires:  autoconf
57 BuildRequires:  automake
58 BuildRequires:  dbus-devel >= 0.92
59 %if %{with apidocs}
60 BuildRequires:  doxygen
61 # for the 'dot' tool used by doxygen
62 BuildRequires:  graphviz
63 %endif
64 BuildRequires:  expat-devel
65 BuildRequires:  gdbm-devel
66 BuildRequires:  gettext-devel
67 %if %{with gtk}
68 BuildRequires:  glib2-devel >= 1:2.12.2
69 BuildRequires:  gtk+2-devel >= 2:2.10.2
70 BuildRequires:  libglade2-devel >= 1:2.6.0
71 %endif
72 %if %{with gtk3}
73 BuildRequires:  glib2-devel
74 BuildRequires:  gtk+3-devel
75 BuildRequires:  libglade2-devel
76 %endif
77 BuildRequires:  intltool >= 0.35
78 BuildRequires:  libcap-devel
79 BuildRequires:  libdaemon-devel >= 0.11
80 BuildRequires:  libtool
81 %if %{with dotnet}
82 BuildRequires:  dotnet-gtk-sharp2-devel >= 2.10
83 BuildRequires:  mono-csharp
84 BuildRequires:  monodoc >= 2.6
85 %endif
86 BuildRequires:  pkgconfig
87 BuildRequires:  python >= 1:2.4
88 BuildRequires:  python-dbus >= 0.71
89 %{?with_pygtk:BuildRequires:    python-pygtk-devel >= 2:2.9.6}
90 %if %{with qt3}
91 BuildRequires:  qt-devel >= 1:3.0
92 %endif
93 %if %{with qt4}
94 BuildRequires:  QtCore-devel
95 BuildRequires:  qt4-build
96 %endif
97 BuildRequires:  rpm-pythonprov
98 BuildRequires:  rpmbuild(macros) >= 1.561
99 Requires(post,preun):   /sbin/chkconfig
100 Requires:       %{name}-libs = %{version}-%{release}
101 Requires:       dbus >= 0.92
102 Requires:       libdaemon >= 0.11
103 Requires:       rc-scripts >= 0.4.3
104 Suggests:       nss_mdns >= 0.10-2
105 Provides:       group(avahi)
106 Provides:       user(avahi)
107 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
108
109 %description
110 Avahi is an implementation the DNS Service Discovery and Multicast DNS
111 specifications for Zeroconf Computing. It uses D-BUS for communication
112 between user applications and a system daemon.
113
114 %description -l pl.UTF-8
115 Avahi jest implementacją specyfikacji DNS Service Discovery i
116 Multicast DNS dla Zeroconf Computing. Używa D-BUSa dla komunikacji
117 pomiędzy programami użytkownika a demonem systemowym.
118
119 %package upstart
120 Summary:        Upstart jobs description for Avahi daemons
121 Summary(pl.UTF-8):      Opis zadań Upstart dla demonów Avahi
122 Group:          Daemons
123 Requires:       %{name} = %{version}-%{release}
124 Requires:       upstart >= 0.6
125
126 %description upstart
127 Upstart jobs description for Avahi daemons.
128
129 %description upstart -l pl.UTF-8
130 Opis zadań Upstart dla demonów Avahi.
131
132 %package autoipd
133 Summary:        IPv4LL network address configuration daemon
134 Summary(pl.UTF-8):      Demon configurujący adresy IPv4LL
135 Group:          Networking/Daemons
136 Requires(postun):       /usr/sbin/groupdel
137 Requires(postun):       /usr/sbin/userdel
138 Requires(pre):  /bin/id
139 Requires(pre):  /usr/bin/getgid
140 Requires(pre):  /usr/sbin/groupadd
141 Requires(pre):  /usr/sbin/useradd
142 Provides:       group(avahi)
143 Provides:       user(avahi)
144
145 %description autoipd
146 avahi-autoipd implements IPv4LL, "Dynamic Configuration of IPv4 Link-
147 Local Addresses" (IETF RFC3927), a protocol for automatic IP address
148 configuration from the link-local 169.254.0.0/16 range without the
149 need for a central server. It is primarily intended to be used in
150 ad-hoc networks which lack a DHCP server.
151
152 IPv4LL is part of the Zeroconf stack.
153
154 %description autoipd -l pl.UTF-8
155 avahi-autoipd jest implementacją IPv4LL, protokołu umożliwiającego
156 automatyczną konfigurację adresu z zakresu 169.254.0.0/16 bez potrzeby
157 użycia centralnego serwera. Jego głównym zastosowaniem są sieci
158 ad-hoc, w których brakuje serwera DHCP.
159
160 IPv4LL jest częścią stosu Zeroconf.
161
162 %package libs
163 Summary:        Avahi client, common and core libraries
164 Summary(pl.UTF-8):      Biblioteki Avahi: klienta, wspólna i główna
165 Group:          Libraries
166
167 %description libs
168 Avahi client, common and core libraries.
169
170 %description libs -l pl.UTF-8
171 Biblioteki Avahi: klienta, wspólna i główna.
172
173 %package devel
174 Summary:        Header files for Avahi library
175 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Avahi
176 Group:          Development/Libraries
177 Requires:       %{name}-libs = %{version}-%{release}
178 Requires:       dbus-devel >= 0.92
179 Requires:       expat-devel
180
181 %description devel
182 This is the package containing the header files for Avahi library.
183
184 %description devel -l pl.UTF-8
185 Ten pakiet zawiera pliki nagłówkowe biblioteki Avahi.
186
187 %package static
188 Summary:        Static Avahi library
189 Summary(pl.UTF-8):      Statyczna biblioteka Avahi
190 Group:          Development/Libraries
191 Requires:       %{name}-devel = %{version}-%{release}
192
193 %description static
194 Static Avahi library.
195
196 %description static -l pl.UTF-8
197 Statyczna biblioteka Avahi.
198
199 %package ui
200 Summary:        Avahi UI library
201 Summary(pl.UTF-8):      Biblioteka Avahi UI
202 Group:          X11/Libraries
203 Requires:       %{name}-libs = %{version}-%{release}
204 Requires:       gtk+2 >= 2:2.10.2
205
206 %description ui
207 Common GTK+ UI support library for Avahi.
208
209 %description ui -l pl.UTF-8
210 Biblioteka wspólnego interfejsu użytkownika GTK+ dla Avahi.
211
212 %package ui-devel
213 Summary:        Header files for Avahi UI library
214 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Avahi UI
215 Group:          X11/Development/Libraries
216 Requires:       %{name}-devel = %{version}-%{release}
217 Requires:       %{name}-ui = %{version}-%{release}
218 Requires:       gtk+2-devel >= 2:2.10.2
219
220 %description ui-devel
221 Header files for Avahi UI library.
222
223 %description ui-devel -l pl.UTF-8
224 Pliki nagłówkowe biblioteki Avahi UI.
225
226 %package ui-static
227 Summary:        Static Avahi UI library
228 Summary(pl.UTF-8):      Statyczna biblioteka Avahi UI
229 Group:          X11/Development/Libraries
230 Requires:       %{name}-ui-devel = %{version}-%{release}
231
232 %description ui-static
233 Static Avahi UI library.
234
235 %description ui-static -l pl.UTF-8
236 Statyczna biblioteka Avahi UI.
237
238 %package compat-libdns_sd
239 Summary:        Avahi Bonjour compat library
240 Summary(pl.UTF-8):      Biblioteka Avahi zgodna z Bonjour
241 Group:          Libraries
242 Provides:       mdns-bonjour
243 Obsoletes:      mDNSResponder-libs
244
245 %description compat-libdns_sd
246 Avahi Bonjour compat library.
247
248 %description compat-libdns_sd -l pl.UTF-8
249 Biblioteka Avahi zgodna z Bonjour.
250
251 %package compat-libdns_sd-devel
252 Summary:        Header files for Avahi Bonjour compat library
253 Summary(pl.UTF-8):      Pliki nagłówkowe wiązań Avahi dla biblioteki zgodnej z Bonjour
254 Group:          Development/Libraries
255 Requires:       %{name}-compat-libdns_sd = %{version}-%{release}
256 Requires:       %{name}-devel = %{version}-%{release}
257 Provides:       mdns-bonjour-devel
258 Obsoletes:      mDNSResponder-devel
259
260 %description compat-libdns_sd-devel
261 Header files for Avahi Bonjour compat library.
262
263 %description compat-libdns_sd-devel -l pl.UTF-8
264 Pliki nagłówkowe wiązań Avahi dla biblioteki zgodnej z Bonjour.
265
266 %package compat-libdns_sd-static
267 Summary:        Static Avahi Bonjour compat library
268 Summary(pl.UTF-8):      Statyczna biblioteka Avahi zgodna z Bonjour
269 Group:          Development/Libraries
270 Requires:       %{name}-compat-libdns_sd-devel = %{version}-%{release}
271 Provides:       mdns-bonjour-static
272
273 %description compat-libdns_sd-static
274 Static Avahi Bonjour compat library.
275
276 %description compat-libdns_sd-static -l pl.UTF-8
277 Statyczna biblioteka Avahi zgodna z Bonjour.
278
279 %package compat-howl
280 Summary:        Avahi Howl compat library
281 Summary(pl.UTF-8):      Biblioteka Avahi zgodna z Howl
282 Group:          Libraries
283 Provides:       mdns-howl-libs
284 Obsoletes:      howl-libs
285
286 %description compat-howl
287 Avahi Howl compat library.
288
289 %description compat-howl -l pl.UTF-8
290 Biblioteka Avahi zgodna z Howl.
291
292 %package compat-howl-devel
293 Summary:        Header files for Avahi Howl compat library
294 Summary(pl.UTF-8):      Pliki nagłówkowe wiązań Avahi dla biblioteki zgodnej z Howl
295 Group:          Development/Libraries
296 Requires:       %{name}-compat-howl = %{version}-%{release}
297 Requires:       %{name}-devel = %{version}-%{release}
298 Provides:       mdns-howl-devel
299 Obsoletes:      howl-devel
300
301 %description compat-howl-devel
302 Header files for Avahi Howl compat library.
303
304 %description compat-howl-devel -l pl.UTF-8
305 Pliki nagłówkowe wiązań Avahi dla biblioteki zgodnej z Howl.
306
307 %package compat-howl-static
308 Summary:        Static Avahi Howl compat library
309 Summary(pl.UTF-8):      Statyczna biblioteka Avahi zgodna z Howl
310 Group:          Development/Libraries
311 Requires:       %{name}-compat-howl-devel = %{version}-%{release}
312 Provides:       mdns-howl-static
313 Obsoletes:      howl-static
314
315 %description compat-howl-static
316 Static Avahi Howl compat library.
317
318 %description compat-howl-static -l pl.UTF-8
319 Statyczna biblioteka Avahi zgodna z Howl.
320
321 %package glib
322 Summary:        Avahi GLib library bindings
323 Summary(pl.UTF-8):      Wiązania Avahi dla bibioteki GLib
324 Group:          Libraries
325
326 %description glib
327 Avahi GLib library bindings.
328
329 %description glib -l pl.UTF-8
330 Wiązania Avahi dla bibioteki GLib.
331
332 %package glib-devel
333 Summary:        Header files for Avahi GLib library bindings
334 Summary(pl.UTF-8):      Pliki nagłówkowe wiązań Avahi dla biblioteki GLib
335 Group:          Development/Libraries
336 Requires:       %{name}-devel = %{version}-%{release}
337 Requires:       %{name}-glib = %{version}-%{release}
338 Requires:       glib2-devel >= 1:2.12.2
339
340 %description glib-devel
341 This is the package containing the header files for Avahi-glib
342 library.
343
344 %description glib-devel -l pl.UTF-8
345 Ten pakiet zawiera pliki nagłówkowe biblioteki Avahi-glib.
346
347 %package glib-static
348 Summary:        Static Avahi GLib library
349 Summary(pl.UTF-8):      Statyczna biblioteka Avahi GLib
350 Group:          Development/Libraries
351 Requires:       %{name}-glib-devel = %{version}-%{release}
352
353 %description glib-static
354 Static Avahi GLib library.
355
356 %description glib-static -l pl.UTF-8
357 Statyczna biblioteka Avahi GLib.
358
359 %package gobject
360 Summary:        Avahi GObject interface
361 Summary(pl.UTF-8):      Interfejs GObject do Avahi
362 Group:          Libraries
363
364 %description gobject
365 Avahi GObject interface.
366
367 %description gobject -l pl.UTF-8
368 Interfejs GObject do Avahi.
369
370 %package gobject-devel
371 Summary:        Header files for Avahi GObject interface
372 Summary(pl.UTF-8):      Pliki nagłówkowe interfejsu GObject do Avahi
373 Group:          Development/Libraries
374 Requires:       %{name}-devel = %{version}-%{release}
375 Requires:       %{name}-gobject = %{version}-%{release}
376 Requires:       glib2-devel >= 1:2.12.2
377
378 %description gobject-devel
379 This is the package containing the header files for Avahi GObject
380 interface.
381
382 %description gobject-devel -l pl.UTF-8
383 Ten pakiet zawiera pliki nagłówkowe interfejsu GObject do Avahi.
384
385 %package gobject-static
386 Summary:        Static Avahi GObject library
387 Summary(pl.UTF-8):      Statyczna biblioteka Avahi GObject
388 Group:          Development/Libraries
389 Requires:       %{name}-gobject-devel = %{version}-%{release}
390
391 %description gobject-static
392 Static Avahi GObject library.
393
394 %description gobject-static -l pl.UTF-8
395 Statyczna biblioteka Avahi GObject.
396
397 %package qt
398 Summary:        Avahi Qt 3 library bindings
399 Summary(pl.UTF-8):      Wiązania Avahi dla biblioteki Qt 3
400 Group:          Libraries
401 Requires:       %{name}-libs = %{version}-%{release}
402 Obsoletes:      avahi-qt3
403
404 %description qt
405 Avahi Qt 3 library bindings.
406
407 %description qt -l pl.UTF-8
408 Wiązania Avahi dla biblioteki Qt 3.
409
410 %package qt-devel
411 Summary:        Header files for Avahi Qt 3 library bindings
412 Summary(pl.UTF-8):      Pliki nagłówkowe wiązań Avahi dla biblioteki Qt 3
413 Group:          Development/Libraries
414 Requires:       %{name}-devel = %{version}-%{release}
415 Requires:       %{name}-qt = %{version}-%{release}
416 Requires:       qt-devel >= 1:3.0
417 Obsoletes:      avahi-qt3-devel
418
419 %description qt-devel
420 Header files for Avahi Qt 3 library bindings.
421
422 %description qt-devel -l pl.UTF-8
423 Pliki nagłówkowe wiązań Avahi dla biblioteki Qt 3.
424
425 %package qt-static
426 Summary:        Static Avahi Qt 3 library
427 Summary(pl.UTF-8):      Statyczna biblioteka Avahi Qt 3
428 Group:          Development/Libraries
429 Requires:       %{name}-qt-devel = %{version}-%{release}
430 Obsoletes:      avahi-qt3-static
431
432 %description qt-static
433 Static Avahi Qt 3 library.
434
435 %description qt-static -l pl.UTF-8
436 Statyczna biblioteka Avahi Qt 3.
437
438 %package Qt
439 Summary:        Avahi Qt 4 library bindings
440 Summary(pl.UTF-8):      Wiązania Avahi dla biblioteki Qt 4
441 Group:          Libraries
442 Requires:       %{name}-libs = %{version}-%{release}
443
444 %description Qt
445 Avahi Qt 4 library bindings.
446
447 %description Qt -l pl.UTF-8
448 Wiązania Avahi dla biblioteki Qt 4.
449
450 %package Qt-devel
451 Summary:        Header files for Avahi Qt 4 library bindings
452 Summary(pl.UTF-8):      Pliki nagłówkowe wiązań Avahi dla biblioteki Qt 4
453 Group:          Development/Libraries
454 Requires:       %{name}-Qt = %{version}-%{release}
455 Requires:       %{name}-devel = %{version}-%{release}
456
457 %description Qt-devel
458 Header files for Avahi Qt 4 library bindings.
459
460 %description Qt-devel -l pl.UTF-8
461 Pliki nagłówkowe wiązań Avahi dla biblioteki Qt 4.
462
463 %package Qt-static
464 Summary:        Static Avahi Qt 4 library
465 Summary(pl.UTF-8):      Statyczna biblioteka Avahi Qt 4
466 Group:          Development/Libraries
467 Requires:       %{name}-Qt-devel = %{version}-%{release}
468
469 %description Qt-static
470 Static Avahi Qt 4 library.
471
472 %description Qt-static -l pl.UTF-8
473 Statyczna biblioteka Avahi Qt 4.
474
475 %package -n python-avahi
476 Summary:        Avahi Python bindings
477 Summary(pl.UTF-8):      Wiązania Avahi dla Pythona
478 Group:          Development/Languages/Python
479 Requires:       %{name}-libs = %{version}-%{release}
480 Requires:       python-dbus >= 0.71
481
482 %description -n python-avahi
483 Avahi Python bindings.
484
485 %description -n python-avahi -l pl.UTF-8
486 Wiązania Avahi dla Pythona.
487
488 %package -n dotnet-avahi
489 Summary:        Avahi MONO bindings
490 Summary(pl.UTF-8):      Wiązania Avahi dla MONO
491 Group:          Libraries
492 Requires:       %{name}-libs = %{version}-%{release}
493
494 %description -n dotnet-avahi
495 Avahi MONO bindings.
496
497 %description -n dotnet-avahi -l pl.UTF-8
498 Wiązania Avahi dla MONO.
499
500 %package -n dotnet-avahi-devel
501 Summary:        Development files for MONO Avahi bindings
502 Summary(pl.UTF-8):      Pliki rozwojowe wiązań Avahi dla MONO
503 Group:          Development/Libraries
504 Requires:       dotnet-avahi = %{version}-%{release}
505 Requires:       monodoc >= 2.6
506
507 %description -n dotnet-avahi-devel
508 Development files for MONO Avahi bindings.
509
510 %description -n dotnet-avahi-devel -l pl.UTF-8
511 Pliki rozwojowe wiązań Avahi dla MONO.
512
513 %package -n dotnet-avahi-ui
514 Summary:        Avahi UI MONO bindings
515 Summary(pl.UTF-8):      Wiązania Avahi UI dla MONO
516 Group:          X11/Libraries
517 Requires:       %{name}-ui = %{version}-%{release}
518 Requires:       dotnet-avahi = %{version}-%{release}
519
520 %description -n dotnet-avahi-ui
521 Avahi UI MONO bindings.
522
523 %description -n dotnet-avahi-ui -l pl.UTF-8
524 Wiązania Avahi UI dla MONO.
525
526 %package -n dotnet-avahi-ui-devel
527 Summary:        Development files for MONO Avahi UI bindings
528 Summary(pl.UTF-8):      Pliki rozwojowe wiązań Avahi UI dla MONO
529 Group:          X11/Development/Libraries
530 Requires:       dotnet-avahi-ui = %{version}-%{release}
531 Requires:       monodoc >= 2.6
532
533 %description -n dotnet-avahi-ui-devel
534 Development files for MONO Avahi UI bindings.
535
536 %description -n dotnet-avahi-ui-devel -l pl.UTF-8
537 Pliki rozwojowe wiązań Avahi UI dla MONO.
538
539 %package bookmarks
540 Summary:        Miniature web server
541 Summary(pl.UTF-8):      Miniaturowy serwer web
542 Group:          Applications
543
544 %description bookmarks
545 A Python based miniature web server that browses for mDNS/DNS-SD
546 services of type '_http._tcp' (i.e. web sites) and makes them
547 available as HTML links on http://localhost:8080/.
548
549 %description bookmarks -l pl.UTF-8
550 Napisany w Pythonie miniaturowy serwer WWW, pozwalający na
551 przeglądanie usług typu '_http._tcp' (np. stron WWW) i udostępniający
552 je jako odnośniki HTML na http://localhost:8080/.
553
554 %package discover
555 Summary:        Avahi Zeroconf browser
556 Summary(pl.UTF-8):      Przeglądarka Zeroconf Avahi
557 Group:          Applications
558 Requires:       python-avahi = %{version}-%{release}
559 Requires:       python-pygtk-glade >= 2:2.9.6
560
561 %description discover
562 A tool for enumerating all available services on the local LAN
563 (python-pygtk implementation).
564
565 %description discover -l pl.UTF-8
566 Narzędzie wymieniające wszystkie dostępne usługi w sieci lokalnej LAN
567 (implementacja w python-pygtk).
568
569 %package discover-standalone
570 Summary:        Avahi Zeroconf browser
571 Summary(pl.UTF-8):      Przeglądarka Zeroconf Avahi
572 Group:          Applications
573 Requires:       %{name}-glib = %{version}-%{release}
574
575 %description discover-standalone
576 GTK+ tool for enumerating all available services on the local LAN.
577
578 %description discover-standalone -l pl.UTF-8
579 Narzędzie GTK+ wymieniające wszystkie dostępne usługi w sieci lokalnej
580 LAN.
581
582 %package utils
583 Summary:        Avahi CLI utilities
584 Summary(pl.UTF-8):      Narzędzia CLI Avahi
585 Group:          Applications
586
587 %description utils
588 Command line utilities using avahi-client.
589
590 %description utils -l pl.UTF-8
591 Narzędzia linii poleceń korzystające z avahi-client.
592
593 %prep
594 %setup -q
595 %patch0 -p1
596 %patch1 -p1
597 %patch2 -p1
598 %patch3 -p1
599 %patch4 -p1
600 %patch5 -p1
601 %patch6 -p1
602 %patch7 -p1
603 %patch8 -p1
604
605 %build
606 %{__intltoolize}
607 %{__libtoolize}
608 %{__aclocal} -I common
609 %{__autoconf}
610 %{__autoheader}
611 %{__automake}
612 %configure \
613         --disable-silent-rules \
614         --enable-compat-libdns_sd \
615         --enable-compat-howl \
616         --with-distro=none \
617         %{!?with_apidocs:--disable-doxygen-doc} \
618         %{!?with_gtk:--disable-gtk} \
619         %{!?with_gtk3:--disable-gtk3} \
620         %{!?with_pygtk:--disable-pygtk} \
621         %{!?with_qt3:--disable-qt3} \
622         %{!?with_qt4:--disable-qt4} \
623         %{!?with_dotnet:--disable-mono} \
624         %{!?with_dotnet:--disable-monodoc} \
625         --with-avahi-priv-access-group=adm \
626         --with-autoipd-user=avahi \
627         --with-autoipd-group=avahi
628 %{__make}
629
630 %install
631 rm -rf $RPM_BUILD_ROOT
632 install -d $RPM_BUILD_ROOT{%{_pixmapsdir},/etc/rc.d/init.d,/etc/init}
633
634 %{__make} install \
635         DESTDIR=$RPM_BUILD_ROOT \
636         pythondir=%{py_sitedir}
637
638 install -p %{SOURCE1} %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d
639 cp -a %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}
640
641 install %{SOURCE4} $RPM_BUILD_ROOT/etc/init/avahi-daemon.conf
642 install %{SOURCE5} $RPM_BUILD_ROOT/etc/init/avahi-dnsconfd.conf
643
644 ln -sf %{_includedir}/avahi-compat-libdns_sd/dns_sd.h \
645         $RPM_BUILD_ROOT%{_includedir}/dns_sd.h
646
647 ln -sf %{_pkgconfigdir}/avahi-compat-howl.pc \
648         $RPM_BUILD_ROOT%{_pkgconfigdir}/howl.pc
649
650 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
651 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
652 %py_postclean
653
654 rm -f $RPM_BUILD_ROOT%{_mandir}/man1/{avahi-{browse-domains,publish-address,publish-service,resolve-address,resolve-host-name},bvnc}.1
655 echo '.so avahi-browse.1' > $RPM_BUILD_ROOT%{_mandir}/man1/avahi-browse-domains.1
656 echo '.so avahi-publish.1' > $RPM_BUILD_ROOT%{_mandir}/man1/avahi-publish-address.1
657 echo '.so avahi-publish.1' > $RPM_BUILD_ROOT%{_mandir}/man1/avahi-publish-service.1
658 echo '.so avahi-resolve.1' > $RPM_BUILD_ROOT%{_mandir}/man1/avahi-resolve-address.1
659 echo '.so avahi-resolve.1' > $RPM_BUILD_ROOT%{_mandir}/man1/avahi-resolve-host-name.1
660 echo '.so bssh.1' > $RPM_BUILD_ROOT%{_mandir}/man1/bvnc.1
661
662 %find_lang %{name}
663
664 %clean
665 rm -rf $RPM_BUILD_ROOT
666
667 %pre
668 %groupadd -g 165 -r -f avahi
669 %useradd -u 165 -r -d /usr/share/empty -s /bin/false -c "Avahi daemon" -g avahi avahi
670
671 %pre autoipd
672 %groupadd -g 165 -r -f avahi
673 %useradd -u 165 -r -d /usr/share/empty -s /bin/false -c "Avahi daemon" -g avahi avahi
674
675 %post
676 /sbin/chkconfig --add %{name}-daemon
677 %service %{name}-daemon restart
678 /sbin/chkconfig --add %{name}-dnsconfd
679 %service %{name}-dnsconfd restart
680
681 %preun
682 if [ "$1" = "0" ]; then
683         %service -q %{name}-dnsconfd stop
684         /sbin/chkconfig --del %{name}-dnsconfd
685         %service -q %{name}-daemon stop
686         /sbin/chkconfig --del %{name}-daemon
687 fi
688
689 %postun
690 if [ "$1" = "0" ]; then
691         %userremove avahi
692         %groupremove avahi
693 fi
694
695 %postun autoipd
696 if [ "$1" = "0" ]; then
697         %userremove avahi
698         %groupremove avahi
699 fi
700
701 %post upstart
702 %upstart_post avahi-daemon
703 %upstart_post avahi-dnsconfd
704
705 %postun upstart
706 %upstart_postun avahi-daemon
707 %upstart_postun avahi-dnsconfd
708
709 %post   libs -p /sbin/ldconfig
710 %postun libs -p /sbin/ldconfig
711
712 %post   ui -p /sbin/ldconfig
713 %postun ui -p /sbin/ldconfig
714
715 %post   compat-libdns_sd -p /sbin/ldconfig
716 %postun compat-libdns_sd -p /sbin/ldconfig
717
718 %post   compat-howl -p /sbin/ldconfig
719 %postun compat-howl -p /sbin/ldconfig
720
721 %post   glib -p /sbin/ldconfig
722 %postun glib -p /sbin/ldconfig
723
724 %post   gobject -p /sbin/ldconfig
725 %postun gobject -p /sbin/ldconfig
726
727 %post   qt -p /sbin/ldconfig
728 %postun qt -p /sbin/ldconfig
729
730 %post   Qt -p /sbin/ldconfig
731 %postun Qt -p /sbin/ldconfig
732
733 %files
734 %defattr(644,root,root,755)
735 %doc docs/AUTHORS docs/COMPAT-LAYERS docs/NEWS docs/README docs/TODO
736
737 %dir %{_sysconfdir}/avahi
738 %dir %{_sysconfdir}/avahi/services
739 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/avahi/avahi-daemon.conf
740 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/avahi/avahi-dnsconfd.action
741 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/avahi/hosts
742 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/avahi/services/ssh.service
743 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/avahi/services/sftp-ssh.service
744 %config(noreplace) %verify(not md5 mtime size) /etc/dbus-1/system.d/*
745
746 %attr(755,root,root) %{_bindir}/avahi-set-host-name
747
748 %attr(755,root,root) %{_sbindir}/avahi-daemon
749 %attr(755,root,root) %{_sbindir}/avahi-dnsconfd
750
751 #%%dir %{_datadir}/%{name}/introspection
752 #%%{_datadir}/%{name}/introspection/*.introspect
753 %{_datadir}/%{name}/avahi-service.dtd
754 %{_datadir}/%{name}/service-types
755 %dir %{_libdir}/%{name}
756 %{_libdir}/%{name}/service-types.db
757
758 %{_mandir}/man1/avahi-set-host-name.1*
759 %{_mandir}/man5/avahi-daemon.conf.5*
760 %{_mandir}/man5/avahi.hosts.5*
761 %{_mandir}/man5/avahi.service.5*
762 %{_mandir}/man8/avahi-daemon.8*
763 %{_mandir}/man8/avahi-dnsconfd.8*
764 %{_mandir}/man8/avahi-dnsconfd.action.8*
765
766 %attr(754,root,root) /etc/rc.d/init.d/%{name}-daemon
767 %attr(754,root,root) /etc/rc.d/init.d/%{name}-dnsconfd
768
769 %files upstart
770 %defattr(644,root,root,755)
771 %config(noreplace) %verify(not md5 mtime size) /etc/init/*.conf
772
773 %files autoipd
774 %defattr(644,root,root,755)
775 %dir %{_sysconfdir}/avahi
776 %attr(755,root,root) %{_sysconfdir}/%{name}/avahi-autoipd.action
777 %dir %{_sysconfdir}/dhclient-enter-hooks.d
778 %config(noreplace) %verify(not md5 mtime size) /etc/dhclient-enter-hooks.d/avahi-autoipd
779 %dir %{_sysconfdir}/dhclient-exit-hooks.d
780 %config(noreplace) %verify(not md5 mtime size) /etc/dhclient-exit-hooks.d/avahi-autoipd
781 %attr(755,root,root) %{_sbindir}/avahi-autoipd
782 %{_mandir}/man8/avahi-autoipd.8*
783 %{_mandir}/man8/avahi-autoipd.action.8*
784
785 %files libs -f %{name}.lang
786 %defattr(644,root,root,755)
787 %attr(755,root,root) %{_libdir}/libavahi-client.so.*.*.*
788 %attr(755,root,root) %ghost %{_libdir}/libavahi-client.so.3
789 %attr(755,root,root) %{_libdir}/libavahi-common.so.*.*.*
790 %attr(755,root,root) %ghost %{_libdir}/libavahi-common.so.3
791 %attr(755,root,root) %{_libdir}/libavahi-core.so.*.*.*
792 %attr(755,root,root) %ghost %{_libdir}/libavahi-core.so.7
793 # common for -discover*
794 %dir %{_datadir}/%{name}
795 %dir %{_datadir}/%{name}/interfaces
796
797 %files devel
798 %defattr(644,root,root,755)
799 %doc docs/API-CHANGES-0.6 docs/DBUS-API docs/HACKING docs/MALLOC
800 %attr(755,root,root) %{_libdir}/libavahi-client.so
801 %attr(755,root,root) %{_libdir}/libavahi-common.so
802 %attr(755,root,root) %{_libdir}/libavahi-core.so
803 %{_libdir}/libavahi-client.la
804 %{_libdir}/libavahi-common.la
805 %{_libdir}/libavahi-core.la
806 %{_includedir}/avahi-client
807 %{_includedir}/avahi-common
808 %{_includedir}/avahi-core
809 %{_pkgconfigdir}/avahi-client.pc
810 %{_pkgconfigdir}/avahi-core.pc
811
812 %files static
813 %defattr(644,root,root,755)
814 %{_libdir}/libavahi-client.a
815 %{_libdir}/libavahi-common.a
816 %{_libdir}/libavahi-core.a
817
818 %if %{with gtk}
819 %files ui
820 %defattr(644,root,root,755)
821 %attr(755,root,root) %{_bindir}/bshell
822 %attr(755,root,root) %{_bindir}/bssh
823 %attr(755,root,root) %{_bindir}/bvnc
824 %attr(755,root,root) %{_libdir}/libavahi-ui.so.*.*.*
825 %attr(755,root,root) %ghost %{_libdir}/libavahi-ui.so.0
826 %{_mandir}/man1/bssh.1*
827 %{_mandir}/man1/bvnc.1*
828 %{_desktopdir}/bssh.desktop
829 %{_desktopdir}/bvnc.desktop
830
831 %files ui-devel
832 %defattr(644,root,root,755)
833 %attr(755,root,root) %{_libdir}/libavahi-ui.so
834 %{_libdir}/libavahi-ui.la
835 %{_includedir}/avahi-ui
836 %{_pkgconfigdir}/avahi-ui.pc
837
838 %files ui-static
839 %defattr(644,root,root,755)
840 %{_libdir}/libavahi-ui.a
841 %endif
842
843 %files compat-libdns_sd
844 %defattr(644,root,root,755)
845 %attr(755,root,root) %{_libdir}/libdns_sd.so.*.*.*
846 %attr(755,root,root) %ghost %{_libdir}/libdns_sd.so.1
847
848 %files compat-libdns_sd-devel
849 %defattr(644,root,root,755)
850 %attr(755,root,root) %{_libdir}/libdns_sd.so
851 %{_libdir}/libdns_sd.la
852 %{_includedir}/avahi-compat-libdns_sd
853 %{_includedir}/dns_sd.h
854 %{_pkgconfigdir}/avahi-compat-libdns_sd.pc
855
856 %files compat-libdns_sd-static
857 %defattr(644,root,root,755)
858 %{_libdir}/libdns_sd.a
859
860 %files compat-howl
861 %defattr(644,root,root,755)
862 %attr(755,root,root) %{_libdir}/libhowl.so.*.*.*
863 %attr(755,root,root) %ghost %{_libdir}/libhowl.so.0
864
865 %files compat-howl-devel
866 %defattr(644,root,root,755)
867 %attr(755,root,root) %{_libdir}/libhowl.so
868 %{_libdir}/libhowl.la
869 %{_includedir}/avahi-compat-howl
870 %{_pkgconfigdir}/avahi-compat-howl.pc
871 %{_pkgconfigdir}/howl.pc
872
873 %files compat-howl-static
874 %defattr(644,root,root,755)
875 %{_libdir}/libhowl.a
876
877 %files -n python-avahi
878 %defattr(644,root,root,755)
879 %{py_sitedir}/avahi
880
881 %if %{with dotnet}
882 %files -n dotnet-avahi
883 %defattr(644,root,root,755)
884 %{_prefix}/lib/mono/gac/avahi-sharp
885
886 %files -n dotnet-avahi-devel
887 %defattr(644,root,root,755)
888 %{_prefix}/lib/mono/avahi-sharp
889 %{_prefix}/lib/monodoc/sources/avahi-sharp-docs.*
890 %{_pkgconfigdir}/avahi-sharp.pc
891
892 %files -n dotnet-avahi-ui
893 %defattr(644,root,root,755)
894 %{_prefix}/lib/mono/gac/avahi-ui-sharp
895
896 %files -n dotnet-avahi-ui-devel
897 %defattr(644,root,root,755)
898 %{_prefix}/lib/mono/avahi-ui-sharp
899 %{_prefix}/lib/monodoc/sources/avahi-ui-sharp-docs.*
900 %{_pkgconfigdir}/avahi-ui-sharp.pc
901 %endif
902
903 %files glib
904 %defattr(644,root,root,755)
905 %attr(755,root,root) %{_libdir}/libavahi-glib.so.*.*.*
906 %attr(755,root,root) %ghost %{_libdir}/libavahi-glib.so.1
907
908 %files glib-devel
909 %defattr(644,root,root,755)
910 %attr(755,root,root) %{_libdir}/libavahi-glib.so
911 %{_libdir}/libavahi-glib.la
912 %{_includedir}/avahi-glib
913 %{_pkgconfigdir}/avahi-glib.pc
914
915 %files glib-static
916 %defattr(644,root,root,755)
917 %{_libdir}/libavahi-glib.a
918
919 %files gobject
920 %defattr(644,root,root,755)
921 %attr(755,root,root) %{_libdir}/libavahi-gobject.so.*.*.*
922 %attr(755,root,root) %ghost %{_libdir}/libavahi-gobject.so.0
923
924 %files gobject-devel
925 %defattr(644,root,root,755)
926 %attr(755,root,root) %{_libdir}/libavahi-gobject.so
927 %{_libdir}/libavahi-gobject.la
928 %{_includedir}/avahi-gobject
929 %{_pkgconfigdir}/avahi-gobject.pc
930
931 %files gobject-static
932 %defattr(644,root,root,755)
933 %{_libdir}/libavahi-gobject.a
934
935 %if %{with qt3}
936 %files qt
937 %defattr(644,root,root,755)
938 %attr(755,root,root) %{_libdir}/libavahi-qt3.so.*.*.*
939 %attr(755,root,root) %ghost %{_libdir}/libavahi-qt3.so.1
940
941 %files qt-devel
942 %defattr(644,root,root,755)
943 %attr(755,root,root) %{_libdir}/libavahi-qt3.so
944 %{_libdir}/libavahi-qt3.la
945 %{_includedir}/avahi-qt3
946 %{_pkgconfigdir}/avahi-qt3.pc
947
948 %files qt-static
949 %defattr(644,root,root,755)
950 %{_libdir}/libavahi-qt3.a
951 %endif
952
953 %if %{with qt4}
954 %files Qt
955 %defattr(644,root,root,755)
956 %attr(755,root,root) %{_libdir}/libavahi-qt4.so.*.*.*
957 %attr(755,root,root) %ghost %{_libdir}/libavahi-qt4.so.1
958
959 %files Qt-devel
960 %defattr(644,root,root,755)
961 %attr(755,root,root) %{_libdir}/libavahi-qt4.so
962 %{_libdir}/libavahi-qt4.la
963 %{_includedir}/avahi-qt4
964 %{_pkgconfigdir}/avahi-qt4.pc
965
966 %files Qt-static
967 %defattr(644,root,root,755)
968 %{_libdir}/libavahi-qt4.a
969 %endif
970
971 %files bookmarks
972 %defattr(644,root,root,755)
973 %attr(755,root,root) %{_bindir}/avahi-bookmarks
974 %{_mandir}/man1/avahi-bookmarks.1*
975
976 %if %{with pygtk}
977 %files discover
978 %defattr(644,root,root,755)
979 %attr(755,root,root) %{_bindir}/avahi-discover
980 %{py_sitedir}/avahi_discover
981 %{_datadir}/%{name}/interfaces/avahi-discover.ui
982 %{_desktopdir}/avahi-discover.desktop
983 %{_pixmapsdir}/avahi.png
984 %{_mandir}/man1/avahi-discover.1*
985 %endif
986
987 %if %{with gtk}
988 %files discover-standalone
989 %defattr(644,root,root,755)
990 %attr(755,root,root) %{_bindir}/avahi-discover-standalone
991 %{_datadir}/%{name}/interfaces/avahi-discover-standalone.glade
992 %endif
993
994 %files utils
995 %defattr(644,root,root,755)
996 %attr(755,root,root) %{_bindir}/avahi-browse
997 %attr(755,root,root) %{_bindir}/avahi-browse-domains
998 %attr(755,root,root) %{_bindir}/avahi-publish
999 %attr(755,root,root) %{_bindir}/avahi-publish-address
1000 %attr(755,root,root) %{_bindir}/avahi-publish-service
1001 %attr(755,root,root) %{_bindir}/avahi-resolve
1002 %attr(755,root,root) %{_bindir}/avahi-resolve-address
1003 %attr(755,root,root) %{_bindir}/avahi-resolve-host-name
1004 %{_mandir}/man1/avahi-browse.1*
1005 %{_mandir}/man1/avahi-browse-domains.1*
1006 %{_mandir}/man1/avahi-publish.1*
1007 %{_mandir}/man1/avahi-publish-address.1*
1008 %{_mandir}/man1/avahi-publish-service.1*
1009 %{_mandir}/man1/avahi-resolve.1*
1010 %{_mandir}/man1/avahi-resolve-address.1*
1011 %{_mandir}/man1/avahi-resolve-host-name.1*
This page took 0.216439 seconds and 3 git commands to generate.