]> git.pld-linux.org Git - packages/avahi.git/blob - avahi.spec
a0c110f132583966ee200a6d0ae6dc3ccf176159
[packages/avahi.git] / avahi.spec
1 #
2 # TODO:
3 # - autoip subpackage ?
4 # - autoip start script ?
5 #
6 # Conditional build:
7 %bcond_without  dotnet          # build without dotnet bindings
8 %bcond_without  qt              # build without (any) qt bindings
9 %bcond_without  qt3             # build without qt3 bindings
10 %bcond_without  qt4             # build without qt4 bindings
11 #
12 %if !%{with qt}
13 %undefine       with_qt3
14 %undefine       with_qt4
15 %endif
16 %if %{with dotnet}
17 %include /usr/lib/rpm/macros.mono
18 %endif
19 #
20 Summary:        Free mDNS/DNS-SD implementation
21 Summary(pl.UTF-8):      Wolna implementacja mDNS/DNS-SD
22 Name:           avahi
23 Version:        0.6.21
24 Release:        1
25 License:        LGPL v2.1+
26 Group:          Applications
27 Source0:        http://avahi.org/download/%{name}-%{version}.tar.gz
28 # Source0-md5:  9cc68f79c50c9dd9e419990c3c9b05b9
29 Source1:        %{name}-daemon
30 Source2:        %{name}-dnsconfd
31 Source3:        %{name}.png
32 Patch0:         %{name}-desktop.patch
33 Patch1:         %{name}-glade.patch
34 Patch2:         %{name}-destdir.patch
35 Patch3:         %{name}-dbus.patch
36 URL:            http://avahi.org/
37 BuildRequires:  autoconf
38 BuildRequires:  automake
39 BuildRequires:  dbus-devel >= 0.92
40 BuildRequires:  doxygen
41 BuildRequires:  expat-devel
42 BuildRequires:  gdbm-devel
43 BuildRequires:  glib2-devel >= 1:2.12.2
44 BuildRequires:  graphviz
45 BuildRequires:  gtk+2-devel >= 2:2.10.2
46 BuildRequires:  libcap-devel
47 BuildRequires:  libdaemon-devel >= 0.11
48 BuildRequires:  libglade2-devel >= 1:2.6.0
49 BuildRequires:  libtool
50 %if %{with dotnet}
51 BuildRequires:  dotnet-gtk-sharp2-devel >= 2.10
52 BuildRequires:  mono-csharp
53 BuildRequires:  monodoc
54 %endif
55 BuildRequires:  pkgconfig
56 BuildRequires:  python >= 1:2.4
57 BuildRequires:  python-dbus >= 0.71
58 BuildRequires:  python-pygtk-devel >= 2:2.9.6
59 %if %{with qt3}
60 BuildRequires:  qt-devel >= 1:3.0
61 %endif
62 %if %{with qt4}
63 BuildRequires:  QtCore-devel
64 BuildRequires:  qt4-build
65 %endif
66 BuildRequires:  rpmbuild(macros) >= 1.228
67 Requires(post,preun):   /sbin/chkconfig
68 Requires:       %{name}-libs = %{version}-%{release}
69 Requires:       dbus >= 0.92
70 Requires:       libdaemon >= 0.11
71 Provides:       group(avahi)
72 Provides:       user(avahi)
73 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
74
75 %description
76 Avahi is an implementation the DNS Service Discovery and Multicast DNS
77 specifications for Zeroconf Computing. It uses D-BUS for communication
78 between user applications and a system daemon.
79
80 %description -l pl.UTF-8
81 Avahi jest implementacją specyfikacji DNS Service Discovery i
82 Multicast DNS dla Zeroconf Computing. Używa D-BUSa dla komunikacji
83 pomiędzy programami użytkownika a demonem systemowym.
84
85 %package libs
86 Summary:        Avahi client, common and core libraries
87 Summary(pl.UTF-8):      Biblioteki Avahi: klienta, wspólna i główna
88 Group:          Libraries
89
90 %description libs
91 Avahi client, common and core libraries.
92
93 %description libs -l pl.UTF-8
94 Biblioteki Avahi: klienta, wspólna i główna.
95
96 %package devel
97 Summary:        Header files for Avahi library
98 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Avahi
99 Group:          Development/Libraries
100 Requires:       %{name}-libs = %{version}-%{release}
101 Requires:       dbus-devel >= 0.92
102 Requires:       expat-devel
103
104 %description devel
105 This is the package containing the header files for Avahi library.
106
107 %description devel -l pl.UTF-8
108 Ten pakiet zawiera pliki nagłówkowe biblioteki Avahi.
109
110 %package static
111 Summary:        Static Avahi library
112 Summary(pl.UTF-8):      Statyczna biblioteka Avahi
113 Group:          Development/Libraries
114 Requires:       %{name}-devel = %{version}-%{release}
115
116 %description static
117 Static Avahi library.
118
119 %description static -l pl.UTF-8
120 Statyczna biblioteka Avahi.
121
122 %package ui
123 Summary:        Avahi UI library
124 Summary(pl.UTF-8):      Biblioteka Avahi UI
125 Group:          X11/Libraries
126 Requires:       %{name}-libs = %{version}-%{release}
127 Requires:       gtk+2 >= 2:2.10.2
128
129 %description ui
130 Common GTK+ UI support library for Avahi.
131
132 %description ui -l pl.UTF-8
133 Biblioteka wspólnego interfejsu użytkownika GTK+ dla Avahi.
134
135 %package ui-devel
136 Summary:        Header files for Avahi UI library
137 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Avahi UI
138 Group:          X11/Development/Libraries
139 Requires:       %{name}-devel = %{version}-%{release}
140 Requires:       %{name}-ui = %{version}-%{release}
141 Requires:       gtk+2-devel >= 2:2.10.2
142
143 %description ui-devel
144 Header files for Avahi UI library.
145
146 %description ui-devel -l pl.UTF-8
147 Pliki nagłówkowe biblioteki Avahi UI.
148
149 %package ui-static
150 Summary:        Static Avahi UI library
151 Summary(pl.UTF-8):      Statyczna biblioteka Avahi UI
152 Group:          X11/Development/Libraries
153 Requires:       %{name}-ui-devel = %{version}-%{release}
154
155 %description ui-static
156 Static Avahi UI library.
157
158 %description ui-static -l pl.UTF-8
159 Statyczna biblioteka Avahi UI.
160
161 %package compat-libdns_sd
162 Summary:        Avahi Bonjour compat library
163 Summary(pl.UTF-8):      Biblioteka Avahi zgodna z Bonjour
164 Group:          Libraries
165 Provides:       mdns-bonjour
166 Obsoletes:      mDNSResponder-libs
167
168 %description compat-libdns_sd
169 Avahi Bonjour compat library.
170
171 %description compat-libdns_sd -l pl.UTF-8
172 Biblioteka Avahi zgodna z Bonjour.
173
174 %package compat-libdns_sd-devel
175 Summary:        Header files for Avahi Bonjour compat library
176 Summary(pl.UTF-8):      Pliki nagłówkowe wiązań Avahi dla biblioteki zgodnej z Bonjour
177 Group:          Development/Libraries
178 Requires:       %{name}-compat-libdns_sd = %{version}-%{release}
179 Requires:       %{name}-devel = %{version}-%{release}
180 Provides:       mdns-bonjour-devel
181 Obsoletes:      mDNSResponder-devel
182
183 %description compat-libdns_sd-devel
184 Header files for Avahi Bonjour compat library.
185
186 %description compat-libdns_sd-devel -l pl.UTF-8
187 Pliki nagłówkowe wiązań Avahi dla biblioteki zgodnej z Bonjour.
188
189 %package compat-libdns_sd-static
190 Summary:        Static Avahi Bonjour compat library
191 Summary(pl.UTF-8):      Statyczna biblioteka Avahi zgodna z Bonjour
192 Group:          Development/Libraries
193 Requires:       %{name}-compat-libdns_sd-devel = %{version}-%{release}
194 Provides:       mdns-bonjour-static
195
196 %description compat-libdns_sd-static
197 Static Avahi Bonjour compat library.
198
199 %description compat-libdns_sd-static -l pl.UTF-8
200 Statyczna biblioteka Avahi zgodna z Bonjour.
201
202 %package compat-howl
203 Summary:        Avahi Howl compat library
204 Summary(pl.UTF-8):      Biblioteka Avahi zgodna z Howl
205 Group:          Libraries
206 Provides:       mdns-howl-libs
207 Obsoletes:      howl-libs
208
209 %description compat-howl
210 Avahi Howl compat library.
211
212 %description compat-howl -l pl.UTF-8
213 Biblioteka Avahi zgodna z Howl.
214
215 %package compat-howl-devel
216 Summary:        Header files for Avahi Howl compat library
217 Summary(pl.UTF-8):      Pliki nagłówkowe wiązań Avahi dla biblioteki zgodnej z Howl
218 Group:          Development/Libraries
219 Requires:       %{name}-compat-howl = %{version}-%{release}
220 Requires:       %{name}-devel = %{version}-%{release}
221 Provides:       mdns-howl-devel
222 Obsoletes:      howl-devel
223
224 %description compat-howl-devel
225 Header files for Avahi Howl compat library.
226
227 %description compat-howl-devel -l pl.UTF-8
228 Pliki nagłówkowe wiązań Avahi dla biblioteki zgodnej z Howl.
229
230 %package compat-howl-static
231 Summary:        Static Avahi Howl compat library
232 Summary(pl.UTF-8):      Statyczna biblioteka Avahi zgodna z Howl
233 Group:          Development/Libraries
234 Requires:       %{name}-compat-howl-devel = %{version}-%{release}
235 Provides:       mdns-howl-static
236 Obsoletes:      howl-static
237
238 %description compat-howl-static
239 Static Avahi Howl compat library.
240
241 %description compat-howl-static -l pl.UTF-8
242 Statyczna biblioteka Avahi zgodna z Howl.
243
244 %package glib
245 Summary:        Avahi GLib library bindings
246 Summary(pl.UTF-8):      Wiązania Avahi dla bibioteki GLib
247 Group:          Libraries
248
249 %description glib
250 Avahi GLib library bindings.
251
252 %description glib -l pl.UTF-8
253 Wiązania Avahi dla bibioteki GLib.
254
255 %package glib-devel
256 Summary:        Header files for Avahi GLib library bindings
257 Summary(pl.UTF-8):      Pliki nagłówkowe wiązań Avahi dla biblioteki GLib
258 Group:          Development/Libraries
259 Requires:       %{name}-devel = %{version}-%{release}
260 Requires:       %{name}-glib = %{version}-%{release}
261 Requires:       glib2-devel >= 1:2.12.2
262
263 %description glib-devel
264 This is the package containing the header files for Avahi-glib
265 library.
266
267 %description glib-devel -l pl.UTF-8
268 Ten pakiet zawiera pliki nagłówkowe biblioteki Avahi-glib.
269
270 %package glib-static
271 Summary:        Static Avahi GLib library
272 Summary(pl.UTF-8):      Statyczna biblioteka Avahi GLib
273 Group:          Development/Libraries
274 Requires:       %{name}-glib-devel = %{version}-%{release}
275
276 %description glib-static
277 Static Avahi GLib library.
278
279 %description glib-static -l pl.UTF-8
280 Statyczna biblioteka Avahi GLib.
281
282 %package qt
283 Summary:        Avahi Qt 3 library bindings
284 Summary(pl.UTF-8):      Wiązania Avahi dla biblioteki Qt 3
285 Group:          Libraries
286 Requires:       %{name}-libs = %{version}-%{release}
287 Obsoletes:      avahi-qt3
288
289 %description qt
290 Avahi Qt 3 library bindings.
291
292 %description qt -l pl.UTF-8
293 Wiązania Avahi dla biblioteki Qt 3.
294
295 %package qt-devel
296 Summary:        Header files for Avahi Qt 3 library bindings
297 Summary(pl.UTF-8):      Pliki nagłówkowe wiązań Avahi dla biblioteki Qt 3
298 Group:          Development/Libraries
299 Requires:       %{name}-devel = %{version}-%{release}
300 Requires:       %{name}-qt = %{version}-%{release}
301 Requires:       qt-devel >= 1:3.0
302 Obsoletes:      avahi-qt3-devel
303
304 %description qt-devel
305 Header files for Avahi Qt 3 library bindings.
306
307 %description qt-devel -l pl.UTF-8
308 Pliki nagłówkowe wiązań Avahi dla biblioteki Qt 3.
309
310 %package qt-static
311 Summary:        Static Avahi Qt 3 library
312 Summary(pl.UTF-8):      Statyczna biblioteka Avahi Qt 3
313 Group:          Development/Libraries
314 Requires:       %{name}-qt-devel = %{version}-%{release}
315 Obsoletes:      avahi-qt3-static
316
317 %description qt-static
318 Static Avahi Qt 3 library.
319
320 %description qt-static -l pl.UTF-8
321 Statyczna biblioteka Avahi Qt 3.
322
323 %package Qt
324 Summary:        Avahi Qt 4 library bindings
325 Summary(pl.UTF-8):      Wiązania Avahi dla biblioteki Qt 4
326 Group:          Libraries
327 Requires:       %{name}-libs = %{version}-%{release}
328
329 %description Qt
330 Avahi Qt 4 library bindings.
331
332 %description Qt -l pl.UTF-8
333 Wiązania Avahi dla biblioteki Qt 4.
334
335 %package Qt-devel
336 Summary:        Header files for Avahi Qt 4 library bindings
337 Summary(pl.UTF-8):      Pliki nagłówkowe wiązań Avahi dla biblioteki Qt 4
338 Group:          Development/Libraries
339 Requires:       %{name}-devel = %{version}-%{release}
340 Requires:       %{name}-Qt = %{version}-%{release}
341
342 %description Qt-devel
343 Header files for Avahi Qt 4 library bindings.
344
345 %description Qt-devel -l pl.UTF-8
346 Pliki nagłówkowe wiązań Avahi dla biblioteki Qt 4.
347
348 %package Qt-static
349 Summary:        Static Avahi Qt 4 library
350 Summary(pl.UTF-8):      Statyczna biblioteka Avahi Qt 4
351 Group:          Development/Libraries
352 Requires:       %{name}-Qt-devel = %{version}-%{release}
353
354 %description Qt-static
355 Static Avahi Qt 4 library.
356
357 %description Qt-static -l pl.UTF-8
358 Statyczna biblioteka Avahi Qt 4.
359
360 %package -n python-avahi
361 Summary:        Avahi Python bindings
362 Summary(pl.UTF-8):      Wiązania Avahi dla Pythona
363 Group:          Development/Languages/Python
364 Requires:       %{name}-libs = %{version}-%{release}
365 Requires:       python-dbus >= 0.71
366
367 %description -n python-avahi
368 Avahi Python bindings.
369
370 %description -n python-avahi -l pl.UTF-8
371 Wiązania Avahi dla Pythona.
372
373 %package -n dotnet-avahi
374 Summary:        Avahi MONO bindings
375 Summary(pl.UTF-8):      Wiązania Avahi dla MONO
376 Group:          Libraries
377 Requires:       %{name}-libs = %{version}-%{release}
378
379 %description -n dotnet-avahi
380 Avahi MONO bindings.
381
382 %description -n dotnet-avahi -l pl.UTF-8
383 Wiązania Avahi dla MONO.
384
385 %package -n dotnet-avahi-devel
386 Summary:        Development files for MONO Avahi bindings
387 Summary(pl.UTF-8):      Pliki rozwojowe wiązań Avahi dla MONO
388 Group:          Development/Libraries
389 Requires:       dotnet-avahi = %{version}-%{release}
390 Requires:       monodoc
391
392 %description -n dotnet-avahi-devel
393 Development files for MONO Avahi bindings.
394
395 %description -n dotnet-avahi-devel -l pl.UTF-8
396 Pliki rozwojowe wiązań Avahi dla MONO.
397
398 %package -n dotnet-avahi-ui
399 Summary:        Avahi UI MONO bindings
400 Summary(pl.UTF-8):      Wiązania Avahi UI dla MONO
401 Group:          X11/Libraries
402 Requires:       %{name}-ui = %{version}-%{release}
403 Requires:       dotnet-avahi = %{version}-%{release}
404
405 %description -n dotnet-avahi-ui
406 Avahi UI MONO bindings.
407
408 %description -n dotnet-avahi-ui -l pl.UTF-8
409 Wiązania Avahi UI dla MONO.
410
411 %package -n dotnet-avahi-ui-devel
412 Summary:        Development files for MONO Avahi UI bindings
413 Summary(pl.UTF-8):      Pliki rozwojowe wiązań Avahi UI dla MONO
414 Group:          X11/Development/Libraries
415 Requires:       dotnet-avahi-ui = %{version}-%{release}
416 Requires:       monodoc
417
418 %description -n dotnet-avahi-ui-devel
419 Development files for MONO Avahi UI bindings.
420
421 %description -n dotnet-avahi-ui-devel -l pl.UTF-8
422 Pliki rozwojowe wiązań Avahi UI dla MONO.
423
424 %package bookmarks
425 Summary:        Miniature web server
426 Summary(pl.UTF-8):      Miniaturowy serwer web
427 Group:          Applications
428
429 %description bookmarks
430 A Python based miniature web server that browses for mDNS/DNS-SD
431 services of type '_http._tcp' (i.e. web sites) and makes them
432 available as HTML links on http://localhost:8080/.
433
434 %description bookmarks -l pl.UTF-8
435 Napisany w Pythonie miniaturowy serwer WWW, pozwalający na
436 przeglądanie usług typu '_http._tcp' (np. stron WWW) i udostępniający
437 je jako odnośniki HTML na http://localhost:8080/.
438
439 %package discover
440 Summary:        Avahi Zeroconf browser
441 Summary(pl.UTF-8):      Przeglądarka Zeroconf Avahi
442 Group:          Applications
443 Requires:       %{name} = %{version}-%{release}
444 Requires:       python-avahi = %{version}-%{release}
445 Requires:       python-pygtk-glade >= 2:2.9.6
446
447 %description discover
448 A tool for enumerating all available services on the local LAN
449 (python-pygtk implementation).
450
451 %description discover -l pl.UTF-8
452 Narzędzie wymieniające wszystkie dostępne usługi w sieci lokalnej LAN
453 (implementacja w python-pygtk).
454
455 %package discover-standalone
456 Summary:        Avahi Zeroconf browser
457 Summary(pl.UTF-8):      Przeglądarka Zeroconf Avahi
458 Group:          Applications
459 Requires:       %{name} = %{version}-%{release}
460 Requires:       python-dbus >= 0.71
461 Requires:       python-pygtk-glade >= 2:2.9.6
462
463 %description discover-standalone
464 GTK+ tool for enumerating all available services on the local LAN.
465
466 %description discover-standalone -l pl.UTF-8
467 Narzędzie GTK+ wymieniające wszystkie dostępne usługi w sieci lokalnej
468 LAN.
469
470 %package utils
471 Summary:        Avahi CLI utilities
472 Summary(pl.UTF-8):      Narzędzia CLI Avahi
473 Group:          Applications
474
475 %description utils
476 Command line utilities using avahi-client.
477
478 %description utils -l pl.UTF-8
479 Narzędzia linii poleceń korzystające z avahi-client.
480
481 %prep
482 %setup -q
483 %patch0 -p1
484 %patch1 -p1
485 %patch2 -p1
486 %patch3 -p1
487
488 %build
489 %{__libtoolize}
490 %{__aclocal} -I common
491 %{__autoconf}
492 %{__autoheader}
493 %{__automake}
494 %configure \
495         --enable-compat-libdns_sd \
496         --enable-compat-howl \
497         --with-distro=none \
498         %{!?with_qt3:--disable-qt3} \
499         %{!?with_qt4:--disable-qt4} \
500         %{!?with_dotnet:--disable-mono} \
501         %{!?with_dotnet:--disable-monodoc}
502 %{__make}
503
504 %install
505 rm -rf $RPM_BUILD_ROOT
506 install -d $RPM_BUILD_ROOT{%{_pixmapsdir},/etc/rc.d/init.d}
507
508 %{__make} install \
509         DESTDIR=$RPM_BUILD_ROOT \
510         pythondir=%{py_sitedir}
511
512 install %{SOURCE1} %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d
513 install %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}
514
515 ln -sf %{_includedir}/avahi-compat-libdns_sd/dns_sd.h \
516         $RPM_BUILD_ROOT%{_includedir}/dns_sd.h
517
518 ln -sf %{_pkgconfigdir}/avahi-compat-howl.pc \
519         $RPM_BUILD_ROOT%{_pkgconfigdir}/howl.pc
520
521 rm -f $RPM_BUILD_ROOT%{py_sitedir}/avahi/{__init__,SimpleGladeApp}.py
522
523 rm -f $RPM_BUILD_ROOT%{_mandir}/man1/{avahi-{browse-domains,publish-address,publish-service,resolve-address,resolve-host-name},bvnc}.1
524 echo '.so avahi-browse.1' > $RPM_BUILD_ROOT%{_mandir}/man1/avahi-browse-domains.1
525 echo '.so avahi-publish.1' > $RPM_BUILD_ROOT%{_mandir}/man1/avahi-publish-address.1
526 echo '.so avahi-publish.1' > $RPM_BUILD_ROOT%{_mandir}/man1/avahi-publish-service.1
527 echo '.so avahi-resolve.1' > $RPM_BUILD_ROOT%{_mandir}/man1/avahi-resolve-address.1
528 echo '.so avahi-resolve.1' > $RPM_BUILD_ROOT%{_mandir}/man1/avahi-resolve-host-name.1
529 echo '.so bssh.1' > $RPM_BUILD_ROOT%{_mandir}/man1/bvnc.1
530
531 %clean
532 rm -rf $RPM_BUILD_ROOT
533
534 %pre
535 %groupadd -g 165 -r -f avahi
536 %useradd -u 165 -r -d /usr/share/empty -s /bin/false -c "Avahi daemon" -g avahi avahi
537
538 %post
539 /sbin/chkconfig --add %{name}-daemon
540 %service %{name}-daemon restart
541 /sbin/chkconfig --add %{name}-dnsconfd
542 %service %{name}-dnsconfd restart
543
544 %preun
545 if [ "$1" = "0" ]; then
546         %service -q %{name}-dnsconfd stop
547         /sbin/chkconfig --del %{name}-dnsconfd
548         %service -q %{name}-daemon stop
549         /sbin/chkconfig --del %{name}-daemon
550 fi
551
552 %postun
553 if [ "$1" = "0" ]; then
554         %userremove avahi
555         %groupremove avahi
556 fi
557
558 %post   libs -p /sbin/ldconfig
559 %postun libs -p /sbin/ldconfig
560
561 %post   ui -p /sbin/ldconfig
562 %postun ui -p /sbin/ldconfig
563
564 %post   compat-libdns_sd -p /sbin/ldconfig
565 %postun compat-libdns_sd -p /sbin/ldconfig
566
567 %post   compat-howl -p /sbin/ldconfig
568 %postun compat-howl -p /sbin/ldconfig
569
570 %post   glib -p /sbin/ldconfig
571 %postun glib -p /sbin/ldconfig
572
573 %post   qt -p /sbin/ldconfig
574 %postun qt -p /sbin/ldconfig
575
576 %post   Qt -p /sbin/ldconfig
577 %postun Qt -p /sbin/ldconfig
578
579 %files
580 %defattr(644,root,root,755)
581 %doc docs/AUTHORS docs/COMPAT-LAYERS docs/NEWS docs/README docs/TODO
582
583 %dir %{_sysconfdir}/avahi
584 %dir %{_sysconfdir}/avahi/services
585 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/avahi/avahi-daemon.conf
586 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/avahi/avahi-dnsconfd.action
587 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/avahi/hosts
588 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/avahi/services/ssh.service
589 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/avahi/services/sftp-ssh.service
590 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/dbus-1/system.d/*
591
592 %attr(755,root,root) %{_bindir}/avahi-set-host-name
593
594 %attr(755,root,root) %{_sbindir}/avahi-daemon
595 %attr(755,root,root) %{_sbindir}/avahi-dnsconfd
596
597 %dir %{_datadir}/%{name}
598 %dir %{_datadir}/%{name}/introspection
599 %{_datadir}/%{name}/introspection/*.introspect
600 %{_datadir}/%{name}/avahi-service.dtd
601 %{_datadir}/%{name}/service-types
602 %{_datadir}/%{name}/service-types.db
603
604 %{_mandir}/man*/*
605
606 %attr(754,root,root) /etc/rc.d/init.d/%{name}-daemon
607 %attr(754,root,root) /etc/rc.d/init.d/%{name}-dnsconfd
608
609 %attr(755,root,root) %{_sysconfdir}/%{name}/avahi-autoipd.action
610 %attr(755,root,root) %{_sbindir}/avahi-autoipd
611
612 %files libs
613 %defattr(644,root,root,755)
614 %attr(755,root,root) %{_libdir}/libavahi-client.so.*.*.*
615 %attr(755,root,root) %{_libdir}/libavahi-common.so.*.*.*
616 %attr(755,root,root) %{_libdir}/libavahi-core.so.*.*.*
617
618 %files devel
619 %defattr(644,root,root,755)
620 %doc docs/API-CHANGES-0.6 docs/DBUS-API docs/HACKING docs/MALLOC
621 %attr(755,root,root) %{_libdir}/libavahi-client.so
622 %attr(755,root,root) %{_libdir}/libavahi-common.so
623 %attr(755,root,root) %{_libdir}/libavahi-core.so
624 %{_libdir}/libavahi-client.la
625 %{_libdir}/libavahi-common.la
626 %{_libdir}/libavahi-core.la
627 %{_includedir}/avahi-client
628 %{_includedir}/avahi-common
629 %{_includedir}/avahi-core
630 %{_pkgconfigdir}/avahi-client.pc
631 %{_pkgconfigdir}/avahi-core.pc
632
633 %files static
634 %defattr(644,root,root,755)
635 %{_libdir}/libavahi-client.a
636 %{_libdir}/libavahi-common.a
637 %{_libdir}/libavahi-core.a
638
639 %files ui
640 %defattr(644,root,root,755)
641 %attr(755,root,root) %{_bindir}/bssh
642 %attr(755,root,root) %{_bindir}/bvnc
643 %attr(755,root,root) %{_libdir}/libavahi-ui.so.*.*.*
644 %{_desktopdir}/bssh.desktop
645 %{_desktopdir}/bvnc.desktop
646
647 %files ui-devel
648 %defattr(644,root,root,755)
649 %attr(755,root,root) %{_libdir}/libavahi-ui.so
650 %{_libdir}/libavahi-ui.la
651 %{_includedir}/avahi-ui
652 %{_pkgconfigdir}/avahi-ui.pc
653
654 %files ui-static
655 %defattr(644,root,root,755)
656 %{_libdir}/libavahi-ui.a
657
658 %files compat-libdns_sd
659 %defattr(644,root,root,755)
660 %attr(755,root,root) %{_libdir}/libdns_sd.so.*.*.*
661
662 %files compat-libdns_sd-devel
663 %defattr(644,root,root,755)
664 %attr(755,root,root) %{_libdir}/libdns_sd.so
665 %{_libdir}/libdns_sd.la
666 %{_includedir}/avahi-compat-libdns_sd
667 %{_includedir}/dns_sd.h
668 %{_pkgconfigdir}/avahi-compat-libdns_sd.pc
669
670 %files compat-libdns_sd-static
671 %defattr(644,root,root,755)
672 %{_libdir}/libdns_sd.a
673
674 %files compat-howl
675 %defattr(644,root,root,755)
676 %attr(755,root,root) %{_libdir}/libhowl.so.*.*.*
677
678 %files compat-howl-devel
679 %defattr(644,root,root,755)
680 %attr(755,root,root) %{_libdir}/libhowl.so
681 %{_libdir}/libhowl.la
682 %{_includedir}/avahi-compat-howl
683 %{_pkgconfigdir}/avahi-compat-howl.pc
684 %{_pkgconfigdir}/howl.pc
685
686 %files compat-howl-static
687 %defattr(644,root,root,755)
688 %{_libdir}/libhowl.a
689
690 %files -n python-avahi
691 %defattr(644,root,root,755)
692 %{py_sitedir}/avahi
693
694 %if %{with dotnet}
695 %files -n dotnet-avahi
696 %defattr(644,root,root,755)
697 %{_prefix}/lib/mono/gac/avahi-sharp
698
699 %files -n dotnet-avahi-devel
700 %defattr(644,root,root,755)
701 %{_libdir}/monodoc/sources/avahi-sharp-docs.*
702 %{_prefix}/lib/mono/avahi-sharp
703 %{_pkgconfigdir}/avahi-sharp.pc
704
705 %files -n dotnet-avahi-ui
706 %defattr(644,root,root,755)
707 %{_prefix}/lib/mono/gac/avahi-ui-sharp
708
709 %files -n dotnet-avahi-ui-devel
710 %defattr(644,root,root,755)
711 %{_libdir}/monodoc/sources/avahi-ui-sharp-docs.*
712 %{_prefix}/lib/mono/avahi-ui-sharp
713 %{_pkgconfigdir}/avahi-ui-sharp.pc
714 %endif
715
716 %files glib
717 %defattr(644,root,root,755)
718 %attr(755,root,root) %{_libdir}/libavahi-glib.so.*.*.*
719
720 %files glib-devel
721 %defattr(644,root,root,755)
722 %attr(755,root,root) %{_libdir}/libavahi-glib.so
723 %{_libdir}/libavahi-glib.la
724 %{_includedir}/avahi-glib
725 %{_pkgconfigdir}/avahi-glib.pc
726
727 %files glib-static
728 %defattr(644,root,root,755)
729 %{_libdir}/libavahi-glib.a
730
731 %if %{with qt3}
732 %files qt
733 %defattr(644,root,root,755)
734 %attr(755,root,root) %{_libdir}/libavahi-qt3.so.*.*.*
735
736 %files qt-devel
737 %defattr(644,root,root,755)
738 %attr(755,root,root) %{_libdir}/libavahi-qt3.so
739 %{_libdir}/libavahi-qt3.la
740 %{_includedir}/avahi-qt3
741 %{_pkgconfigdir}/avahi-qt3.pc
742
743 %files qt-static
744 %defattr(644,root,root,755)
745 %{_libdir}/libavahi-qt3.a
746 %endif
747
748 %if %{with qt4}
749 %files Qt
750 %defattr(644,root,root,755)
751 %attr(755,root,root) %{_libdir}/libavahi-qt4.so.*.*.*
752
753 %files Qt-devel
754 %defattr(644,root,root,755)
755 %attr(755,root,root) %{_libdir}/libavahi-qt4.so
756 %{_libdir}/libavahi-qt4.la
757 %{_includedir}/avahi-qt4
758 %{_pkgconfigdir}/avahi-qt4.pc
759
760 %files Qt-static
761 %defattr(644,root,root,755)
762 %{_libdir}/libavahi-qt4.a
763 %endif
764
765 %files bookmarks
766 %defattr(644,root,root,755)
767 %attr(755,root,root) %{_bindir}/avahi-bookmarks
768
769 %files discover
770 %defattr(644,root,root,755)
771 %attr(755,root,root) %{_bindir}/avahi-discover
772 # XXX: possibly missing %{_datadir}/%{name} dir, shared subdir
773 %dir %{_datadir}/%{name}/interfaces
774 %{_datadir}/%{name}/interfaces/avahi-discover.glade
775 %{_desktopdir}/avahi-discover.desktop
776 %{_pixmapsdir}/avahi.png
777
778 %files discover-standalone
779 %defattr(644,root,root,755)
780 %attr(755,root,root) %{_bindir}/avahi-discover-standalone
781 # XXX: possibly missing %{_datadir}/%{name} dir, shared subdir
782 %dir %{_datadir}/%{name}/interfaces
783 %{_datadir}/%{name}/interfaces/avahi-discover-standalone.glade
784
785 %files utils
786 %defattr(644,root,root,755)
787 %attr(755,root,root) %{_bindir}/avahi-browse
788 %attr(755,root,root) %{_bindir}/avahi-publish
789 %attr(755,root,root) %{_bindir}/avahi-resolve
This page took 0.095097 seconds and 2 git commands to generate.