]> git.pld-linux.org Git - packages/avahi.git/blob - avahi.spec
- up to 0.6.28
[packages/avahi.git] / avahi.spec
1 #
2 # TODO:
3 #       - finish with_apidocs
4 #       - check BRs for gtk+3
5 #       - make gtk3 bcond enabled by default when gtk+3 will be stable
6 #       - introspection files
7 #       - dbus files
8 #
9 # Conditional build:
10 %bcond_with     apidocs         # build API documentation
11 %bcond_without  dotnet          # build without dotnet bindings
12 %bcond_without  gtk             # build without GTK+
13 %bcond_with     gtk3            # build without GTK+3
14 %bcond_without  pygtk           # build without PyGTK
15 %bcond_without  qt              # build without (any) qt bindings
16 %bcond_without  qt3             # build without qt3 bindings
17 %bcond_without  qt4             # build without qt4 bindings
18
19 %ifnarch %{ix86} %{x8664} alpha arm hppa ia64 mips ppc s390 s390x sparc sparcv9
20 %undefine with_dotnet
21 %endif
22 %ifarch i386
23 %undefine with_dotnet
24 %endif
25
26 %if %{without qt}
27 %undefine       with_qt3
28 %undefine       with_qt4
29 %endif
30
31 %{?with_dotnet:%include /usr/lib/rpm/macros.mono}
32 Summary:        Free mDNS/DNS-SD/Zeroconf implementation
33 Summary(pl.UTF-8):      Wolna implementacja mDNS/DNS-SD/Zeroconf
34 Name:           avahi
35 Version:        0.6.28
36 Release:        1
37 License:        LGPL v2.1+
38 Group:          Applications
39 Source0:        http://avahi.org/download/%{name}-%{version}.tar.gz
40 # Source0-md5:  d0143a5aa3265019072e53ab497818d0
41 Source1:        %{name}-daemon
42 Source2:        %{name}-dnsconfd
43 Source3:        %{name}.png
44 Source4:        %{name}-daemon.upstart
45 Source5:        %{name}-dnsconfd.upstart
46 Patch0:         %{name}-desktop.patch
47 Patch1:         %{name}-glade.patch
48 Patch2:         %{name}-destdir.patch
49 Patch3:         %{name}-mono-dir.patch
50 Patch4:         nss-mdns-package.patch
51 Patch5:         %{name}-dhclient_hooks.patch
52 Patch6:         %{name}-autoipd-sbin_ip.patch
53 URL:            http://avahi.org/
54 BuildRequires:  autoconf
55 BuildRequires:  automake
56 BuildRequires:  dbus-devel >= 0.92
57 %if %{with apidocs}
58 BuildRequires:  doxygen
59 # for the 'dot' tool used by doxygen
60 BuildRequires:  graphviz
61 %endif
62 BuildRequires:  expat-devel
63 BuildRequires:  gdbm-devel
64 BuildRequires:  gettext-devel
65 %if %{with gtk}
66 BuildRequires:  glib2-devel >= 1:2.12.2
67 BuildRequires:  gtk+2-devel >= 2:2.10.2
68 BuildRequires:  libglade2-devel >= 1:2.6.0
69 %endif
70 %if %{with gtk3}
71 BuildRequires:  glib2-devel
72 BuildRequires:  gtk+3-devel
73 BuildRequires:  libglade2-devel
74 %endif
75 BuildRequires:  intltool >= 0.35
76 BuildRequires:  libcap-devel
77 BuildRequires:  libdaemon-devel >= 0.11
78 BuildRequires:  libtool
79 %if %{with dotnet}
80 BuildRequires:  dotnet-gtk-sharp2-devel >= 2.10
81 BuildRequires:  mono-csharp
82 BuildRequires:  monodoc >= 2.6
83 %endif
84 BuildRequires:  pkgconfig
85 BuildRequires:  python >= 1:2.4
86 BuildRequires:  python-dbus >= 0.71
87 %{?with_pygtk:BuildRequires:    python-pygtk-devel >= 2:2.9.6}
88 %if %{with qt3}
89 BuildRequires:  qt-devel >= 1:3.0
90 %endif
91 %if %{with qt4}
92 BuildRequires:  QtCore-devel
93 BuildRequires:  qt4-build
94 %endif
95 BuildRequires:  rpm-pythonprov
96 BuildRequires:  rpmbuild(macros) >= 1.561
97 Requires(post,preun):   /sbin/chkconfig
98 Requires:       %{name}-libs = %{version}-%{release}
99 Requires:       dbus >= 0.92
100 Requires:       libdaemon >= 0.11
101 Requires:       rc-scripts >= 0.4.3
102 Suggests:       nss_mdns >= 0.10-2
103 Provides:       group(avahi)
104 Provides:       user(avahi)
105 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
106
107 %description
108 Avahi is an implementation the DNS Service Discovery and Multicast DNS
109 specifications for Zeroconf Computing. It uses D-BUS for communication
110 between user applications and a system daemon.
111
112 %description -l pl.UTF-8
113 Avahi jest implementacją specyfikacji DNS Service Discovery i
114 Multicast DNS dla Zeroconf Computing. Używa D-BUSa dla komunikacji
115 pomiędzy programami użytkownika a demonem systemowym.
116
117 %package upstart
118 Summary:        Upstart jobs description for Avahi daemons
119 Summary(pl.UTF-8):      Opis zadań Upstart dla demonów Avahi
120 Group:          Daemons
121 Requires:       %{name} = %{version}-%{release}
122 Requires:       upstart >= 0.6
123
124 %description upstart
125 Upstart jobs description for Avahi daemons.
126
127 %description upstart -l pl.UTF-8
128 Opis zadań Upstart dla demonów Avahi.
129
130 %package autoipd
131 Summary:        IPv4LL network address configuration daemon
132 Summary(pl.UTF-8):      Demon configurujący adresy IPv4LL
133 Group:          Networking/Daemons
134 Requires(postun):       /usr/sbin/groupdel
135 Requires(postun):       /usr/sbin/userdel
136 Requires(pre):  /bin/id
137 Requires(pre):  /usr/bin/getgid
138 Requires(pre):  /usr/sbin/groupadd
139 Requires(pre):  /usr/sbin/useradd
140 Provides:       group(avahi)
141 Provides:       user(avahi)
142
143 %description autoipd
144 avahi-autoipd implements IPv4LL, "Dynamic Configuration of IPv4 Link-
145 Local Addresses" (IETF RFC3927), a protocol for automatic IP address
146 configuration from the link-local 169.254.0.0/16 range without the
147 need for a central server. It is primarily intended to be used in
148 ad-hoc networks which lack a DHCP server.
149
150 IPv4LL is part of the Zeroconf stack.
151
152 %description autoipd -l pl.UTF-8
153 avahi-autoipd jest implementacją IPv4LL, protokołu umożliwiającego
154 automatyczną konfigurację adresu z zakresu 169.254.0.0/16 bez potrzeby
155 użycia centralnego serwera. Jego głównym zastosowaniem są sieci
156 ad-hoc, w których brakuje serwera DHCP.
157
158 IPv4LL jest częścią stosu Zeroconf.
159
160 %package libs
161 Summary:        Avahi client, common and core libraries
162 Summary(pl.UTF-8):      Biblioteki Avahi: klienta, wspólna i główna
163 Group:          Libraries
164
165 %description libs
166 Avahi client, common and core libraries.
167
168 %description libs -l pl.UTF-8
169 Biblioteki Avahi: klienta, wspólna i główna.
170
171 %package devel
172 Summary:        Header files for Avahi library
173 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Avahi
174 Group:          Development/Libraries
175 Requires:       %{name}-libs = %{version}-%{release}
176 Requires:       dbus-devel >= 0.92
177 Requires:       expat-devel
178
179 %description devel
180 This is the package containing the header files for Avahi library.
181
182 %description devel -l pl.UTF-8
183 Ten pakiet zawiera pliki nagłówkowe biblioteki Avahi.
184
185 %package static
186 Summary:        Static Avahi library
187 Summary(pl.UTF-8):      Statyczna biblioteka Avahi
188 Group:          Development/Libraries
189 Requires:       %{name}-devel = %{version}-%{release}
190
191 %description static
192 Static Avahi library.
193
194 %description static -l pl.UTF-8
195 Statyczna biblioteka Avahi.
196
197 %package ui
198 Summary:        Avahi UI library
199 Summary(pl.UTF-8):      Biblioteka Avahi UI
200 Group:          X11/Libraries
201 Requires:       %{name}-libs = %{version}-%{release}
202 Requires:       gtk+2 >= 2:2.10.2
203
204 %description ui
205 Common GTK+ UI support library for Avahi.
206
207 %description ui -l pl.UTF-8
208 Biblioteka wspólnego interfejsu użytkownika GTK+ dla Avahi.
209
210 %package ui-devel
211 Summary:        Header files for Avahi UI library
212 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Avahi UI
213 Group:          X11/Development/Libraries
214 Requires:       %{name}-devel = %{version}-%{release}
215 Requires:       %{name}-ui = %{version}-%{release}
216 Requires:       gtk+2-devel >= 2:2.10.2
217
218 %description ui-devel
219 Header files for Avahi UI library.
220
221 %description ui-devel -l pl.UTF-8
222 Pliki nagłówkowe biblioteki Avahi UI.
223
224 %package ui-static
225 Summary:        Static Avahi UI library
226 Summary(pl.UTF-8):      Statyczna biblioteka Avahi UI
227 Group:          X11/Development/Libraries
228 Requires:       %{name}-ui-devel = %{version}-%{release}
229
230 %description ui-static
231 Static Avahi UI library.
232
233 %description ui-static -l pl.UTF-8
234 Statyczna biblioteka Avahi UI.
235
236 %package compat-libdns_sd
237 Summary:        Avahi Bonjour compat library
238 Summary(pl.UTF-8):      Biblioteka Avahi zgodna z Bonjour
239 Group:          Libraries
240 Provides:       mdns-bonjour
241 Obsoletes:      mDNSResponder-libs
242
243 %description compat-libdns_sd
244 Avahi Bonjour compat library.
245
246 %description compat-libdns_sd -l pl.UTF-8
247 Biblioteka Avahi zgodna z Bonjour.
248
249 %package compat-libdns_sd-devel
250 Summary:        Header files for Avahi Bonjour compat library
251 Summary(pl.UTF-8):      Pliki nagłówkowe wiązań Avahi dla biblioteki zgodnej z Bonjour
252 Group:          Development/Libraries
253 Requires:       %{name}-compat-libdns_sd = %{version}-%{release}
254 Requires:       %{name}-devel = %{version}-%{release}
255 Provides:       mdns-bonjour-devel
256 Obsoletes:      mDNSResponder-devel
257
258 %description compat-libdns_sd-devel
259 Header files for Avahi Bonjour compat library.
260
261 %description compat-libdns_sd-devel -l pl.UTF-8
262 Pliki nagłówkowe wiązań Avahi dla biblioteki zgodnej z Bonjour.
263
264 %package compat-libdns_sd-static
265 Summary:        Static Avahi Bonjour compat library
266 Summary(pl.UTF-8):      Statyczna biblioteka Avahi zgodna z Bonjour
267 Group:          Development/Libraries
268 Requires:       %{name}-compat-libdns_sd-devel = %{version}-%{release}
269 Provides:       mdns-bonjour-static
270
271 %description compat-libdns_sd-static
272 Static Avahi Bonjour compat library.
273
274 %description compat-libdns_sd-static -l pl.UTF-8
275 Statyczna biblioteka Avahi zgodna z Bonjour.
276
277 %package compat-howl
278 Summary:        Avahi Howl compat library
279 Summary(pl.UTF-8):      Biblioteka Avahi zgodna z Howl
280 Group:          Libraries
281 Provides:       mdns-howl-libs
282 Obsoletes:      howl-libs
283
284 %description compat-howl
285 Avahi Howl compat library.
286
287 %description compat-howl -l pl.UTF-8
288 Biblioteka Avahi zgodna z Howl.
289
290 %package compat-howl-devel
291 Summary:        Header files for Avahi Howl compat library
292 Summary(pl.UTF-8):      Pliki nagłówkowe wiązań Avahi dla biblioteki zgodnej z Howl
293 Group:          Development/Libraries
294 Requires:       %{name}-compat-howl = %{version}-%{release}
295 Requires:       %{name}-devel = %{version}-%{release}
296 Provides:       mdns-howl-devel
297 Obsoletes:      howl-devel
298
299 %description compat-howl-devel
300 Header files for Avahi Howl compat library.
301
302 %description compat-howl-devel -l pl.UTF-8
303 Pliki nagłówkowe wiązań Avahi dla biblioteki zgodnej z Howl.
304
305 %package compat-howl-static
306 Summary:        Static Avahi Howl compat library
307 Summary(pl.UTF-8):      Statyczna biblioteka Avahi zgodna z Howl
308 Group:          Development/Libraries
309 Requires:       %{name}-compat-howl-devel = %{version}-%{release}
310 Provides:       mdns-howl-static
311 Obsoletes:      howl-static
312
313 %description compat-howl-static
314 Static Avahi Howl compat library.
315
316 %description compat-howl-static -l pl.UTF-8
317 Statyczna biblioteka Avahi zgodna z Howl.
318
319 %package glib
320 Summary:        Avahi GLib library bindings
321 Summary(pl.UTF-8):      Wiązania Avahi dla bibioteki GLib
322 Group:          Libraries
323
324 %description glib
325 Avahi GLib library bindings.
326
327 %description glib -l pl.UTF-8
328 Wiązania Avahi dla bibioteki GLib.
329
330 %package glib-devel
331 Summary:        Header files for Avahi GLib library bindings
332 Summary(pl.UTF-8):      Pliki nagłówkowe wiązań Avahi dla biblioteki GLib
333 Group:          Development/Libraries
334 Requires:       %{name}-devel = %{version}-%{release}
335 Requires:       %{name}-glib = %{version}-%{release}
336 Requires:       glib2-devel >= 1:2.12.2
337
338 %description glib-devel
339 This is the package containing the header files for Avahi-glib
340 library.
341
342 %description glib-devel -l pl.UTF-8
343 Ten pakiet zawiera pliki nagłówkowe biblioteki Avahi-glib.
344
345 %package glib-static
346 Summary:        Static Avahi GLib library
347 Summary(pl.UTF-8):      Statyczna biblioteka Avahi GLib
348 Group:          Development/Libraries
349 Requires:       %{name}-glib-devel = %{version}-%{release}
350
351 %description glib-static
352 Static Avahi GLib library.
353
354 %description glib-static -l pl.UTF-8
355 Statyczna biblioteka Avahi GLib.
356
357 %package gobject
358 Summary:        Avahi GObject interface
359 Summary(pl.UTF-8):      Interfejs GObject do Avahi
360 Group:          Libraries
361
362 %description gobject
363 Avahi GObject interface.
364
365 %description gobject -l pl.UTF-8
366 Interfejs GObject do Avahi.
367
368 %package gobject-devel
369 Summary:        Header files for Avahi GObject interface
370 Summary(pl.UTF-8):      Pliki nagłówkowe interfejsu GObject do Avahi
371 Group:          Development/Libraries
372 Requires:       %{name}-devel = %{version}-%{release}
373 Requires:       %{name}-gobject = %{version}-%{release}
374 Requires:       glib2-devel >= 1:2.12.2
375
376 %description gobject-devel
377 This is the package containing the header files for Avahi GObject
378 interface.
379
380 %description gobject-devel -l pl.UTF-8
381 Ten pakiet zawiera pliki nagłówkowe interfejsu GObject do Avahi.
382
383 %package gobject-static
384 Summary:        Static Avahi GObject library
385 Summary(pl.UTF-8):      Statyczna biblioteka Avahi GObject
386 Group:          Development/Libraries
387 Requires:       %{name}-gobject-devel = %{version}-%{release}
388
389 %description gobject-static
390 Static Avahi GObject library.
391
392 %description gobject-static -l pl.UTF-8
393 Statyczna biblioteka Avahi GObject.
394
395 %package qt
396 Summary:        Avahi Qt 3 library bindings
397 Summary(pl.UTF-8):      Wiązania Avahi dla biblioteki Qt 3
398 Group:          Libraries
399 Requires:       %{name}-libs = %{version}-%{release}
400 Obsoletes:      avahi-qt3
401
402 %description qt
403 Avahi Qt 3 library bindings.
404
405 %description qt -l pl.UTF-8
406 Wiązania Avahi dla biblioteki Qt 3.
407
408 %package qt-devel
409 Summary:        Header files for Avahi Qt 3 library bindings
410 Summary(pl.UTF-8):      Pliki nagłówkowe wiązań Avahi dla biblioteki Qt 3
411 Group:          Development/Libraries
412 Requires:       %{name}-devel = %{version}-%{release}
413 Requires:       %{name}-qt = %{version}-%{release}
414 Requires:       qt-devel >= 1:3.0
415 Obsoletes:      avahi-qt3-devel
416
417 %description qt-devel
418 Header files for Avahi Qt 3 library bindings.
419
420 %description qt-devel -l pl.UTF-8
421 Pliki nagłówkowe wiązań Avahi dla biblioteki Qt 3.
422
423 %package qt-static
424 Summary:        Static Avahi Qt 3 library
425 Summary(pl.UTF-8):      Statyczna biblioteka Avahi Qt 3
426 Group:          Development/Libraries
427 Requires:       %{name}-qt-devel = %{version}-%{release}
428 Obsoletes:      avahi-qt3-static
429
430 %description qt-static
431 Static Avahi Qt 3 library.
432
433 %description qt-static -l pl.UTF-8
434 Statyczna biblioteka Avahi Qt 3.
435
436 %package Qt
437 Summary:        Avahi Qt 4 library bindings
438 Summary(pl.UTF-8):      Wiązania Avahi dla biblioteki Qt 4
439 Group:          Libraries
440 Requires:       %{name}-libs = %{version}-%{release}
441
442 %description Qt
443 Avahi Qt 4 library bindings.
444
445 %description Qt -l pl.UTF-8
446 Wiązania Avahi dla biblioteki Qt 4.
447
448 %package Qt-devel
449 Summary:        Header files for Avahi Qt 4 library bindings
450 Summary(pl.UTF-8):      Pliki nagłówkowe wiązań Avahi dla biblioteki Qt 4
451 Group:          Development/Libraries
452 Requires:       %{name}-Qt = %{version}-%{release}
453 Requires:       %{name}-devel = %{version}-%{release}
454
455 %description Qt-devel
456 Header files for Avahi Qt 4 library bindings.
457
458 %description Qt-devel -l pl.UTF-8
459 Pliki nagłówkowe wiązań Avahi dla biblioteki Qt 4.
460
461 %package Qt-static
462 Summary:        Static Avahi Qt 4 library
463 Summary(pl.UTF-8):      Statyczna biblioteka Avahi Qt 4
464 Group:          Development/Libraries
465 Requires:       %{name}-Qt-devel = %{version}-%{release}
466
467 %description Qt-static
468 Static Avahi Qt 4 library.
469
470 %description Qt-static -l pl.UTF-8
471 Statyczna biblioteka Avahi Qt 4.
472
473 %package -n python-avahi
474 Summary:        Avahi Python bindings
475 Summary(pl.UTF-8):      Wiązania Avahi dla Pythona
476 Group:          Development/Languages/Python
477 Requires:       %{name}-libs = %{version}-%{release}
478 Requires:       python-dbus >= 0.71
479
480 %description -n python-avahi
481 Avahi Python bindings.
482
483 %description -n python-avahi -l pl.UTF-8
484 Wiązania Avahi dla Pythona.
485
486 %package -n dotnet-avahi
487 Summary:        Avahi MONO bindings
488 Summary(pl.UTF-8):      Wiązania Avahi dla MONO
489 Group:          Libraries
490 Requires:       %{name}-libs = %{version}-%{release}
491
492 %description -n dotnet-avahi
493 Avahi MONO bindings.
494
495 %description -n dotnet-avahi -l pl.UTF-8
496 Wiązania Avahi dla MONO.
497
498 %package -n dotnet-avahi-devel
499 Summary:        Development files for MONO Avahi bindings
500 Summary(pl.UTF-8):      Pliki rozwojowe wiązań Avahi dla MONO
501 Group:          Development/Libraries
502 Requires:       dotnet-avahi = %{version}-%{release}
503 Requires:       monodoc >= 2.6
504
505 %description -n dotnet-avahi-devel
506 Development files for MONO Avahi bindings.
507
508 %description -n dotnet-avahi-devel -l pl.UTF-8
509 Pliki rozwojowe wiązań Avahi dla MONO.
510
511 %package -n dotnet-avahi-ui
512 Summary:        Avahi UI MONO bindings
513 Summary(pl.UTF-8):      Wiązania Avahi UI dla MONO
514 Group:          X11/Libraries
515 Requires:       %{name}-ui = %{version}-%{release}
516 Requires:       dotnet-avahi = %{version}-%{release}
517
518 %description -n dotnet-avahi-ui
519 Avahi UI MONO bindings.
520
521 %description -n dotnet-avahi-ui -l pl.UTF-8
522 Wiązania Avahi UI dla MONO.
523
524 %package -n dotnet-avahi-ui-devel
525 Summary:        Development files for MONO Avahi UI bindings
526 Summary(pl.UTF-8):      Pliki rozwojowe wiązań Avahi UI dla MONO
527 Group:          X11/Development/Libraries
528 Requires:       dotnet-avahi-ui = %{version}-%{release}
529 Requires:       monodoc >= 2.6
530
531 %description -n dotnet-avahi-ui-devel
532 Development files for MONO Avahi UI bindings.
533
534 %description -n dotnet-avahi-ui-devel -l pl.UTF-8
535 Pliki rozwojowe wiązań Avahi UI dla MONO.
536
537 %package bookmarks
538 Summary:        Miniature web server
539 Summary(pl.UTF-8):      Miniaturowy serwer WWW
540 Group:          Applications
541
542 %description bookmarks
543 A Python based miniature web server that browses for mDNS/DNS-SD
544 services of type '_http._tcp' (i.e. web sites) and makes them
545 available as HTML links on http://localhost:8080/.
546
547 %description bookmarks -l pl.UTF-8
548 Napisany w Pythonie miniaturowy serwer WWW, pozwalający na
549 przeglądanie usług typu '_http._tcp' (np. stron WWW) i udostępniający
550 je jako odnośniki HTML na http://localhost:8080/.
551
552 %package discover
553 Summary:        Avahi Zeroconf browser
554 Summary(pl.UTF-8):      Przeglądarka Zeroconf Avahi
555 Group:          Applications
556 Requires:       python-avahi = %{version}-%{release}
557 Requires:       python-pygtk-glade >= 2:2.9.6
558
559 %description discover
560 A tool for enumerating all available services on the local LAN
561 (python-pygtk implementation).
562
563 %description discover -l pl.UTF-8
564 Narzędzie wymieniające wszystkie dostępne usługi w sieci lokalnej LAN
565 (implementacja w python-pygtk).
566
567 %package discover-standalone
568 Summary:        Avahi Zeroconf browser
569 Summary(pl.UTF-8):      Przeglądarka Zeroconf Avahi
570 Group:          Applications
571 Requires:       %{name}-glib = %{version}-%{release}
572
573 %description discover-standalone
574 GTK+ tool for enumerating all available services on the local LAN.
575
576 %description discover-standalone -l pl.UTF-8
577 Narzędzie GTK+ wymieniające wszystkie dostępne usługi w sieci lokalnej
578 LAN.
579
580 %package utils
581 Summary:        Avahi CLI utilities
582 Summary(pl.UTF-8):      Narzędzia CLI Avahi
583 Group:          Applications
584
585 %description utils
586 Command line utilities using avahi-client.
587
588 %description utils -l pl.UTF-8
589 Narzędzia linii poleceń korzystające z avahi-client.
590
591 %prep
592 %setup -q
593 %patch0 -p1
594 %patch1 -p1
595 %patch2 -p1
596 %patch3 -p1
597 %patch4 -p1
598 %patch5 -p1
599 %patch6 -p1
600
601 %build
602 %{__intltoolize}
603 %{__libtoolize}
604 %{__aclocal} -I common
605 %{__autoconf}
606 %{__autoheader}
607 %{__automake}
608 %configure \
609         --disable-silent-rules \
610         --enable-compat-libdns_sd \
611         --enable-compat-howl \
612         --with-distro=none \
613         %{!?with_apidocs:--disable-doxygen-doc} \
614         %{!?with_gtk:--disable-gtk} \
615         %{!?with_gtk3:--disable-gtk3} \
616         %{!?with_pygtk:--disable-pygtk} \
617         %{!?with_qt3:--disable-qt3} \
618         %{!?with_qt4:--disable-qt4} \
619         %{!?with_dotnet:--disable-mono} \
620         %{!?with_dotnet:--disable-monodoc} \
621         --with-avahi-priv-access-group=adm \
622         --with-autoipd-user=avahi \
623         --with-autoipd-group=avahi
624 %{__make}
625
626 %install
627 rm -rf $RPM_BUILD_ROOT
628 install -d $RPM_BUILD_ROOT{%{_pixmapsdir},/etc/rc.d/init.d,/etc/init}
629
630 %{__make} install \
631         DESTDIR=$RPM_BUILD_ROOT \
632         pythondir=%{py_sitedir}
633
634 install -p %{SOURCE1} %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d
635 cp -a %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}
636
637 install %{SOURCE4} $RPM_BUILD_ROOT/etc/init/avahi-daemon.conf
638 install %{SOURCE5} $RPM_BUILD_ROOT/etc/init/avahi-dnsconfd.conf
639
640 ln -sf %{_includedir}/avahi-compat-libdns_sd/dns_sd.h \
641         $RPM_BUILD_ROOT%{_includedir}/dns_sd.h
642
643 ln -sf %{_pkgconfigdir}/avahi-compat-howl.pc \
644         $RPM_BUILD_ROOT%{_pkgconfigdir}/howl.pc
645
646 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
647 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
648 %py_postclean
649
650 rm -f $RPM_BUILD_ROOT%{_mandir}/man1/{avahi-{browse-domains,publish-address,publish-service,resolve-address,resolve-host-name},bvnc}.1
651 echo '.so avahi-browse.1' > $RPM_BUILD_ROOT%{_mandir}/man1/avahi-browse-domains.1
652 echo '.so avahi-publish.1' > $RPM_BUILD_ROOT%{_mandir}/man1/avahi-publish-address.1
653 echo '.so avahi-publish.1' > $RPM_BUILD_ROOT%{_mandir}/man1/avahi-publish-service.1
654 echo '.so avahi-resolve.1' > $RPM_BUILD_ROOT%{_mandir}/man1/avahi-resolve-address.1
655 echo '.so avahi-resolve.1' > $RPM_BUILD_ROOT%{_mandir}/man1/avahi-resolve-host-name.1
656 echo '.so bssh.1' > $RPM_BUILD_ROOT%{_mandir}/man1/bvnc.1
657
658 %find_lang %{name}
659
660 %clean
661 rm -rf $RPM_BUILD_ROOT
662
663 %pre
664 %groupadd -g 165 -r -f avahi
665 %useradd -u 165 -r -d /usr/share/empty -s /bin/false -c "Avahi daemon" -g avahi avahi
666
667 %pre autoipd
668 %groupadd -g 165 -r -f avahi
669 %useradd -u 165 -r -d /usr/share/empty -s /bin/false -c "Avahi daemon" -g avahi avahi
670
671 %post
672 /sbin/chkconfig --add %{name}-daemon
673 %service %{name}-daemon restart
674 /sbin/chkconfig --add %{name}-dnsconfd
675 %service %{name}-dnsconfd restart
676
677 %preun
678 if [ "$1" = "0" ]; then
679         %service -q %{name}-dnsconfd stop
680         /sbin/chkconfig --del %{name}-dnsconfd
681         %service -q %{name}-daemon stop
682         /sbin/chkconfig --del %{name}-daemon
683 fi
684
685 %postun
686 if [ "$1" = "0" ]; then
687         %userremove avahi
688         %groupremove avahi
689 fi
690
691 %postun autoipd
692 if [ "$1" = "0" ]; then
693         %userremove avahi
694         %groupremove avahi
695 fi
696
697 %post upstart
698 %upstart_post avahi-daemon
699 %upstart_post avahi-dnsconfd
700
701 %postun upstart
702 %upstart_postun avahi-daemon
703 %upstart_postun avahi-dnsconfd
704
705 %post   libs -p /sbin/ldconfig
706 %postun libs -p /sbin/ldconfig
707
708 %post   ui -p /sbin/ldconfig
709 %postun ui -p /sbin/ldconfig
710
711 %post   compat-libdns_sd -p /sbin/ldconfig
712 %postun compat-libdns_sd -p /sbin/ldconfig
713
714 %post   compat-howl -p /sbin/ldconfig
715 %postun compat-howl -p /sbin/ldconfig
716
717 %post   glib -p /sbin/ldconfig
718 %postun glib -p /sbin/ldconfig
719
720 %post   gobject -p /sbin/ldconfig
721 %postun gobject -p /sbin/ldconfig
722
723 %post   qt -p /sbin/ldconfig
724 %postun qt -p /sbin/ldconfig
725
726 %post   Qt -p /sbin/ldconfig
727 %postun Qt -p /sbin/ldconfig
728
729 %files
730 %defattr(644,root,root,755)
731 %doc docs/AUTHORS docs/COMPAT-LAYERS docs/NEWS docs/README docs/TODO
732
733 %dir %{_sysconfdir}/avahi
734 %dir %{_sysconfdir}/avahi/services
735 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/avahi/avahi-daemon.conf
736 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/avahi/avahi-dnsconfd.action
737 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/avahi/hosts
738 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/avahi/services/ssh.service
739 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/avahi/services/sftp-ssh.service
740 %config(noreplace) %verify(not md5 mtime size) /etc/dbus-1/system.d/*
741
742 %attr(755,root,root) %{_bindir}/avahi-set-host-name
743
744 %attr(755,root,root) %{_sbindir}/avahi-daemon
745 %attr(755,root,root) %{_sbindir}/avahi-dnsconfd
746 %dir %{_libdir}/%{name}
747 %{_libdir}/%{name}/service-types.db
748 #%%dir %{_datadir}/%{name}/introspection
749 #%%{_datadir}/%{name}/introspection/*.introspect
750 %{_datadir}/%{name}/avahi-service.dtd
751 %{_datadir}/%{name}/service-types
752 %{_datadir}/dbus-1/interfaces/org.freedesktop.Avahi.*.xml
753
754 %{_mandir}/man1/avahi-set-host-name.1*
755 %{_mandir}/man5/avahi-daemon.conf.5*
756 %{_mandir}/man5/avahi.hosts.5*
757 %{_mandir}/man5/avahi.service.5*
758 %{_mandir}/man8/avahi-daemon.8*
759 %{_mandir}/man8/avahi-dnsconfd.8*
760 %{_mandir}/man8/avahi-dnsconfd.action.8*
761
762 %attr(754,root,root) /etc/rc.d/init.d/%{name}-daemon
763 %attr(754,root,root) /etc/rc.d/init.d/%{name}-dnsconfd
764
765 %if "%{pld_release}" != "ti"
766 %files upstart
767 %defattr(644,root,root,755)
768 %config(noreplace) %verify(not md5 mtime size) /etc/init/*.conf
769 %endif
770
771 %files autoipd
772 %defattr(644,root,root,755)
773 %dir %{_sysconfdir}/avahi
774 %attr(755,root,root) %{_sysconfdir}/%{name}/avahi-autoipd.action
775 %dir %{_sysconfdir}/dhclient-enter-hooks.d
776 %config(noreplace) %verify(not md5 mtime size) /etc/dhclient-enter-hooks.d/avahi-autoipd
777 %dir %{_sysconfdir}/dhclient-exit-hooks.d
778 %config(noreplace) %verify(not md5 mtime size) /etc/dhclient-exit-hooks.d/avahi-autoipd
779 %attr(755,root,root) %{_sbindir}/avahi-autoipd
780 %{_mandir}/man8/avahi-autoipd.8*
781 %{_mandir}/man8/avahi-autoipd.action.8*
782
783 %files libs -f %{name}.lang
784 %defattr(644,root,root,755)
785 %attr(755,root,root) %{_libdir}/libavahi-client.so.*.*.*
786 %attr(755,root,root) %ghost %{_libdir}/libavahi-client.so.3
787 %attr(755,root,root) %{_libdir}/libavahi-common.so.*.*.*
788 %attr(755,root,root) %ghost %{_libdir}/libavahi-common.so.3
789 %attr(755,root,root) %{_libdir}/libavahi-core.so.*.*.*
790 %attr(755,root,root) %ghost %{_libdir}/libavahi-core.so.7
791 # common for -discover*
792 %dir %{_datadir}/%{name}
793 %dir %{_datadir}/%{name}/interfaces
794
795 %files devel
796 %defattr(644,root,root,755)
797 %doc docs/API-CHANGES-0.6 docs/DBUS-API docs/HACKING docs/MALLOC
798 %attr(755,root,root) %{_libdir}/libavahi-client.so
799 %attr(755,root,root) %{_libdir}/libavahi-common.so
800 %attr(755,root,root) %{_libdir}/libavahi-core.so
801 %{_libdir}/libavahi-client.la
802 %{_libdir}/libavahi-common.la
803 %{_libdir}/libavahi-core.la
804 %{_includedir}/avahi-client
805 %{_includedir}/avahi-common
806 %{_includedir}/avahi-core
807 %{_pkgconfigdir}/avahi-client.pc
808 %{_pkgconfigdir}/avahi-core.pc
809
810 %files static
811 %defattr(644,root,root,755)
812 %{_libdir}/libavahi-client.a
813 %{_libdir}/libavahi-common.a
814 %{_libdir}/libavahi-core.a
815
816 %if %{with gtk}
817 %files ui
818 %defattr(644,root,root,755)
819 %attr(755,root,root) %{_bindir}/bshell
820 %attr(755,root,root) %{_bindir}/bssh
821 %attr(755,root,root) %{_bindir}/bvnc
822 %attr(755,root,root) %{_libdir}/libavahi-ui.so.*.*.*
823 %attr(755,root,root) %ghost %{_libdir}/libavahi-ui.so.0
824 %{_mandir}/man1/bssh.1*
825 %{_mandir}/man1/bvnc.1*
826 %{_desktopdir}/bssh.desktop
827 %{_desktopdir}/bvnc.desktop
828
829 %files ui-devel
830 %defattr(644,root,root,755)
831 %attr(755,root,root) %{_libdir}/libavahi-ui.so
832 %{_libdir}/libavahi-ui.la
833 %{_includedir}/avahi-ui
834 %{_pkgconfigdir}/avahi-ui.pc
835
836 %files ui-static
837 %defattr(644,root,root,755)
838 %{_libdir}/libavahi-ui.a
839 %endif
840
841 %files compat-libdns_sd
842 %defattr(644,root,root,755)
843 %attr(755,root,root) %{_libdir}/libdns_sd.so.*.*.*
844 %attr(755,root,root) %ghost %{_libdir}/libdns_sd.so.1
845
846 %files compat-libdns_sd-devel
847 %defattr(644,root,root,755)
848 %attr(755,root,root) %{_libdir}/libdns_sd.so
849 %{_libdir}/libdns_sd.la
850 %{_includedir}/avahi-compat-libdns_sd
851 %{_includedir}/dns_sd.h
852 %{_pkgconfigdir}/avahi-compat-libdns_sd.pc
853
854 %files compat-libdns_sd-static
855 %defattr(644,root,root,755)
856 %{_libdir}/libdns_sd.a
857
858 %files compat-howl
859 %defattr(644,root,root,755)
860 %attr(755,root,root) %{_libdir}/libhowl.so.*.*.*
861 %attr(755,root,root) %ghost %{_libdir}/libhowl.so.0
862
863 %files compat-howl-devel
864 %defattr(644,root,root,755)
865 %attr(755,root,root) %{_libdir}/libhowl.so
866 %{_libdir}/libhowl.la
867 %{_includedir}/avahi-compat-howl
868 %{_pkgconfigdir}/avahi-compat-howl.pc
869 %{_pkgconfigdir}/howl.pc
870
871 %files compat-howl-static
872 %defattr(644,root,root,755)
873 %{_libdir}/libhowl.a
874
875 %files -n python-avahi
876 %defattr(644,root,root,755)
877 %{py_sitedir}/avahi
878
879 %if %{with dotnet}
880 %files -n dotnet-avahi
881 %defattr(644,root,root,755)
882 %{_prefix}/lib/mono/gac/avahi-sharp
883
884 %files -n dotnet-avahi-devel
885 %defattr(644,root,root,755)
886 %{_prefix}/lib/mono/avahi-sharp
887 %{_prefix}/lib/monodoc/sources/avahi-sharp-docs.*
888 %{_pkgconfigdir}/avahi-sharp.pc
889
890 %files -n dotnet-avahi-ui
891 %defattr(644,root,root,755)
892 %{_prefix}/lib/mono/gac/avahi-ui-sharp
893
894 %files -n dotnet-avahi-ui-devel
895 %defattr(644,root,root,755)
896 %{_prefix}/lib/mono/avahi-ui-sharp
897 %{_prefix}/lib/monodoc/sources/avahi-ui-sharp-docs.*
898 %{_pkgconfigdir}/avahi-ui-sharp.pc
899 %endif
900
901 %files glib
902 %defattr(644,root,root,755)
903 %attr(755,root,root) %{_libdir}/libavahi-glib.so.*.*.*
904 %attr(755,root,root) %ghost %{_libdir}/libavahi-glib.so.1
905
906 %files glib-devel
907 %defattr(644,root,root,755)
908 %attr(755,root,root) %{_libdir}/libavahi-glib.so
909 %{_libdir}/libavahi-glib.la
910 %{_includedir}/avahi-glib
911 %{_pkgconfigdir}/avahi-glib.pc
912
913 %files glib-static
914 %defattr(644,root,root,755)
915 %{_libdir}/libavahi-glib.a
916
917 %files gobject
918 %defattr(644,root,root,755)
919 %attr(755,root,root) %{_libdir}/libavahi-gobject.so.*.*.*
920 %attr(755,root,root) %ghost %{_libdir}/libavahi-gobject.so.0
921 %{_libdir}/girepository-1.0/Avahi-0.6.typelib
922 %{_libdir}/girepository-1.0/AvahiCore-0.6.typelib
923
924 %files gobject-devel
925 %defattr(644,root,root,755)
926 %attr(755,root,root) %{_libdir}/libavahi-gobject.so
927 %{_libdir}/libavahi-gobject.la
928 %{_includedir}/avahi-gobject
929 %{_pkgconfigdir}/avahi-gobject.pc
930 %{_datadir}/gir-1.0/Avahi-0.6.gir
931 %{_datadir}/gir-1.0/AvahiCore-0.6.gir
932
933 %files gobject-static
934 %defattr(644,root,root,755)
935 %{_libdir}/libavahi-gobject.a
936
937 %if %{with qt3}
938 %files qt
939 %defattr(644,root,root,755)
940 %attr(755,root,root) %{_libdir}/libavahi-qt3.so.*.*.*
941 %attr(755,root,root) %ghost %{_libdir}/libavahi-qt3.so.1
942
943 %files qt-devel
944 %defattr(644,root,root,755)
945 %attr(755,root,root) %{_libdir}/libavahi-qt3.so
946 %{_libdir}/libavahi-qt3.la
947 %{_includedir}/avahi-qt3
948 %{_pkgconfigdir}/avahi-qt3.pc
949
950 %files qt-static
951 %defattr(644,root,root,755)
952 %{_libdir}/libavahi-qt3.a
953 %endif
954
955 %if %{with qt4}
956 %files Qt
957 %defattr(644,root,root,755)
958 %attr(755,root,root) %{_libdir}/libavahi-qt4.so.*.*.*
959 %attr(755,root,root) %ghost %{_libdir}/libavahi-qt4.so.1
960
961 %files Qt-devel
962 %defattr(644,root,root,755)
963 %attr(755,root,root) %{_libdir}/libavahi-qt4.so
964 %{_libdir}/libavahi-qt4.la
965 %{_includedir}/avahi-qt4
966 %{_pkgconfigdir}/avahi-qt4.pc
967
968 %files Qt-static
969 %defattr(644,root,root,755)
970 %{_libdir}/libavahi-qt4.a
971 %endif
972
973 %files bookmarks
974 %defattr(644,root,root,755)
975 %attr(755,root,root) %{_bindir}/avahi-bookmarks
976 %{_mandir}/man1/avahi-bookmarks.1*
977
978 %if %{with pygtk}
979 %files discover
980 %defattr(644,root,root,755)
981 %attr(755,root,root) %{_bindir}/avahi-discover
982 %{py_sitedir}/avahi_discover
983 %{_datadir}/%{name}/interfaces/avahi-discover.ui
984 %{_desktopdir}/avahi-discover.desktop
985 %{_pixmapsdir}/avahi.png
986 %{_mandir}/man1/avahi-discover.1*
987 %endif
988
989 %if %{with gtk}
990 %files discover-standalone
991 %defattr(644,root,root,755)
992 %attr(755,root,root) %{_bindir}/avahi-discover-standalone
993 %{_datadir}/%{name}/interfaces/avahi-discover-standalone.glade
994 %endif
995
996 %files utils
997 %defattr(644,root,root,755)
998 %attr(755,root,root) %{_bindir}/avahi-browse
999 %attr(755,root,root) %{_bindir}/avahi-browse-domains
1000 %attr(755,root,root) %{_bindir}/avahi-publish
1001 %attr(755,root,root) %{_bindir}/avahi-publish-address
1002 %attr(755,root,root) %{_bindir}/avahi-publish-service
1003 %attr(755,root,root) %{_bindir}/avahi-resolve
1004 %attr(755,root,root) %{_bindir}/avahi-resolve-address
1005 %attr(755,root,root) %{_bindir}/avahi-resolve-host-name
1006 %{_mandir}/man1/avahi-browse.1*
1007 %{_mandir}/man1/avahi-browse-domains.1*
1008 %{_mandir}/man1/avahi-publish.1*
1009 %{_mandir}/man1/avahi-publish-address.1*
1010 %{_mandir}/man1/avahi-publish-service.1*
1011 %{_mandir}/man1/avahi-resolve.1*
1012 %{_mandir}/man1/avahi-resolve-address.1*
1013 %{_mandir}/man1/avahi-resolve-host-name.1*
This page took 0.17533 seconds and 3 git commands to generate.