]> git.pld-linux.org Git - packages/autopsy.git/blob - autopsy.spec
- pl desc
[packages/autopsy.git] / autopsy.spec
1 # TODO
2 #       - %%service stuff
3 #       - add user autopsy with proper homedir rights
4 %include        /usr/lib/rpm/macros.perl
5 Summary:        The Autopsy Forensic Browser - a graphical interface to The Sleuth Kit utilities
6 Summary(pl):    Autopsy Forensic Browser - graficzny interfejs do narzêdzi z The Sleuth Kit
7 Name:           autopsy
8 Version:        2.08
9 Release:        0.3
10 License:        GPL
11 Group:          Applications
12 Source0:        http://dl.sourceforge.net/autopsy/%{name}-%{version}.tar.gz
13 # Source0-md5:  0ac9db9acf66742f8f01f3d8b0cf2f90
14 URL:            http://www.sleuthkit.org/autopsy
15 BuildRequires:  rpm-perlprov >= 4.1-13
16 Requires:       coreutils
17 Requires:       file
18 # check: openssl contains only shared lib and I don't see any native code here
19 # shouldn't it be openssl-tools or some openssl-based perl module?
20 Requires:       openssl
21 Requires:       perl-Date-Manip
22 Requires:       sleuthkit
23 # noarch?
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 The Autopsy Forensic Browser is a graphical interface to utilities
28 found in The Sleuth Kit (TSK). TSK is a collection of command line
29 tools that allow you to investigate a Windows or Unix system by
30 examining the hard disk contents. TSK and Autopsy will show you the
31 files, data units, and metadata of NTFS, FAT, EXTxFS, and UFS file
32 system images in a read-only environment. Autopsy allows you to search
33 for specific types of evidence based on keywords, MAC times, hash
34 values, and file types.
35
36 %description -l pl
37 Autopsy Forensic Browser to graficzny interfejs do narzêdzi z pakietu
38 The Sleuth Kit (TSK). TSK to zbiór programów dzia³aj±cych z linii
39 poleceñ pozwalaj±cych zbadaæ system Windows lub uniksowy poprzez
40 sprawdzanie zawarto¶ci twardego dysku. TSK i Autopsy pokazuj± pliki,
41 jednostki danych i metadane obrazów systemów plików NTFS, FAT, EXTxFS
42 i UFS w ¶rodowisku tylko do odczytu. Autopsy pozwala wyszukiwaæ
43 okre¶lone rodzaje dowodów w oparciu o s³owa kluczowe, czasy MAC,
44 warto¶ci haszy i rodzaje plików.
45
46 %prep
47 %setup -q
48
49 echo '#!%{__perl} -wT' > autopsy
50 echo 'use lib qw(%{perl_vendorlib}/Autopsy);' >> autopsy
51 echo 'use lib qw(%{perl_vendorlib}/Autopsy/lib);' >> autopsy
52 cat base/autopsy.base >> autopsy
53
54 cat > conf.pl <<-'EOF'
55         # Autopsy configuration settings
56
57         # when set to 1, the server will stop after it receives no
58         # connections for STIMEOUT seconds.
59         $USE_STIMEOUT = 0;
60         $STIMEOUT = 3600;
61
62         # number of seconds that child waits for input from client
63         $CTIMEOUT = 15;
64
65         # set to 1 to save the cookie value in a file (for scripting)
66         $SAVE_COOKIE = 1;
67
68         $INSTALLDIR = '%{perl_vendorlib}/Autopsy/';
69
70         # System Utilities
71         $GREP_EXE = '/bin/grep';
72
73         # Directories
74         $TSKDIR = '%{_bindir}';
75         $FILE_EXE = '%{_bindir}/file';
76         $NSRLDB = '';
77 # FIXME: FHS: /var/{lib,run}/autopsy?
78         $LOCKDIR = '/home/services/autopsy';
79 EOF
80
81 %install
82 rm -rf $RPM_BUILD_ROOT
83
84 install -d $RPM_BUILD_ROOT%{_bindir}
85 install -d $RPM_BUILD_ROOT%{_mandir}/man1
86 install -d $RPM_BUILD_ROOT/home/services/autopsy
87 install -d $RPM_BUILD_ROOT%{perl_vendorlib}/Autopsy/{lib,pict}
88
89 install autopsy $RPM_BUILD_ROOT%{_bindir}
90 install conf.pl $RPM_BUILD_ROOT%{perl_vendorlib}/Autopsy
91 install lib/* $RPM_BUILD_ROOT%{perl_vendorlib}/Autopsy/lib
92 install pict/* $RPM_BUILD_ROOT%{perl_vendorlib}/Autopsy/pict
93
94 install man/man1/* $RPM_BUILD_ROOT%{_mandir}/man1
95
96 %clean
97 rm -rf $RPM_BUILD_ROOT
98
99 %files
100 %defattr(644,root,root,755)
101 %doc README.txt docs/sleuthkit-informer-13.txt
102 %attr(755,root,root) %{_bindir}/*
103 %dir %{perl_vendorlib}/Autopsy
104 %{perl_vendorlib}/Autopsy/conf.pl
105 %{perl_vendorlib}/Autopsy/lib
106 %{perl_vendorlib}/Autopsy/pict
107 %{_mandir}/man1/*
108 /home/services/autopsy
This page took 0.112808 seconds and 3 git commands to generate.