]> git.pld-linux.org Git - packages/autopano-sift-C.git/blob - autopano-sift-C.spec
- use Release build type (pass appropriate C_FLAGS and CXX_FLAGS to cmake - both...
[packages/autopano-sift-C.git] / autopano-sift-C.spec
1 Summary:        SIFT Feature Detection implementation
2 Summary(pl.UTF-8):      Implementacja algorytmu SIFT do wykrywania cech obrazu
3 Name:           autopano-sift-C
4 Version:        2.5.1
5 Release:        1
6 License:        GPL v2, but SIFT algorithm may require license in some countries
7 Group:          Applications/Graphics
8 Source0:        http://downloads.sourceforge.net/hugin/%{name}-%{version}.tar.gz
9 # Source0-md5:  b9bade07e8c4f2ea383c22a082c260e0
10 URL:            http://wiki.panotools.org/Autopano-sift-C
11 BuildRequires:  cmake >= 2.4
12 BuildRequires:  libjpeg-devel
13 BuildRequires:  libpano13-devel
14 BuildRequires:  libpng-devel
15 BuildRequires:  libtiff-devel
16 BuildRequires:  libstdc++-devel
17 BuildRequires:  libxml2-devel >= 2.0
18 BuildRequires:  pkgconfig
19 BuildRequires:  rpmbuild(macros) >= 1.471
20 BuildRequires:  sed >= 4.0
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 The SIFT algorithm provides the capability to identify key feature
25 points within arbitrary images. It further extracts highly distinct
26 information for each such point and allows to characterize the point
27 invariant to a number of modifications to the image. It is invariant
28 to contrast/brightness changes, to rotation, scaling and partially
29 invariant to other kinds of transformations. The algorithm can be
30 flexibly used to create input data for image matching, object
31 identification and other computer vision related algorithms.
32
33 autopano-sift-C is a C port of the C# software autopano-sift. It is
34 somewhat faster and doesn't require a C# runtime. Additionally,
35 autopano-sift-C has experimental modifications to perform feature
36 identification in conformal image space, this helps with wide angle or
37 fisheye Projection photographs.
38
39 %description -l pl.UTF-8
40 Algorytm SIFT daje możliwość określenia kluczowych punktów
41 charakterystycznych na dowolnych zdjęciach. Następnie wydobywa
42 informacje wyodrębniające dla każdego takiego punktu i pozwala
43 scharakteryzować ten punkt niezależnie od liczby modyfikacji obrazu.
44 Jest niezależny od zmian kontrastu/jasności, obrotów, skalowania i
45 częściowo niezależny od innych rodzajów przekształceń. Algorytm może
46 być elastycznie używany do tworzenia danych wejściowych do
47 dopasowywania obrazów, identyfikowania obiektów i innych algorytmów
48 związanych z grafiką komputerową.
49
50 autopano-sift-C to port C programu autopano-sift napisanego w C#.
51 Jest nieco szybszy i nie wymaga środowiska uruchomieniowego C#.
52 Ponadto zawiera nieco eksperymentalnych modyfikacji w celu
53 przeprowadzania identyfikacji punktów w wiernokątnej przestrzeni
54 obrazu, co pomaga przy zdjęciach obiektywami szerokokątnymi lub
55 "rybim okiem".
56
57 %prep
58 %setup -q 
59
60 %build
61 install -d build
62 cd build
63 # CMAKE_AR is a hack, cmake is unable to find it otherwise :/
64 %cmake .. \
65         -DCMAKE_AR=/usr/bin/ar \
66         -DCMAKE_BUILD_TYPE=%{?debug:Debug}%{!?debug:Release} \
67         -DCMAKE_C_FLAGS_RELEASE="-DNDEBUG" \
68         -DCMAKE_CXX_FLAGS_RELEASE="-DNDEBUG" \
69         -DCMAKE_INSTALL_PREFIX=%{_prefix} \
70         -DCMAKE_VERBOSE_MAKEFILE=ON \
71 %if "%{_lib}" == "lib64"
72         -DLIB_SUFFIX=64
73 %endif
74
75 %{__make}
76
77 %install
78 rm -rf $RPM_BUILD_ROOT
79
80 %{__make} -C build install \
81         DESTDIR=$RPM_BUILD_ROOT
82
83 # resolve conflict with autopano-sift
84 mv $RPM_BUILD_ROOT%{_mandir}/man1/autopano{,-c}.1
85 mv $RPM_BUILD_ROOT%{_mandir}/man1/generatekeys{,-c}.1
86
87 %clean
88 rm -rf $RPM_BUILD_ROOT
89
90 %files
91 %defattr(644,root,root,755)
92 %doc ChangeLog README README.1ST
93 %attr(755,root,root) %{_bindir}/autopano
94 %attr(755,root,root) %{_bindir}/autopano-c-complete.sh
95 %attr(755,root,root) %{_bindir}/autopano-sift-c
96 %attr(755,root,root) %{_bindir}/generatekeys
97 %{_mandir}/man1/autopano-c.1*
98 %{_mandir}/man1/autopano-c-complete.1*
99 %{_mandir}/man1/generatekeys-c.1*
100 %{_mandir}/man7/autopano-sift-c.7*
This page took 0.078115 seconds and 3 git commands to generate.