]> git.pld-linux.org Git - packages/automake.git/commitdiff
- man patch is back but modified and can be used after release 1.4b-1
authorkloczek <kloczek@pld-linux.org>
Wed, 10 Jan 2001 11:15:17 +0000 (11:15 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
  (because on rebuild will be requires this version automake).

Changed files:
    automake-man.patch -> 1.3

automake-man.patch [new file with mode: 0644]

diff --git a/automake-man.patch b/automake-man.patch
new file mode 100644 (file)
index 0000000..8c7a91c
--- /dev/null
@@ -0,0 +1,623 @@
+--- automake-1.4.orig/Makefile.am
++++ automake-1.4/Makefile.am
+@@ -9,6 +9,7 @@
+ bin_SCRIPTS = automake aclocal
+ info_TEXINFOS = automake.texi
++man_MANS = automake.1 aclocal.1
+ amfiles = clean-hdr.am clean-kr.am clean.am comp-vars.am compile.am \
+ data-clean.am data.am dejagnu.am depend.am depend2.am dist-vars.am \
+--- automake-1.4.orig/automake.1
++++ automake-1.4/automake.1
+@@ -0,0 +1,223 @@
++.\" Copyright (C) 1992, 1993, 1994, 1995, 1996 Free Software Foundation, Inc.
++.\" Copyright (C) 1998 Ben Pfaff.
++.\"
++.\" Permission is granted to make and distribute verbatim copies of
++.\" this manual provided the copyright notice and this permission notice
++.\" are preserved on all copies.
++.\" 
++.\" Permission is granted to copy and distribute modified versions of this
++.\" manual under the conditions for verbatim copying, provided that the entire
++.\" resulting derived work is distributed under the terms of a permission
++.\" notice identical to this one.
++.\" 
++.\" Permission is granted to copy and distribute translations of this manual
++.\" into another language, under the above conditions for modified versions,
++.\" except that this permission notice may be stated in a translation approved
++.\" by the Foundation.
++.\"
++.TH AUTOMAKE 1 "Automake"
++.SH NAME
++automake - automatically create Makefile.in's from Makefile.am's
++.SH SYNOPSIS
++.B automake
++[
++.B -a
++|
++.B --add-missing
++] [
++.BR --amdir= DIR
++] [
++.BR --build-dir= DIR
++] [
++.B --cygnus
++] [
++.B --foreign
++] [
++.B --gnits
++] [
++.B --gnu
++] [
++.B --help
++] [
++.B -i
++|
++.B --include-deps
++] [
++.B --no-force
++] [
++.B -o 
++DIR
++] [
++.BR --output-dir= DIR
++] [
++.BR --srcdir-name= DIR
++] [
++.B -v
++|
++.B --verbose
++] [
++.B --version
++]
++.SH DESCRIPTION
++.PP
++To create all the 
++.BR Makefile.in s 
++for a package, run the 
++.B automake
++program in the top level directory, with no arguments.  
++.B automake
++will automatically find each appropriate 
++.B Makefile.am
++(by scanning
++.BR configure.in )
++and generate the corresponding 
++.BR Makefile.in .
++Note that 
++.B automake
++has a rather simplistic view of what constitutes a package; it assumes
++that a package has only one
++.BR configure.in , 
++at the
++top.  If your package has multiple 
++.BR configure.in s, 
++then you must run
++.B automake
++in each directory holding a 
++.BR configure.in .
++.PP
++You can optionally give 
++.B automake
++an argument; 
++.B .am
++is appended to the argument and the result is used as the name of the
++input file.  This feature is generally only used to automatically
++rebuild an out-of-date
++.BR Makefile.in .  
++Note that 
++.B automake
++must always be run from the topmost directory of a project, even if
++being used to regenerate the
++.B Makefile.in
++in some subdirectory.  This is necessary
++because 
++.B automake
++must scan 
++.BR configure.in ,
++and because 
++.B automake
++uses the knowledge that a 
++.B Makefile.in
++is in a subdirectory to change its behavior in some cases.
++.PP
++.B automake
++accepts the following options:
++.TP
++.BI -a
++.TP
++.BI --add-missing
++Automake requires certain common files to exist in certain
++situations; for instance 
++.B config.guess
++is required if
++.B configure.in
++runs 
++.BR AC_CANONICAL_HOST .  
++Automake is distributed with several of these files; this option will
++cause the missing ones to be automatically added to the package,
++whenever possible.  In general if Automake tells you a file is
++missing, try using this option.
++.TP
++.BI --amdir=\fRDIR
++Look for Automake data files in directory DIR instead of in the
++installation directory.  This is typically used for debugging.
++.TP
++.BI --build-dir=\fRDIR
++Tell Automake where the build directory is.  This option is used
++when including dependencies into a 
++.B Makefile.in
++generated by 
++.B make
++.BR dist ; 
++it should not be used otherwise.
++.TP
++.BI --cygnus
++Causes the generated 
++.BR Makefile.in s 
++to follow Cygnus rules, instead of GNU or Gnits rules.
++.TP
++.BI --foreign
++Set the global strictness to 
++.BR foreign .
++.TP
++.BI --gnits
++Set the global strictness to 
++.BR gnits .
++.TP
++.BI --gnu
++Set the global strictness to 
++.BR gnu .
++This is the default strictness.
++.TP
++.BI --help
++Print a summary of the command line options and exit.
++.TP
++.BI -i
++.TP
++.BI --include-deps
++Include all automatically generated dependency information in the
++generated
++.BR Makefile.in . 
++This is generally done
++when making a distribution.
++.TP
++.BI --no-force
++Ordinarily 
++.B automake
++creates all 
++.BR Makefile.in s
++mentioned in
++.BR configure.in .
++This option causes it to only update those
++.BR Makefile.in s 
++which are out of date with respect to one of their dependents.
++.TP
++.BI -o\ \fRDIR
++.TP
++.BI --output-dir=\fRDIR
++Put the generated 
++.B Makefile.in
++in the directory DIR.  Ordinarily
++each 
++.B Makefile.in
++is created in the directory of the
++corresponding 
++.BR Makefile.am .  
++This option is used when making
++distributions.
++.TP
++.BI --srcdir-name=\fRDIR
++Tell Automake the name of the source directory associated with the
++current build.  This option is used when including dependencies into a
++.B Makefile.in
++generated by 
++.BR make dist ; 
++it should not be used otherwise.
++.TP
++.BI -v
++.TP
++.BI --verbose
++Cause Automake to print information about which files are being read
++or created.
++.TP
++.BI --version
++Print the version number of Automake and exit.
++.PP
++.SH "SEE ALSO"
++.BR aclocal (1),
++and the Texinfo documentation for automake
++.SH AUTHORS
++Automake was written primarily by David Mackenzie and Tom Tromey.
++This manpage written by Ben Pfaff <pfaffben@pilot.msu.edu> for the
++Debian GNU/Linux
++.B automake
++package.
+--- automake-1.4.orig/aclocal.1
++++ automake-1.4/aclocal.1
+@@ -0,0 +1,108 @@
++.\" Copyright (C) 1992, 1993, 1994, 1995, 1996 Free Software Foundation, Inc.
++.\" Copyright (C) 1998 Ben Pfaff.
++.\"
++.\" Permission is granted to make and distribute verbatim copies of
++.\" this manual provided the copyright notice and this permission notice
++.\" are preserved on all copies.
++.\" 
++.\" Permission is granted to copy and distribute modified versions of this
++.\" manual under the conditions for verbatim copying, provided that the entire
++.\" resulting derived work is distributed under the terms of a permission
++.\" notice identical to this one.
++.\" 
++.\" Permission is granted to copy and distribute translations of this manual
++.\" into another language, under the above conditions for modified versions,
++.\" except that this permission notice may be stated in a translation approved
++.\" by the Foundation.
++.\"
++.TH ACLOCAL 1 "Automake"
++.SH NAME
++aclocal - automatically generate aclocal.m4 from configure.in
++.SH SYNOPSIS
++.B aclocal
++[
++.BR --acdir= DIR
++] [
++.B --help
++] [
++.B -I
++DIR ] [
++.BR --output= FILE
++] [
++.B --verbose
++] [
++.B --version
++]
++.SH DESCRIPTION
++.PP
++Automake includes a number of Autoconf macros which can be used in
++your package; some of them are actually required by Automake in certain
++situations.  These macros must be defined in your 
++.BR aclocal.m4 ;
++otherwise they will not be seen by 
++.BR autoconf .
++.PP
++The 
++.B aclocal
++program will automatically generate 
++.B aclocal.m4
++files based on the contents of 
++.BR configure.in .  
++This provides a convenient way to get Automake-provided macros,
++without having to search around.  Also, the 
++.B aclocal
++mechanism is extensible for use by other packages.
++.PP
++At startup, 
++.B aclocal
++scans all the 
++.B .m4
++files it can find, looking for macro definitions.  Then it scans
++.BR configure.in .  
++Any mention of one of the macros found in the first step causes that
++macro, and any macros it in turn requires, to be put into
++.BR aclocal.m4 .
++.PP
++The contents of 
++.BR acinclude.m4 , 
++if it exists, are also automatically included in 
++.BR aclocal.m4 .  
++This is useful for incorporating local macros into 
++.BR configure .
++.PP
++.B aclocal
++accepts the following options:
++.TP
++.BI --acdir=\fRDIR
++Look for the macro files in DIR instead of the installation
++directory.  This is typically used for debugging.
++.TP
++.BI --help
++Print a summary of the command line options and exit.
++.TP
++.BI -I\fR\ DIR
++Add the directory DIR to the list of directories searched for
++.B .m4
++files.
++.TP
++.BI --output=\fRFILE
++Cause the output to be put into FILE instead of 
++.BR aclocal.m4 .
++.TP
++.BI -v
++.TP
++.BI --verbose
++Print the names of the files it examines.
++.TP
++.BI --version
++Print the version number of Automake and exit.
++.PP
++.SH "SEE ALSO"
++.BR automake (1),
++and the Texinfo documentation for automake
++.SH AUTHORS
++Automake was written primarily by David Mackenzie and Tom Tromey.
++This manpage written by Ben Pfaff <pfaffben@pilot.msu.edu> for the
++Debian GNU/Linux
++.B automake
++package.
+--- automake-1.4.orig/debian/control
++++ automake-1.4/debian/control
+@@ -0,0 +1,17 @@
++Source: automake
++Section: devel
++Priority: optional
++Maintainer: Kevin Dalley <kevind@rahul.net>
++Standards-Version: 2.4.0.0
++
++Package: automake
++Architecture: all
++Section: devel
++Depends: autoconf
++Description: A tool for generating GNU Standards-compliant Makefiles.
++ Automake is a tool for automatically generating `Makefile.in's from
++ files called `Makefile.am'.  The `Makefile.am' is basically a series of
++ `make' macro definitions (with rules being thrown in occasionally).
++ The generated `Makefile.in's are compliant with the GNU Makefile
++ standards.
++
+--- automake-1.4.orig/debian/changelog
++++ automake-1.4/debian/changelog
+@@ -0,0 +1,120 @@
++automake (1.4-2) unstable; urgency=low
++
++  * This patch allows the proper use and detection of alphapca56
++    machines.  Debian Alpha needs this.  (fixes bug #32390).
++
++ -- Kevin Dalley <kevind@rahul.net>  Sat, 30 Jan 1999 14:49:29 -0800
++
++automake (1.4-1) unstable; urgency=low
++
++  * first release of automake-1.4, which includes support for latest
++    autoconf, fixes a number of bugs
++
++ -- Kevin Dalley <kevind@rahul.net>  Sat, 16 Jan 1999 14:26:53 -0800
++
++automake (1.3-1) frozen unstable; urgency=low
++
++  * first non-alpha release of automake compatible with 1.0h
++
++ -- Kevin Dalley <kevind@rahul.net>  Fri, 10 Apr 1998 01:34:25 -0700
++
++automake (1.2h-1) frozen unstable; urgency=low
++
++  * first release of automake-1.2h
++  * compatible with current release of libtool
++  * moved from experimental to main release
++
++ -- Kevin Dalley <kevind@rahul.net>  Tue, 24 Mar 1998 02:13:22 -0800
++
++automake (1.2f-1) experimental; urgency=low
++
++  * first release of automake-1.2f
++  * reimplemented man page handling
++
++ -- Kevin Dalley <kevind@rahul.net>  Fri, 27 Feb 1998 23:51:55 -0800
++
++automake (1.2e-2) experimental; urgency=low
++
++  * added aclocal and automake man pages (fixes: bug #18200)
++
++ -- Kevin Dalley <kevind@rahul.net>  Sun, 22 Feb 1998 13:53:11 -0800
++
++automake (1.2e-1) experimental; urgency=low
++
++  * first release of automake-1.2e
++  * added undocumented man pages
++  * installed additional files to /usr/doc/automake
++  * upgraded to Standards-Version 2.4.0.0
++  * corrected copyright file
++
++ -- Kevin Dalley <kevind@rahul.net>  Sat, 14 Feb 1998 13:16:13 -0800
++
++automake (1.2d-2) experimental; urgency=low
++
++  * corrected copyright file, updated control file
++
++ -- Kevin Dalley <kevind@rahul.net>  Sun, 21 Dec 1997 20:21:41 -0800
++
++automake (1.2d-1) experimental; urgency=low
++
++  * first release of 1.2d.  This version is beta.  Use at your own risk.
++
++ -- Kevin Dalley <kevind@rahul.net>  Wed,  3 Dec 1997 22:49:05 -0800
++
++automake (1.2-1) unstable; urgency=low
++
++  * automake-1.2 release
++
++ -- Kevin Dalley <kevin@aimnet.com>  Fri,  4 Jul 1997 12:31:49 -0700
++
++automake (1.0-4) frozen unstable; urgency=low
++
++  * rebuilt using /usr/bin/perl rather than /bin/perl
++
++ -- Kevin Dalley <kevin@aimnet.com>  Mon,  2 Jun 1997 23:55:56 -0700
++
++automake (1.0-3) frozen unstable; urgency=low
++
++  * now in frozen and unstable
++
++ -- Kevin Dalley <kevin@aimnet.com>  Wed, 9 Apr 1997 23:23:41 -0700
++
++automake (1.0-2) unstable; urgency=low
++
++  * added ";" to tags.am for compatibility with bash-2.0.
++
++ -- Kevin Dalley <kevin@aimnet.com>  Tue, 8 Apr 1997 22:39:25 -0700
++
++automake (1.0-1) unstable; urgency=low
++
++  * Updated to Standards-Version 2.1.1.0.
++  * fixed bug #3551, summary starts with pkg name
++  * modified clean target
++
++ -- Kevin Dalley <kevin@aimnet.com>  Thu, 10 Oct 1996 23:54:45 -0700
++
++Sat Oct  5 15:30:42 1996  Kevin Dalley  <kevin@aimnet.com>
++
++      * debian/rules, debian/postrm, debian/postinst, debian/control,
++      debian/copyright, debian/rules, debian/ChangeLog: moved files to
++      debian directory and removed "debian." prefix
++      
++      * debian.rules, debian.postrm, debian.postinst, debian.control,
++      debian.README, debian.rules, debian.ChangeLog: moved files to
++      debian directory and removed "debian." prefix
++      
++      * debian.control: added multiple line description
++      
++
++Sun Jun  2 16:26:54 1996  Kevin Dalley  <kevin@aplysia.iway.aimnet.com (Kevin Dalley)>
++
++      * debian.rules: changed diff options
++      use $Date$ for last update
++
++      * debian.README, debian.control, debian.postinst, debian.postrm,
++      debian.rules: added debian files
++      
++
++Local variables:
++mode: debian-changelog
++End:
+--- automake-1.4.orig/debian/copyright
++++ automake-1.4/debian/copyright
+@@ -0,0 +1,16 @@
++This is the Debian GNU/Linux prepackaged version of GNU automake.
++automake was primarily written by David Mackenzie and Tom Tromey.
++
++
++This package was put together by Kevin Dalley <kevind@rahul.net>,
++from sources obtained from:
++ ftp.cygnus.com:/pub/tromey
++
++Changes:
++ * added Debian GNU/Linux package maintenance system files
++ * added manual pages for automake and aclocal
++
++automake is Copyright (C) 1999 Free Software Foundation, Inc.
++
++On Debian GNU/Linux systems, the complete text of the GNU General
++Public License can be found in `/usr/doc/copyright/GPL'.
+--- automake-1.4.orig/debian/postinst
++++ automake-1.4/debian/postinst
+@@ -0,0 +1,6 @@
++#! /bin/sh
++
++set -e
++
++install-info --quiet --section "Development" "Development" \
++ /usr/info/automake.info
+--- automake-1.4.orig/debian/rules
++++ automake-1.4/debian/rules
+@@ -0,0 +1,84 @@
++#! /usr/bin/make -f
++#
++# Last updated: $Date$ by Kevin Dalley <kevind@rahul.net>
++#
++# Copyright 1994,1995 by Ian Jackson.
++# I hereby give you perpetual unlimited permission to copy,
++# modify and relicense this file, provided that you do not remove
++# my name from the file itself.  (I assert my moral right of
++# paternity under the Copyright, Designs and Patents Act 1988.)
++# This file may have to be extensively modified
++# Copyright 1996, 1997, 1998 by Kevin Dalley.
++
++# To make the binary distribution package, the ``Debianized'' source package
++# and the context diff to the original package, type `./debian.rules dist'.
++# Make sure that `debian.rules' is executable before the final distribution
++# is made.
++#
++# Invoke each target with `./debian.rules <target>'.  All targets should be
++# invoked with the package root as the current directory.
++#
++# The `binary' target must be run as root, as it needs to install files with
++# specific ownerships.  The `diff' target assumes that you have the original
++# source package available, unpacked, in ../$(p)-$(v).orig, or that you have
++# the previous revision of the ``Debianized'' source package and context diff
++# in the parent directory.
++
++# The name of the package (for example, `emacs').
++package = automake
++
++build:
++      $(checkdir)
++      ./configure --prefix=/usr
++      $(MAKE)
++      touch build
++
++clean:
++      $(checkdir)
++      -rm -f build
++      -$(MAKE) -i distclean || $(MAKE) -f Makefile.in distclean
++      -rm -rf *~ debian/tmp debian/*~ debian/files*
++
++binary-indep: checkroot build
++      $(checkdir)
++      -rm -rf debian/tmp
++      install -d debian/tmp debian/tmp/DEBIAN
++      install -d debian/tmp/usr/doc/$(package)
++      install debian/{postinst,prerm} debian/tmp/DEBIAN/.
++      $(MAKE) INSTALL_PROGRAM='install -c' \
++              prefix=`pwd`/debian/tmp/usr install
++      gzip -9v debian/tmp/usr/info/*
++      gzip -9v debian/tmp/usr/man/man1/*
++      install -m 644 debian/copyright debian/tmp/usr/doc/$(package)/.
++      install -m 644 debian/changelog \
++              debian/tmp/usr/doc/$(package)/changelog.Debian
++      gzip -9v debian/tmp/usr/doc/$(package)/changelog.Debian
++      for file in AUTHORS ChangeLog INSTALL NEWS README \
++              THANKS TODO; do \
++              install -m 644 $$file \
++                      debian/tmp/usr/doc/$(package);\
++              gzip -9v debian/tmp/usr/doc/$(package)/$$file;\
++      done
++      ln -s ChangeLog.gz debian/tmp/usr/doc/$(package)/changelog.gz
++      dpkg-gencontrol
++      dpkg --build debian/tmp ..
++
++binary-arch:
++
++
++define checkdir
++      test -f $(package).texi -a -f debian/rules
++endef
++
++# Below here is fairly generic really
++
++binary:               binary-indep binary-arch
++
++source diff:
++      @echo >&2 'source and diff are obsolete - use dpkg-source -b'; false
++
++checkroot:
++      $(checkdir)
++      test root = "`whoami`"
++
++.PHONY: binary binary-arch binary-indep clean checkroot
+--- automake-1.4.orig/debian/prerm
++++ automake-1.4/debian/prerm
+@@ -0,0 +1,4 @@
++#! /bin/sh -e
++
++install-info --quiet --remove /usr/info/automake.info
++
+--- automake-1.4.orig/config.h.in
++++ automake-1.4/config.h.in
+@@ -0,0 +1,8 @@
++/* config.h.in.  Generated automatically from configure.in by autoheader.  */
++
++/* Name of package */
++#undef PACKAGE
++
++/* Version number of package */
++#undef VERSION
++
This page took 0.06016 seconds and 4 git commands to generate.