]> git.pld-linux.org Git - packages/automake.git/blob - automake.spec
- fix version detection for python 3.10, rel 3
[packages/automake.git] / automake.spec
1 #
2 # Conditional build:
3 %bcond_with     bootstrap       # without full regeneration
4
5 %include        /usr/lib/rpm/macros.perl
6 Summary:        GNU automake - Makefile configuration tools
7 Summary(de.UTF-8):      GNU automake - Makefile-Konfigurationstools
8 Summary(es.UTF-8):      GNU automake - herramientas de configuración de Makefile
9 Summary(fr.UTF-8):      automake de GNU - Outils de configuration des makefiles
10 Summary(ko.UTF-8):      스스로 Makefile을 만들어주는 GNU 도구
11 Summary(pl.UTF-8):      GNU Automake - generator plików Makefile
12 Summary(pt_BR.UTF-8):   GNU automake - ferramentas de configuração de Makefile
13 Summary(ru.UTF-8):      GNU automake - инструменты для автоматической генерации Makefile'ов
14 Summary(tr.UTF-8):      Makefile yapılandırma araçları
15 Summary(uk.UTF-8):      GNU automake - інструменти для автоматичної генерації Makefile'ів
16 Name:           automake
17 Version:        1.16.1
18 Release:        1
19 Epoch:          1
20 License:        GPL v2+
21 Group:          Development/Building
22 Source0:        http://ftp.gnu.org/gnu/automake/%{name}-%{version}.tar.xz
23 # Source0-md5:  53f38e7591fa57c3d2cee682be668e5b
24 Patch0:         %{name}-info.patch
25 Patch1:         %{name}-man.patch
26 Patch2:         %{name}-no_versioned_dir.patch
27 Patch3:         %{name}-morearchs.patch
28 Patch4:         revert-debian-python-hacks.patch
29 URL:            http://sources.redhat.com/automake/
30 BuildRequires:  autoconf >= 2.69
31 %if %{without bootstrap}
32 BuildRequires:  automake >= 1:1.14
33 %endif
34 BuildRequires:  help2man
35 BuildRequires:  rpm-perlprov
36 BuildRequires:  tar >= 1:1.22
37 BuildRequires:  texinfo >= 4.9
38 BuildRequires:  xz
39 Requires(pre):  fileutils
40 Requires:       filesystem >= 3.0-2
41 Requires:       perl(File::Glob)
42 %if %(%{__perl} -le 'use threads; print 1' || echo 0)
43 # required only if perl was built with threads
44 Requires:       perl(Thread::Queue)
45 Requires:       perl(threads)
46 %endif
47 Conflicts:      autoconf < 2.65
48 Conflicts:      libtool < 2:1.5-11
49 Conflicts:      texinfo < 4.9
50 BuildArch:      noarch
51 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
52
53 %define         ver_maj         %(echo %{version} | cut -d. -f1-2)
54 %define         _enable_debug_packages  0
55
56 %description
57 Automake is an experimental Makefile generator. Automake was inspired
58 by the 4.4BSD make and include files, but aims to be portable and to
59 conform to the GNU standards for Makefile variables and targets.
60
61 %description -l de.UTF-8
62 Automake ist ein experimenteller Makefile-Generator, inspiriert durch
63 die 4.4BSD-Make und Include-Dateien, der jedoch auf Portabilität und
64 Konformität mit den GNU-Standards für Makefile-Variable und Targets
65 abzielt.
66
67 %description -l es.UTF-8
68 Automake es un creador experimental de Makefiles. Fue inspirado en el
69 4.4BSD make y incluye archivos, pero visa ser portátil y compatible
70 con los padrones GNU para variables y dianas de Makefile.
71
72 %description -l fr.UTF-8
73 automake est un générateur expérimental de makefiles. Il a été inspiré
74 par le make de BSD 4.4, mais se veut portable et conforme aux
75 standards GNU pour les variables et les cibles des makefiles.
76
77 %description -l pl.UTF-8
78 Automake jest eksperymentalnym generatorem plików Makefile'a.
79 Narzędzie to jest wzorowane na make i plikach nagłówkowych z systemu
80 4.4BSD. Umożliwia ono generowanie plików Makefile w oderwaniu od
81 platformy systemowej będąc jednocześnie zgodnym ze standardami GNU.
82
83 %description -l pt_BR.UTF-8
84 Automake é um gerador experimental de Makefiles. Ele foi inspirado
85 pelo 4.4BSD make e inclui arquivos, mas visa ser portável e compatível
86 com os padrões GNU para variáveis e alvos de Makefile.
87
88 %description -l ru.UTF-8
89 Automake - это экспериментальный генератор Makefile'ов. Идея была
90 навеяна программой make и хедерами из 4.4BSD, но automake претендует
91 на то, чтобы быть портабельной и соответствовать стандартам GNU на
92 переменные и цели Makefile'ов.
93
94 %description -l tr.UTF-8
95 Automake deneysel bir Makefile üreticisidir. 4.4BSD make ve include
96 dosyalarından esinlenilmistir, ama amaç taşınabilir olmak ve Makefile
97 değişkenleri ve hedefleri için GNU standartlarına uyum göstermektir.
98
99 %description -l uk.UTF-8
100 Automake - це експериментальний генератор Makefile'ів. Ідея була
101 навіяна програмою make та хедерами з 4.4BSD, але automake має за ціль
102 мобільність та відповідність стандартам GNU на змінні ті цілі
103 Makefile'ів.
104
105 %prep
106 %setup -q
107 %patch0 -p1
108 %patch1 -p1
109 %patch2 -p1
110 %patch3 -p1
111 %patch4 -p1
112
113 %if %{without bootstrap}
114 # prepare temporary copy of m4 dir without amversion.m4 (which causes automake version check)
115 mkdir m4-tmp
116 cd m4-tmp
117 ln -s ../m4/[!a]*.m4 ../m4/a[!m]*.m4 .
118 %endif
119
120 %build
121 %if %{without bootstrap}
122 %{__aclocal} -I m4-tmp
123 %endif
124 %{__autoconf}
125 %if %{without bootstrap}
126 %{__automake}
127 %endif
128
129 %configure \
130 %if "%{_host_cpu}" != "x32"
131         --host=%{_host} \
132         --build=%{_host} \
133 %endif
134         --disable-silent-rules
135 %{__make}
136
137 %install
138 rm -rf $RPM_BUILD_ROOT
139 install -d $RPM_BUILD_ROOT%{_mandir}/man1
140
141 %{__make} install \
142         DESTDIR=$RPM_BUILD_ROOT \
143         pkgvdatadir=%{_datadir}/automake
144
145 cp -a aclocal.1 automake.1 $RPM_BUILD_ROOT%{_mandir}/man1
146
147 # not needed when dir/files are handled by package system
148 %{__rm} $RPM_BUILD_ROOT%{_datadir}/aclocal/README
149
150 rm -f $RPM_BUILD_ROOT%{_infodir}/dir*
151
152 %clean
153 rm -rf $RPM_BUILD_ROOT
154
155 %post   -p /sbin/postshell
156 -/usr/sbin/fix-info-dir -c %{_infodir}
157
158 %postun -p /sbin/postshell
159 -/usr/sbin/fix-info-dir -c %{_infodir}
160
161 %files
162 %defattr(644,root,root,755)
163 %doc AUTHORS ChangeLog NEWS README THANKS
164 %attr(755,root,root) %{_bindir}/aclocal*
165 %attr(755,root,root) %{_bindir}/automake*
166 %{_infodir}/automake.info*
167 %{_infodir}/automake-history.info*
168 %{_mandir}/man1/aclocal.1*
169 %{_mandir}/man1/aclocal-%{ver_maj}.1*
170 %{_mandir}/man1/automake.1*
171 %{_mandir}/man1/automake-%{ver_maj}.1*
172
173 %{_datadir}/aclocal-%{ver_maj}
174 %dir %{_datadir}/automake
175 %{_datadir}/automake/am
176 %{_datadir}/automake/Automake
177 %{_datadir}/automake/COPYING
178 %{_datadir}/automake/INSTALL
179 %{_datadir}/automake/texinfo.tex
180 %attr(755,root,root) %{_datadir}/automake/ar-lib
181 %attr(755,root,root) %{_datadir}/automake/compile
182 %attr(755,root,root) %{_datadir}/automake/config.guess
183 %attr(755,root,root) %{_datadir}/automake/config.sub
184 %attr(755,root,root) %{_datadir}/automake/depcomp
185 %attr(755,root,root) %{_datadir}/automake/install-sh
186 %attr(755,root,root) %{_datadir}/automake/mdate-sh
187 %attr(755,root,root) %{_datadir}/automake/missing
188 %attr(755,root,root) %{_datadir}/automake/mkinstalldirs
189 %attr(755,root,root) %{_datadir}/automake/py-compile
190 %attr(755,root,root) %{_datadir}/automake/tap-driver.sh
191 %attr(755,root,root) %{_datadir}/automake/test-driver
192 %attr(755,root,root) %{_datadir}/automake/ylwrap
This page took 0.035696 seconds and 3 git commands to generate.