]> git.pld-linux.org Git - packages/automake.git/blob - automake.spec
- updated to 1.12.1
[packages/automake.git] / automake.spec
1 #
2 # Conditional build:
3 %bcond_with     bootstrap       # without full regeneration
4
5 %include        /usr/lib/rpm/macros.perl
6 Summary:        GNU automake - Makefile configuration tools
7 Summary(de.UTF-8):      GNU automake - Makefile-Konfigurationstools
8 Summary(es.UTF-8):      GNU automake - herramientas de configuración de Makefile
9 Summary(fr.UTF-8):      automake de GNU - Outils de configuration des makefiles
10 Summary(ko.UTF-8):      스스로 Makefile을 만들어주는 GNU 도구
11 Summary(pl.UTF-8):      GNU Automake - generator plików Makefile
12 Summary(pt_BR.UTF-8):   GNU automake - ferramentas de configuração de Makefile
13 Summary(ru.UTF-8):      GNU automake - инструменты для автоматической генерации Makefile'ов
14 Summary(tr.UTF-8):      Makefile yapılandırma araçları
15 Summary(uk.UTF-8):      GNU automake - інструменти для автоматичної генерації Makefile'ів
16 Name:           automake
17 Version:        1.12.1
18 Release:        1
19 Epoch:          1
20 License:        GPL v2+
21 Group:          Development/Building
22 Source0:        http://ftp.gnu.org/gnu/automake/%{name}-%{version}.tar.xz
23 # Source0-md5:  036d79de6e443e02aec2be1df2b4f0ac
24 Patch0:         %{name}-info.patch
25 Patch1:         %{name}-man.patch
26 Patch2:         %{name}-no_versioned_dir.patch
27 Patch3:         %{name}-morearchs.patch
28 URL:            http://sources.redhat.com/automake/
29 %if %{with bootstrap}
30 BuildRequires:  autoconf >= 2.62
31 %else
32 BuildRequires:  autoconf >= 2.68
33 BuildRequires:  automake >= 1:1.10a
34 %endif
35 BuildRequires:  help2man
36 BuildRequires:  rpm-perlprov
37 BuildRequires:  tar >= 1:1.22
38 BuildRequires:  texinfo >= 4.7
39 BuildRequires:  xz
40 Requires(pre):  fileutils
41 Requires:       filesystem >= 3.0-2
42 Requires:       perl(File::Glob)
43 %if %(%{__perl} -le 'use threads; print 1' || echo 0)
44 # required only if perl was built with threads
45 Requires:       perl(Thread::Queue)
46 Requires:       perl(threads)
47 %endif
48 Conflicts:      autoconf < 2.60
49 Conflicts:      libtool < 2:1.5-11
50 BuildArch:      noarch
51 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
52
53 %define         _enable_debug_packages  0
54
55 %description
56 Automake is an experimental Makefile generator. Automake was inspired
57 by the 4.4BSD make and include files, but aims to be portable and to
58 conform to the GNU standards for Makefile variables and targets.
59
60 %description -l de.UTF-8
61 Automake ist ein experimenteller Makefile-Generator, inspiriert durch
62 die 4.4BSD-Make und Include-Dateien, der jedoch auf Portabilität und
63 Konformität mit den GNU-Standards für Makefile-Variable und Targets
64 abzielt.
65
66 %description -l es.UTF-8
67 Automake es un creador experimental de Makefiles. Fue inspirado en el
68 4.4BSD make y incluye archivos, pero visa ser portátil y compatible
69 con los padrones GNU para variables y dianas de Makefile.
70
71 %description -l fr.UTF-8
72 automake est un générateur expérimental de makefiles. Il a été inspiré
73 par le make de BSD 4.4, mais se veut portable et conforme aux
74 standards GNU pour les variables et les cibles des makefiles.
75
76 %description -l pl.UTF-8
77 Automake jest eksperymentalnym generatorem plików Makefile'a.
78 Narzędzie to jest wzorowane na make i plikach nagłówkowych z systemu
79 4.4BSD. Umożliwia ono generowanie plików Makefile w oderwaniu od
80 platformy systemowej będąc jednocześnie zgodnym ze standardami GNU.
81
82 %description -l pt_BR.UTF-8
83 Automake é um gerador experimental de Makefiles. Ele foi inspirado
84 pelo 4.4BSD make e inclui arquivos, mas visa ser portável e compatível
85 com os padrões GNU para variáveis e alvos de Makefile.
86
87 %description -l ru.UTF-8
88 Automake - это экспериментальный генератор Makefile'ов. Идея была
89 навеяна программой make и хедерами из 4.4BSD, но automake претендует
90 на то, чтобы быть портабельной и соответствовать стандартам GNU на
91 переменные и цели Makefile'ов.
92
93 %description -l tr.UTF-8
94 Automake deneysel bir Makefile üreticisidir. 4.4BSD make ve include
95 dosyalarından esinlenilmistir, ama amaç taşınabilir olmak ve Makefile
96 değişkenleri ve hedefleri için GNU standartlarına uyum göstermektir.
97
98 %description -l uk.UTF-8
99 Automake - це експериментальний генератор Makefile'ів. Ідея була
100 навіяна програмою make та хедерами з 4.4BSD, але automake має за ціль
101 мобільність та відповідність стандартам GNU на змінні ті цілі
102 Makefile'ів.
103
104 %prep
105 %setup -q
106 %patch0 -p1
107 %patch1 -p1
108 %patch2 -p1
109 %patch3 -p1
110
111 %if %{without bootstrap}
112 # prepare temporary copy of m4 dir without amversion.m4 (which causes automake version check)
113 mkdir m4-tmp
114 cd m4-tmp
115 ln -s ../m4/[!a]*.m4 ../m4/a[!m]*.m4 .
116 %endif
117
118 %build
119 %if %{without bootstrap}
120 %{__aclocal} -I m4-tmp
121 %endif
122 %{__autoconf}
123 %if %{without bootstrap}
124 %{__automake}
125 %endif
126
127 # NOTE: _target macro becames "noarch" if ./builder passes --target=noarch, so
128 # be sure use plain /usr/bin/rpmbuild.
129 %configure \
130         --host=%{_host} \
131         --build=%{_host}
132 %{__make}
133
134 %install
135 rm -rf $RPM_BUILD_ROOT
136 install -d $RPM_BUILD_ROOT%{_mandir}/man1
137
138 %{__make} install \
139         DESTDIR=$RPM_BUILD_ROOT \
140         pkgvdatadir=%{_datadir}/automake
141
142 cp -a aclocal.1 automake.1 $RPM_BUILD_ROOT%{_mandir}/man1
143
144 # not needed when dir/files are handled by package system
145 %{__rm} $RPM_BUILD_ROOT%{_datadir}/aclocal/README
146
147 rm -f $RPM_BUILD_ROOT%{_infodir}/dir*
148
149 %clean
150 rm -rf $RPM_BUILD_ROOT
151
152 %post   -p /sbin/postshell
153 -/usr/sbin/fix-info-dir -c %{_infodir}
154
155 %postun -p /sbin/postshell
156 -/usr/sbin/fix-info-dir -c %{_infodir}
157
158 %files
159 %defattr(644,root,root,755)
160 %doc AUTHORS ChangeLog NEWS README THANKS
161 %attr(755,root,root) %{_bindir}/aclocal*
162 %attr(755,root,root) %{_bindir}/automake*
163 %{_infodir}/automake.info*
164 %{_infodir}/automake-history.info*
165 %{_mandir}/man1/aclocal.1*
166 %{_mandir}/man1/aclocal-1.12.1*
167 %{_mandir}/man1/automake.1*
168 %{_mandir}/man1/automake-1.12.1*
169
170 %{_datadir}/aclocal-*
171 %dir %{_datadir}/automake
172 %{_datadir}/automake/am
173 %{_datadir}/automake/Automake
174 %{_datadir}/automake/COPYING
175 %{_datadir}/automake/INSTALL
176 %{_datadir}/automake/texinfo.tex
177 %attr(755,root,root) %{_datadir}/automake/ar-lib
178 %attr(755,root,root) %{_datadir}/automake/compile
179 %attr(755,root,root) %{_datadir}/automake/config.guess
180 %attr(755,root,root) %{_datadir}/automake/config.sub
181 %attr(755,root,root) %{_datadir}/automake/depcomp
182 %attr(755,root,root) %{_datadir}/automake/elisp-comp
183 %attr(755,root,root) %{_datadir}/automake/install-sh
184 %attr(755,root,root) %{_datadir}/automake/mdate-sh
185 %attr(755,root,root) %{_datadir}/automake/missing
186 %attr(755,root,root) %{_datadir}/automake/mkinstalldirs
187 %attr(755,root,root) %{_datadir}/automake/py-compile
188 %attr(755,root,root) %{_datadir}/automake/tap-driver.pl
189 %attr(755,root,root) %{_datadir}/automake/tap-driver.sh
190 %attr(755,root,root) %{_datadir}/automake/test-driver
191 %attr(755,root,root) %{_datadir}/automake/ylwrap
This page took 0.350538 seconds and 3 git commands to generate.