]> git.pld-linux.org Git - packages/automake.git/blob - automake.spec
93dfdb4769446f52ba0d3bf8871d0ed636e247b0
[packages/automake.git] / automake.spec
1 #
2 # Conditional build:
3 %bcond_with     bootstrap       # without full regeneration
4
5 %include        /usr/lib/rpm/macros.perl
6 Summary:        GNU automake - Makefile configuration tools
7 Summary(de.UTF-8):      GNU automake - Makefile-Konfigurationstools
8 Summary(es.UTF-8):      GNU automake - herramientas de configuración de Makefile
9 Summary(fr.UTF-8):      automake de GNU - Outils de configuration des makefiles
10 Summary(ko.UTF-8):      스스로 Makefile을 만들어주는 GNU 도구
11 Summary(pl.UTF-8):      GNU Automake - generator plików Makefile
12 Summary(pt_BR.UTF-8):   GNU automake - ferramentas de configuração de Makefile
13 Summary(ru.UTF-8):      GNU automake - инструменты для автоматической генерации Makefile'ов
14 Summary(tr.UTF-8):      Makefile yapılandırma araçları
15 Summary(uk.UTF-8):      GNU automake - інструменти для автоматичної генерації Makefile'ів
16 Name:           automake
17 Version:        1.15
18 Release:        4
19 Epoch:          1
20 License:        GPL v2+
21 Group:          Development/Building
22 Source0:        http://ftp.gnu.org/gnu/automake/%{name}-%{version}.tar.xz
23 # Source0-md5:  9a1ddb0e053474d9d1105cfe39b0c48d
24 Patch0:         %{name}-info.patch
25 Patch1:         %{name}-man.patch
26 Patch2:         %{name}-no_versioned_dir.patch
27 Patch3:         %{name}-morearchs.patch
28 Patch4:         automake-1.15-perl-escape-curly-bracket.patch
29 Patch5:         revert-debian-python-hacks.patch
30 URL:            http://sources.redhat.com/automake/
31 BuildRequires:  autoconf >= 2.69
32 %if %{without bootstrap}
33 BuildRequires:  automake >= 1:1.14
34 %endif
35 BuildRequires:  help2man
36 BuildRequires:  rpm-perlprov
37 BuildRequires:  tar >= 1:1.22
38 BuildRequires:  texinfo >= 4.9
39 BuildRequires:  xz
40 Requires(pre):  fileutils
41 Requires:       filesystem >= 3.0-2
42 Requires:       perl(File::Glob)
43 %if %(%{__perl} -le 'use threads; print 1' || echo 0)
44 # required only if perl was built with threads
45 Requires:       perl(Thread::Queue)
46 Requires:       perl(threads)
47 %endif
48 Conflicts:      autoconf < 2.65
49 Conflicts:      libtool < 2:1.5-11
50 Conflicts:      texinfo < 4.9
51 BuildArch:      noarch
52 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
53
54 %define         ver_maj         %(echo %{version} | cut -d. -f1-2)
55 %define         _enable_debug_packages  0
56
57 %description
58 Automake is an experimental Makefile generator. Automake was inspired
59 by the 4.4BSD make and include files, but aims to be portable and to
60 conform to the GNU standards for Makefile variables and targets.
61
62 %description -l de.UTF-8
63 Automake ist ein experimenteller Makefile-Generator, inspiriert durch
64 die 4.4BSD-Make und Include-Dateien, der jedoch auf Portabilität und
65 Konformität mit den GNU-Standards für Makefile-Variable und Targets
66 abzielt.
67
68 %description -l es.UTF-8
69 Automake es un creador experimental de Makefiles. Fue inspirado en el
70 4.4BSD make y incluye archivos, pero visa ser portátil y compatible
71 con los padrones GNU para variables y dianas de Makefile.
72
73 %description -l fr.UTF-8
74 automake est un générateur expérimental de makefiles. Il a été inspiré
75 par le make de BSD 4.4, mais se veut portable et conforme aux
76 standards GNU pour les variables et les cibles des makefiles.
77
78 %description -l pl.UTF-8
79 Automake jest eksperymentalnym generatorem plików Makefile'a.
80 Narzędzie to jest wzorowane na make i plikach nagłówkowych z systemu
81 4.4BSD. Umożliwia ono generowanie plików Makefile w oderwaniu od
82 platformy systemowej będąc jednocześnie zgodnym ze standardami GNU.
83
84 %description -l pt_BR.UTF-8
85 Automake é um gerador experimental de Makefiles. Ele foi inspirado
86 pelo 4.4BSD make e inclui arquivos, mas visa ser portável e compatível
87 com os padrões GNU para variáveis e alvos de Makefile.
88
89 %description -l ru.UTF-8
90 Automake - это экспериментальный генератор Makefile'ов. Идея была
91 навеяна программой make и хедерами из 4.4BSD, но automake претендует
92 на то, чтобы быть портабельной и соответствовать стандартам GNU на
93 переменные и цели Makefile'ов.
94
95 %description -l tr.UTF-8
96 Automake deneysel bir Makefile üreticisidir. 4.4BSD make ve include
97 dosyalarından esinlenilmistir, ama amaç taşınabilir olmak ve Makefile
98 değişkenleri ve hedefleri için GNU standartlarına uyum göstermektir.
99
100 %description -l uk.UTF-8
101 Automake - це експериментальний генератор Makefile'ів. Ідея була
102 навіяна програмою make та хедерами з 4.4BSD, але automake має за ціль
103 мобільність та відповідність стандартам GNU на змінні ті цілі
104 Makefile'ів.
105
106 %prep
107 %setup -q
108 %patch0 -p1
109 %patch1 -p1
110 %patch2 -p1
111 %patch3 -p1
112 %patch4 -p1
113 %patch5 -p1
114
115 %if %{without bootstrap}
116 # prepare temporary copy of m4 dir without amversion.m4 (which causes automake version check)
117 mkdir m4-tmp
118 cd m4-tmp
119 ln -s ../m4/[!a]*.m4 ../m4/a[!m]*.m4 .
120 %endif
121
122 %build
123 %if %{without bootstrap}
124 %{__aclocal} -I m4-tmp
125 %endif
126 %{__autoconf}
127 %if %{without bootstrap}
128 %{__automake}
129 %endif
130
131 # NOTE: _target macro becames "noarch" if ./builder passes --target=noarch, so
132 # be sure use plain /usr/bin/rpmbuild.
133 %configure \
134 %if %{_host_cpu} == "x32"
135         --host=%{_target_platform} \
136         --build=%{_target_platform}
137 %else
138         --host=%{_host} \
139         --build=%{_host}
140 %endif
141 %{__make}
142
143 %install
144 rm -rf $RPM_BUILD_ROOT
145 install -d $RPM_BUILD_ROOT%{_mandir}/man1
146
147 %{__make} install \
148         DESTDIR=$RPM_BUILD_ROOT \
149         pkgvdatadir=%{_datadir}/automake
150
151 cp -a aclocal.1 automake.1 $RPM_BUILD_ROOT%{_mandir}/man1
152
153 # not needed when dir/files are handled by package system
154 %{__rm} $RPM_BUILD_ROOT%{_datadir}/aclocal/README
155
156 rm -f $RPM_BUILD_ROOT%{_infodir}/dir*
157
158 %clean
159 rm -rf $RPM_BUILD_ROOT
160
161 %post   -p /sbin/postshell
162 -/usr/sbin/fix-info-dir -c %{_infodir}
163
164 %postun -p /sbin/postshell
165 -/usr/sbin/fix-info-dir -c %{_infodir}
166
167 %files
168 %defattr(644,root,root,755)
169 %doc AUTHORS ChangeLog NEWS README THANKS
170 %attr(755,root,root) %{_bindir}/aclocal*
171 %attr(755,root,root) %{_bindir}/automake*
172 %{_infodir}/automake.info*
173 %{_infodir}/automake-history.info*
174 %{_mandir}/man1/aclocal.1*
175 %{_mandir}/man1/aclocal-%{ver_maj}.1*
176 %{_mandir}/man1/automake.1*
177 %{_mandir}/man1/automake-%{ver_maj}.1*
178
179 %{_datadir}/aclocal-%{ver_maj}
180 %dir %{_datadir}/automake
181 %{_datadir}/automake/am
182 %{_datadir}/automake/Automake
183 %{_datadir}/automake/COPYING
184 %{_datadir}/automake/INSTALL
185 %{_datadir}/automake/texinfo.tex
186 %attr(755,root,root) %{_datadir}/automake/ar-lib
187 %attr(755,root,root) %{_datadir}/automake/compile
188 %attr(755,root,root) %{_datadir}/automake/config.guess
189 %attr(755,root,root) %{_datadir}/automake/config.sub
190 %attr(755,root,root) %{_datadir}/automake/depcomp
191 %attr(755,root,root) %{_datadir}/automake/install-sh
192 %attr(755,root,root) %{_datadir}/automake/mdate-sh
193 %attr(755,root,root) %{_datadir}/automake/missing
194 %attr(755,root,root) %{_datadir}/automake/mkinstalldirs
195 %attr(755,root,root) %{_datadir}/automake/py-compile
196 %attr(755,root,root) %{_datadir}/automake/tap-driver.sh
197 %attr(755,root,root) %{_datadir}/automake/test-driver
198 %attr(755,root,root) %{_datadir}/automake/ylwrap
This page took 0.069619 seconds and 2 git commands to generate.