]> git.pld-linux.org Git - packages/autofs.git/commitdiff
Some patches updated
authorPaweł Gołaszewski <blues@pld-linux.org>
Sat, 23 Jun 2001 12:31:35 +0000 (12:31 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
45df38e9458bde07315a1bfce099b84a  SOURCES/autofs-4.0.0pre10.tar.bz2

Changed files:
    autofs-clean.patch -> 1.2
    autofs-hesiod-bind.patch -> 1.2

autofs-clean.patch
autofs-hesiod-bind.patch

index 97fa8bc36e30d3a1c51a9515deaab472906852ad..f3dd6874064cc3749e2727a7ba3880a0a00a8fa7 100644 (file)
@@ -1,5 +1,5 @@
---- autofs-4.0.0pre7/daemon/mount.c    Tue Aug  1 14:01:36 2000
-+++ autofs-4.0.0pre7/daemon/mount.c    Tue Aug  1 14:01:41 2000
+--- ./daemon/mount.c.orig      Sat Jun 23 13:55:53 2001
++++ ./daemon/mount.c   Sat Jun 23 13:56:22 2001
 @@ -21,6 +21,7 @@
  
  #include <syslog.h>
@@ -8,9 +8,9 @@
  #include "automount.h"
  
  /* These filesystems are known not to work with the "generic" module */
---- autofs-4.0.0pre7/modules/parse_sun.c       Tue Aug  1 14:03:36 2000
-+++ autofs-4.0.0pre7/modules/parse_sun.c       Tue Aug  1 14:09:33 2000
-@@ -16,6 +16,7 @@
+--- ./modules/parse_sun.c.orig Sat Jun 23 13:57:04 2001
++++ ./modules/parse_sun.c      Sat Jun 23 14:02:22 2001
+@@ -17,6 +17,7 @@
  
  #include <stdio.h>
  #include <malloc.h>
  #include <errno.h>
  #include <netdb.h>
  #include <fcntl.h>
-@@ -378,7 +379,7 @@
-   }
- }
--static const char *dequote(const char *str, int strlen)
-+static char *dequote(const char *str, int strlen)
- {
-   char *ret = malloc(strlen+1);
-   char *cp = ret;
-@@ -415,7 +416,7 @@
-   return cp + len;
- }
--static const char *concat_options(const char *left, char *right)
-+static char *concat_options(char *left, char *right)
- {
-   char *ret;
-@@ -531,7 +532,8 @@
- {
-   struct parse_context *ctxt = (struct parse_context *) context;
-   char *pmapent;
--  const char *p, *options;
-+  const char *p;
-+  char *options;
-   int mapent_len, rv;
-   int optlen;
-@@ -577,7 +579,7 @@
-     /* It's a multi-mount; deal with it */
-     do {
-       char *myoptions = strdup(options);
--      const char *path, *loc;
-+      char *path, *loc;
-       int pathlen, loclen;
-       if (myoptions == NULL) {
-@@ -641,7 +643,7 @@
-     return rv;
-   } else {
-     /* Normal (non-multi) entries */
--    const char *loc;
-+    char *loc;
-     int loclen;
-     if ( *p == ':' ) p++;     /* Sun escape for entries starting with / */
---- autofs-4.0.0pre7/modules/mount_nfs.c       Tue Aug  1 14:09:40 2000
-+++ autofs-4.0.0pre7/modules/mount_nfs.c       Tue Aug  1 14:10:49 2000
+--- ./modules/mount_nfs.c.orig Sat Jun 23 14:02:40 2001
++++ ./modules/mount_nfs.c      Sat Jun 23 14:04:29 2001
 @@ -17,6 +17,7 @@
  
  #include <stdio.h>
  #include <errno.h>
  #include <netdb.h>
  #include <fcntl.h>
-@@ -201,7 +202,7 @@
-     /* Local host -- do a symlink */
-     /* Chomp trailing '/'s */
--    cp = name+strlen(name);
-+    cp = (char*) name+strlen(name);
-     while(cp[-1] == '/')
-           cp--;
-     *cp = '\0';
---- autofs-4.0.0pre7/modules/mount_generic.c   Tue Aug  1 14:11:04 2000
-+++ autofs-4.0.0pre7/modules/mount_generic.c   Tue Aug  1 14:11:13 2000
+--- ./modules/mount_generic.c.orig     Sat Jun 23 14:04:41 2001
++++ ./modules/mount_generic.c  Sat Jun 23 14:04:59 2001
 @@ -16,6 +16,7 @@
  
  #include <stdio.h>
  #include <errno.h>
  #include <fcntl.h>
  #include <unistd.h>
---- autofs-4.0.0pre7/modules/mount_ext2.c      Tue Aug  1 14:02:41 2000
-+++ autofs-4.0.0pre7/modules/mount_ext2.c      Tue Aug  1 14:02:56 2000
-@@ -16,4 +16,5 @@ 
+--- ./modules/mount_ext2.c.orig        Sat Jun 23 14:05:18 2001
++++ ./modules/mount_ext2.c     Sat Jun 23 14:05:35 2001
+@@ -16,6 +16,7 @@
  #include <stdio.h>
  #include <malloc.h>
 +#include <alloca.h>
  #include <errno.h>
  #include <fcntl.h>
---- autofs-4.0.0pre7/Makefile.rules    Tue Aug  1 14:15:37 2000
-+++ autofs-4.0.0pre7/Makefile.rules    Tue Aug  1 14:16:29 2000
+ #include <unistd.h>
+--- ./Makefile.rules.orig      Sat Jun 23 14:07:08 2001
++++ ./Makefile.rules   Sat Jun 23 14:08:24 2001
 @@ -15,13 +15,13 @@
  # The STRIP defined here *must not* remove any dynamic-loading symbols
  
  ifdef DEBUG
 -CFLAGS    = -O2 -g -DDEBUG
 -LDFLAGS   = -g
-+CFLAGS    = $(RPM_OPT_FLAGS) -ggdb
++CFLAGS    = -O3 -fomit-frame-pointer -Wall
 +LDFLAGS   = -ggdb
  STRIP     = :
  else
 -LDFLAGS   = -s
 -STRIP     = strip --strip-debug
 +CFLAGS    = $(RPM_OPT_FLAGS)
-+LDFLAGS   =
++LDFLAGS   = 
 +STRIP     = :
  endif
  
index 33c75e3e0175d6128f2b77565a89526309ace446..9ae31fa6b55de2a6012cdc95b94a44508f0259a0 100644 (file)
@@ -1,43 +1,17 @@
-diff -uNr autofs-3.1.4/Makefile.conf.in autofs-3.1.4/Makefile.conf.in
---- autofs-3.1.4/Makefile.conf.in      Fri Jan 21 14:08:10 2000
-+++ autofs-3.1.4/Makefile.conf.in      Tue Feb 29 10:34:33 2000
-@@ -12,6 +12,7 @@
- # Hesiod support: yes (1) no (0)
- HESIOD = @HAVE_HESIOD@
-+HESIOD_BIND = @HAVE_HESIOD_BIND@
- LIBHESIOD = @LIBHESIOD@
- HESIOD_FLAGS = @HESIOD_FLAGS@
-diff -uNr autofs-3.1.4/configure.in autofs-3.1.4/configure.in
---- autofs-3.1.4/configure.in  Fri Jan 21 14:08:10 2000
-+++ autofs-3.1.4/configure.in  Tue Feb 29 10:40:43 2000
-@@ -73,7 +73,9 @@
- HAVE_HESIOD=0
- AC_CHECK_LIB(hesiod, hes_resolve, HAVE_HESIOD=1 LIBHESIOD="$LIBHESIOD -lhesiod", , $LIBRESOLV)
-+AC_CHECK_LIB(bind, hesiod_resolve, HAVE_HESIOD=1 HAVE_HESIOD_BIND=1 LIBHESIOD="$LIBHESIOD -lbind", , $LIBRESOLV)
- AC_SUBST(HAVE_HESIOD)
-+AC_SUBST(HAVE_HESIOD_BIND)
- AC_SUBST(LIBHESIOD)
- AC_SUBST(HESIOD_FLAGS)
- LDFLAGS="${AF_tmp_ldflags}"
-diff -uNr autofs-3.1.4/modules/Makefile autofs-3.1.4/modules/Makefile
---- autofs-3.1.4/modules/Makefile      Tue Feb 29 10:48:15 2000
-+++ autofs-3.1.4/modules/Makefile      Tue Feb 29 10:36:07 2000
+--- ./modules/Makefile.orig    Sat Jun 23 14:16:40 2001
++++ ./modules/Makefile Sat Jun 23 14:17:51 2001
 @@ -24,6 +24,9 @@
  endif
  
  ifeq ($(HESIOD), 1)
 +  ifeq ($(HESIOD_BIND), 1)
-+    CFLAGS += -DHESIOD_BIND
++      CFLAGS += -DHESIOD_BIND
 +  endif
    SRCS += lookup_hesiod.c  parse_hesiod.c
    MODS += lookup_hesiod.so parse_hesiod.so
  endif
-diff -uNr autofs-3.1.4/modules/lookup_hesiod.c autofs-3.1.4/modules/lookup_hesiod.c
---- autofs-3.1.4/modules/lookup_hesiod.c       Fri Jan 21 14:08:09 2000
-+++ autofs-3.1.4/modules/lookup_hesiod.c       Wed Mar  1 10:07:43 2000
+--- ./modules/lookup_hesiod.c.orig     Sat Jun 23 14:18:07 2001
++++ ./modules/lookup_hesiod.c  Sat Jun 23 14:22:42 2001
 @@ -28,6 +28,9 @@
  
  struct lookup_context {
@@ -55,18 +29,19 @@ diff -uNr autofs-3.1.4/modules/lookup_hesiod.c autofs-3.1.4/modules/lookup_hesio
 +#ifdef HESIOD_BIND
 +  /* Initialize the hesiod context. */
 +  if(hesiod_init(&(ctxt->hesiod_context)) != 0) {
-+    syslog(LOG_CRIT, MODPREFIX "hesiod_init(): %m");
-+    return 1;
++        syslog(LOG_CRIT, MODPREFIX "hesiod_init(): %m");
++        return 1;
 +  }
 +#endif
-+
++  
    /* If a map type isn't explicitly given, parse it as hesiod entries. */
    if ( !mapfmt )
      mapfmt = MAPFMT_DEFAULT;
-@@ -73,7 +84,11 @@
+@@ -72,8 +83,11 @@
    chdir("/");                  /* If this is not here the filesystem stays
                                    busy, for some reason... */
+-
 +#ifdef HESIOD_BIND
 +  hes_result = hesiod_resolve(ctxt->hesiod_context, name, "filsys");
 +#else
@@ -75,7 +50,7 @@ diff -uNr autofs-3.1.4/modules/lookup_hesiod.c autofs-3.1.4/modules/lookup_hesio
  
    if ( !hes_result ) {
      syslog(LOG_NOTICE, MODPREFIX "entry \"%s\" not found in map\n", name);
-@@ -83,7 +98,11 @@
+@@ -83,7 +97,11 @@
    syslog(LOG_DEBUG, MODPREFIX "lookup for \"%s\" gave \"%s\"",
         name, hes_result[0]);
    rv = ctxt->parser->parse_mount(root,name,name_len,hes_result[0],ctxt->parser->context);
@@ -87,7 +62,7 @@ diff -uNr autofs-3.1.4/modules/lookup_hesiod.c autofs-3.1.4/modules/lookup_hesio
    return rv;
  }
  
-@@ -93,6 +112,9 @@
+@@ -93,6 +111,9 @@
  {
    struct lookup_context *ctxt = (struct lookup_context *) context;
    int rv = close_parse(ctxt->parser);
@@ -97,3 +72,28 @@ diff -uNr autofs-3.1.4/modules/lookup_hesiod.c autofs-3.1.4/modules/lookup_hesio
    free(ctxt);
    return rv;
  }
+--- ./Makefile.conf.in.orig    Sat Jun 23 14:12:16 2001
++++ ./Makefile.conf.in Sat Jun 23 14:12:43 2001
+@@ -12,6 +12,7 @@
+ # Hesiod support: yes (1) no (0)
+ HESIOD = @HAVE_HESIOD@
++HESIOD_BIND = @HAVE_HESIOD_BIND@
+ LIBHESIOD = @LIBHESIOD@
+ HESIOD_FLAGS = @HESIOD_FLAGS@
+--- ./configure.in.orig        Sat Jun 23 14:12:58 2001
++++ ./configure.in     Sat Jun 23 14:16:32 2001
+@@ -78,10 +78,10 @@
+ if test -z "$HAVE_HESIOD"
+ then
+       HAVE_HESIOD=0
+-      AC_CHECK_LIB(hesiod, hes_resolve, HAVE_HESIOD=1 LIBHESIOD="$LIBHESIOD -lhesiod", ,
+-                   $LIBRESOLV)
++      AC_CHECK_LIB(bind, hesiod_resolve, HAVE_HESIOD=1 HAVE_HESIOD_BIND=1 LIBHESIOD="$LIBHESIOD -lbind", , $LIBRESOLV)
+ fi
+ AC_SUBST(HAVE_HESIOD)
++AC_SUBST(HAVE_HESIOD_BIND)
+ AC_SUBST(LIBHESIOD)
+ AC_SUBST(HESIOD_FLAGS)
+ LDFLAGS="${AF_tmp_ldflags}"
This page took 0.125906 seconds and 4 git commands to generate.