]> git.pld-linux.org Git - packages/autoconf.git/blob - autoconf.spec
- added patch for AC_SYS_LARGEFILE etc.
[packages/autoconf.git] / autoconf.spec
1 #
2 # Conditional build:
3 %bcond_with     emacs   # emacs autoconf-mode
4 %bcond_with     xemacs  # XEmacs autoconf-mode
5 %bcond_without  tests   # do not perform "make check"
6
7 Summary:        GNU autoconf - source configuration tools
8 Summary(de.UTF-8):      Ein GNU-Hilfsmittel für Quellencode automatisch konfigurieren
9 Summary(es.UTF-8):      Una herramienta GNU para configurar automáticamente el código fuente
10 Summary(fr.UTF-8):      Un outil de GNU pour configurer automatiquement le code source
11 Summary(it.UTF-8):      Uno strumento di GNU per automaticamente la configurazione del codice sorgente
12 Summary(ko.UTF-8):      스스로 환경에 따라 소스 코드를 맞춰주는 GNU 도구
13 Summary(pl.UTF-8):      GNU autoconf - narzędzie do automatycznego konfigurowania źródeł
14 Summary(pt_BR.UTF-8):   GNU autoconf - ferramentas de configuração de fontes
15 Summary(ru.UTF-8):      GNU autoconf - автоконфигуратор исходных текстов
16 Summary(uk.UTF-8):      GNU autoconf - автоконфігуратор вихідних текстів
17 Name:           autoconf
18 Version:        2.72
19 Release:        0.1
20 License:        GPL v2+/v3+
21 Group:          Development/Building
22 # stable releases:
23 Source0:        https://ftp.gnu.org/gnu/autoconf/%{name}-%{version}.tar.xz
24 # Source0-md5:  1be79f7106ab6767f18391c5e22be701
25 # devel releases:
26 #Source0:       http://alpha.gnu.org/gnu/autoconf/%{name}-%{version}.tar.bz2
27 Patch0:         %{name}-mawk.patch
28 Patch1:         %{name}-info.patch
29 Patch2:         %{name}-AC_EGREP.patch
30 Patch3:         %{name}-cxxcpp-warnonly.patch
31 Patch4:         %{name}-mksh.patch
32 # https://savannah.gnu.org/support/index.php?110983 (AC_SYS_LARGEFILE/AC_SYS_YEAR2038 test failures on ix86)
33 Patch5:         %{name}-largefile.patch
34 Patch6:         %{name}-tests.patch
35 URL:            http://www.gnu.org/software/autoconf/
36 %{?with_emacs:BuildRequires:    emacs}
37 BuildRequires:  xz
38 BuildRequires:  m4 >= 3:1.4.13
39 BuildRequires:  rpm-perlprov
40 BuildRequires:  tar >= 1:1.22
41 BuildRequires:  texinfo >= 4.2
42 %{?with_xemacs:BuildRequires:   xemacs}
43 BuildConflicts: m4 = 1.4o
44 Requires:       /bin/awk
45 Requires:       diffutils
46 Conflicts:      automake < 1:1.8
47 Conflicts:      gettext < 0.10.38-3
48 Conflicts:      pkgconfig < 1:0.25-2
49 %requires_eq    m4
50 Requires:       mktemp
51 Obsoletes:      autoconf252 < 2.53
52 Obsoletes:      autoconf253 < 2.54
53 BuildArch:      noarch
54 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
55
56 %if "%{_host_cpu}" == "x32"
57 %define build_arch %{_target_platform}
58 %else
59 %define build_arch %{_host}
60 %endif
61
62 %define         _libdir         %{_datadir}
63
64 %description
65 GNU's Autoconf is a tool for configuring source code and Makefiles.
66 Using Autoconf, programmers can create portable and configurable
67 packages, since the person building the package is allowed to specify
68 various configuration options.
69
70 You should install Autoconf if you are developing software and you'd
71 like to use it to create shell scripts which will configure your
72 source code packages.
73
74 Note that the Autoconf package is not required for the end user who
75 may be configuring software with an Autoconf-generated script;
76 Autoconf is only required for the generation of the scripts, not their
77 use.
78
79 %description -l de.UTF-8
80 GNU's Autoconf ist eines Hilfsmittels für das Konfigurieren des
81 Quellencodes und der Makefiles. Mit Autoconf können Programmierer die
82 beweglichen und konfigurierbaren Pakete erstellen, da der Person, die
83 das Paket aufbaut, erlaubt wird, verschiedene Konfiguration Optionen
84 zu spezifizieren.
85
86 Sie sollten Autoconf installieren, wenn Sie Software entwickeln und
87 Sie sie benutzen möchten, um Shellindexe zu erstellen, die Ihre
88 Quellencodepakete konfigurieren.
89
90 Beachten Sie, daß das Paket Autoconf nicht für den Endbenutzer
91 angefordert wird, der Software mit einem Autoconf-festgelegten Index
92 konfigurieren kann; Autoconf wird nur für das Erzeugung der Indexe,
93 nicht ihr Gebrauch angefordert.
94
95 %description -l es.UTF-8
96 Autoconf de GNU es una herramienta para configurar código y makefiles
97 de fuente. Usando Autoconf, los programadores pueden crear los
98 conjuntos portables y configurables, puesto que se permite a la
99 persona que construye el conjunto especificar varias opciones de la
100 configuración.
101
102 Usted debe instalar Autoconf si está desarrollando software y quisiera
103 utilizarlo para crear los shell scriptes que configurarán sus
104 conjuntos del código fuente.
105
106 Observe que el conjunto de Autoconf no está requerido para el
107 utilizador del extremo que puede configurar software con una escritura
108 Autoconf-generada; Autoconf se requiere solamente para la generación
109 de las escrituras, no su uso.
110
111 %description -l fr.UTF-8
112 GNU's Autoconf est un outil pour configurer le code source et les
113 fichiers makefile. En utilisant Autoconf, les programmeurs peuvent
114 créer les modules portatifs et configurables, puisqu'on permet à la la
115 personne établissant le module d'indiquer de diverses options de
116 configuration.
117
118 Vous devriez installer Autoconf si vous développez le logiciel et vous
119 voudriez l'employer pour créer les séquences type d'interpréteur de
120 commandes interactif qui configureront vos modules de code source.
121
122 Notez que le module d'Autoconf n'est pas exigé pour l'utilisateur qui
123 peut configurer le logiciel avec une séquence type Autoconf-produite;
124 Autoconf est seulement exigé pour la génération des séquences type,
125 non leur utilisation.
126
127 %description -l it.UTF-8
128 GNU's Autoconf è uno strumento per la configurazione il codice e dei
129 makefiles sorgente. Usando Autoconf, i programmatori possono creare i
130 pacchetti portatili e configurabili, poiché alla persona che sviluppa
131 il pacchetto è permessa specificare le varie opzioni di
132 configurazione.
133
134 Dovreste installare Autoconf se state sviluppando il software e
135 voleste usarli per creare gli scritti di coperture che configureranno
136 i vostri pacchetti di codice sorgente.
137
138 Si noti che il pacchetto di Autoconf non è richiesto per l'
139 utilizzatore finale che può configurare il software con uno scritto
140 Autoconf-generato; Autoconf è richiesto soltanto per la generazione
141 degli scritti, il non loro uso.
142
143 %description -l pl.UTF-8
144 GNU autoconf jest narzędziem wykorzystywanym do automatycznego
145 konfigurowania kodów źródłowych pakietów programów oraz do generowania
146 na podstawie automatycznie rozpoznanego środowiska plików Makefile i
147 innych zależnych od zawartości systemu, w którym ma przebiegać proces
148 kompilacji. Pomaga programiście w konfigurowaniu i tworzeniu
149 oprogramowania dającego się przenieść na różne platformy. Umożliwia
150 wybór wielu opcji podczas procesu przygotowania do kompilacji.
151
152 GNU autoconf nie jest generalnie potrzebny końcowemu użytkownikowi, a
153 tylko podczas generowania samych skryptów autokonfiguracyjnych.
154
155 %description -l pt_BR.UTF-8
156 GNU "autoconf" é uma ferramenta para configuração de fontes e
157 Makefiles. Ele ajuda o programador na criação de pacotes portáveis e
158 configuráveis, permitindo que a pessoa que programa o pacote
159 especifique várias opções de configuração. Autoconf é necessário
160 somente para gerar scripts de configuração.
161
162 %description -l ru.UTF-8
163 GNU autoconf - инструмент для автоконфигурации исходных текстов и
164 генерации Makefile'ов. Помогает программисту создавать портируемые и
165 конфигурируемые пакеты, позволяя тому, кто эти пакеты собирает,
166 задавать различные опции конфигурации.
167
168 "autoconf" не является необходимым для конечного пользователя, его
169 используют только для генерации конфигурационных скриптов.
170
171 %description -l uk.UTF-8
172 GNU autoconf - це інструмент для автоматичної конфігурації вихідних
173 текстів та генерації Makefile'ів. Допомогає програмісту створювати
174 мобільні пакети, що дозволяють конфігурацію. Це дозволяє тому, хто
175 займається зборкою таких пакетів, задавати різні опції конфігурації.
176
177 "autoconf" не є необхідним для кінцевого користувача, його
178 використовують тільки для генерації конфігураційних скриптів.
179
180 %package -n emacs-autoconf-mode-pkg
181 Summary:        emacs autoconf-mode
182 Summary(pl.UTF-8):      Tryb autoconf dla emacsa
183 Group:          Applications/Editors/Emacs
184 Requires:       emacs
185
186 %description -n emacs-autoconf-mode-pkg
187 Emacs autoconf-mode.
188
189 %description -n emacs-autoconf-mode-pkg -l pl.UTF-8
190 Tryb edycji autoconf dla emacsa.
191
192 %package -n xemacs-autoconf-mode-pkg
193 Summary:        xemacs autoconf-mode
194 Summary(pl.UTF-8):      Tryb autoconf dla emacsa
195 Group:          Applications/Editors/Emacs
196 Requires:       xemacs
197
198 %description -n xemacs-autoconf-mode-pkg
199 Emacs autoconf-mode.
200
201 %description -n xemacs-autoconf-mode-pkg -l pl.UTF-8
202 Tryb edycji autoconf dla emacsa.
203
204 %prep
205 %setup -q
206 %patch0 -p1
207 %patch1 -p1
208 %patch2 -p1
209 %patch3 -p1
210 %patch4 -p1
211 %patch5 -p1
212 %patch6 -p1
213
214 %build
215 %configure \
216         --host=%{build_arch} \
217         --build=%{build_arch} \
218         %{?with_xemacs:EMACS=xemacs}
219 %{__make} -j1
220
221 %{?with_tests:%{__make} check}
222
223 %install
224 rm -rf $RPM_BUILD_ROOT
225
226 %{__make} -j1 install \
227         DESTDIR=$RPM_BUILD_ROOT \
228 %if %{with xemacs}
229         lispdir=%{_datadir}/xemacs-packages/autoconf
230 %endif
231
232 %if %{with xemacs}
233 xemacs -batch -no-autoloads -l autoload -f batch-update-directory \
234         $RPM_BUILD_ROOT%{_datadir}/xemacs-packages/autoconf
235 xemacs -batch -vanilla -f batch-byte-compile \
236         $RPM_BUILD_ROOT%{_datadir}/xemacs-packages/autoconf/auto-autoloads.el
237 %endif
238
239 %if %{with emacs} && %{with xemacs}
240 %{__rm} lib/emacs/*.elc
241 %{__make} -C lib/emacs install-dist_lispLISP \
242         DESTDIR=$RPM_BUILD_ROOT \
243         EMACS=emacs \
244         lispdir=%{_emacs_lispdir}
245 %endif
246
247 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
248
249 %clean
250 rm -rf $RPM_BUILD_ROOT
251
252 %post   -p /sbin/postshell
253 -/usr/sbin/fix-info-dir -c %{_infodir}
254
255 %postun -p /sbin/postshell
256 -/usr/sbin/fix-info-dir -c %{_infodir}
257
258 %files
259 %defattr(644,root,root,755)
260 %doc AUTHORS BUGS ChangeLog ChangeLog.2 NEWS README THANKS TODO
261 %attr(755,root,root) %{_bindir}/autoconf
262 %attr(755,root,root) %{_bindir}/autoheader
263 %attr(755,root,root) %{_bindir}/autom4te
264 %attr(755,root,root) %{_bindir}/autoreconf
265 %attr(755,root,root) %{_bindir}/autoscan
266 %attr(755,root,root) %{_bindir}/autoupdate
267 %attr(755,root,root) %{_bindir}/ifnames
268 %{_libdir}/autoconf
269 %{_infodir}/autoconf.info*
270 %{_infodir}/standards.info*
271 %{_mandir}/man1/autoconf.1*
272 %{_mandir}/man1/autoheader.1*
273 %{_mandir}/man1/autom4te.1*
274 %{_mandir}/man1/autoreconf.1*
275 %{_mandir}/man1/autoscan.1*
276 %{_mandir}/man1/autoupdate.1*
277 %{_mandir}/man1/ifnames.1*
278
279 %if %{with emacs}
280 %files -n emacs-autoconf-mode-pkg
281 %defattr(644,root,root,755)
282 %{_emacs_lispdir}/autoconf/*.elc
283 %endif
284
285 %if %{with xemacs}
286 %files -n xemacs-autoconf-mode-pkg
287 %defattr(644,root,root,755)
288 %dir %{_datadir}/xemacs-packages/autoconf
289 %{_datadir}/xemacs-packages/autoconf/*.elc
290 %endif
This page took 0.075797 seconds and 3 git commands to generate.