]> git.pld-linux.org Git - packages/autoconf.git/blob - autoconf.spec
- standarization to "* text: (link). description" index info entries format.
[packages/autoconf.git] / autoconf.spec
1 Summary:        GNU autoconf - source configuration tools
2 Summary(pl):    GNU autoconf - narzêdzie do automatycznego konfigurowania ¼róde³
3 Name:           autoconf
4 Version:        2.14.1
5 Release:        1
6 Copyright:      GPL
7 Group:          Development/Building
8 Group(pl):      Programowanie/Budowanie
9 Source:         ftp://prep.ai.mit.edu/pub/gnu/%{name}-%{version}.tar.bz2
10 Patch0:         autoconf-tmprace.patch
11 Patch1:         autoconf-info.patch
12 Patch2:         autoconf-mawk.patch
13 Patch3:         autoconf-man.patch
14 Patch4:         autoconf-notmp.patch
15 Patch5:         autoconf-pinard.patch
16 Patch6:         autoconf-fhs.patch
17 URL:            http://sourceware.cygnus.com/autoconf/
18 Requires:       gawk
19 Requires:       m4
20 Requires:       mktemp
21 Prereq:         /sbin/install-info
22 BuildRoot:      /tmp/%{name}-%{version}-root
23 Buildarch:      noarch
24
25 %description
26 GNU's "autoconf" is a tool for source and Makefile configuration. It
27 assists the programmer in creating portable and configurable packages, by
28 allowing the person building the package to specify various configuration
29 options. 
30
31 "autoconf" is not required for the end user - it is needed only to
32 generate the configuration scripts. 
33
34 %description -l pl
35 GNU autoconf jest narzêdziem wykorzystywanym do automatycznego
36 konfigurowania kodów ¼ród³owych pakietów programów oraz do generowania na
37 podstawie automatycznie rozoznanego ¶rodowiska plików Makefile i innch
38 zale¿nych od zawarto¶ci systemu w którym ma przebiegaæ proces kompilacji.
39 Pomaga programi¶cie w konfigurowaniu i tworzeniu opragramowania daj±cego siê
40 przenie¶æ na ró¿ne platformy. Umo¿liwia wybór wielu opcji podczas procesu
41 przygotowania do kompilacji.
42
43 GNU autoconf nie jest generalnie potrzebny dla u¿ytkownika koñcowego, a
44 tylko podczas generowania samych skryptów autokonfiguracyjnych.
45  
46 %prep
47 %setup -q
48 %patch0 -p1
49 %patch1 -p1
50 %patch2 -p1
51 %patch3 -p1
52 %patch4 -p1
53 %patch5 -p1
54 %patch6 -p1
55
56 %build
57 ./configure \
58         --prefix=%{_prefix} \
59         --infodir=%{_infodir} \
60         --mandir=%{_mandir}
61 make datadir=%{_libdir}
62
63 %install
64 rm -rf $RPM_BUILD_ROOT
65 install -d $RPM_BUILD_ROOT{%{_infodir},%{_mandir}/man1}
66
67 make install \
68         prefix=$RPM_BUILD_ROOT%{_prefix} \
69         datadir=$RPM_BUILD_ROOT%{_libdir} \
70         infodir=$RPM_BUILD_ROOT%{_infodir} \
71         mandir=$RPM_BUILD_ROOT%{_mandir} \
72 install install-sh $RPM_BUILD_ROOT%{_libdir}/autoconf
73
74 install {autoconf,autoheader,autoreconf,autoscan,autoupdate,ifnames}.1 \
75         $RPM_BUILD_ROOT%{_mandir}/man1
76
77 gzip -9nf $RPM_BUILD_ROOT%{_infodir}/autoconf.info* \
78         $RPM_BUILD_ROOT%{_mandir}/man1/*
79
80 %post
81 /sbin/install-info %{_infodir}/autoconf.info.gz /etc/info-dir
82
83 %preun
84 if [ "$1" = "0" ]; then
85         /sbin/install-info --del %{_infodir}/autoconf.info.gz /etc/info-dir
86 fi
87
88 %clean
89 rm -rf $RPM_BUILD_ROOT
90
91 %files
92 %defattr(644,root,root,755)
93 %attr(755,root,root) %{_bindir}/*
94
95 %{_infodir}/autoconf.info*
96 %{_mandir}/man1/*
97
98 %{_libdir}/autoconf
This page took 0.5149 seconds and 3 git commands to generate.