]> git.pld-linux.org Git - packages/aufs.git/blob - aufs.spec
- BR kernel-module-build >= 3:2.6.20.2
[packages/aufs.git] / aufs.spec
1 #
2 # Conditional build:
3 %bcond_without  dist_kernel     # allow non-distribution kernel
4 %bcond_without  kernel          # don't build kernel modules
5 %bcond_without  userspace       # don't build userspace programs
6 %bcond_with     verbose         # verbose build (V=1)
7 %bcond_without  vserver         # kernel build without vserver & grsecurity
8
9 %if %{without kernel}
10 %undefine       with_dist_kernel
11 %endif
12
13 %define         _cvsdate        20070528
14 %define         _rel            0.%{_cvsdate}.1
15 Summary:        aufs - Another Unionfs
16 Summary(pl.UTF-8):      aufs (Another Unionfs) - inny unionfs
17 Name:           aufs
18 Version:        0
19 Release:        %{_rel}
20 License:        GPL v2
21 Group:          Base/Kernel
22 Source0:        %{name}-%{_cvsdate}.tar.bz2
23 # Source0-md5:  38736bd2d7b329d8ee99f8f4b6f03aa1
24 Patch0:         %{name}-vserver.patch
25 URL:            http://aufs.sourceforge.net/
26 %if %{with kernel}
27 %{?with_dist_kernel:BuildRequires:      kernel%{_alt_kernel}-module-build >= 3:2.6.20.2}
28 BuildRequires:  rpmbuild(macros) >= 1.379
29 %endif
30 BuildRequires:  sed >= 4.0
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 In the early days, aufs was entirely re-designed and re-implemented
35 Unionfs. After many original ideas, approaches, improvements and
36 implementations, it becomes totally different from Unionfs while
37 keeping the basic features. Unionfs is being developed by Professor
38 Erez Zadok at Stony Brook University and his team. If you don't know
39 Unionfs, I recommend you to try and know it before using aufs. Some
40 terminology in aufs follows Unionfs's.
41
42 %description -l pl.UTF-8
43 Początkowo aufs był całkowicie przeprojektowanym i od nowa
44 zaimplementowanym unionfs-em. Po wielu oryginalnych pomysłach,
45 podejściach, poprawkach i implementacjach stał sie całkowicie innym
46 niż unionfs zachowując podstawowe możliwości. unionfs jest rozwijany
47 przez profesora Ereza Zadoka w Stony Brook University i jego zespół.
48 Nie znający unionfs-a powinni spróbować go i poznać przed używaniem
49 aufs-a. Część terminologii wywodzi się z unionfs-a.
50
51 %package -n kernel%{_alt_kernel}-fs-aufs
52 Summary:        Linux driver for aufs
53 Summary(pl.UTF-8):      Sterownik dla Linuksa do aufs
54 Release:        %{_rel}@%{_kernel_ver_str}
55 Group:          Base/Kernel
56 Requires(post,postun):  /sbin/depmod
57 %if %{with dist_kernel}
58 %requires_releq_kernel
59 Requires(postun):       %releq_kernel
60 %endif
61
62 %description -n kernel%{_alt_kernel}-fs-aufs
63 This is driver for aufs for Linux.
64
65 This package contains Linux module.
66
67 %description -n kernel%{_alt_kernel}-fs-aufs -l pl.UTF-8
68 Sterownik dla Linuksa do aufs.
69
70 Ten pakiet zawiera moduł jądra Linuksa.
71
72 %prep
73 %setup -qn %{name}
74 %if %{with vserver}
75 %patch0 -p1
76 %endif
77
78 sed '
79         s/$(CONFIG_AUFS)/m/; 
80         %{!?debug:s/$(CONFIG_AUFS_DEBUG.*)/n/}; 
81         s/$(CONFIG_AUFS_HINOTIFY)/n/;
82         s/$(CONFIG_AUFS_EXPORT)/y/;
83         s/$(CONFIG_AUFS_SYSAUFS)/n/
84 ' -i fs/aufs/Makefile
85 cp -a include/linux fs/aufs
86
87 %build
88 %if %{with kernel}
89 %build_kernel_modules -C fs/aufs -m aufs \
90         EXTRA_CFLAGS=" \
91                 -DCONFIG_AUFS_BRANCH_MAX_127 \
92                 -DCONFIG_AUFS_BRANCH_MAX_CHAR \
93                 -DCONFIG_AUFS_FAKE_DM \
94                 -DCONFIG_AUFS_MODULE \
95                 -UCONFIG_AUFS_KSIZE_PATCH \
96                 %{?debug:-DCONFIG_AUFS_DEBUG} \
97                 %{?with_vserver:-DVSERVER} \
98         "
99 %endif
100
101 %if %{with userspace}
102 %{__make} -C util \
103         CC="%{__cc}" \
104         CFLAGS="%{rpmcflags} -DCONFIG_AUFS_BRANCH_MAX_127"
105 %endif
106
107 %install
108 rm -rf $RPM_BUILD_ROOT
109
110 %if %{with userspace}
111 install -d $RPM_BUILD_ROOT{%{_mandir}/man5,%{_sbindir}}
112 install util/{mount.aufs,umount.aufs,auplink,aulchown} $RPM_BUILD_ROOT%{_sbindir}
113 install util/aufs.5 $RPM_BUILD_ROOT%{_mandir}/man5/
114 %endif
115
116 %if %{with kernel}
117 %install_kernel_modules -m fs/aufs/aufs -d kernel/fs/aufs
118 %endif
119
120 %clean
121 rm -rf $RPM_BUILD_ROOT
122
123 %post   -n kernel%{_alt_kernel}-fs-aufs
124 %depmod %{_kernel_ver}
125
126 %postun -n kernel%{_alt_kernel}-fs-aufs
127 %depmod %{_kernel_ver}
128
129 %if %{with kernel}
130 %files -n kernel%{_alt_kernel}-fs-aufs
131 %defattr(644,root,root,755)
132 %dir /lib/modules/%{_kernel_ver}/kernel/fs/aufs
133 /lib/modules/%{_kernel_ver}/kernel/fs/aufs/*.ko*
134 %endif
135
136 %if %{with userspace}
137 %files
138 %defattr(644,root,root,755)
139 %doc README History
140 %attr(755,root,root) %{_sbindir}/*
141 %{_mandir}/man5/*
142 %endif
This page took 0.036582 seconds and 3 git commands to generate.