]> git.pld-linux.org Git - packages/aufs.git/blob - aufs.spec
- rel 11 (2.6.22.19-5)
[packages/aufs.git] / aufs.spec
1 #
2 # Conditional build:
3 %bcond_without  dist_kernel     # allow non-distribution kernel
4 %bcond_without  kernel          # don't build kernel modules
5 %bcond_without  userspace       # don't build userspace programs
6 %bcond_with     verbose         # verbose build (V=1)
7
8 %if %{without kernel}
9 %undefine       with_dist_kernel
10 %endif
11
12 %define         subver          20080313
13 %define         prel            0.%{subver}.%{rel}
14
15 %define         rel             11
16 Summary:        aufs - Another Unionfs
17 Summary(pl.UTF-8):      aufs (Another Unionfs) - inny unionfs
18 Name:           aufs
19 Version:        0
20 Release:        %{prel}
21 License:        GPL v2
22 Group:          Base/Kernel
23 Source0:        %{name}-%{subver}.tar.bz2
24 # Source0-md5:  044ba36a61ca6a0ebe72108aaa77b816
25 Patch0:         %{name}-vserver.patch
26 Patch1:         %{name}-disable-security_inode_permission.patch
27 URL:            http://aufs.sourceforge.net/
28 %if %{with kernel}
29 %{?with_dist_kernel:BuildRequires:      kernel%{_alt_kernel}-module-build >= 3:2.6.20.2}
30 BuildRequires:  rpmbuild(macros) >= 1.379
31 %endif
32 BuildRequires:  sed >= 4.0
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 In the early days, aufs was entirely re-designed and re-implemented
37 Unionfs. After many original ideas, approaches, improvements and
38 implementations, it becomes totally different from Unionfs while
39 keeping the basic features. Unionfs is being developed by Professor
40 Erez Zadok at Stony Brook University and his team. If you don't know
41 Unionfs, I recommend you to try and know it before using aufs. Some
42 terminology in aufs follows Unionfs's.
43
44 %description -l pl.UTF-8
45 Początkowo aufs był całkowicie przeprojektowanym i od nowa
46 zaimplementowanym unionfs-em. Po wielu oryginalnych pomysłach,
47 podejściach, poprawkach i implementacjach stał sie całkowicie innym
48 niż unionfs zachowując podstawowe możliwości. unionfs jest rozwijany
49 przez profesora Ereza Zadoka w Stony Brook University i jego zespół.
50 Nie znający unionfs-a powinni spróbować go i poznać przed używaniem
51 aufs-a. Część terminologii wywodzi się z unionfs-a.
52
53 %package -n kernel%{_alt_kernel}-fs-aufs
54 Summary:        Linux driver for aufs
55 Summary(pl.UTF-8):      Sterownik dla Linuksa do aufs
56 Release:        %{prel}@%{_kernel_ver_str}
57 Group:          Base/Kernel
58 Requires(post,postun):  /sbin/depmod
59 %if %{with dist_kernel}
60 %requires_releq_kernel
61 Requires(postun):       %releq_kernel
62 %endif
63
64 %description -n kernel%{_alt_kernel}-fs-aufs
65 This is driver for aufs for Linux.
66
67 This package contains Linux module.
68
69 %description -n kernel%{_alt_kernel}-fs-aufs -l pl.UTF-8
70 Sterownik dla Linuksa do aufs.
71
72 Ten pakiet zawiera moduł jądra Linuksa.
73
74 %prep
75 %setup -qn %{name}
76 %patch0 -p1
77 %patch1 -p1
78
79 sed '
80         s/$(CONFIG_AUFS)/m/; 
81         %{!?debug:s/$(CONFIG_AUFS_DEBUG.*)/n/}; 
82         s/$(CONFIG_AUFS_HINOTIFY)/n/;
83         s/$(CONFIG_AUFS_EXPORT)/y/;
84         s/$(CONFIG_AUFS_SYSAUFS)/n/
85 ' -i fs/aufs/Makefile
86 cp -a include/linux fs/aufs
87
88 %build
89 %if %{with kernel}
90 if [ -f %{_kernelsrcdir}/include/linux/vs_base.h ]; then
91         isvserver="-DVSERVER"
92 fi
93 %build_kernel_modules -C fs/aufs -m aufs \
94         EXTRA_CFLAGS=" \
95                 -DCONFIG_AUFS_BRANCH_MAX_127 \
96                 -DCONFIG_AUFS_BRANCH_MAX_CHAR \
97                 -DCONFIG_AUFS_FAKE_DM \
98                 -DCONFIG_AUFS_MODULE \
99                 -UCONFIG_AUFS_KSIZE_PATCH \
100                 -UCONFIG_AUFS_DLGT \
101                 %{?debug:-DCONFIG_AUFS_DEBUG} \
102                 $isvserver"
103 %endif
104
105 %if %{with userspace}
106 %{__make} -C util \
107         CC="%{__cc}" \
108         CFLAGS="%{rpmcflags} -DCONFIG_AUFS_BRANCH_MAX_127"
109 %endif
110
111 %install
112 rm -rf $RPM_BUILD_ROOT
113
114 %if %{with userspace}
115 install -d $RPM_BUILD_ROOT{%{_mandir}/man5,%{_sbindir}}
116 install util/{mount.aufs,umount.aufs,auplink,aulchown} $RPM_BUILD_ROOT%{_sbindir}
117 install util/aufs.5 $RPM_BUILD_ROOT%{_mandir}/man5/
118 %endif
119
120 %if %{with kernel}
121 %install_kernel_modules -m fs/aufs/aufs -d kernel/fs/aufs
122 %endif
123
124 %clean
125 rm -rf $RPM_BUILD_ROOT
126
127 %post   -n kernel%{_alt_kernel}-fs-aufs
128 %depmod %{_kernel_ver}
129
130 %postun -n kernel%{_alt_kernel}-fs-aufs
131 %depmod %{_kernel_ver}
132
133 %if %{with kernel}
134 %files -n kernel%{_alt_kernel}-fs-aufs
135 %defattr(644,root,root,755)
136 %dir /lib/modules/%{_kernel_ver}/kernel/fs/aufs
137 /lib/modules/%{_kernel_ver}/kernel/fs/aufs/*.ko*
138 %endif
139
140 %if %{with userspace}
141 %files
142 %defattr(644,root,root,755)
143 %doc README History
144 %attr(755,root,root) %{_sbindir}/*
145 %{_mandir}/man5/*
146 %endif
This page took 0.096387 seconds and 3 git commands to generate.