]> git.pld-linux.org Git - packages/audit.git/commitdiff
- up to 2.4.3 auto/th/audit-2.4.3-1
authorJan Rękorajski <baggins@pld-linux.org>
Tue, 21 Jul 2015 07:38:52 +0000 (09:38 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Tue, 21 Jul 2015 07:38:52 +0000 (09:38 +0200)
- added python3 bindings
- fixed golang bindings path

audit.spec
golang-paths.patch

index e456a91f41fcbc1e6c86f6a579b08e8e25fc9675..7f3f76fa5e43299ad723b0f6183dc4d0ef43bfa6 100644 (file)
@@ -4,6 +4,7 @@
 %bcond_without prelude         # prelude audisp plugin
 %bcond_without golang          # Go language bindings
 %bcond_without python          # Python bindings
+%bcond_without python3         # Python3 bindings
 %bcond_without zos_remote      # zos-remote audisp plugin (LDAP dep)
 
 %ifnarch %{ix86} %{x8664} %{arm}
 Summary:       User space tools for 2.6 kernel auditing
 Summary(pl.UTF-8):     Narzędzia przestrzeni użytkownika do audytu jąder 2.6
 Name:          audit
-Version:       2.4.2
+Version:       2.4.3
 Release:       1
 License:       GPL v2+
 Group:         Daemons
 Source0:       http://people.redhat.com/sgrubb/audit/%{name}-%{version}.tar.gz
-# Source0-md5: 52e535e449f6fb80a4491267e35f1cec
+# Source0-md5: 544d863af2016b76afd8d1691b251164
 Source2:       %{name}d.init
 Source3:       %{name}d.sysconfig
 Patch0:                %{name}-install.patch
@@ -49,6 +50,11 @@ BuildRequires:       python-devel >= 1:2.5
 BuildRequires: rpm-pythonprov
 BuildRequires: swig-python
 %endif
+%if %{with python3}
+BuildRequires: python3-devel
+BuildRequires: rpm-pythonprov
+BuildRequires: swig-python
+%endif
 BuildRequires: rpmbuild(macros) >= 1.623
 BuildRequires: sed >= 4.0
 Requires(post,preun):  /sbin/chkconfig
@@ -162,6 +168,19 @@ Python interface to libaudit library.
 %description -n python-audit -l pl.UTF-8
 Pythonowy interfejs do biblioteki libaudit.
 
+%package -n python3-audit
+Summary:       Python interface to libaudit library
+Summary(pl.UTF-8):     Pythonowy interfejs do biblioteki libaudit
+License:       LGPL v2.1+
+Group:         Libraries/Python
+Requires:      %{name}-libs = %{version}-%{release}
+
+%description -n python3-audit
+Python interface to libaudit library.
+
+%description -n python3-audit -l pl.UTF-8
+Pythonowy interfejs do biblioteki libaudit.
+
 %prep
 %setup -q
 %patch0 -p1
@@ -223,6 +242,10 @@ ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/libauparse.so.*.*.*) \
 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/*.{la,a}
 %endif
 
+%if %{with python}
+%{__rm} $RPM_BUILD_ROOT%{py3_sitedir}/*.{la,a}
+%endif
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -330,6 +353,7 @@ fi
 %{_includedir}/auparse*.h
 %{_includedir}/libaudit.h
 %{_pkgconfigdir}/audit.pc
+%{_pkgconfigdir}/auparse.pc
 %{_mandir}/man3/audit_*.3*
 %{_mandir}/man3/auparse_*.3*
 %{_mandir}/man3/ausearch_*.3*
@@ -354,8 +378,8 @@ fi
 %if %{with golang}
 %files -n golang-audit
 %defattr(644,root,root,755)
-%dir %{_libdir}/golang/src/pkg/redhat.com
-%{_libdir}/golang/src/pkg/redhat.com/audit
+%dir %{_libdir}/golang/src/redhat.com
+%{_libdir}/golang/src/redhat.com/audit
 %endif
 
 %if %{with python}
@@ -365,3 +389,11 @@ fi
 %attr(755,root,root) %{py_sitedir}/auparse.so
 %{py_sitedir}/audit.py[co]
 %endif
+
+%if %{with python3}
+%files -n python3-audit
+%defattr(644,root,root,755)
+%attr(755,root,root) %{py3_sitedir}/_audit.so
+%attr(755,root,root) %{py3_sitedir}/auparse.so
+%{py3_sitedir}/audit.py
+%endif
index 6dc073fff0b47d0b48dbf610aecc924104eb1a50..2505cecf5be106077ec0b13df96f9785b6742263 100644 (file)
@@ -6,7 +6,7 @@
  
 -LIBDIR = lib
 -GODIR = $(LIBDIR)/golang/src/pkg/redhat.com/audit
-+GODIR = ${libdir}/golang/src/pkg/redhat.com/audit
++GODIR = ${libdir}/golang/src/redhat.com/audit
  dist_check_SCRIPTS = test.go
  
  install:
This page took 0.118033 seconds and 4 git commands to generate.