]> git.pld-linux.org Git - packages/audiere.git/blob - audiere.spec
- add gcc44 fixes
[packages/audiere.git] / audiere.spec
1 Summary:        Portable audio library
2 Summary(pl.UTF-8):      Przenośna biblioteka audio
3 Name:           audiere
4 Version:        1.9.4
5 Release:        2
6 License:        LGPL v2.1+
7 Group:          Libraries
8 Source0:        http://dl.sourceforge.net/audiere/%{name}-%{version}.tar.gz
9 # Source0-md5:  b95dfe6f1e69cfd12371747f22772766
10 Patch0:         gcc44.patch
11 URL:            http://audiere.sourceforge.net/
12 # should be shared to avoid PIC issue
13 #BuildRequires: dumb-devel
14 #BuildRequires: flac-devel < 1.1.3
15 BuildRequires:  libcdaudio-devel
16 BuildRequires:  libogg-devel
17 BuildRequires:  libstdc++-devel
18 BuildRequires:  libvorbis-devel
19 # needs fix (-I, invalid conversion)
20 #BuildRequires: speex-devel
21 #BR: wxWidgets for example player (needs passing WX_CONFIG)
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 The Audiere Audio System is a portable audio library which supports
26 playing MP3, Ogg Vorbis, WAV, IT, XM, S3M, and MOD files. You can use
27 it from C, C++, Python, Java, and any language that supports XPCOM
28 (JavaScript in Mozilla, for example). It currently supports
29 DirectSound 3, DirectSound 8, and arbitrary DLLs for output in
30 Windows, and OSS in Linux.
31
32 %description -l pl.UTF-8
33 Audiere Audio System jest przenośną biblioteką obsługującą odtwarzanie
34 plików MP3, Ogg Vorbis, WAV, IT, XM, S3M oraz MOD. Można jej używać z
35 poziomu C, C++, Pythona, Javy oraz innych języków obsługujących XPCOM
36 (jak na przykład JavaScript w Mozilli). Biblioteka jako wyjście
37 obsługuje obecnie DirectSound 3, DirectSound 8 jak również dowolne
38 biblioteki DLL dla Windows oraz OSS pod Linuksem.
39
40 %package devel
41 Summary:        Header files for audiere library
42 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki audiere
43 Group:          Development/Libraries
44 Requires:       %{name} = %{version}-%{release}
45 Requires:       libcdaudio-devel
46 Requires:       libogg-devel
47 Requires:       libstdc++-devel
48 Requires:       libvorbis-devel
49
50 %description devel
51 Header files for audiere library.
52
53 %description devel -l pl.UTF-8
54 Pliki nagłówkowe biblioteki audiere.
55
56 %package static
57 Summary:        Static audiere library
58 Summary(pl.UTF-8):      Statyczna biblioteka audiere
59 Group:          Development/Libraries
60 Requires:       %{name}-devel = %{version}-%{release}
61
62 %description static
63 Static audiere library.
64
65 %description static -l pl.UTF-8
66 Statyczna biblioteka audiere.
67
68 %prep
69 %setup -q
70 %patch0 -p1
71
72 %build
73 %configure
74 %{__make}
75
76 %install
77 rm -rf $RPM_BUILD_ROOT
78
79 %{__make} install \
80         DESTDIR=$RPM_BUILD_ROOT
81
82 %clean
83 rm -rf $RPM_BUILD_ROOT
84
85 %files
86 %defattr(644,root,root,755)
87 %doc doc/*.txt
88 %attr(755,root,root) %{_libdir}/libaudiere-%{version}.so
89
90 %files devel
91 %defattr(644,root,root,755)
92 %attr(755,root,root) %{_bindir}/audiere-config
93 %attr(755,root,root) %{_libdir}/libaudiere.so
94 %{_libdir}/libaudiere.la
95 %{_includedir}/audiere.h
96
97 %files static
98 %defattr(644,root,root,755)
99 %{_libdir}/libaudiere.a
This page took 0.107612 seconds and 3 git commands to generate.