]> git.pld-linux.org Git - packages/audacity.git/blob - audacity.spec
- updated to 1.3.14
[packages/audacity.git] / audacity.spec
1 # TODO:
2 # - internal portaudio crashes when only OSS is available on startup
3 # - use system portaudio (>= 19, but relies on local changes)
4 # - use system portSMF?
5 # - use system ffmpeg (libavcodec >= 51.53, libavformat >= 52.12)
6 # - use system sbsms (>= 1.6.0, but relies on local changes)
7 #
8 # Conditional build:
9 %bcond_with     libresample     # using libresample (default libsamplerate)
10 #
11 Summary:        Audacity - manipulate digital audio waveforms
12 Summary(pl.UTF-8):      Audacity - narzędzie do obróbki plików dźwiękowych
13 Summary(ru.UTF-8):      Кроссплатформенный звуковой редактор
14 Name:           audacity
15 Version:        1.3.14
16 Release:        1
17 License:        GPL v2+
18 Group:          X11/Applications/Sound
19 #Source0Download: http://code.google.com/p/audacity/downloads/list
20 Source0:        http://audacity.googlecode.com/files/%{name}-minsrc-%{version}-beta.tar.bz2
21 # Source0-md5:  e7754757e7c3b543db9aa32180b0fb6f
22 # Link from http://manual.audacityteam.org/index.php?title=Main_Page
23 Source1:        http://manual.audacityteam.org/help.zip
24 # Source1-md5:  0b5c73fb1013f87c3e771d817aa5e9f9
25 Source2:        %{name}.desktop
26 Source3:        %{name}-icon.png
27 Patch0:         %{name}-system-libs.patch
28 Patch1:         %{name}-opt.patch
29 Patch2:         %{name}-no-macos.patch
30 # modified from http://audioscience.com/internet/download/drivers/released/v4/06/portaudio_asihpi_406.patch
31 Patch3:         portaudio_asihpi_406.patch
32 Patch4:         %{name}-ffmpeg.patch
33 URL:            http://audacity.sourceforge.net/
34 BuildRequires:  autoconf >= 2.59
35 BuildRequires:  automake
36 BuildRequires:  expat-devel >= 1.95
37 BuildRequires:  ffmpeg-devel >= 0.8.0
38 BuildRequires:  flac-c++-devel >= 1.2.0
39 BuildRequires:  gettext-devel
40 BuildRequires:  hpklinux-devel >= 4.06
41 BuildRequires:  libid3tag-devel >= 0.15.0b-2
42 BuildRequires:  libjpeg-devel
43 BuildRequires:  libmad-devel >= 0.14.2b-4
44 %{?with_libresample:BuildRequires:      libresample-devel >= 0.1.3}
45 %{!?with_libresample:BuildRequires:     libsamplerate-devel >= 0.1.2}
46 #BuildRequires: libsbsms-devel >= 1.6.0
47 BuildRequires:  libsndfile-devel >= 1.0.0
48 BuildRequires:  libstdc++-devel
49 BuildRequires:  libvorbis-devel >= 1:1.0
50 #BuildRequires: portaudio-devel >= 19
51 BuildRequires:  pkgconfig
52 BuildRequires:  soundtouch-devel >= 1.3.0
53 BuildRequires:  speex-devel
54 BuildRequires:  twolame-devel >= 0.3.9
55 BuildRequires:  unzip
56 BuildRequires:  vamp-devel >= 2.0
57 BuildRequires:  which
58 BuildRequires:  wxGTK2-unicode-devel >= 2.8.0
59 Requires(post,postun):  shared-mime-info
60 Requires:       flac-c++ >= 1.2.0
61 Requires:       lame-libs
62 Requires:       libid3tag >= 0.15.0b-2
63 Requires:       libmad >= 0.14.2b-4
64 %{?with_libresample:Requires:   libresample >= 0.1.3}
65 %{!?with_libresample:Requires:  libsamplerate >= 0.1.2}
66 Requires:       libsndfile >= 1.0.0
67 Requires:       soundtouch >= 1.3.0
68 Requires:       twolame-libs >= 0.3.9
69 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
70
71 %description
72 Audacity is a program that lets you manipulate digital audio
73 waveforms. It imports many sound file formats, including WAV, AIFF,
74 AU, IRCAM, MP3, and Ogg Vorbis. It supports all common editing
75 operations such as Cut, Copy, and Paste, plus it will mix tracks and
76 let you apply plug-in effects to any part of a sound.
77
78 %description -l pl.UTF-8
79 Audacity to program obsługujący różne formaty plików audio. Obsługuje
80 WAV, AIFF, AU, IRCAM, MP3, oraz Ogg Vorbis. Program ten umożliwia
81 wykonywanie podstawowych czynności edycyjnych takich jak kasowanie,
82 wstawianie i miksowanie ścieżki dźwiękowej. Umożliwia także
83 wykonywanie dowolnych innych operacji poprzez system wtyczek.
84
85 %description -l ru.UTF-8
86 Audacity - это звуковой редактор, позволяющий работать с файлами в
87 форматах WAV, AIFF, AU, IRCAM, MP3 и Ogg Vorbis. В нем реализованы все
88 основные операции, такие как удаление, копирование, вставка,
89 микширование треков и применение эффектов, оформленных в виде
90 плагинов, к любой части звукового файла.
91
92 %prep
93 %setup -q -n %{name}-src-%{version}-beta
94 %patch0 -p1
95 %patch1 -p1
96 %patch2 -p1
97 cd lib-src/portaudio-v19
98 %patch3 -p0
99 cd ../..
100 %patch4 -p1
101
102 %{__sed} -i 's/libmp3lame.so/libmp3lame.so.0/g' locale/*.po
103
104 %build
105 cd lib-src/portmixer
106 %{__autoconf}
107 cd ../portsmf
108 %{__aclocal} -I autotools/m4
109 %{__autoconf}
110 cd ../..
111 %{__aclocal} -I m4
112 %{__autoconf}
113
114 export WX_CONFIG=$(which wx-gtk2-unicode-config)
115 %configure \
116 %if %{with libresample}
117         --with-libresample=system \
118 %else
119         --with-libresample=no \
120         --with-libsamplerate=system \
121 %endif
122         --with-help \
123         --with-id3tag=system \
124         --with-libmad=system \
125         --with-libsndfile=system \
126         --with-libflac=system \
127         --with-sbsms=local \
128         --with-vorbis=system
129
130 %{__make}
131
132 %install
133 rm -rf $RPM_BUILD_ROOT
134 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
135
136 %{__make} install \
137         DESTDIR=$RPM_BUILD_ROOT \
138         INSTALL_PATH=$RPM_BUILD_ROOT
139
140 cp -a %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
141 cp -a %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}
142 %{__unzip} -qq -a %{SOURCE1} -d $RPM_BUILD_ROOT%{_datadir}/%{name}/help
143
144 mv -f $RPM_BUILD_ROOT%{_datadir}/locale/{zh,zh_CN}
145 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
146
147 %{__rm} $RPM_BUILD_ROOT%{_datadir}/pixmaps/audacity.xpm
148 %{__rm} $RPM_BUILD_ROOT%{_datadir}/pixmaps/audacity16.xpm
149 %{__rm} $RPM_BUILD_ROOT%{_datadir}/pixmaps/audacity32.xpm
150 %{__rm} $RPM_BUILD_ROOT%{_datadir}/pixmaps/gnome-mime-application-x-audacity-project.xpm
151
152 %find_lang %{name}
153
154 %clean
155 rm -rf $RPM_BUILD_ROOT
156
157 %post
158 %update_mime_database
159
160 %postun
161 %update_mime_database
162
163 %files -f %{name}.lang
164 %defattr(644,root,root,755)
165 %doc README.txt
166 %attr(755,root,root) %{_bindir}/audacity
167 %dir %{_datadir}/%{name}
168 %{_datadir}/%{name}/nyquist
169 %{_datadir}/%{name}/plug-ins
170 %{_datadir}/%{name}/EQDefaultCurves.xml
171 %doc %{_datadir}/%{name}/help
172 %{_mandir}/man1/audacity.1*
173 %{_desktopdir}/audacity.desktop
174 %{_pixmapsdir}/audacity-icon.png
175 %{_datadir}/mime/packages/audacity.xml
176 %{_iconsdir}/hicolor/*/apps/audacity.png
177 %{_iconsdir}/hicolor/*/apps/audacity.svg
This page took 0.914291 seconds and 4 git commands to generate.