]> git.pld-linux.org Git - packages/audacity.git/blob - audacity.spec
- updated to 2.0.2
[packages/audacity.git] / audacity.spec
1 # TODO:
2 # - internal portaudio crashes when only OSS is available on startup
3 # - use system portaudio (>= 19, but relies on local changes)
4 # - use system portSMF?
5 # - use system ffmpeg (libavcodec >= 51.53, libavformat >= 52.12)
6 # - use system sbsms (>= 1.6.0, but relies on local changes)
7 #
8 # Conditional build:
9 %bcond_with     libresample     # using libresample (default libsamplerate)
10 #
11 Summary:        Audacity - manipulate digital audio waveforms
12 Summary(pl.UTF-8):      Audacity - narzędzie do obróbki plików dźwiękowych
13 Summary(ru.UTF-8):      Кроссплатформенный звуковой редактор
14 Name:           audacity
15 Version:        2.0.2
16 Release:        0.1
17 License:        GPL v2+
18 Group:          X11/Applications/Sound
19 #Source0Download: http://code.google.com/p/audacity/downloads/list
20 Source0:        http://audacity.googlecode.com/files/%{name}-minsrc-%{version}.tar.bz2
21 # Source0-md5:  c838bc4485b0af104a7f6d9c6955a284
22 # Link from http://manual.audacityteam.org/index.php?title=Main_Page
23 Source1:        http://audacity.googlecode.com/files/%{name}-manual-%{version}.zip
24 # Source1-md5:  2c80017f602dd6239ec3b6b0c25e68df
25 Source2:        %{name}.desktop
26 Source3:        %{name}-icon.png
27 Patch0:         %{name}-system-libs.patch
28 Patch1:         %{name}-opt.patch
29 Patch2:         %{name}-no-macos.patch
30 # modified from http://audioscience.com/internet/download/drivers/released/v4/06/portaudio_asihpi_406.patch
31 Patch3:         portaudio_asihpi_406.patch
32 URL:            http://audacity.sourceforge.net/
33 BuildRequires:  autoconf >= 2.59
34 BuildRequires:  automake
35 BuildRequires:  expat-devel >= 1.95
36 BuildRequires:  ffmpeg-devel >= 0.8.0
37 BuildRequires:  flac-c++-devel >= 1.2.0
38 BuildRequires:  gettext-devel
39 BuildRequires:  hpklinux-devel >= 4.06
40 BuildRequires:  libid3tag-devel >= 0.15.0b-2
41 BuildRequires:  libjpeg-devel
42 BuildRequires:  libmad-devel >= 0.14.2b-4
43 %{?with_libresample:BuildRequires:      libresample-devel >= 0.1.3}
44 %{!?with_libresample:BuildRequires:     libsamplerate-devel >= 0.1.2}
45 #BuildRequires: libsbsms-devel >= 1.6.0
46 BuildRequires:  libsndfile-devel >= 1.0.0
47 BuildRequires:  libstdc++-devel
48 BuildRequires:  libvorbis-devel >= 1:1.0
49 #BuildRequires: portaudio-devel >= 19
50 BuildRequires:  pkgconfig
51 BuildRequires:  soundtouch-devel >= 1.3.0
52 BuildRequires:  speex-devel
53 BuildRequires:  twolame-devel >= 0.3.9
54 BuildRequires:  unzip
55 BuildRequires:  vamp-devel >= 2.0
56 BuildRequires:  which
57 BuildRequires:  wxGTK2-unicode-devel >= 2.8.0
58 Requires(post,postun):  shared-mime-info
59 Requires:       flac-c++ >= 1.2.0
60 Requires:       lame-libs
61 Requires:       libid3tag >= 0.15.0b-2
62 Requires:       libmad >= 0.14.2b-4
63 %{?with_libresample:Requires:   libresample >= 0.1.3}
64 %{!?with_libresample:Requires:  libsamplerate >= 0.1.2}
65 Requires:       libsndfile >= 1.0.0
66 Requires:       soundtouch >= 1.3.0
67 Requires:       twolame-libs >= 0.3.9
68 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
69
70 %description
71 Audacity is a program that lets you manipulate digital audio
72 waveforms. It imports many sound file formats, including WAV, AIFF,
73 AU, IRCAM, MP3, and Ogg Vorbis. It supports all common editing
74 operations such as Cut, Copy, and Paste, plus it will mix tracks and
75 let you apply plug-in effects to any part of a sound.
76
77 %description -l pl.UTF-8
78 Audacity to program obsługujący różne formaty plików audio. Obsługuje
79 WAV, AIFF, AU, IRCAM, MP3, oraz Ogg Vorbis. Program ten umożliwia
80 wykonywanie podstawowych czynności edycyjnych takich jak kasowanie,
81 wstawianie i miksowanie ścieżki dźwiękowej. Umożliwia także
82 wykonywanie dowolnych innych operacji poprzez system wtyczek.
83
84 %description -l ru.UTF-8
85 Audacity - это звуковой редактор, позволяющий работать с файлами в
86 форматах WAV, AIFF, AU, IRCAM, MP3 и Ogg Vorbis. В нем реализованы все
87 основные операции, такие как удаление, копирование, вставка,
88 микширование треков и применение эффектов, оформленных в виде
89 плагинов, к любой части звукового файла.
90
91 %prep
92 %setup -q -n %{name}-src-%{version}
93 %patch0 -p1
94 %patch1 -p1
95 %patch2 -p1
96 cd lib-src/portaudio-v19
97 %patch3 -p0
98 cd ../..
99
100 %{__sed} -i 's/libmp3lame.so/libmp3lame.so.0/g' locale/*.po
101
102 %build
103 cd lib-src/portmixer
104 %{__autoconf}
105 cd ../portsmf
106 %{__aclocal} -I autotools/m4
107 %{__autoconf}
108 cd ../..
109 %{__aclocal} -I m4
110 %{__autoconf}
111
112 export WX_CONFIG=$(which wx-gtk2-unicode-config)
113 %configure \
114 %if %{with libresample}
115         --with-libresample=system \
116 %else
117         --with-libresample=no \
118         --with-libsamplerate=system \
119 %endif
120         --with-help \
121         --with-id3tag=system \
122         --with-libmad=system \
123         --with-libsndfile=system \
124         --with-libflac=system \
125         --with-sbsms=local \
126         --with-vorbis=system
127
128 %{__make}
129
130 %install
131 rm -rf $RPM_BUILD_ROOT
132 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
133
134 %{__make} install \
135         DESTDIR=$RPM_BUILD_ROOT \
136         INSTALL_PATH=$RPM_BUILD_ROOT
137
138 cp -a %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
139 cp -a %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}
140 %{__unzip} -qq -a %{SOURCE1} -d $RPM_BUILD_ROOT%{_datadir}/%{name}/help
141
142 # unsupported
143 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/locale/sr_RS
144
145 mv -f $RPM_BUILD_ROOT%{_datadir}/locale/{zh,zh_CN}
146 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
147
148 %{__rm} $RPM_BUILD_ROOT%{_datadir}/pixmaps/audacity.xpm
149 %{__rm} $RPM_BUILD_ROOT%{_datadir}/pixmaps/audacity16.xpm
150 %{__rm} $RPM_BUILD_ROOT%{_datadir}/pixmaps/audacity32.xpm
151 %{__rm} $RPM_BUILD_ROOT%{_datadir}/pixmaps/gnome-mime-application-x-audacity-project.xpm
152
153 %find_lang %{name}
154
155 %clean
156 rm -rf $RPM_BUILD_ROOT
157
158 %post
159 %update_mime_database
160
161 %postun
162 %update_mime_database
163
164 %files -f %{name}.lang
165 %defattr(644,root,root,755)
166 %doc README.txt
167 %attr(755,root,root) %{_bindir}/audacity
168 %dir %{_datadir}/%{name}
169 %{_datadir}/%{name}/nyquist
170 %{_datadir}/%{name}/plug-ins
171 %{_datadir}/%{name}/EQDefaultCurves.xml
172 %doc %{_datadir}/%{name}/help
173 %{_mandir}/man1/audacity.1*
174 %{_desktopdir}/audacity.desktop
175 %{_pixmapsdir}/audacity-icon.png
176 %{_datadir}/mime/packages/audacity.xml
177 %{_iconsdir}/hicolor/*/apps/audacity.png
178 %{_iconsdir}/hicolor/*/apps/audacity.svg
This page took 0.092233 seconds and 4 git commands to generate.