]> git.pld-linux.org Git - packages/audacity.git/blob - audacity.spec
- versioned install time lilv,suil dependencies (non-versioned are autodetected btw)
[packages/audacity.git] / audacity.spec
1 # TODO:
2 # - internal portaudio crashes when only OSS is available on startup
3 # - use system portaudio (>= 19, but relies on local changes)
4 # - use system portSMF?
5 # - use system ffmpeg (libavcodec >= 51.53, libavformat >= 52.12, libavutil)
6 # - use system sbsms (>= 1.6.0, but relies on local changes)
7 # - use system libnyquist (if ever; currently it's a part of audacity project)
8 #
9 # Conditional build:
10 %bcond_with     ffmpeg          # build with ffmpeg support (currently audacity does not support ffmpeg 1.0)
11 %bcond_with     gtk3            # GTK+ 3.x instead of 2.x
12 #
13 Summary:        Audacity - manipulate digital audio waveforms
14 Summary(pl.UTF-8):      Audacity - narzędzie do obróbki plików dźwiękowych
15 Summary(ru.UTF-8):      Кроссплатформенный звуковой редактор
16 Name:           audacity
17 Version:        2.1.1
18 Release:        2
19 License:        GPL v2+
20 Group:          X11/Applications/Sound
21 #Source0Download: http://www.oldfoss.com/Audacity.html
22 Source0:        http://app.oldfoss.com:81/download/Audacity/%{name}-minsrc-%{version}.tar.xz
23 # Source0-md5:  9e37b1f5cde38d089a35febb904a9e39
24 Source1:        http://app.oldfoss.com:81/download/Audacity/%{name}-manual-%{version}.zip
25 # Source1-md5:  a4116a20798b827cd1e06e50c8099aa6
26 Source2:        %{name}.desktop
27 Source3:        %{name}-icon.png
28 Patch0:         %{name}-cast.patch
29 Patch1:         %{name}-opt.patch
30 Patch2:         %{name}-no-macos.patch
31 URL:            http://audacityteam.org/
32 BuildRequires:  alsa-lib-devel
33 BuildRequires:  autoconf >= 2.59
34 BuildRequires:  automake >= 1:1.9
35 BuildRequires:  expat-devel >= 1.95
36 # libavcodec >= 51.53 libavformat >= 52.12 libavutil
37 %{?with_ffmpeg:BuildRequires:   ffmpeg-devel >= 0.8.0}
38 BuildRequires:  flac-c++-devel >= 1.3.0
39 BuildRequires:  gettext-tools >= 0.18
40 %{!?with_gtk3:BuildRequires:    gtk+2-devel >= 2.0}
41 %{?with_gtk3:BuildRequires:     gtk+3-devel >= 3.0}
42 BuildRequires:  jack-audio-connection-kit-devel
43 BuildRequires:  hpklinux-devel >= 4.06
44 BuildRequires:  lame-libs-devel
45 BuildRequires:  libid3tag-devel >= 0.15.0b-2
46 BuildRequires:  libjpeg-devel
47 BuildRequires:  libmad-devel >= 0.14.2b-4
48 #BuildRequires: libsbsms-devel >= 1.6.0
49 #BuildRequires: libsbsms2-devel >= 2.0.2
50 BuildRequires:  libsndfile-devel >= 1.0.0
51 BuildRequires:  libstdc++-devel
52 BuildRequires:  libtool >= 2:2
53 BuildRequires:  libvorbis-devel >= 1:1.0
54 BuildRequires:  lilv-devel >= 0.16
55 BuildRequires:  lv2-devel
56 #BuildRequires: portaudio-devel >= 19
57 BuildRequires:  pkgconfig
58 BuildRequires:  soundtouch-devel >= 1.3.0
59 BuildRequires:  soxr-devel >= 0.0.5
60 BuildRequires:  speex-devel
61 BuildRequires:  suil-devel >= 0.8.2
62 BuildRequires:  twolame-devel >= 0.3.9
63 BuildRequires:  udev-devel
64 BuildRequires:  unzip
65 BuildRequires:  vamp-devel >= 2.0
66 BuildRequires:  which
67 %{!?with_gtk3:BuildRequires:    wxGTK2-unicode-devel >= 2.8.0}
68 %{?with_gtk3:BuildRequires:     wxGTK3-unicode-devel >= 2.8.0}
69 Requires(post,postun):  shared-mime-info
70 Requires:       flac-c++ >= 1.3.0
71 # dlopened
72 Requires:       lame-libs
73 Requires:       libid3tag >= 0.15.0b-2
74 Requires:       libmad >= 0.14.2b-4
75 Requires:       libsndfile >= 1.0.0
76 Requires:       lilv >= 0.16
77 Requires:       soundtouch >= 1.3.0
78 %{?with_soxr:Requires:  soxr >= 0.0.5}
79 Requires:       suil >= 0.8.2
80 Requires:       twolame-libs >= 0.3.9
81 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
82
83 %description
84 Audacity is a program that lets you manipulate digital audio
85 waveforms. It imports many sound file formats, including WAV, AIFF,
86 AU, IRCAM, MP3, and Ogg Vorbis. It supports all common editing
87 operations such as Cut, Copy, and Paste, plus it will mix tracks and
88 let you apply plug-in effects to any part of a sound.
89
90 %description -l pl.UTF-8
91 Audacity to program obsługujący różne formaty plików audio. Obsługuje
92 WAV, AIFF, AU, IRCAM, MP3, oraz Ogg Vorbis. Program ten umożliwia
93 wykonywanie podstawowych czynności edycyjnych takich jak kasowanie,
94 wstawianie i miksowanie ścieżki dźwiękowej. Umożliwia także
95 wykonywanie dowolnych innych operacji poprzez system wtyczek.
96
97 %description -l ru.UTF-8
98 Audacity - это звуковой редактор, позволяющий работать с файлами в
99 форматах WAV, AIFF, AU, IRCAM, MP3 и Ogg Vorbis. В нем реализованы все
100 основные операции, такие как удаление, копирование, вставка,
101 микширование треков и применение эффектов, оформленных в виде
102 плагинов, к любой части звукового файла.
103
104 %package devel
105 Summary:        Header files for Audacity interfaces
106 Summary(pl.UTF-8):      Pliki nagłówkowe interfejsów Audacity
107 Group:          Development/Libraries
108 Requires:       libstdc++-devel
109 Requires:       wxWidgets-devel >= 2.8.0
110 # doesn't require base
111
112 %description devel
113 Header files for Audacity interfaces.
114
115 %description devel -l pl.UTF-8
116 Pliki nagłówkowe interfejsów Audacity.
117
118 %prep
119 %setup -q -n %{name}-minsrc-%{version}
120 %patch0 -p1
121 %patch1 -p1
122 %patch2 -p1
123
124 # OPTIONAL_SUBDIRS are not included in tarball; allow autotools to work
125 %{__sed} -i '/SUBDIRS += \$(OPTIONAL_SUBDIRS)/d' lib-src/Makefile.am
126
127 %{__sed} -i 's/libmp3lame.so/libmp3lame.so.0/g' locale/*.po
128
129 %build
130 cd lib-src/portmixer
131 %{__libtoolize}
132 %{__aclocal} -I m4
133 %{__autoconf}
134 %{__automake}
135 cd ../lib-widget-extra
136 %{__libtoolize}
137 %{__aclocal} -I m4
138 %{__autoconf}
139 %{__automake}
140 cd ../FileDialog
141 %{__libtoolize}
142 %{__aclocal} -I m4
143 %{__autoconf}
144 %{__automake}
145 cd ../portsmf
146 %{__aclocal} -I autotools/m4
147 %{__autoconf}
148 %{__automake}
149 cd ../..
150 %{__libtoolize}
151 %{__aclocal} -I m4
152 %{__autoconf}
153 %{__automake}
154
155 export WX_CONFIG=$(which wx-gtk%{?with_gtk3:3}%{!?with_gtk3:2}-unicode-config)
156 %configure \
157         %{?with_gtk3:--enable-gtk3} \
158         --with-ffmpeg%{!?with_ffmpeg:=no} \
159         --with-help \
160         --with-id3tag=system \
161         --with-libmad=system \
162         --with-libsndfile=system \
163         --with-libflac=system \
164         --with-sbsms=local \
165         --with-soxr=system \
166         --with-vorbis=system
167
168 %{__make}
169
170 %install
171 rm -rf $RPM_BUILD_ROOT
172 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
173
174 %{__make} install \
175         DESTDIR=$RPM_BUILD_ROOT \
176         INSTALL_PATH=$RPM_BUILD_ROOT
177
178 # install headers in standard location
179 install -d $RPM_BUILD_ROOT%{_includedir}
180 %{__mv} $RPM_BUILD_ROOT%{_datadir}/audacity/include/audacity $RPM_BUILD_ROOT%{_includedir}
181 rmdir $RPM_BUILD_ROOT%{_datadir}/audacity/include
182
183 cp -a %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
184 cp -a %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}
185 %{__unzip} -qq -a %{SOURCE1} -d $RPM_BUILD_ROOT%{_datadir}/%{name}/help
186
187 # unify locale names
188 %{__mv} $RPM_BUILD_ROOT%{_datadir}/locale/{ca_ES@valencia,ca@valencia}
189 %{__mv} $RPM_BUILD_ROOT%{_datadir}/locale/{sr_RS,sr}
190 %{__mv} $RPM_BUILD_ROOT%{_datadir}/locale/{sr_RS@latin,sr@latin}
191 %{__mv} $RPM_BUILD_ROOT%{_datadir}/locale/{zh,zh_CN}
192
193 %{__rm} $RPM_BUILD_ROOT%{_datadir}/pixmaps/audacity.xpm
194 %{__rm} $RPM_BUILD_ROOT%{_datadir}/pixmaps/audacity16.xpm
195 %{__rm} $RPM_BUILD_ROOT%{_datadir}/pixmaps/audacity32.xpm
196 %{__rm} $RPM_BUILD_ROOT%{_datadir}/pixmaps/gnome-mime-application-x-audacity-project.xpm
197
198 %find_lang %{name}
199
200 %clean
201 rm -rf $RPM_BUILD_ROOT
202
203 %post
204 %update_mime_database
205
206 %postun
207 %update_mime_database
208
209 %files -f %{name}.lang
210 %defattr(644,root,root,755)
211 %doc README.txt
212 %attr(755,root,root) %{_bindir}/audacity
213 %dir %{_datadir}/%{name}
214 %{_datadir}/%{name}/nyquist
215 %{_datadir}/%{name}/plug-ins
216 %{_datadir}/%{name}/EQDefaultCurves.xml
217 %doc %{_datadir}/%{name}/help
218 %{_mandir}/man1/audacity.1*
219 %{_desktopdir}/audacity.desktop
220 %{_pixmapsdir}/audacity-icon.png
221 %{_datadir}/appdata/audacity.appdata.xml
222 %{_datadir}/mime/packages/audacity.xml
223 %{_iconsdir}/hicolor/*/apps/audacity.png
224 %{_iconsdir}/hicolor/*/apps/audacity.svg
225
226 %files devel
227 %defattr(644,root,root,755)
228 %{_includedir}/audacity
This page took 0.048312 seconds and 4 git commands to generate.