]> git.pld-linux.org Git - packages/audacity.git/blob - audacity.spec
- wxWidgets rebuild
[packages/audacity.git] / audacity.spec
1 # TODO:
2 # - internal portaudio crashes when only OSS is available on startup
3 # - use system portaudio (>= 19, but relies on local changes)
4 # - use system portSMF?
5 # - use system ffmpeg (libavcodec >= 51.53, libavformat >= 52.12), libavutil
6 # - use system sbsms (>= 1.6.0, but relies on local changes)
7 # - use system libnyquist (if ever; currently it's a part of audacity project)
8 #
9 # Conditional build:
10 %bcond_with     libresample     # using libresample for resampling (default is soxr)
11 %bcond_with     libsamplerate   # using libsamplerate for resampling (default is soxr)
12 %bcond_with     ffmpeg          # build with ffmpeg support (currently audacity does not support ffmpeg 1.0)
13 #
14 %if %{without libresample} && %{without libsamplerate}
15 %define with_soxr       1
16 %endif
17 Summary:        Audacity - manipulate digital audio waveforms
18 Summary(pl.UTF-8):      Audacity - narzędzie do obróbki plików dźwiękowych
19 Summary(ru.UTF-8):      Кроссплатформенный звуковой редактор
20 Name:           audacity
21 Version:        2.0.5
22 Release:        2
23 License:        GPL v2+
24 Group:          X11/Applications/Sound
25 #Source0Download: http://code.google.com/p/audacity/downloads/list
26 Source0:        http://audacity.googlecode.com/files/%{name}-minsrc-%{version}.tar.xz
27 # Source0-md5:  657f71a5a214fe84731ed9842e09fa04
28 # Link from http://manual.audacityteam.org/index.php?title=Main_Page
29 Source1:        http://audacity.googlecode.com/files/%{name}-manual-%{version}.zip
30 # Source1-md5:  9f0b9db3f37aa4b9455a4b4e2046e1e4
31 Source2:        %{name}.desktop
32 Source3:        %{name}-icon.png
33 Patch0:         %{name}-system-libs.patch
34 Patch1:         %{name}-opt.patch
35 Patch2:         %{name}-no-macos.patch
36 URL:            http://audacity.sourceforge.net/
37 BuildRequires:  alsa-lib-devel
38 BuildRequires:  autoconf >= 2.59
39 BuildRequires:  automake
40 BuildRequires:  expat-devel >= 1.95
41 %{?with_ffmpeg:BuildRequires:   ffmpeg-devel >= 0.8.0}
42 BuildRequires:  flac-c++-devel >= 1.2.0
43 BuildRequires:  gettext-devel
44 BuildRequires:  gtk+2-devel >= 2.0
45 BuildRequires:  jack-audio-connection-kit-devel
46 BuildRequires:  hpklinux-devel >= 4.06
47 BuildRequires:  lame-libs-devel
48 BuildRequires:  libid3tag-devel >= 0.15.0b-2
49 BuildRequires:  libjpeg-devel
50 BuildRequires:  libmad-devel >= 0.14.2b-4
51 %{?with_libresample:BuildRequires:      libresample-devel >= 0.1.3}
52 %{?with_libsamplerate:BuildRequires:    libsamplerate-devel >= 0.1.2}
53 #BuildRequires: libsbsms-devel >= 1.6.0
54 BuildRequires:  libsndfile-devel >= 1.0.0
55 BuildRequires:  libstdc++-devel
56 BuildRequires:  libvorbis-devel >= 1:1.0
57 #BuildRequires: portaudio-devel >= 19
58 BuildRequires:  pkgconfig
59 BuildRequires:  soundtouch-devel >= 1.3.0
60 %{?with_soxr:BuildRequires:     soxr-devel >= 0.0.5}
61 BuildRequires:  speex-devel
62 BuildRequires:  twolame-devel >= 0.3.9
63 BuildRequires:  unzip
64 BuildRequires:  vamp-devel >= 2.0
65 BuildRequires:  which
66 BuildRequires:  wxGTK2-unicode-devel >= 2.8.0
67 Requires(post,postun):  shared-mime-info
68 Requires:       flac-c++ >= 1.2.0
69 Requires:       lame-libs
70 Requires:       libid3tag >= 0.15.0b-2
71 Requires:       libmad >= 0.14.2b-4
72 %{?with_libresample:Requires:   libresample >= 0.1.3}
73 %{?with_libsamplerate:Requires: libsamplerate >= 0.1.2}
74 Requires:       libsndfile >= 1.0.0
75 Requires:       soundtouch >= 1.3.0
76 %{?with_soxr:Requires:  soxr >= 0.0.5}
77 Requires:       twolame-libs >= 0.3.9
78 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
79
80 %description
81 Audacity is a program that lets you manipulate digital audio
82 waveforms. It imports many sound file formats, including WAV, AIFF,
83 AU, IRCAM, MP3, and Ogg Vorbis. It supports all common editing
84 operations such as Cut, Copy, and Paste, plus it will mix tracks and
85 let you apply plug-in effects to any part of a sound.
86
87 %description -l pl.UTF-8
88 Audacity to program obsługujący różne formaty plików audio. Obsługuje
89 WAV, AIFF, AU, IRCAM, MP3, oraz Ogg Vorbis. Program ten umożliwia
90 wykonywanie podstawowych czynności edycyjnych takich jak kasowanie,
91 wstawianie i miksowanie ścieżki dźwiękowej. Umożliwia także
92 wykonywanie dowolnych innych operacji poprzez system wtyczek.
93
94 %description -l ru.UTF-8
95 Audacity - это звуковой редактор, позволяющий работать с файлами в
96 форматах WAV, AIFF, AU, IRCAM, MP3 и Ogg Vorbis. В нем реализованы все
97 основные операции, такие как удаление, копирование, вставка,
98 микширование треков и применение эффектов, оформленных в виде
99 плагинов, к любой части звукового файла.
100
101 %prep
102 %setup -q -n %{name}-src-%{version}
103 %patch0 -p1
104 %patch1 -p1
105 %patch2 -p1
106
107 %{__sed} -i 's/libmp3lame.so/libmp3lame.so.0/g' locale/*.po
108
109 %build
110 cd lib-src/portmixer
111 %{__autoconf}
112 cd ../portsmf
113 %{__aclocal} -I autotools/m4
114 %{__autoconf}
115 %{__automake}
116 cd ../..
117 %{__aclocal} -I m4
118 %{__autoconf}
119
120 export WX_CONFIG=$(which wx-gtk2-unicode-config)
121 %configure \
122         --with-ffmpeg%{!?with_ffmpeg:=no} \
123         --with-help \
124         --with-id3tag=system \
125         --with-libmad=system \
126         %{?with_libresample:--with-libresample=system} \
127         %{?with_libsamplerate:--with-libsamplerate=system} \
128         --with-libsndfile=system \
129         --with-libflac=system \
130         --with-sbsms=local \
131         %{?with_soxr:--with-soxr=system} \
132         --with-vorbis=system
133
134 %{__make}
135
136 %install
137 rm -rf $RPM_BUILD_ROOT
138 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
139
140 %{__make} install \
141         DESTDIR=$RPM_BUILD_ROOT \
142         INSTALL_PATH=$RPM_BUILD_ROOT
143
144 cp -a %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
145 cp -a %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}
146 %{__unzip} -qq -a %{SOURCE1} -d $RPM_BUILD_ROOT%{_datadir}/%{name}/help
147
148 # unsupported
149 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/locale/sr_RS*
150
151 mv -f $RPM_BUILD_ROOT%{_datadir}/locale/{zh,zh_CN}
152
153 %{__rm} $RPM_BUILD_ROOT%{_datadir}/pixmaps/audacity.xpm
154 %{__rm} $RPM_BUILD_ROOT%{_datadir}/pixmaps/audacity16.xpm
155 %{__rm} $RPM_BUILD_ROOT%{_datadir}/pixmaps/audacity32.xpm
156 %{__rm} $RPM_BUILD_ROOT%{_datadir}/pixmaps/gnome-mime-application-x-audacity-project.xpm
157
158 %find_lang %{name}
159
160 %clean
161 rm -rf $RPM_BUILD_ROOT
162
163 %post
164 %update_mime_database
165
166 %postun
167 %update_mime_database
168
169 %files -f %{name}.lang
170 %defattr(644,root,root,755)
171 %doc README.txt
172 %attr(755,root,root) %{_bindir}/audacity
173 %dir %{_datadir}/%{name}
174 %{_datadir}/%{name}/nyquist
175 %{_datadir}/%{name}/plug-ins
176 %{_datadir}/%{name}/EQDefaultCurves.xml
177 %doc %{_datadir}/%{name}/help
178 %{_mandir}/man1/audacity.1*
179 %{_desktopdir}/audacity.desktop
180 %{_pixmapsdir}/audacity-icon.png
181 %{_datadir}/mime/packages/audacity.xml
182 %{_iconsdir}/hicolor/*/apps/audacity.png
183 %{_iconsdir}/hicolor/*/apps/audacity.svg
This page took 0.336023 seconds and 4 git commands to generate.