]> git.pld-linux.org Git - packages/audacity.git/blob - audacity.spec
- download URL
[packages/audacity.git] / audacity.spec
1 # TODO:
2 # - internal portaudio crashes when only OSS is available on startup
3 # - use system vamp (vamp-hostsdk >= 2.0)
4 # - use system ffmpeg (libavcodec >= 51.53, libavformat >= 52.12)
5 # - use system sbsms (>= 1.6.0)
6 #
7 # Conditional build:
8 %bcond_with     libresample     # using libresample (default libsamplerate)
9 #
10 Summary:        Audacity - manipulate digital audio waveforms
11 Summary(pl.UTF-8):      Audacity - narzędzie do obróbki plików dźwiękowych
12 Summary(ru.UTF-8):      Кроссплатформенный звуковой редактор
13 Name:           audacity
14 Version:        1.3.12
15 Release:        1
16 License:        GPL v2
17 Group:          X11/Applications/Sound
18 #Source0Download: http://code.google.com/p/audacity/downloads/list
19 Source0:        http://audacity.googlecode.com/files/%{name}-minsrc-%{version}-beta.tar.bz2
20 # Source0-md5:  76996fec67181ca82ba191e012518b57
21 # Link from http://manual.audacityteam.org/index.php?title=Main_Page
22 Source1:        http://manual.audacityteam.org/help.zip
23 # Source1-md5:  2043778cfd3c7df9b3774526e123d6d8
24 Source2:        %{name}.desktop
25 Source3:        %{name}-icon.png
26 Patch0:         %{name}-system-libs.patch
27 Patch1:         %{name}-opt.patch
28 Patch2:         %{name}-no-macos.patch
29 URL:            http://audacity.sourceforge.net/
30 BuildRequires:  autoconf >= 2.59
31 BuildRequires:  automake
32 BuildRequires:  expat-devel >= 1.95
33 BuildRequires:  flac-c++-devel >= 1.2.0
34 BuildRequires:  gettext-devel
35 BuildRequires:  libid3tag-devel >= 0.15.0b-2
36 BuildRequires:  libjpeg-devel
37 BuildRequires:  libmad-devel >= 0.14.2b-4
38 %{?with_libresample:BuildRequires:      libresample-devel >= 0.1.3}
39 %{!?with_libresample:BuildRequires:     libsamplerate-devel >= 0.1.2}
40 BuildRequires:  libsndfile-devel >= 1.0.0
41 BuildRequires:  libstdc++-devel
42 BuildRequires:  libvorbis-devel >= 1:1.0
43 BuildRequires:  pkgconfig
44 BuildRequires:  soundtouch-devel >= 1.3.0
45 BuildRequires:  speex-devel
46 BuildRequires:  twolame-devel >= 0.3.9
47 BuildRequires:  unzip
48 BuildRequires:  which
49 BuildRequires:  wxGTK2-unicode-devel >= 2.8.0
50 Requires(post,postun):  shared-mime-info
51 Requires:       flac-c++ >= 1.2.0
52 Requires:       lame-libs
53 Requires:       libid3tag >= 0.15.0b-2
54 Requires:       libmad >= 0.14.2b-4
55 %{?with_libresample:Requires:   libresample >= 0.1.3}
56 %{!?with_libresample:Requires:  libsamplerate >= 0.1.2}
57 Requires:       libsndfile >= 1.0.0
58 Requires:       soundtouch >= 1.3.0
59 Requires:       twolame-libs >= 0.3.9
60 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
61
62 %description
63 Audacity is a program that lets you manipulate digital audio
64 waveforms. It imports many sound file formats, including WAV, AIFF,
65 AU, IRCAM, MP3, and Ogg Vorbis. It supports all common editing
66 operations such as Cut, Copy, and Paste, plus it will mix tracks and
67 let you apply plug-in effects to any part of a sound.
68
69 %description -l pl.UTF-8
70 Audacity to program obsługujący różne formaty plików audio. Obsługuje
71 WAV, AIFF, AU, IRCAM, MP3, oraz Ogg Vorbis. Program ten umożliwia
72 wykonywanie podstawowych czynności edycyjnych takich jak kasowanie,
73 wstawianie i miksowanie ścieżki dźwiękowej. Umożliwia także
74 wykonywanie dowolnych innych operacji poprzez system wtyczek.
75
76 %description -l ru.UTF-8
77 Audacity - это звуковой редактор, позволяющий работать с файлами в
78 форматах WAV, AIFF, AU, IRCAM, MP3 и Ogg Vorbis. В нем реализованы все
79 основные операции, такие как удаление, копирование, вставка,
80 микширование треков и применение эффектов, оформленных в виде
81 плагинов, к любой части звукового файла.
82
83 %prep
84 %setup -q -n %{name}-src-%{version}-beta
85 %patch0 -p1
86 %patch1 -p1
87 %patch2 -p1
88
89 sed -i 's/libmp3lame.so/libmp3lame.so.0/g' locale/*.po
90
91 %build
92 cd lib-src/portmixer
93 %{__autoconf}
94 cd ../portsmf
95 %{__aclocal} -I autotools/m4
96 %{__autoconf}
97 cd ../..
98 %{__aclocal} -I m4
99 %{__autoconf}
100
101 export WX_CONFIG=$(which wx-gtk2-unicode-config)
102 %configure \
103 %if %{with libresample}
104         --with-libresample=system \
105 %else
106         --with-libresample=no \
107         --with-libsamplerate=system \
108 %endif
109         --with-help \
110         --with-id3tag=system \
111         --with-libmad=system \
112         --with-libsndfile=system \
113         --with-libflac=system \
114         --with-vorbis=system
115
116 %{__make}
117
118 %install
119 rm -rf $RPM_BUILD_ROOT
120 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
121
122 %{__make} install \
123         DESTDIR=$RPM_BUILD_ROOT \
124         INSTALL_PATH=$RPM_BUILD_ROOT
125
126 cp -a %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
127 cp -a %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}
128 %{__unzip} -qq -a %{SOURCE1} -d $RPM_BUILD_ROOT%{_datadir}/%{name}/help
129
130 mv -f $RPM_BUILD_ROOT%{_datadir}/locale/{zh,zh_CN}
131 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
132
133 %{__rm} $RPM_BUILD_ROOT%{_datadir}/pixmaps/audacity.xpm
134 %{__rm} $RPM_BUILD_ROOT%{_datadir}/pixmaps/audacity16.xpm
135 %{__rm} $RPM_BUILD_ROOT%{_datadir}/pixmaps/audacity32.xpm
136 %{__rm} $RPM_BUILD_ROOT%{_datadir}/pixmaps/gnome-mime-application-x-audacity-project.xpm
137
138 %find_lang %{name}
139
140 %clean
141 rm -rf $RPM_BUILD_ROOT
142
143 %post
144 %update_mime_database
145
146 %postun
147 %update_mime_database
148
149 %files -f %{name}.lang
150 %defattr(644,root,root,755)
151 %doc README.txt
152 %attr(755,root,root) %{_bindir}/audacity
153 %dir %{_datadir}/%{name}
154 %{_datadir}/%{name}/nyquist
155 %{_datadir}/%{name}/plug-ins
156 %doc %{_datadir}/%{name}/help
157 %{_mandir}/man1/audacity.1*
158 %{_desktopdir}/audacity.desktop
159 %{_pixmapsdir}/audacity-icon.png
160 %{_datadir}/mime/packages/audacity.xml
161 %{_iconsdir}/hicolor/*/apps/audacity.png
162 %{_iconsdir}/hicolor/*/apps/audacity.svg
This page took 0.110323 seconds and 4 git commands to generate.