]> git.pld-linux.org Git - packages/audacity.git/blob - audacity.spec
- updated to 2.0.3
[packages/audacity.git] / audacity.spec
1 # TODO:
2 # - internal portaudio crashes when only OSS is available on startup
3 # - use system portaudio (>= 19, but relies on local changes)
4 # - use system portSMF?
5 # - use system ffmpeg (libavcodec >= 51.53, libavformat >= 52.12)
6 # - use system sbsms (>= 1.6.0, but relies on local changes)
7 #
8 # Conditional build:
9 %bcond_with     libresample     # using libresample (default libsamplerate)
10 %bcond_with     ffmpeg          # build with ffmpeg support (currently audacity does not support ffmpeg 1.0)
11 #
12 Summary:        Audacity - manipulate digital audio waveforms
13 Summary(pl.UTF-8):      Audacity - narzędzie do obróbki plików dźwiękowych
14 Summary(ru.UTF-8):      Кроссплатформенный звуковой редактор
15 Name:           audacity
16 Version:        2.0.3
17 Release:        1
18 License:        GPL v2+
19 Group:          X11/Applications/Sound
20 #Source0Download: http://code.google.com/p/audacity/downloads/list
21 Source0:        http://audacity.googlecode.com/files/%{name}-minsrc-%{version}.tar.xz
22 # Source0-md5:  648cce8a9ce86eebfc53921172ee9d89
23 # Link from http://manual.audacityteam.org/index.php?title=Main_Page
24 Source1:        http://audacity.googlecode.com/files/%{name}-manual-%{version}.zip
25 # Source1-md5:  e11a2b16ec3234b4fdab0a4d396b9def
26 Source2:        %{name}.desktop
27 Source3:        %{name}-icon.png
28 Patch0:         %{name}-system-libs.patch
29 Patch1:         %{name}-opt.patch
30 Patch2:         %{name}-no-macos.patch
31 # modified from http://audioscience.com/internet/download/drivers/released/v4/06/portaudio_asihpi_406.patch
32 Patch3:         portaudio_asihpi_406.patch
33 URL:            http://audacity.sourceforge.net/
34 BuildRequires:  autoconf >= 2.59
35 BuildRequires:  automake
36 BuildRequires:  expat-devel >= 1.95
37 %{?with_ffmpeg:BuildRequires:   ffmpeg-devel >= 0.8.0}
38 BuildRequires:  flac-c++-devel >= 1.2.0
39 BuildRequires:  gettext-devel
40 BuildRequires:  hpklinux-devel >= 4.06
41 BuildRequires:  libid3tag-devel >= 0.15.0b-2
42 BuildRequires:  libjpeg-devel
43 BuildRequires:  libmad-devel >= 0.14.2b-4
44 %{?with_libresample:BuildRequires:      libresample-devel >= 0.1.3}
45 %{!?with_libresample:BuildRequires:     libsamplerate-devel >= 0.1.2}
46 #BuildRequires: libsbsms-devel >= 1.6.0
47 BuildRequires:  libsndfile-devel >= 1.0.0
48 BuildRequires:  libstdc++-devel
49 BuildRequires:  libvorbis-devel >= 1:1.0
50 #BuildRequires: portaudio-devel >= 19
51 BuildRequires:  pkgconfig
52 BuildRequires:  soundtouch-devel >= 1.3.0
53 BuildRequires:  speex-devel
54 BuildRequires:  twolame-devel >= 0.3.9
55 BuildRequires:  unzip
56 BuildRequires:  vamp-devel >= 2.0
57 BuildRequires:  which
58 BuildRequires:  wxGTK2-unicode-devel >= 2.8.0
59 Requires(post,postun):  shared-mime-info
60 Requires:       flac-c++ >= 1.2.0
61 Requires:       lame-libs
62 Requires:       libid3tag >= 0.15.0b-2
63 Requires:       libmad >= 0.14.2b-4
64 %{?with_libresample:Requires:   libresample >= 0.1.3}
65 %{!?with_libresample:Requires:  libsamplerate >= 0.1.2}
66 Requires:       libsndfile >= 1.0.0
67 Requires:       soundtouch >= 1.3.0
68 Requires:       twolame-libs >= 0.3.9
69 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
70
71 %description
72 Audacity is a program that lets you manipulate digital audio
73 waveforms. It imports many sound file formats, including WAV, AIFF,
74 AU, IRCAM, MP3, and Ogg Vorbis. It supports all common editing
75 operations such as Cut, Copy, and Paste, plus it will mix tracks and
76 let you apply plug-in effects to any part of a sound.
77
78 %description -l pl.UTF-8
79 Audacity to program obsługujący różne formaty plików audio. Obsługuje
80 WAV, AIFF, AU, IRCAM, MP3, oraz Ogg Vorbis. Program ten umożliwia
81 wykonywanie podstawowych czynności edycyjnych takich jak kasowanie,
82 wstawianie i miksowanie ścieżki dźwiękowej. Umożliwia także
83 wykonywanie dowolnych innych operacji poprzez system wtyczek.
84
85 %description -l ru.UTF-8
86 Audacity - это звуковой редактор, позволяющий работать с файлами в
87 форматах WAV, AIFF, AU, IRCAM, MP3 и Ogg Vorbis. В нем реализованы все
88 основные операции, такие как удаление, копирование, вставка,
89 микширование треков и применение эффектов, оформленных в виде
90 плагинов, к любой части звукового файла.
91
92 %prep
93 %setup -q -n %{name}-src-%{version}
94 %patch0 -p1
95 %patch1 -p1
96 %patch2 -p1
97 cd lib-src/portaudio-v19
98 %patch3 -p0
99 cd ../..
100
101 %{__sed} -i 's/libmp3lame.so/libmp3lame.so.0/g' locale/*.po
102
103 %build
104 cd lib-src/portmixer
105 %{__autoconf}
106 cd ../portsmf
107 %{__aclocal} -I autotools/m4
108 %{__autoconf}
109 cd ../..
110 %{__aclocal} -I m4
111 %{__autoconf}
112
113 export WX_CONFIG=$(which wx-gtk2-unicode-config)
114 %configure \
115 %if %{with libresample}
116         --with-libresample=system \
117 %else
118         --with-libresample=no \
119         --with-libsamplerate=system \
120 %endif
121         --with%{!?with_ffmpeg:out}-ffmpeg \
122         --with-help \
123         --with-id3tag=system \
124         --with-libmad=system \
125         --with-libsndfile=system \
126         --with-libflac=system \
127         --with-sbsms=local \
128         --with-vorbis=system
129
130 %{__make}
131
132 %install
133 rm -rf $RPM_BUILD_ROOT
134 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
135
136 %{__make} install \
137         DESTDIR=$RPM_BUILD_ROOT \
138         INSTALL_PATH=$RPM_BUILD_ROOT
139
140 cp -a %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
141 cp -a %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}
142 %{__unzip} -qq -a %{SOURCE1} -d $RPM_BUILD_ROOT%{_datadir}/%{name}/help
143
144 # unsupported
145 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/locale/sr_RS*
146
147 mv -f $RPM_BUILD_ROOT%{_datadir}/locale/{zh,zh_CN}
148
149 %{__rm} $RPM_BUILD_ROOT%{_datadir}/pixmaps/audacity.xpm
150 %{__rm} $RPM_BUILD_ROOT%{_datadir}/pixmaps/audacity16.xpm
151 %{__rm} $RPM_BUILD_ROOT%{_datadir}/pixmaps/audacity32.xpm
152 %{__rm} $RPM_BUILD_ROOT%{_datadir}/pixmaps/gnome-mime-application-x-audacity-project.xpm
153
154 %find_lang %{name}
155
156 %clean
157 rm -rf $RPM_BUILD_ROOT
158
159 %post
160 %update_mime_database
161
162 %postun
163 %update_mime_database
164
165 %files -f %{name}.lang
166 %defattr(644,root,root,755)
167 %doc README.txt
168 %attr(755,root,root) %{_bindir}/audacity
169 %dir %{_datadir}/%{name}
170 %{_datadir}/%{name}/nyquist
171 %{_datadir}/%{name}/plug-ins
172 %{_datadir}/%{name}/EQDefaultCurves.xml
173 %doc %{_datadir}/%{name}/help
174 %{_mandir}/man1/audacity.1*
175 %{_desktopdir}/audacity.desktop
176 %{_pixmapsdir}/audacity-icon.png
177 %{_datadir}/mime/packages/audacity.xml
178 %{_iconsdir}/hicolor/*/apps/audacity.png
179 %{_iconsdir}/hicolor/*/apps/audacity.svg
This page took 0.047588 seconds and 4 git commands to generate.