]> git.pld-linux.org Git - packages/audacity.git/blob - audacity.spec
- finished port to wxWidgets 3.0
[packages/audacity.git] / audacity.spec
1 # TODO:
2 # - internal portaudio crashes when only OSS is available on startup
3 # - use system portaudio (>= 19, but relies on local changes)
4 # - use system portSMF?
5 # - use system ffmpeg (libavcodec >= 51.53, libavformat >= 52.12), libavutil
6 # - use system sbsms (>= 1.6.0, but relies on local changes)
7 # - use system libnyquist (if ever; currently it's a part of audacity project)
8 #
9 # Conditional build:
10 %bcond_with     libresample     # using libresample for resampling (default is soxr)
11 %bcond_with     libsamplerate   # using libsamplerate for resampling (default is soxr)
12 %bcond_with     ffmpeg          # build with ffmpeg support (currently audacity does not support ffmpeg 1.0)
13 #
14 %if %{without libresample} && %{without libsamplerate}
15 %define with_soxr       1
16 %endif
17 Summary:        Audacity - manipulate digital audio waveforms
18 Summary(pl.UTF-8):      Audacity - narzędzie do obróbki plików dźwiękowych
19 Summary(ru.UTF-8):      Кроссплатформенный звуковой редактор
20 Name:           audacity
21 Version:        2.0.5
22 Release:        3
23 License:        GPL v2+
24 Group:          X11/Applications/Sound
25 #Source0Download: http://code.google.com/p/audacity/downloads/list
26 Source0:        http://audacity.googlecode.com/files/%{name}-minsrc-%{version}.tar.xz
27 # Source0-md5:  657f71a5a214fe84731ed9842e09fa04
28 # Link from http://manual.audacityteam.org/index.php?title=Main_Page
29 Source1:        http://audacity.googlecode.com/files/%{name}-manual-%{version}.zip
30 # Source1-md5:  9f0b9db3f37aa4b9455a4b4e2046e1e4
31 Source2:        %{name}.desktop
32 Source3:        %{name}-icon.png
33 Patch0:         %{name}-system-libs.patch
34 Patch1:         %{name}-opt.patch
35 Patch2:         %{name}-no-macos.patch
36 Patch3:         %{name}-wx.patch
37 URL:            http://audacity.sourceforge.net/
38 BuildRequires:  alsa-lib-devel
39 BuildRequires:  autoconf >= 2.59
40 BuildRequires:  automake
41 BuildRequires:  expat-devel >= 1.95
42 %{?with_ffmpeg:BuildRequires:   ffmpeg-devel >= 0.8.0}
43 BuildRequires:  flac-c++-devel >= 1.2.0
44 BuildRequires:  gettext-devel
45 BuildRequires:  gtk+2-devel >= 2.0
46 BuildRequires:  jack-audio-connection-kit-devel
47 BuildRequires:  hpklinux-devel >= 4.06
48 BuildRequires:  lame-libs-devel
49 BuildRequires:  libid3tag-devel >= 0.15.0b-2
50 BuildRequires:  libjpeg-devel
51 BuildRequires:  libmad-devel >= 0.14.2b-4
52 %{?with_libresample:BuildRequires:      libresample-devel >= 0.1.3}
53 %{?with_libsamplerate:BuildRequires:    libsamplerate-devel >= 0.1.2}
54 #BuildRequires: libsbsms-devel >= 1.6.0
55 BuildRequires:  libsndfile-devel >= 1.0.0
56 BuildRequires:  libstdc++-devel
57 BuildRequires:  libvorbis-devel >= 1:1.0
58 #BuildRequires: portaudio-devel >= 19
59 BuildRequires:  pkgconfig
60 BuildRequires:  soundtouch-devel >= 1.3.0
61 %{?with_soxr:BuildRequires:     soxr-devel >= 0.0.5}
62 BuildRequires:  speex-devel
63 BuildRequires:  twolame-devel >= 0.3.9
64 BuildRequires:  unzip
65 BuildRequires:  vamp-devel >= 2.0
66 BuildRequires:  which
67 BuildRequires:  wxGTK2-unicode-devel >= 2.8.0
68 BuildRequires:  wxX11-devel >= 2.8.0
69 Requires(post,postun):  shared-mime-info
70 Requires:       flac-c++ >= 1.2.0
71 Requires:       lame-libs
72 Requires:       libid3tag >= 0.15.0b-2
73 Requires:       libmad >= 0.14.2b-4
74 %{?with_libresample:Requires:   libresample >= 0.1.3}
75 %{?with_libsamplerate:Requires: libsamplerate >= 0.1.2}
76 Requires:       libsndfile >= 1.0.0
77 Requires:       soundtouch >= 1.3.0
78 %{?with_soxr:Requires:  soxr >= 0.0.5}
79 Requires:       twolame-libs >= 0.3.9
80 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
81
82 %description
83 Audacity is a program that lets you manipulate digital audio
84 waveforms. It imports many sound file formats, including WAV, AIFF,
85 AU, IRCAM, MP3, and Ogg Vorbis. It supports all common editing
86 operations such as Cut, Copy, and Paste, plus it will mix tracks and
87 let you apply plug-in effects to any part of a sound.
88
89 %description -l pl.UTF-8
90 Audacity to program obsługujący różne formaty plików audio. Obsługuje
91 WAV, AIFF, AU, IRCAM, MP3, oraz Ogg Vorbis. Program ten umożliwia
92 wykonywanie podstawowych czynności edycyjnych takich jak kasowanie,
93 wstawianie i miksowanie ścieżki dźwiękowej. Umożliwia także
94 wykonywanie dowolnych innych operacji poprzez system wtyczek.
95
96 %description -l ru.UTF-8
97 Audacity - это звуковой редактор, позволяющий работать с файлами в
98 форматах WAV, AIFF, AU, IRCAM, MP3 и Ogg Vorbis. В нем реализованы все
99 основные операции, такие как удаление, копирование, вставка,
100 микширование треков и применение эффектов, оформленных в виде
101 плагинов, к любой части звукового файла.
102
103 %prep
104 %setup -q -n %{name}-src-%{version}
105 %patch0 -p1
106 %patch1 -p1
107 %patch2 -p1
108 %patch3 -p1
109
110 %{__sed} -i 's/libmp3lame.so/libmp3lame.so.0/g' locale/*.po
111
112 %build
113 cd lib-src/portmixer
114 %{__autoconf}
115 cd ../lib-widget-extra
116 %{__aclocal} -I m4
117 %{__autoconf}
118 cd ../portsmf
119 %{__aclocal} -I autotools/m4
120 %{__autoconf}
121 %{__automake}
122 cd ../..
123 %{__aclocal} -I m4
124 %{__autoconf}
125
126 export WX_CONFIG=$(which wx-gtk2-unicode-config)
127 %configure \
128         --with-ffmpeg%{!?with_ffmpeg:=no} \
129         --with-help \
130         --with-id3tag=system \
131         --with-libmad=system \
132         %{?with_libresample:--with-libresample=system} \
133         %{?with_libsamplerate:--with-libsamplerate=system} \
134         --with-libsndfile=system \
135         --with-libflac=system \
136         --with-sbsms=local \
137         %{?with_soxr:--with-soxr=system} \
138         --with-vorbis=system
139
140 %{__make}
141
142 %install
143 rm -rf $RPM_BUILD_ROOT
144 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
145
146 %{__make} install \
147         DESTDIR=$RPM_BUILD_ROOT \
148         INSTALL_PATH=$RPM_BUILD_ROOT
149
150 cp -a %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
151 cp -a %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}
152 %{__unzip} -qq -a %{SOURCE1} -d $RPM_BUILD_ROOT%{_datadir}/%{name}/help
153
154 # unsupported
155 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/locale/sr_RS*
156
157 mv -f $RPM_BUILD_ROOT%{_datadir}/locale/{zh,zh_CN}
158
159 %{__rm} $RPM_BUILD_ROOT%{_datadir}/pixmaps/audacity.xpm
160 %{__rm} $RPM_BUILD_ROOT%{_datadir}/pixmaps/audacity16.xpm
161 %{__rm} $RPM_BUILD_ROOT%{_datadir}/pixmaps/audacity32.xpm
162 %{__rm} $RPM_BUILD_ROOT%{_datadir}/pixmaps/gnome-mime-application-x-audacity-project.xpm
163
164 %find_lang %{name}
165
166 %clean
167 rm -rf $RPM_BUILD_ROOT
168
169 %post
170 %update_mime_database
171
172 %postun
173 %update_mime_database
174
175 %files -f %{name}.lang
176 %defattr(644,root,root,755)
177 %doc README.txt
178 %attr(755,root,root) %{_bindir}/audacity
179 %dir %{_datadir}/%{name}
180 %{_datadir}/%{name}/nyquist
181 %{_datadir}/%{name}/plug-ins
182 %{_datadir}/%{name}/EQDefaultCurves.xml
183 %doc %{_datadir}/%{name}/help
184 %{_mandir}/man1/audacity.1*
185 %{_desktopdir}/audacity.desktop
186 %{_pixmapsdir}/audacity-icon.png
187 %{_datadir}/mime/packages/audacity.xml
188 %{_iconsdir}/hicolor/*/apps/audacity.png
189 %{_iconsdir}/hicolor/*/apps/audacity.svg
This page took 0.0843120000000001 seconds and 4 git commands to generate.