]> git.pld-linux.org Git - packages/audacity.git/blob - audacity.spec
- resampling library defaults to soxr now
[packages/audacity.git] / audacity.spec
1 # TODO:
2 # - internal portaudio crashes when only OSS is available on startup
3 # - use system portaudio (>= 19, but relies on local changes)
4 # - use system portSMF?
5 # - use system ffmpeg (libavcodec >= 51.53, libavformat >= 52.12), libavutil
6 # - use system sbsms (>= 1.6.0, but relies on local changes)
7 # - use system libnyquist (if ever; currently it's a part of audacity project)
8 #
9 # Conditional build:
10 %bcond_with     libresample     # using libresample for resampling (default is soxr)
11 %bcond_with     libsamplerate   # using libsamplerate for resampling (default is soxr)
12 %bcond_with     ffmpeg          # build with ffmpeg support (currently audacity does not support ffmpeg 1.0)
13 #
14 %if %{without libresample} && %{without libsamplerate}
15 %define with_soxr       1
16 %endif
17 Summary:        Audacity - manipulate digital audio waveforms
18 Summary(pl.UTF-8):      Audacity - narzędzie do obróbki plików dźwiękowych
19 Summary(ru.UTF-8):      Кроссплатформенный звуковой редактор
20 Name:           audacity
21 Version:        2.0.3
22 Release:        1
23 License:        GPL v2+
24 Group:          X11/Applications/Sound
25 #Source0Download: http://code.google.com/p/audacity/downloads/list
26 Source0:        http://audacity.googlecode.com/files/%{name}-minsrc-%{version}.tar.xz
27 # Source0-md5:  648cce8a9ce86eebfc53921172ee9d89
28 # Link from http://manual.audacityteam.org/index.php?title=Main_Page
29 Source1:        http://audacity.googlecode.com/files/%{name}-manual-%{version}.zip
30 # Source1-md5:  e11a2b16ec3234b4fdab0a4d396b9def
31 Source2:        %{name}.desktop
32 Source3:        %{name}-icon.png
33 Patch0:         %{name}-system-libs.patch
34 Patch1:         %{name}-opt.patch
35 Patch2:         %{name}-no-macos.patch
36 # modified from http://audioscience.com/internet/download/drivers/released/v4/06/portaudio_asihpi_406.patch
37 Patch3:         portaudio_asihpi_406.patch
38 URL:            http://audacity.sourceforge.net/
39 BuildRequires:  alsa-lib-devel
40 BuildRequires:  autoconf >= 2.59
41 BuildRequires:  automake
42 BuildRequires:  expat-devel >= 1.95
43 %{?with_ffmpeg:BuildRequires:   ffmpeg-devel >= 0.8.0}
44 BuildRequires:  flac-c++-devel >= 1.2.0
45 BuildRequires:  gettext-devel
46 BuildRequires:  gtk+2-devel >= 2.0
47 BuildRequires:  jack-audio-connection-kit-devel
48 BuildRequires:  hpklinux-devel >= 4.06
49 BuildRequires:  lame-libs-devel
50 BuildRequires:  libid3tag-devel >= 0.15.0b-2
51 BuildRequires:  libjpeg-devel
52 BuildRequires:  libmad-devel >= 0.14.2b-4
53 %{?with_libresample:BuildRequires:      libresample-devel >= 0.1.3}
54 %{?with_libsamplerate:BuildRequires:    libsamplerate-devel >= 0.1.2}
55 #BuildRequires: libsbsms-devel >= 1.6.0
56 BuildRequires:  libsndfile-devel >= 1.0.0
57 BuildRequires:  libstdc++-devel
58 BuildRequires:  libvorbis-devel >= 1:1.0
59 #BuildRequires: portaudio-devel >= 19
60 BuildRequires:  pkgconfig
61 BuildRequires:  soundtouch-devel >= 1.3.0
62 %{?with_soxr:BuildRequires:     soxr-devel >= 0.0.5}
63 BuildRequires:  speex-devel
64 BuildRequires:  twolame-devel >= 0.3.9
65 BuildRequires:  unzip
66 BuildRequires:  vamp-devel >= 2.0
67 BuildRequires:  which
68 BuildRequires:  wxGTK2-unicode-devel >= 2.8.0
69 Requires(post,postun):  shared-mime-info
70 Requires:       flac-c++ >= 1.2.0
71 Requires:       lame-libs
72 Requires:       libid3tag >= 0.15.0b-2
73 Requires:       libmad >= 0.14.2b-4
74 %{?with_libresample:Requires:   libresample >= 0.1.3}
75 %{?with_libsamplerate:Requires: libsamplerate >= 0.1.2}
76 Requires:       libsndfile >= 1.0.0
77 Requires:       soundtouch >= 1.3.0
78 %{?with_soxr:Requires:  soxr >= 0.0.5}
79 Requires:       twolame-libs >= 0.3.9
80 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
81
82 %description
83 Audacity is a program that lets you manipulate digital audio
84 waveforms. It imports many sound file formats, including WAV, AIFF,
85 AU, IRCAM, MP3, and Ogg Vorbis. It supports all common editing
86 operations such as Cut, Copy, and Paste, plus it will mix tracks and
87 let you apply plug-in effects to any part of a sound.
88
89 %description -l pl.UTF-8
90 Audacity to program obsługujący różne formaty plików audio. Obsługuje
91 WAV, AIFF, AU, IRCAM, MP3, oraz Ogg Vorbis. Program ten umożliwia
92 wykonywanie podstawowych czynności edycyjnych takich jak kasowanie,
93 wstawianie i miksowanie ścieżki dźwiękowej. Umożliwia także
94 wykonywanie dowolnych innych operacji poprzez system wtyczek.
95
96 %description -l ru.UTF-8
97 Audacity - это звуковой редактор, позволяющий работать с файлами в
98 форматах WAV, AIFF, AU, IRCAM, MP3 и Ogg Vorbis. В нем реализованы все
99 основные операции, такие как удаление, копирование, вставка,
100 микширование треков и применение эффектов, оформленных в виде
101 плагинов, к любой части звукового файла.
102
103 %prep
104 %setup -q -n %{name}-src-%{version}
105 %patch0 -p1
106 %patch1 -p1
107 %patch2 -p1
108 cd lib-src/portaudio-v19
109 %patch3 -p0
110 cd ../..
111
112 %{__sed} -i 's/libmp3lame.so/libmp3lame.so.0/g' locale/*.po
113
114 %build
115 cd lib-src/portmixer
116 %{__autoconf}
117 cd ../portsmf
118 %{__aclocal} -I autotools/m4
119 %{__autoconf}
120 cd ../..
121 %{__aclocal} -I m4
122 %{__autoconf}
123
124 export WX_CONFIG=$(which wx-gtk2-unicode-config)
125 %configure \
126         --with-ffmpeg%{!?with_ffmpeg:=no} \
127         --with-help \
128         --with-id3tag=system \
129         --with-libmad=system \
130         %{?with_libresample:--with-libresample=system} \
131         %{?with_libsamplerate:--with-libsamplerate=system} \
132         --with-libsndfile=system \
133         --with-libflac=system \
134         --with-sbsms=local \
135         %{?with_soxr:--with-soxr=system} \
136         --with-vorbis=system
137
138 %{__make}
139
140 %install
141 rm -rf $RPM_BUILD_ROOT
142 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
143
144 %{__make} install \
145         DESTDIR=$RPM_BUILD_ROOT \
146         INSTALL_PATH=$RPM_BUILD_ROOT
147
148 cp -a %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
149 cp -a %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}
150 %{__unzip} -qq -a %{SOURCE1} -d $RPM_BUILD_ROOT%{_datadir}/%{name}/help
151
152 # unsupported
153 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/locale/sr_RS*
154
155 mv -f $RPM_BUILD_ROOT%{_datadir}/locale/{zh,zh_CN}
156
157 %{__rm} $RPM_BUILD_ROOT%{_datadir}/pixmaps/audacity.xpm
158 %{__rm} $RPM_BUILD_ROOT%{_datadir}/pixmaps/audacity16.xpm
159 %{__rm} $RPM_BUILD_ROOT%{_datadir}/pixmaps/audacity32.xpm
160 %{__rm} $RPM_BUILD_ROOT%{_datadir}/pixmaps/gnome-mime-application-x-audacity-project.xpm
161
162 %find_lang %{name}
163
164 %clean
165 rm -rf $RPM_BUILD_ROOT
166
167 %post
168 %update_mime_database
169
170 %postun
171 %update_mime_database
172
173 %files -f %{name}.lang
174 %defattr(644,root,root,755)
175 %doc README.txt
176 %attr(755,root,root) %{_bindir}/audacity
177 %dir %{_datadir}/%{name}
178 %{_datadir}/%{name}/nyquist
179 %{_datadir}/%{name}/plug-ins
180 %{_datadir}/%{name}/EQDefaultCurves.xml
181 %doc %{_datadir}/%{name}/help
182 %{_mandir}/man1/audacity.1*
183 %{_desktopdir}/audacity.desktop
184 %{_pixmapsdir}/audacity-icon.png
185 %{_datadir}/mime/packages/audacity.xml
186 %{_iconsdir}/hicolor/*/apps/audacity.png
187 %{_iconsdir}/hicolor/*/apps/audacity.svg
This page took 0.317384 seconds and 4 git commands to generate.