]> git.pld-linux.org Git - packages/audacity.git/blob - audacity.spec
- versioned install-time dependencies
[packages/audacity.git] / audacity.spec
1 # TODO:
2 # - internal portaudio crashes when only OSS is available on startup
3 # - use system vamp (vamp-hostsdk >= 2.0)
4 # - use system ffmpeg (libavcodec >= 51.53, libavformat >= 52.12)
5 # - use system sbsms (>= 1.6.0)
6 #
7 # Conditional build:
8 %bcond_with     libresample     # using libresample (default libsamplerate)
9 #
10 Summary:        Audacity - manipulate digital audio waveforms
11 Summary(pl.UTF-8):      Audacity - narzędzie do obróbki plików dźwiękowych
12 Summary(ru.UTF-8):      Кроссплатформенный звуковой редактор
13 Name:           audacity
14 Version:        1.3.12
15 Release:        1
16 License:        GPL v2
17 Group:          X11/Applications/Sound
18 Source0:        http://audacity.googlecode.com/files/%{name}-minsrc-%{version}-beta.tar.bz2
19 # Source0-md5:  76996fec67181ca82ba191e012518b57
20 # Link from http://manual.audacityteam.org/index.php?title=Main_Page
21 Source1:        http://manual.audacityteam.org/help.zip
22 # Source1-md5:  2043778cfd3c7df9b3774526e123d6d8
23 Source2:        %{name}.desktop
24 Source3:        %{name}-icon.png
25 Patch0:         %{name}-system-libs.patch
26 Patch1:         %{name}-opt.patch
27 Patch2:         %{name}-no-macos.patch
28 URL:            http://audacity.sourceforge.net/
29 BuildRequires:  autoconf >= 2.59
30 BuildRequires:  automake
31 BuildRequires:  expat-devel >= 1.95
32 BuildRequires:  flac-c++-devel >= 1.2.0
33 BuildRequires:  gettext-devel
34 BuildRequires:  libid3tag-devel >= 0.15.0b-2
35 BuildRequires:  libjpeg-devel
36 BuildRequires:  libmad-devel >= 0.14.2b-4
37 %{?with_libresample:BuildRequires:      libresample-devel >= 0.1.3}
38 %{!?with_libresample:BuildRequires:     libsamplerate-devel >= 0.1.2}
39 BuildRequires:  libsndfile-devel >= 1.0.0
40 BuildRequires:  libstdc++-devel
41 BuildRequires:  libvorbis-devel >= 1:1.0
42 BuildRequires:  pkgconfig
43 BuildRequires:  soundtouch-devel >= 1.3.0
44 BuildRequires:  speex-devel
45 BuildRequires:  twolame-devel >= 0.3.9
46 BuildRequires:  unzip
47 BuildRequires:  which
48 BuildRequires:  wxGTK2-unicode-devel >= 2.8.0
49 Requires(post,postun):  shared-mime-info
50 Requires:       flac-c++ >= 1.2.0
51 Requires:       lame-libs
52 Requires:       libid3tag >= 0.15.0b-2
53 Requires:       libmad >= 0.14.2b-4
54 %{?with_libresample:Requires:   libresample >= 0.1.3}
55 %{!?with_libresample:Requires:  libsamplerate >= 0.1.2}
56 Requires:       libsndfile >= 1.0.0
57 Requires:       soundtouch >= 1.3.0
58 Requires:       twolame-libs >= 0.3.9
59 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
60
61 %description
62 Audacity is a program that lets you manipulate digital audio
63 waveforms. It imports many sound file formats, including WAV, AIFF,
64 AU, IRCAM, MP3, and Ogg Vorbis. It supports all common editing
65 operations such as Cut, Copy, and Paste, plus it will mix tracks and
66 let you apply plug-in effects to any part of a sound.
67
68 %description -l pl.UTF-8
69 Audacity to program obsługujący różne formaty plików audio. Obsługuje
70 WAV, AIFF, AU, IRCAM, MP3, oraz Ogg Vorbis. Program ten umożliwia
71 wykonywanie podstawowych czynności edycyjnych takich jak kasowanie,
72 wstawianie i miksowanie ścieżki dźwiękowej. Umożliwia także
73 wykonywanie dowolnych innych operacji poprzez system wtyczek.
74
75 %description -l ru.UTF-8
76 Audacity - это звуковой редактор, позволяющий работать с файлами в
77 форматах WAV, AIFF, AU, IRCAM, MP3 и Ogg Vorbis. В нем реализованы все
78 основные операции, такие как удаление, копирование, вставка,
79 микширование треков и применение эффектов, оформленных в виде
80 плагинов, к любой части звукового файла.
81
82 %prep
83 %setup -q -n %{name}-src-%{version}-beta
84 %patch0 -p1
85 %patch1 -p1
86 %patch2 -p1
87
88 sed -i 's/libmp3lame.so/libmp3lame.so.0/g' locale/*.po
89
90 %build
91 cd lib-src/portmixer
92 %{__autoconf}
93 cd ../portsmf
94 %{__aclocal} -I autotools/m4
95 %{__autoconf}
96 cd ../..
97 %{__aclocal} -I m4
98 %{__autoconf}
99
100 export WX_CONFIG=$(which wx-gtk2-unicode-config)
101 %configure \
102 %if %{with libresample}
103         --with-libresample=system \
104 %else
105         --with-libresample=no \
106         --with-libsamplerate=system \
107 %endif
108         --with-help \
109         --with-id3tag=system \
110         --with-libmad=system \
111         --with-libsndfile=system \
112         --with-libflac=system \
113         --with-vorbis=system
114
115 %{__make}
116
117 %install
118 rm -rf $RPM_BUILD_ROOT
119 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
120
121 %{__make} install \
122         DESTDIR=$RPM_BUILD_ROOT \
123         INSTALL_PATH=$RPM_BUILD_ROOT
124
125 cp -a %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
126 cp -a %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}
127 %{__unzip} -qq -a %{SOURCE1} -d $RPM_BUILD_ROOT%{_datadir}/%{name}/help
128
129 mv -f $RPM_BUILD_ROOT%{_datadir}/locale/{zh,zh_CN}
130 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
131
132 %{__rm} $RPM_BUILD_ROOT%{_datadir}/pixmaps/audacity.xpm
133 %{__rm} $RPM_BUILD_ROOT%{_datadir}/pixmaps/audacity16.xpm
134 %{__rm} $RPM_BUILD_ROOT%{_datadir}/pixmaps/audacity32.xpm
135 %{__rm} $RPM_BUILD_ROOT%{_datadir}/pixmaps/gnome-mime-application-x-audacity-project.xpm
136
137 %find_lang %{name}
138
139 %clean
140 rm -rf $RPM_BUILD_ROOT
141
142 %post
143 %update_mime_database
144
145 %postun
146 %update_mime_database
147
148 %files -f %{name}.lang
149 %defattr(644,root,root,755)
150 %doc README.txt
151 %attr(755,root,root) %{_bindir}/audacity
152 %dir %{_datadir}/%{name}
153 %{_datadir}/%{name}/nyquist
154 %{_datadir}/%{name}/plug-ins
155 %doc %{_datadir}/%{name}/help
156 %{_mandir}/man1/audacity.1*
157 %{_desktopdir}/audacity.desktop
158 %{_pixmapsdir}/audacity-icon.png
159 %{_datadir}/mime/packages/audacity.xml
160 %{_iconsdir}/hicolor/*/apps/audacity.png
161 %{_iconsdir}/hicolor/*/apps/audacity.svg
This page took 0.186649 seconds and 4 git commands to generate.