]> git.pld-linux.org Git - packages/audacity.git/blob - audacity.spec
- updated to 1.3.13
[packages/audacity.git] / audacity.spec
1 # TODO:
2 # - internal portaudio crashes when only OSS is available on startup
3 # - use system portaudio (>= 19, but relies on local changes)
4 # - use system portSMF?
5 # - use system ffmpeg (libavcodec >= 51.53, libavformat >= 52.12)
6 # - use system sbsms (>= 1.6.0, but relies on local changes)
7 #
8 # Conditional build:
9 %bcond_with     libresample     # using libresample (default libsamplerate)
10 #
11 Summary:        Audacity - manipulate digital audio waveforms
12 Summary(pl.UTF-8):      Audacity - narzędzie do obróbki plików dźwiękowych
13 Summary(ru.UTF-8):      Кроссплатформенный звуковой редактор
14 Name:           audacity
15 Version:        1.3.13
16 Release:        1
17 License:        GPL v2
18 Group:          X11/Applications/Sound
19 #Source0Download: http://code.google.com/p/audacity/downloads/list
20 Source0:        http://audacity.googlecode.com/files/%{name}-minsrc-%{version}-beta.tar.bz2
21 # Source0-md5:  57be7fadb8c8dd17b8462c7ac1561d03
22 # Link from http://manual.audacityteam.org/index.php?title=Main_Page
23 Source1:        http://manual.audacityteam.org/help.zip
24 # Source1-md5:  2043778cfd3c7df9b3774526e123d6d8
25 Source2:        %{name}.desktop
26 Source3:        %{name}-icon.png
27 Patch0:         %{name}-system-libs.patch
28 Patch1:         %{name}-opt.patch
29 Patch2:         %{name}-no-macos.patch
30 # modified from http://audioscience.com/internet/download/drivers/released/v4/06/portaudio_asihpi_406.patch
31 Patch3:         portaudio_asihpi_406.patch
32 URL:            http://audacity.sourceforge.net/
33 BuildRequires:  autoconf >= 2.59
34 BuildRequires:  automake
35 BuildRequires:  expat-devel >= 1.95
36 BuildRequires:  flac-c++-devel >= 1.2.0
37 BuildRequires:  gettext-devel
38 BuildRequires:  hpklinux-devel >= 4.06
39 BuildRequires:  libid3tag-devel >= 0.15.0b-2
40 BuildRequires:  libjpeg-devel
41 BuildRequires:  libmad-devel >= 0.14.2b-4
42 %{?with_libresample:BuildRequires:      libresample-devel >= 0.1.3}
43 %{!?with_libresample:BuildRequires:     libsamplerate-devel >= 0.1.2}
44 #BuildRequires: libsbsms-devel >= 1.6.0
45 BuildRequires:  libsndfile-devel >= 1.0.0
46 BuildRequires:  libstdc++-devel
47 BuildRequires:  libvorbis-devel >= 1:1.0
48 #BuildRequires: portaudio-devel >= 19
49 BuildRequires:  pkgconfig
50 BuildRequires:  soundtouch-devel >= 1.3.0
51 BuildRequires:  speex-devel
52 BuildRequires:  twolame-devel >= 0.3.9
53 BuildRequires:  unzip
54 BuildRequires:  vamp-devel >= 2.0
55 BuildRequires:  which
56 BuildRequires:  wxGTK2-unicode-devel >= 2.8.0
57 Requires(post,postun):  shared-mime-info
58 Requires:       flac-c++ >= 1.2.0
59 Requires:       lame-libs
60 Requires:       libid3tag >= 0.15.0b-2
61 Requires:       libmad >= 0.14.2b-4
62 %{?with_libresample:Requires:   libresample >= 0.1.3}
63 %{!?with_libresample:Requires:  libsamplerate >= 0.1.2}
64 Requires:       libsndfile >= 1.0.0
65 Requires:       soundtouch >= 1.3.0
66 Requires:       twolame-libs >= 0.3.9
67 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
68
69 %description
70 Audacity is a program that lets you manipulate digital audio
71 waveforms. It imports many sound file formats, including WAV, AIFF,
72 AU, IRCAM, MP3, and Ogg Vorbis. It supports all common editing
73 operations such as Cut, Copy, and Paste, plus it will mix tracks and
74 let you apply plug-in effects to any part of a sound.
75
76 %description -l pl.UTF-8
77 Audacity to program obsługujący różne formaty plików audio. Obsługuje
78 WAV, AIFF, AU, IRCAM, MP3, oraz Ogg Vorbis. Program ten umożliwia
79 wykonywanie podstawowych czynności edycyjnych takich jak kasowanie,
80 wstawianie i miksowanie ścieżki dźwiękowej. Umożliwia także
81 wykonywanie dowolnych innych operacji poprzez system wtyczek.
82
83 %description -l ru.UTF-8
84 Audacity - это звуковой редактор, позволяющий работать с файлами в
85 форматах WAV, AIFF, AU, IRCAM, MP3 и Ogg Vorbis. В нем реализованы все
86 основные операции, такие как удаление, копирование, вставка,
87 микширование треков и применение эффектов, оформленных в виде
88 плагинов, к любой части звукового файла.
89
90 %prep
91 %setup -q -n %{name}-src-%{version}-beta
92 %patch0 -p1
93 %patch1 -p1
94 %patch2 -p1
95 cd lib-src/portaudio-v19
96 %patch3 -p0
97 cd ../..
98
99 sed -i 's/libmp3lame.so/libmp3lame.so.0/g' locale/*.po
100
101 %build
102 cd lib-src/portmixer
103 %{__autoconf}
104 cd ../portsmf
105 %{__aclocal} -I autotools/m4
106 %{__autoconf}
107 cd ../..
108 %{__aclocal} -I m4
109 %{__autoconf}
110
111 export WX_CONFIG=$(which wx-gtk2-unicode-config)
112 %configure \
113 %if %{with libresample}
114         --with-libresample=system \
115 %else
116         --with-libresample=no \
117         --with-libsamplerate=system \
118 %endif
119         --with-help \
120         --with-id3tag=system \
121         --with-libmad=system \
122         --with-libsndfile=system \
123         --with-libflac=system \
124         --with-sbsms=local \
125         --with-vorbis=system
126
127 %{__make}
128
129 %install
130 rm -rf $RPM_BUILD_ROOT
131 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
132
133 %{__make} install \
134         DESTDIR=$RPM_BUILD_ROOT \
135         INSTALL_PATH=$RPM_BUILD_ROOT
136
137 cp -a %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
138 cp -a %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}
139 %{__unzip} -qq -a %{SOURCE1} -d $RPM_BUILD_ROOT%{_datadir}/%{name}/help
140
141 mv -f $RPM_BUILD_ROOT%{_datadir}/locale/{zh,zh_CN}
142 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
143
144 %{__rm} $RPM_BUILD_ROOT%{_datadir}/pixmaps/audacity.xpm
145 %{__rm} $RPM_BUILD_ROOT%{_datadir}/pixmaps/audacity16.xpm
146 %{__rm} $RPM_BUILD_ROOT%{_datadir}/pixmaps/audacity32.xpm
147 %{__rm} $RPM_BUILD_ROOT%{_datadir}/pixmaps/gnome-mime-application-x-audacity-project.xpm
148
149 %find_lang %{name}
150
151 %clean
152 rm -rf $RPM_BUILD_ROOT
153
154 %post
155 %update_mime_database
156
157 %postun
158 %update_mime_database
159
160 %files -f %{name}.lang
161 %defattr(644,root,root,755)
162 %doc README.txt
163 %attr(755,root,root) %{_bindir}/audacity
164 %dir %{_datadir}/%{name}
165 %{_datadir}/%{name}/nyquist
166 %{_datadir}/%{name}/plug-ins
167 %{_datadir}/%{name}/EQDefaultCurves.xml
168 %doc %{_datadir}/%{name}/help
169 %{_mandir}/man1/audacity.1*
170 %{_desktopdir}/audacity.desktop
171 %{_pixmapsdir}/audacity-icon.png
172 %{_datadir}/mime/packages/audacity.xml
173 %{_iconsdir}/hicolor/*/apps/audacity.png
174 %{_iconsdir}/hicolor/*/apps/audacity.svg
This page took 0.047941 seconds and 4 git commands to generate.