]> git.pld-linux.org Git - packages/audacity.git/blob - audacity.spec
try enabling cpu flags explicitly based on target arch
[packages/audacity.git] / audacity.spec
1 # TODO:
2 # - internal portaudio crashes when only OSS is available on startup
3 # - use system portaudio (>= 19, but relies on local changes)
4 # - use system portSMF?
5 # - use system ffmpeg (libavcodec >= 51.53, libavformat >= 52.12, libavutil)
6 # - use system sbsms (>= 1.6.0, but relies on local changes)
7 # - use system libnyquist (if ever; currently it's a part of audacity project)
8 #
9 # Conditional build:
10 %bcond_without  ffmpeg          # build without ffmpeg support
11 %bcond_with     gtk3            # GTK+ 3.x instead of 2.x (not fully supported)
12 %bcond_without  mmx             # MMX instructions
13 %bcond_without  sse             # SSE instructions
14 %bcond_without  sse2            # SSE2 instructions
15 #
16 %ifnarch %{x8664} pentium2 pentium3 pentium4 athlon
17 %undefine       with_mmx
18 %endif
19 %ifnarch %{x8664} pentium3 pentium4
20 %undefine       with_sse
21 %endif
22 %ifnarch %{x8664} pentium4
23 %undefine       with_sse2
24 %endif
25
26 Summary:        Audacity - manipulate digital audio waveforms
27 Summary(pl.UTF-8):      Audacity - narzędzie do obróbki plików dźwiękowych
28 Summary(ru.UTF-8):      Кроссплатформенный звуковой редактор
29 Name:           audacity
30 Version:        2.4.2
31 Release:        1
32 License:        GPL v2+
33 Group:          X11/Applications/Sound
34 #Source0Download: http://www.fosshub.com/Audacity.html
35 Source0:        %{name}-minsrc-%{version}.tar.xz
36 # Source0-md5:  4a34c1c66f69f1fedc400c71d5155ea8
37 Source1:        %{name}-manual-%{version}.zip
38 # Source1-md5:  084830de81c157d229089338a594baab
39 Patch0:         %{name}-opt.patch
40 Patch1:         %{name}-no-macos.patch
41 Patch2:         %{name}-desktop.patch
42 URL:            http://audacityteam.org/
43 BuildRequires:  alsa-lib-devel
44 BuildRequires:  autoconf >= 2.59
45 BuildRequires:  automake >= 1:1.9
46 BuildRequires:  expat-devel >= 1.95
47 # libavcodec >= 51.53 libavformat >= 52.12 libavutil
48 %{?with_ffmpeg:BuildRequires:   ffmpeg-devel >= 0.8.0}
49 BuildRequires:  flac-c++-devel >= 1.3.0
50 BuildRequires:  gettext-tools >= 0.18
51 %{!?with_gtk3:BuildRequires:    gtk+2-devel >= 2.0}
52 %{?with_gtk3:BuildRequires:     gtk+3-devel >= 3.0}
53 BuildRequires:  hpklinux-devel >= 4.06
54 BuildRequires:  jack-audio-connection-kit-devel
55 BuildRequires:  lame-libs-devel
56 BuildRequires:  libid3tag-devel >= 0.15.0b-2
57 BuildRequires:  libjpeg-devel
58 BuildRequires:  libmad-devel >= 0.14.2b-4
59 #BuildRequires: libsbsms-devel >= 1.6.0
60 #BuildRequires: libsbsms2-devel >= 2.0.2
61 BuildRequires:  libsndfile-devel >= 1.0.0
62 BuildRequires:  libstdc++-devel
63 BuildRequires:  libtool >= 2:2
64 BuildRequires:  libvorbis-devel >= 1:1.0
65 BuildRequires:  lilv-devel >= 0.16
66 BuildRequires:  lv2-devel
67 BuildRequires:  nasm
68 BuildRequires:  pkgconfig
69 #BuildRequires: portaudio-devel >= 19
70 BuildRequires:  rpmbuild(macros) >= 1.742
71 BuildRequires:  soundtouch-devel >= 1.3.0
72 BuildRequires:  soxr-devel >= 0.0.5
73 BuildRequires:  speex-devel
74 BuildRequires:  suil-devel >= 0.8.2
75 BuildRequires:  twolame-devel >= 0.3.9
76 BuildRequires:  udev-devel
77 BuildRequires:  unzip
78 BuildRequires:  vamp-devel >= 2.0
79 BuildRequires:  which
80 %{!?with_gtk3:BuildRequires:    wxGTK2-unicode-devel >= 3.0.0}
81 %{?with_gtk3:BuildRequires:     wxGTK3-unicode-devel >= 3.0.0}
82 Requires(post,postun):  shared-mime-info
83 Requires:       flac-c++ >= 1.3.0
84 # dlopened
85 Requires:       lame-libs
86 Requires:       libid3tag >= 0.15.0b-2
87 Requires:       libmad >= 0.14.2b-4
88 Requires:       libsndfile >= 1.0.0
89 Requires:       lilv >= 0.16
90 Requires:       soundtouch >= 1.3.0
91 Requires:       soxr >= 0.0.5
92 Requires:       suil >= 0.8.2
93 Requires:       twolame-libs >= 0.3.9
94 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
95
96 %description
97 Audacity is a program that lets you manipulate digital audio
98 waveforms. It imports many sound file formats, including WAV, AIFF,
99 AU, IRCAM, MP3, and Ogg Vorbis. It supports all common editing
100 operations such as Cut, Copy, and Paste, plus it will mix tracks and
101 let you apply plug-in effects to any part of a sound.
102
103 %description -l pl.UTF-8
104 Audacity to program obsługujący różne formaty plików audio. Obsługuje
105 WAV, AIFF, AU, IRCAM, MP3, oraz Ogg Vorbis. Program ten umożliwia
106 wykonywanie podstawowych czynności edycyjnych takich jak kasowanie,
107 wstawianie i miksowanie ścieżki dźwiękowej. Umożliwia także
108 wykonywanie dowolnych innych operacji poprzez system wtyczek.
109
110 %description -l ru.UTF-8
111 Audacity - это звуковой редактор, позволяющий работать с файлами в
112 форматах WAV, AIFF, AU, IRCAM, MP3 и Ogg Vorbis. В нем реализованы все
113 основные операции, такие как удаление, копирование, вставка,
114 микширование треков и применение эффектов, оформленных в виде
115 плагинов, к любой части звукового файла.
116
117 %prep
118 %setup -q -n %{name}-minsrc-%{version}
119 %patch0 -p1
120 %patch1 -p1
121 %patch2 -p1
122
123 %{__sed} -i 's/libmp3lame.so/libmp3lame.so.0/g' locale/*.po
124
125 # Audacity's cmake can't find libmp3lame without a .pc file
126 # This is a temporary workaround.
127 if ! test -e %{_pkgconfigdir}/lame.pc
128 then
129 echo "creating lame.pc"
130 cat << EOF > lame.pc
131 prefix=%{_prefix}
132 libdir=%{_libdir}
133 includedir=%{_includedir}/lame
134
135 Name: mp3lame
136 Description: encoder that converts audio to the MP3 file format.
137 Version: 3.100
138 Libs: -L${libdir} -lmp3lame
139 Cflags: -I${includedir}
140 EOF
141 fi
142
143 %build
144 if ! test -e %{_pkgconfigdir}/lame.pc
145 then
146 export PKG_CONFIG_PATH="`echo $PWD`:%{_pkgconfigdir}"
147 fi
148
149 mkdir -p build
150 cd build
151 %cmake .. \
152         %{cmake_on_off mmx HAVE_MMX} \
153         %{cmake_on_off sse HAVE_SSE} \
154         %{cmake_on_off sse2 HAVE_SSE2} \
155         -DwxWidgets_CONFIG_EXECUTABLE:FILEPATH=$(which wx-gtk%{?with_gtk3:3}%{!?with_gtk3:2}-unicode-config) \
156         %{!?with_ffmpeg:-Daudacity_use_ffmpeg:STRING=off} \
157         -DCMAKE_BUILD_TYPE=Release
158
159 %{__make}
160
161 %install
162 rm -rf $RPM_BUILD_ROOT
163
164 cd build
165 %{__make} install \
166         DESTDIR=$RPM_BUILD_ROOT \
167         INSTALL_PATH=$RPM_BUILD_ROOT
168 cd ..
169
170 %{__unzip} -qq -a %{SOURCE1} -d $RPM_BUILD_ROOT%{_datadir}/%{name}/help
171
172 # unify locale names
173 %{__mv} $RPM_BUILD_ROOT%{_localedir}/{ca_ES@valencia,ca@valencia}
174 %{__mv} $RPM_BUILD_ROOT%{_localedir}/{pt_PT,pt}
175 %{__mv} $RPM_BUILD_ROOT%{_localedir}/{sr_RS,sr}
176 %{__mv} $RPM_BUILD_ROOT%{_localedir}/{sr_RS@latin,sr@latin}
177
178 # remove unsupported locale
179 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/eu_ES
180
181 %{__rm} $RPM_BUILD_ROOT%{_pixmapsdir}/audacity.xpm
182 %{__rm} $RPM_BUILD_ROOT%{_pixmapsdir}/audacity16.xpm
183 %{__rm} $RPM_BUILD_ROOT%{_pixmapsdir}/audacity32.xpm
184 %{__rm} $RPM_BUILD_ROOT%{_pixmapsdir}/gnome-mime-application-x-audacity-project.xpm
185
186 %{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/README.txt
187 %{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/LICENSE.txt
188 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
189
190 install -d $RPM_BUILD_ROOT%{_iconsdir}/hicolor/{16x16,22x22,24x24,32x32,48x48}/apps
191 %{__mv} $RPM_BUILD_ROOT%{_iconsdir}/hicolor/{16x16,16x16/apps}/%{name}.png
192 %{__mv} $RPM_BUILD_ROOT%{_iconsdir}/hicolor/{22x22,22x22/apps}/%{name}.png
193 %{__mv} $RPM_BUILD_ROOT%{_iconsdir}/hicolor/{24x24,24x24/apps}/%{name}.png
194 %{__mv} $RPM_BUILD_ROOT%{_iconsdir}/hicolor/{32x32,32x32/apps}/%{name}.png
195 %{__mv} $RPM_BUILD_ROOT%{_iconsdir}/hicolor/{48x48,48x48/apps}/%{name}.png
196
197
198 %find_lang %{name}
199
200 %clean
201 rm -rf $RPM_BUILD_ROOT
202
203 %post
204 %update_mime_database
205
206 %postun
207 %update_mime_database
208
209 %files -f %{name}.lang
210 %defattr(644,root,root,755)
211 %doc README.txt LICENSE.txt
212 %attr(755,root,root) %{_bindir}/audacity
213 %dir %{_datadir}/%{name}
214 %dir %{_datadir}/%{name}/modules
215 %attr(755,root,root) %{_datadir}/%{name}/modules/mod-script-pipe.so
216 %{_datadir}/%{name}/nyquist
217 %{_datadir}/%{name}/plug-ins
218 %{_datadir}/%{name}/EQDefaultCurves.xml
219 %doc %{_datadir}/%{name}/help
220 %{_mandir}/man1/audacity.1*
221 %{_desktopdir}/audacity.desktop
222 %{_datadir}/appdata/audacity.appdata.xml
223 %{_datadir}/mime/packages/audacity.xml
224 %{_iconsdir}/hicolor/*/apps/*.*
This page took 0.070967 seconds and 3 git commands to generate.