]> git.pld-linux.org Git - packages/audacity.git/blob - audacity.spec
- more
[packages/audacity.git] / audacity.spec
1 # TODO:
2 # - internal portaudio crashes when only OSS is available on startup
3 # - use system portaudio (>= 19, but relies on local changes)
4 # - use system portSMF?
5 # - use system ffmpeg (libavcodec >= 51.53, libavformat >= 52.12), libavutil
6 # - use system sbsms (>= 1.6.0, but relies on local changes)
7 # - use system libnyquist (if ever; currently it's a part of audacity project)
8 #
9 # Conditional build:
10 %bcond_with     libresample     # using libresample for resampling (default is soxr)
11 %bcond_with     libsamplerate   # using libsamplerate for resampling (default is soxr)
12 %bcond_with     ffmpeg          # build with ffmpeg support (currently audacity does not support ffmpeg 1.0)
13 #
14 %if %{without libresample} && %{without libsamplerate}
15 %define with_soxr       1
16 %endif
17 Summary:        Audacity - manipulate digital audio waveforms
18 Summary(pl.UTF-8):      Audacity - narzędzie do obróbki plików dźwiękowych
19 Summary(ru.UTF-8):      Кроссплатформенный звуковой редактор
20 Name:           audacity
21 Version:        2.0.5
22 Release:        2
23 License:        GPL v2+
24 Group:          X11/Applications/Sound
25 #Source0Download: http://code.google.com/p/audacity/downloads/list
26 Source0:        http://audacity.googlecode.com/files/%{name}-minsrc-%{version}.tar.xz
27 # Source0-md5:  657f71a5a214fe84731ed9842e09fa04
28 # Link from http://manual.audacityteam.org/index.php?title=Main_Page
29 Source1:        http://audacity.googlecode.com/files/%{name}-manual-%{version}.zip
30 # Source1-md5:  9f0b9db3f37aa4b9455a4b4e2046e1e4
31 Source2:        %{name}.desktop
32 Source3:        %{name}-icon.png
33 Patch0:         %{name}-system-libs.patch
34 Patch1:         %{name}-opt.patch
35 Patch2:         %{name}-no-macos.patch
36 Patch3:         %{name}-wx.patch
37 URL:            http://audacity.sourceforge.net/
38 BuildRequires:  alsa-lib-devel
39 BuildRequires:  autoconf >= 2.59
40 BuildRequires:  automake
41 BuildRequires:  expat-devel >= 1.95
42 %{?with_ffmpeg:BuildRequires:   ffmpeg-devel >= 0.8.0}
43 BuildRequires:  flac-c++-devel >= 1.2.0
44 BuildRequires:  gettext-devel
45 BuildRequires:  gtk+2-devel >= 2.0
46 BuildRequires:  jack-audio-connection-kit-devel
47 BuildRequires:  hpklinux-devel >= 4.06
48 BuildRequires:  lame-libs-devel
49 BuildRequires:  libid3tag-devel >= 0.15.0b-2
50 BuildRequires:  libjpeg-devel
51 BuildRequires:  libmad-devel >= 0.14.2b-4
52 %{?with_libresample:BuildRequires:      libresample-devel >= 0.1.3}
53 %{?with_libsamplerate:BuildRequires:    libsamplerate-devel >= 0.1.2}
54 #BuildRequires: libsbsms-devel >= 1.6.0
55 BuildRequires:  libsndfile-devel >= 1.0.0
56 BuildRequires:  libstdc++-devel
57 BuildRequires:  libvorbis-devel >= 1:1.0
58 #BuildRequires: portaudio-devel >= 19
59 BuildRequires:  pkgconfig
60 BuildRequires:  soundtouch-devel >= 1.3.0
61 %{?with_soxr:BuildRequires:     soxr-devel >= 0.0.5}
62 BuildRequires:  speex-devel
63 BuildRequires:  twolame-devel >= 0.3.9
64 BuildRequires:  unzip
65 BuildRequires:  vamp-devel >= 2.0
66 BuildRequires:  which
67 BuildRequires:  wxGTK2-unicode-devel >= 2.8.0
68 Requires(post,postun):  shared-mime-info
69 Requires:       flac-c++ >= 1.2.0
70 Requires:       lame-libs
71 Requires:       libid3tag >= 0.15.0b-2
72 Requires:       libmad >= 0.14.2b-4
73 %{?with_libresample:Requires:   libresample >= 0.1.3}
74 %{?with_libsamplerate:Requires: libsamplerate >= 0.1.2}
75 Requires:       libsndfile >= 1.0.0
76 Requires:       soundtouch >= 1.3.0
77 %{?with_soxr:Requires:  soxr >= 0.0.5}
78 Requires:       twolame-libs >= 0.3.9
79 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
80
81 %description
82 Audacity is a program that lets you manipulate digital audio
83 waveforms. It imports many sound file formats, including WAV, AIFF,
84 AU, IRCAM, MP3, and Ogg Vorbis. It supports all common editing
85 operations such as Cut, Copy, and Paste, plus it will mix tracks and
86 let you apply plug-in effects to any part of a sound.
87
88 %description -l pl.UTF-8
89 Audacity to program obsługujący różne formaty plików audio. Obsługuje
90 WAV, AIFF, AU, IRCAM, MP3, oraz Ogg Vorbis. Program ten umożliwia
91 wykonywanie podstawowych czynności edycyjnych takich jak kasowanie,
92 wstawianie i miksowanie ścieżki dźwiękowej. Umożliwia także
93 wykonywanie dowolnych innych operacji poprzez system wtyczek.
94
95 %description -l ru.UTF-8
96 Audacity - это звуковой редактор, позволяющий работать с файлами в
97 форматах WAV, AIFF, AU, IRCAM, MP3 и Ogg Vorbis. В нем реализованы все
98 основные операции, такие как удаление, копирование, вставка,
99 микширование треков и применение эффектов, оформленных в виде
100 плагинов, к любой части звукового файла.
101
102 %prep
103 %setup -q -n %{name}-src-%{version}
104 %patch0 -p1
105 %patch1 -p1
106 %patch2 -p1
107 %patch3 -p1
108
109 %{__sed} -i 's/libmp3lame.so/libmp3lame.so.0/g' locale/*.po
110
111 %build
112 cd lib-src/portmixer
113 %{__autoconf}
114 cd ../lib-widget-extra
115 %{__aclocal} -I m4
116 %{__autoconf}
117 cd ../portsmf
118 %{__aclocal} -I autotools/m4
119 %{__autoconf}
120 %{__automake}
121 cd ../..
122 %{__aclocal} -I m4
123 %{__autoconf}
124
125 export WX_CONFIG=$(which wx-gtk2-unicode-config)
126 %configure \
127         --with-ffmpeg%{!?with_ffmpeg:=no} \
128         --with-help \
129         --with-id3tag=system \
130         --with-libmad=system \
131         %{?with_libresample:--with-libresample=system} \
132         %{?with_libsamplerate:--with-libsamplerate=system} \
133         --with-libsndfile=system \
134         --with-libflac=system \
135         --with-sbsms=local \
136         %{?with_soxr:--with-soxr=system} \
137         --with-vorbis=system
138
139 %{__make}
140
141 %install
142 rm -rf $RPM_BUILD_ROOT
143 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
144
145 %{__make} install \
146         DESTDIR=$RPM_BUILD_ROOT \
147         INSTALL_PATH=$RPM_BUILD_ROOT
148
149 cp -a %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
150 cp -a %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}
151 %{__unzip} -qq -a %{SOURCE1} -d $RPM_BUILD_ROOT%{_datadir}/%{name}/help
152
153 # unsupported
154 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/locale/sr_RS*
155
156 mv -f $RPM_BUILD_ROOT%{_datadir}/locale/{zh,zh_CN}
157
158 %{__rm} $RPM_BUILD_ROOT%{_datadir}/pixmaps/audacity.xpm
159 %{__rm} $RPM_BUILD_ROOT%{_datadir}/pixmaps/audacity16.xpm
160 %{__rm} $RPM_BUILD_ROOT%{_datadir}/pixmaps/audacity32.xpm
161 %{__rm} $RPM_BUILD_ROOT%{_datadir}/pixmaps/gnome-mime-application-x-audacity-project.xpm
162
163 %find_lang %{name}
164
165 %clean
166 rm -rf $RPM_BUILD_ROOT
167
168 %post
169 %update_mime_database
170
171 %postun
172 %update_mime_database
173
174 %files -f %{name}.lang
175 %defattr(644,root,root,755)
176 %doc README.txt
177 %attr(755,root,root) %{_bindir}/audacity
178 %dir %{_datadir}/%{name}
179 %{_datadir}/%{name}/nyquist
180 %{_datadir}/%{name}/plug-ins
181 %{_datadir}/%{name}/EQDefaultCurves.xml
182 %doc %{_datadir}/%{name}/help
183 %{_mandir}/man1/audacity.1*
184 %{_desktopdir}/audacity.desktop
185 %{_pixmapsdir}/audacity-icon.png
186 %{_datadir}/mime/packages/audacity.xml
187 %{_iconsdir}/hicolor/*/apps/audacity.png
188 %{_iconsdir}/hicolor/*/apps/audacity.svg
This page took 0.040574 seconds and 3 git commands to generate.