]> git.pld-linux.org Git - packages/audacity.git/blob - audacity.spec
40e5e71ca5c0bb4c54db4bed160f3e9068b3552b
[packages/audacity.git] / audacity.spec
1 # TODO:
2 # - internal portaudio crashes when only OSS is available on startup
3 # - use system portaudio (>= 19, but relies on local changes)
4 # - use system portSMF?
5 # - use system ffmpeg (libavcodec >= 51.53, libavformat >= 52.12), libavutil
6 # - use system sbsms (>= 1.6.0, but relies on local changes)
7 # - use system libnyquist (if ever; currently it's a part of audacity project)
8 #
9 # Conditional build:
10 %bcond_with     libresample     # using libresample for resampling (default is soxr)
11 %bcond_with     libsamplerate   # using libsamplerate for resampling (default is soxr)
12 %bcond_with     ffmpeg          # build with ffmpeg support (currently audacity does not support ffmpeg 1.0)
13 #
14 %if %{without libresample} && %{without libsamplerate}
15 %define with_soxr       1
16 %endif
17 Summary:        Audacity - manipulate digital audio waveforms
18 Summary(pl.UTF-8):      Audacity - narzędzie do obróbki plików dźwiękowych
19 Summary(ru.UTF-8):      Кроссплатформенный звуковой редактор
20 Name:           audacity
21 Version:        2.0.5
22 Release:        4
23 License:        GPL v2+
24 Group:          X11/Applications/Sound
25 #Source0Download: http://code.google.com/p/audacity/downloads/list
26 Source0:        http://audacity.googlecode.com/files/%{name}-minsrc-%{version}.tar.xz
27 # Source0-md5:  657f71a5a214fe84731ed9842e09fa04
28 # Link from http://manual.audacityteam.org/index.php?title=Main_Page
29 Source1:        http://audacity.googlecode.com/files/%{name}-manual-%{version}.zip
30 # Source1-md5:  9f0b9db3f37aa4b9455a4b4e2046e1e4
31 Source2:        %{name}.desktop
32 Source3:        %{name}-icon.png
33 Patch0:         %{name}-system-libs.patch
34 Patch1:         %{name}-opt.patch
35 Patch2:         %{name}-no-macos.patch
36 # https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=749659
37 Patch3:         wx-fd-constants.patch
38 Patch4:         wx30.patch
39 URL:            http://audacity.sourceforge.net/
40 BuildRequires:  alsa-lib-devel
41 BuildRequires:  autoconf >= 2.59
42 BuildRequires:  automake
43 BuildRequires:  expat-devel >= 1.95
44 %{?with_ffmpeg:BuildRequires:   ffmpeg-devel >= 0.8.0}
45 BuildRequires:  flac-c++-devel >= 1.2.0
46 BuildRequires:  gettext-devel
47 BuildRequires:  gtk+2-devel >= 2.0
48 BuildRequires:  jack-audio-connection-kit-devel
49 BuildRequires:  hpklinux-devel >= 4.06
50 BuildRequires:  lame-libs-devel
51 BuildRequires:  libid3tag-devel >= 0.15.0b-2
52 BuildRequires:  libjpeg-devel
53 BuildRequires:  libmad-devel >= 0.14.2b-4
54 %{?with_libresample:BuildRequires:      libresample-devel >= 0.1.3}
55 %{?with_libsamplerate:BuildRequires:    libsamplerate-devel >= 0.1.2}
56 #BuildRequires: libsbsms-devel >= 1.6.0
57 BuildRequires:  libsndfile-devel >= 1.0.0
58 BuildRequires:  libstdc++-devel
59 BuildRequires:  libvorbis-devel >= 1:1.0
60 #BuildRequires: portaudio-devel >= 19
61 BuildRequires:  pkgconfig
62 BuildRequires:  soundtouch-devel >= 1.3.0
63 %{?with_soxr:BuildRequires:     soxr-devel >= 0.0.5}
64 BuildRequires:  speex-devel
65 BuildRequires:  twolame-devel >= 0.3.9
66 BuildRequires:  unzip
67 BuildRequires:  vamp-devel >= 2.0
68 BuildRequires:  which
69 BuildRequires:  wxGTK2-unicode-devel >= 2.8.0
70 BuildRequires:  wxX11-devel >= 2.8.0
71 Requires(post,postun):  shared-mime-info
72 Requires:       flac-c++ >= 1.2.0
73 Requires:       lame-libs
74 Requires:       libid3tag >= 0.15.0b-2
75 Requires:       libmad >= 0.14.2b-4
76 %{?with_libresample:Requires:   libresample >= 0.1.3}
77 %{?with_libsamplerate:Requires: libsamplerate >= 0.1.2}
78 Requires:       libsndfile >= 1.0.0
79 Requires:       soundtouch >= 1.3.0
80 %{?with_soxr:Requires:  soxr >= 0.0.5}
81 Requires:       twolame-libs >= 0.3.9
82 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
83
84 %description
85 Audacity is a program that lets you manipulate digital audio
86 waveforms. It imports many sound file formats, including WAV, AIFF,
87 AU, IRCAM, MP3, and Ogg Vorbis. It supports all common editing
88 operations such as Cut, Copy, and Paste, plus it will mix tracks and
89 let you apply plug-in effects to any part of a sound.
90
91 %description -l pl.UTF-8
92 Audacity to program obsługujący różne formaty plików audio. Obsługuje
93 WAV, AIFF, AU, IRCAM, MP3, oraz Ogg Vorbis. Program ten umożliwia
94 wykonywanie podstawowych czynności edycyjnych takich jak kasowanie,
95 wstawianie i miksowanie ścieżki dźwiękowej. Umożliwia także
96 wykonywanie dowolnych innych operacji poprzez system wtyczek.
97
98 %description -l ru.UTF-8
99 Audacity - это звуковой редактор, позволяющий работать с файлами в
100 форматах WAV, AIFF, AU, IRCAM, MP3 и Ogg Vorbis. В нем реализованы все
101 основные операции, такие как удаление, копирование, вставка,
102 микширование треков и применение эффектов, оформленных в виде
103 плагинов, к любой части звукового файла.
104
105 %prep
106 %setup -q -n %{name}-src-%{version}
107 %patch0 -p1
108 %patch1 -p1
109 %patch2 -p1
110 %patch3 -p2
111 %patch4 -p1
112
113 %{__sed} -i 's/libmp3lame.so/libmp3lame.so.0/g' locale/*.po
114
115 %build
116 cd lib-src/portmixer
117 %{__autoconf}
118 cd ../lib-widget-extra
119 %{__aclocal} -I m4
120 %{__autoconf}
121 cd ../FileDialog
122 %{__aclocal}
123 %{__autoconf}
124 cd ../portsmf
125 %{__aclocal} -I autotools/m4
126 %{__autoconf}
127 %{__automake}
128 cd ../..
129 %{__aclocal} -I m4
130 %{__autoconf}
131
132 export WX_CONFIG=$(which wx-gtk2-unicode-config)
133 %configure \
134         --with-ffmpeg%{!?with_ffmpeg:=no} \
135         --with-help \
136         --with-id3tag=system \
137         --with-libmad=system \
138         %{?with_libresample:--with-libresample=system} \
139         %{?with_libsamplerate:--with-libsamplerate=system} \
140         --with-libsndfile=system \
141         --with-libflac=system \
142         --with-sbsms=local \
143         %{?with_soxr:--with-soxr=system} \
144         --with-vorbis=system
145
146 %{__make}
147
148 %install
149 rm -rf $RPM_BUILD_ROOT
150 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
151
152 %{__make} install \
153         DESTDIR=$RPM_BUILD_ROOT \
154         INSTALL_PATH=$RPM_BUILD_ROOT
155
156 cp -a %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
157 cp -a %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}
158 %{__unzip} -qq -a %{SOURCE1} -d $RPM_BUILD_ROOT%{_datadir}/%{name}/help
159
160 # unsupported
161 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/locale/sr_RS*
162
163 mv -f $RPM_BUILD_ROOT%{_datadir}/locale/{zh,zh_CN}
164
165 %{__rm} $RPM_BUILD_ROOT%{_datadir}/pixmaps/audacity.xpm
166 %{__rm} $RPM_BUILD_ROOT%{_datadir}/pixmaps/audacity16.xpm
167 %{__rm} $RPM_BUILD_ROOT%{_datadir}/pixmaps/audacity32.xpm
168 %{__rm} $RPM_BUILD_ROOT%{_datadir}/pixmaps/gnome-mime-application-x-audacity-project.xpm
169
170 %find_lang %{name}
171
172 %clean
173 rm -rf $RPM_BUILD_ROOT
174
175 %post
176 %update_mime_database
177
178 %postun
179 %update_mime_database
180
181 %files -f %{name}.lang
182 %defattr(644,root,root,755)
183 %doc README.txt
184 %attr(755,root,root) %{_bindir}/audacity
185 %dir %{_datadir}/%{name}
186 %{_datadir}/%{name}/nyquist
187 %{_datadir}/%{name}/plug-ins
188 %{_datadir}/%{name}/EQDefaultCurves.xml
189 %doc %{_datadir}/%{name}/help
190 %{_mandir}/man1/audacity.1*
191 %{_desktopdir}/audacity.desktop
192 %{_pixmapsdir}/audacity-icon.png
193 %{_datadir}/mime/packages/audacity.xml
194 %{_iconsdir}/hicolor/*/apps/audacity.png
195 %{_iconsdir}/hicolor/*/apps/audacity.svg
This page took 0.085105 seconds and 2 git commands to generate.