]> git.pld-linux.org Git - packages/audacious.git/commitdiff
This commit was manufactured by cvs2git to create branch 'AC-branch'. AC-branch
authorcvs2git <feedback@pld-linux.org>
Thu, 5 Apr 2007 15:38:05 +0000 (15:38 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Sprout from master 2004-09-17 05:38:57 UTC freetz <freetz@pld-linux.org> '- Categories fix'
Cherrypick from master 2007-04-05 15:38:05 UTC arvenil <arvenil@pld-linux.org> '- up to 1.3.2':
    audacious-desktop.patch -> 1.6
    audacious-home_etc.patch -> 1.4
    audacious.spec -> 1.24

audacious-desktop.patch [new file with mode: 0644]
audacious-home_etc.patch [new file with mode: 0644]
audacious.spec [new file with mode: 0644]

diff --git a/audacious-desktop.patch b/audacious-desktop.patch
new file mode 100644 (file)
index 0000000..c6173c7
--- /dev/null
@@ -0,0 +1,17 @@
+diff -urN audacious-1.2.2/src/audacious/audacious.desktop.in audacious-1.2.2.new/src/audacious/audacious.desktop.in
+--- audacious-1.2.2/src/audacious/audacious.desktop.in 2006-11-16 20:46:06.000000000 +0100
++++ audacious-1.2.2.new/src/audacious/audacious.desktop.in     2006-11-19 13:55:33.000000000 +0100
+@@ -2,10 +2,11 @@
+ Name=Audacious
+ Comment=Play music
+ Comment[hu]=Zene lejátszása
++Comment[pl]=Odtwarzacz muzyki
+ Exec=audacious %U
+ Icon=audacious
+-MimeType=application/x-ogg;audio/mp3;audio/mpeg;audio/mpegurl;audio/prs.sid;audio/x-flac;audio/x-it;audio/x-mod;audio/x-mp3;audio/x-mpeg;audio/x-mpegurl;audio/x-ms-wma;audio/x-musepack;audio/x-s3m;audio/x-scpls;audio/x-stm;audio/x-wav;audio/x-xm;application/ogg;audio/x-vorbis+ogg
+-Categories=Application;GTK;AudioVideo;Player;
++MimeType=application/x-ogg;audio/mp3;audio/mpeg;audio/mpegurl;audio/prs.sid;audio/x-flac;audio/x-it;audio/x-mod;audio/x-mp3;audio/x-mpeg;audio/x-mpegurl;audio/x-ms-wma;audio/x-musepack;audio/x-s3m;audio/x-scpls;audio/x-stm;audio/x-wav;audio/x-xm;application/ogg;audio/x-vorbis+ogg;
++Categories=GTK;Audio;Player;
+ Terminal=false
+ Type=Application
+ Encoding=UTF-8
diff --git a/audacious-home_etc.patch b/audacious-home_etc.patch
new file mode 100644 (file)
index 0000000..383fe57
--- /dev/null
@@ -0,0 +1,70 @@
+--- audacious-1.3.0/src/audacious/Makefile     2007-01-26 18:58:10.000000000 +0100
++++ audacious-1.3.0/src/audacious/Makefile     2007-01-26 18:59:45.000000000 +0100
+@@ -15,6 +15,7 @@
+       $(GTK_LIBS) \
+       $(LIBGLADE_LIBS) \
+       $(REGEX_LIBS) \
++      -lhome_etc \
+       ./widgets/libwidgets.a
+ CFLAGS += \
+--- audacious-1.3.0/src/libaudacious/configdb.h        2007-01-26 18:58:10.000000000 +0100
++++ audacious-1.3.0/src/libaudacious/configdb.h        2007-01-26 19:01:51.000000000 +0100
+@@ -2,6 +2,7 @@
+ #define CONFIGDB_H
+ #include <glib.h>
++#include <home_etc.h>
+ /**
+  * ConfigDb:
+--- audacious-1.3.0/src/libaudacious/Makefile  2007-01-23 19:22:32.000000000 +0100
++++ audacious-1.3.0/src/libaudacious/Makefile  2007-01-26 19:03:46.000000000 +0100
+@@ -9,7 +9,8 @@
+ LIBADD = \
+       $(GTK_LIBS) \
+       $(GCONF_LIBS) \
+-      $(LIBMCS_LIBS)
++      $(LIBMCS_LIBS) \
++      -lhome_etc
+ CFLAGS += $(PICFLAGS) \
+       $(GTK_CFLAGS) \
+--- audacious-1.3.0/src/audacious/main.c       2007-01-23 03:21:22.000000000 +0100
++++ audacious-1.3.0/src/audacious/main.c       2007-01-26 19:08:25.000000000 +0100
+@@ -490,13 +490,13 @@
+     char *xdg_cache_home;
+     xdg_config_home = (getenv("XDG_CONFIG_HOME") == NULL
+-        ? g_build_filename(g_get_home_dir(), ".config", NULL)
++        ? g_build_filename(_HEdir, ".config", NULL)
+         : g_strdup(getenv("XDG_CONFIG_HOME")));
+     xdg_data_home = (getenv("XDG_DATA_HOME") == NULL
+-        ? g_build_filename(g_get_home_dir(), ".local", "share", NULL)
++        ? g_build_filename(_HEdir, ".local", "share", NULL)
+         : g_strdup(getenv("XDG_DATA_HOME")));
+     xdg_cache_home = (getenv("XDG_CACHE_HOME") == NULL
+-        ? g_build_filename(g_get_home_dir(), ".cache", NULL)
++        ? g_build_filename(_HEdir, ".cache", NULL)
+         : g_strdup(getenv("XDG_CACHE_HOME")));
+     bmp_paths[BMP_PATH_USER_DIR] =
+--- audacious-1.3.0/src/audacious/util.c       2007-01-27 14:01:55.000000000 +0100
++++ audacious-1.3.0/src/audacious/util.c       2007-02-05 22:48:12.000000000 +0100
+@@ -29,6 +29,7 @@
+ #include "util.h"
+ #include <glib.h>
++#include <home_etc.h>
+ #include <glib/gi18n.h>
+ #include <glade/glade.h>
+ #include <gtk/gtk.h>
+@@ -1011,7 +1012,7 @@
+   gchar *tmp;
+   if ( (tmp = getenv("XDG_CONFIG_HOME")) == NULL )
+-    datadir = g_build_filename( g_get_home_dir() , ".config" , "audacious" ,  NULL );
++    datadir = g_build_filename( _HEdir , ".config" , "audacious" ,  NULL );
+   else
+     datadir = g_build_filename( tmp , "audacious" , NULL );
diff --git a/audacious.spec b/audacious.spec
new file mode 100644 (file)
index 0000000..fcd13eb
--- /dev/null
@@ -0,0 +1,146 @@
+#
+# Conditional build:
+%bcond_with    gconf           # build without gconf support
+#
+
+Summary:       Sound player with the WinAmp GUI, for Unix-based systems for GTK+2
+Summary(pl.UTF-8):     Odtwarzacz dźwięku z interfejsem WinAmpa dla GTK+2
+Name:          audacious
+Version:       1.3.2
+Release:       1
+License:       GPL
+Group:         X11/Applications/Sound
+Source0:       http://static.audacious-media-player.org/release/%{name}-%{version}.tgz
+# Source0-md5: b784a30604a2f9d84e9da310069f43f9
+Source1:       mp3license
+Patch0:                %{name}-desktop.patch
+Patch1:                %{name}-home_etc.patch
+URL:           http://audacious-media-player.org/
+%{?with_gconf:BuildRequires:   GConf2-devel >= 2.6.0}
+BuildRequires: autoconf >= 2.59
+BuildRequires: automake
+BuildRequires: gettext-devel
+BuildRequires: gtk+2-devel >= 2:2.6.0
+BuildRequires: home-etc-devel
+BuildRequires: libglade2-devel >= 2.3.1
+BuildRequires: libstdc++-devel
+BuildRequires: mcs-devel
+BuildRequires: pkgconfig
+BuildRequires: rpmbuild(macros) >= 1.198
+Requires(post,postun): desktop-file-utils
+Requires:      %{name}-libs = %{version}-%{release}
+Requires:      audacious-output-plugin
+Obsoletes:     audacious-static
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%description
+Audacious is a media player based on BMP. Since the development of the
+former project had been terminated, this fork was created.
+
+%description -l pl.UTF-8
+Audacious to odtwarzacz mediów oparty na BMP. Powstał on ponieważ
+rozwój pierwowzoru został zakończony.
+
+%package libs
+Summary:       Audacious media player library
+Summary(pl.UTF-8):     Biblioteka odtwarzacza multimedialnego Audacious
+Group:         X11/Applications/Sound
+
+%description libs
+Audacious media player library.
+
+%description libs -l pl.UTF-8
+Biblioteka odtwarzacza multimedialnego Audacious.
+
+%package devel
+Summary:       Header files for Audacious media player
+Summary(pl.UTF-8):     Pliki nagłówkowe odtwarzacza multimedialnego Audacious
+Group:         X11/Development/Libraries
+Requires:      %{name}-libs = %{version}-%{release}
+Requires:      gtk+2-devel >= 2:2.6.0
+Requires:      home-etc-devel
+Requires:      mcs-devel
+
+%description devel
+Header files required for compiling Audacious media player plugins.
+
+%description devel -l pl.UTF-8
+Pliki nagłówkowe potrzebne do kompilowania wtyczek odtwarzacza
+multimedialnego Audacious.
+
+%prep
+%setup -q
+%patch0 -p1
+%patch1 -p1
+
+%build
+%{__aclocal} -I m4
+%{__autoconf}
+%{__autoheader}
+%configure \
+       --%{?with_gconf:en}%{!?with_gconf:dis}able-gconf \
+       --enable-shared
+
+%{__make}
+
+%install
+rm -rf $RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT%{_libdir}/audacious/{Container,Effect,General,Input,Output,Visualization}
+
+%{__make} install \
+       DESTDIR=$RPM_BUILD_ROOT
+
+%find_lang %{name}
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%post
+%banner %{name} -e << EOF
+Remember to install appropriate input plugins for files
+you want to play!
+EOF
+
+%update_desktop_database_post
+
+%postun
+%update_desktop_database_postun
+
+%post  libs -p /sbin/ldconfig
+%postun        libs -p /sbin/ldconfig
+
+%files -f %{name}.lang
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/audacious
+%attr(755,root,root) %{_bindir}/audtool
+%dir %{_libdir}/audacious
+%dir %{_libdir}/audacious/Container
+%dir %{_libdir}/audacious/Effect
+%dir %{_libdir}/audacious/General
+%dir %{_libdir}/audacious/Input
+%dir %{_libdir}/audacious/Output
+%dir %{_libdir}/audacious/Visualization
+
+%{_mandir}/man*/*
+
+%dir %{_datadir}/audacious
+%{_datadir}/audacious/glade
+%dir %{_datadir}/audacious/images
+%{_datadir}/audacious/images/*
+%{_datadir}/audacious/Skins
+%{_datadir}/audacious/ui
+%{_desktopdir}/*.desktop
+%{_pixmapsdir}/*.png
+
+%files libs
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/libaudacious.so.*.*.*
+%ghost %attr(755,root,root) %{_libdir}/libaudacious.so.?
+%dir %{_libdir}/audacious
+%attr(755,root,root) %{_libdir}/audacious/libaudid3tag.so
+
+%files devel
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/libaudacious.so
+%{_includedir}/audacious
+%{_pkgconfigdir}/audacious.pc
This page took 0.053335 seconds and 4 git commands to generate.